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ITY AND FITNESS FOR A
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TION, EITHER EXPRESS OR
IMPLIED, WITH RESPECT TO
SOFTWARE, ITS QUALITY,
PERFORMANCE, MERCHANT-
ABILITY, OR FITNESS FOR A
PARTICULAR PURPOSE. AS A
RESULT, THIS SOFTWARE IS
SOLD “AS IS,” AND YOU THE
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ENTIRE RISK AS TO ITS
QUALITY AND PERFORMANCE.

IN NO EVENT WILL APPLE BE
LIABLE FOR DIRECT, INDIRECT,
SPECIAL, INCIDENTAL, OR
CONSEQUENTIAL DAMAGES
RESULTING FROM ANY DEFECT
IN THE SOFTWARE OR ITS
DOCUMENTATION, even if advised
of the possibility of such damages.
In particular, Apple shall have no
liability for any programs or data
stored in or used with Apple
products, including the costs of
recovering such programs or data.

THE WARRANTY AND REMEDIES
SET FORTH ABOVE ARE EXCLU-
SIVE AND IN LIEU OF ALL
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EXPRESS OR IMPLIED. No Apple
dealer, agent, or employee is
authorized to make any modifi-
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Some states do not allow the
exclusion or limitation of implied
warranties or liability for incidental
or consequential damages, so the
above limitation or exclusion may
not apply to you. This warranty
gives you specific legal rights, and
you may also have other rights
which vary from state to state.
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HyperCard™ is a new kind of application—a unique information
environment for your Apple® Macintosh™ computer. Use it to look
for and store information—words, charts, pictures, digitized
photographs—about any subject that suits you. Any piece of
information in HyperCard can connect to any other piece of
information, so you can find out what you want to know in as much
or as little detail as you need.

 

 

 

What you need to use HyperCard
HyperCard works in any Apple Macintosh computer with 1

megabyte of memory or more, and two 800K disk drives. It works
best in systems with a hard disk drive and a printer.

» HyperCard andMultiFinder: To get the most out of your system
when you’re using HyperCard and any other application under
MultiFinder™, your system should have at least 2 megabytes of
memory. Your authorized Apple dealer can quickly upgrade your
system with the necessary extra memory.

oe

 

About system software
HyperCard comes with the latest System file, a file your computer
uses to perform its basic operations. The System Folder in the disk
labeled HyperCard Startup has System version 4.1.

You need to be concerned about the version number of the System
file if you plan to use HyperCard on your own startup disks. (Startup
disks all have System files on them.) HyperCard works fine under
System files with the version numbers in Table P-1 (or higher
numbers).

 

 

Table P-1
System file versions

Computer System Finder

Macintosh Plus System 3.2 Finder 5.3
Macintosh SE System 4.0 Finder 5.4
Macintosh II System 4.1 Finder 5.5

To find out the version of the System file on your startup disks, look
in the System file Get Info box.
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Do not use the System file on the HyperCard Startup disk to run
the Macintosh Il, even though its version number is 4.1: it will
not work properly. Use whatever System Folder you currently
have to start up your computer.
 

“ LaserWriter users take note: To use a LaserWriter® printer with
HyperCard, you must be using LaserWriter file version 4.0 (or
higher numbers).

“ Finder not necessary: You don’t need a Finder on startup disks
that you use exclusively for HyperCard. You do, however, need a

System file.

 

What you need to know
This guide assumes you’ve already read and are familiar with the
owner's guide that came with your computer. Before you use
HyperCard, you should know how to

O use the mouse

O open applications and documents

O do simple editing

O use the Finder

 

What comes with HyperCard
Besides this manual, your HyperCard package should contain four
disks, named as follows:

O HyperCard Startup

O HyperCard & Stacks

O HyperCard Help

O HyperCard Ideas

In the unlikely event that anything is missing, immediately contact
your dealer for replacement.

See Appendix B, “HyperCard Disks,” for a list of the stacks (the
name for HyperCard documents) and other files on each disk.
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Copy your disks
Before you do anything else, make copies of all the HyperCard disks
to use as your working disks. Then put the originals away in a safe

place.

HyperCard is an inviting program to use and to experiment with.
HyperCard documents are extremely easy to change. You might
want to use your original HyperCard documents to replace a

document you’ve experimented with; so it’s important that you keep
a set of these documents in their unaltered states.

Copy your HyperCard disks now, before you do anything else. If
you’re not sure how to copy disks, see the owner’s guide that came
with your computer.

 
 
 

Installing HyperCard on a hard disk
Using HyperCard on a hard disk system is easy. Just copy all the files
on all the disks except HyperCard Startup to your hard disk.

“+ Hard disk set up? This section assumes your hard disk is already
set up. If it isn’t set up yet, see the Macintosh Utilities User's

Guide that came with your computer and your hard disk owner’s
manual for instructions.

= To install HyperCard on a hard disk:

1. Start your computer as you normally would.

2. Insert the disk labeled HyperCard & Stacks into your
computer’s built-in 3.5-inch disk drive.

It doesn’t matter which drive you use ifyou have two 3.5-inch disk
drives.

3. Open the HyperCard & Stacks disk.

To open the disk, click its icon and choose Open from the File
menu. Double-clicking the disk also opens it.
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. Choose Select All from the Edit menu, then drag all the files
to your hard disk.

See the owner’s guide that came with your computer if you don’t
know how to drag toa disk.

. Drag the HyperCard & Stacks disk to the Trash and insert the
HyperCard Help disk.

Dragging a disk to the Trash ejects the disk and removes its icon
from the desktop. (It does not erase the disk.)

. Open the disk, choose Select All from the Edit menu, and
drag to the hard disk.

. Drag the HyperCard Help disk to the Trash and insert the
HyperCard Ideas disk.

. Open the disk, choose Select All from the Edit menu, and
drag to the hard disk.

Drag the HyperCard Ideas disk to the Trash.

HyperCard is now installed on your hard disk and ready to go.

 

 

 

How this guide is organized
This section describes all the chapters and appendixes in this guide.

O Chapter 1, “Browsing and Editing,” is a tutorial on getting
around in HyperCard. It teaches you how to use some of
HyperCard’s most important features.

Chapter 2, “Customizing,” presents two more tutorials. These
tutorials teach you how to customize HyperCard documents for
your own use.

Chapter 3, “Home,” gives details about this all-important
HyperCard document.

Chapter 4, “Text in HyperCard,” provides information on
HyperCard fields (the places you create to hold text), how to
enter text into those fields, and how to control text styles.

Chapter 5, “Graphics in HyperCard,” pulls together
HyperCard’s graphic elements and suggests ways to use various
HyperCard tools and commands to produce finished pictures.

How this guide is organized xix
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Warning

Definitions of terms and
references to other parts of the
book sometimes appear in the
margin.

O Chapter 6, “Menu Commands,” gives detailed descriptions of
every HyperCard menu command. This chapter also includes
step-by-step instructions for carrying out HyperCard’s most
common procedures.

O Chapter 7, “Keyboard Commands,” summarizes all the
HyperCard commands and features that you can execute directly
from the keyboard.

O Appendix A, “Common HyperCard Messages,” lists the most
common instructions you send to HyperCard using a feature
called the Message box. (This appendix is for advanced
HyperCard users.)

O Appendix B, “HyperCard Disks,” gives a listing of the
documents and other files on each of the disks that comes with
HyperCard.

 

 
 

Some conventions used in this guide
Several special elements in this manual’s text are designed to make
learning easier.

* By the way: A note like this presents additional information or
interesting sidelights.

 

Be sure to read every item that’s labeled this way, with a tag
in the margin.

 

 

Warnings like this alert you to situations where you could
damage software or lose data.

 

Terms in boldface type are defined in the glossary. Sometimes the
definition or additional information about such terms also appears
in the margin.

A special typeface indicates characters that you should type:

It looks like this.
mu How-to sections are indicated by a red symbol.
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On-line help is assistance you
can get from an application
program while it’s running.

 
 
 

About on-line help
HyperCard’s Help system gives you immediate, on-line assistance
whenever you get stuck. Use it when you’ve forgotten some
procedure you read about in this book, or when you want a quick
overview of a feature that’s unfamiliar to you.

 

On-line help versus this guide
On-line help in HyperCard differs from the help you'll find in this
user’s guide in these key ways:

O On-line help is brief; this guide is detailed. Turn to this guide
when you need an in-depth discussion of a topic.

O On-line help might have information on a feature added after
this guide was written.

O On-line help lets you get to the information you need by clicking
buttons and by doing electronic searches. It uses HyperCard’s
best features to explain HyperCard, and stands as an example of
what HyperCard can do. To find information in this guide, you
look up the subject in the table of contents or in the index and
(alas) manually turn to the referenced page.

 
 
 

Where to get HyperCard stacks
Stacks are collections of information created by and used with
HyperCard. You can create stacks yourself, or you can get them
from a variety of sources.

O You'll find Stackware™ documents for sale at your local
computer software store. Stackware products are expressly
created for use with HyperCard.

OQ Check with your local Macintosh user group to find out the
meeting time of the HyperCard special interest group. Members
often exchange member-created stacks with each other.

0 Most on-line electronic information services like CompuServe
and GEnie have Macintosh special interest groups. These groups
have (or soon will have) stacks you can get free, except for the
service’s time charges.

Where to get HyperCard stacks Xxi



 

 

 

User groups
Ask your dealer for the name of a Macintosh user group near you. If
you live in the United States, you can call 1-800-538-9696 for the
name, address, and telephone number of up to three Macintosh
user groups in your geographic area.

Outside the United States, ask your dealer or get in touch with

The Boston Computer Society
One Center Plaza
Boston, Massachusetts 02108
(617) 367-8080

or

Berkeley Macintosh User Group
1442-A Walnut Street #62
Berkeley, California 94709
(415) 849-9114

Either of these organizations can provide you with the name of a
Macintosh user group near you. You can also join either of these
groups or ask them for information on starting your own Macintosh
user group.

 

 

 

Advanced documentation
This guide covers everything you need to know to use HyperCard
effectively up to the scripting level. For details about scripts and
other advanced HyperCard features, see the HyperCard Script
Language Guide, available from:

Apple Programmer’s and Developer’s Association
290 SW 43rd Street
Renton, WA 98055
Telephone: (206) 251-6548
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HyperCard icon

Important

This chapter teaches you HyperCard basics. It covers things
everyone must know to use HyperCard. You'll learn how to
O use some important HyperCard documents (called stacks)
O roam through HyperCard stacks

QO search for information

O edit text on cards (HyperCard’s basic unit of information)
O create places to hold new information

 
 

 

Getting the most out of the tutorials
Throughout this chapter and Chapter 2, you’ll see one or more
boldfaced sentences that begin with the symbol =. The symbol
marks an action for you to do, to give you some experience working
with HyperCard. Follow any numbered boldfaced steps in order.

 
 
 

Getting started
Before you can start your tutorials, you need to get HyperCard up
and running. You start HyperCard the same way you start any
Macintosh application.

= Start HyperCard:

If you’re starting HyperCard from a hard disk:

1. Click the HyperCard icon in the Finder to select it.

2. Choose Open from the File menu.
Or double-click the icon to open it.

If you’re using HyperCard with 3.5-inch disk drives:

1. Start the computer.
If the computer is already on, choose Restart from the Special
menu. (If you don’t have Restart, choose Shut Down.)

2. Put a copy of the disk labeled HyperCard Startup into the
startup drive.

 

HyperCard cannot work with a locked disk (or locked volume).
Make sure that any disk you want to use is unlocked.
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Macintosh Il
 

Do not use the HyperCard Startup disk. Use your regular startup
disk, and put a copy of the disk labeled HyperCard & Stacks
Into the other drive, skipping Step 3. Open HyperCard by
double-clicking Its Icon. Swap disks as needed to get to the
Help Stacks or Ideas Stacks folders while doing the tutorial.
 

3. Put a copy of the disk labeled HyperCard Help into the other
drive.

HyperCard starts automatically. You'll see the screen in Figure 1-1.

Figure 1-1
Starting HyperCard

 

 

 

Browsing
Before you start to explore HyperCard, you’ll need to know a few
terms—specifically browsing, card, stack, button, and tool.

Browsing is HyperCard’s term for roaming around cards and
stacks.

A card is HyperCard’s basic unit of information. A card fills the
entire screen. (On larger-screen Macintoshes like the Macintosh II,
a card appears in a window—you have some extra room on the
edges.) What you see on the screen now is a card; Figure 1-2 shows
some others.

Browsing 3



Stack icon

Browse tool

Figure 1-2
Some cards—HyperCard’s fundamental units of information

A named collection of cards is called a stack. You can think of a
stack as a HyperCard document. Cards in a stack usually (but not
necessarily) are based on the same theme. An icon for each stack
appears in the Finder.

You do much of your browsing in HyperCard by clicking buttons.
You activate buttons with the Browse tool.

m Move the mouse around.

The little hand you see moving around when you move the mouse is
the Browse tool. HyperCard has many tools that you use to look for
and to create information. The Browse tool is the tool you'll use
most often.

 

Letting HyperCard teach you
You can learn a lot about HyperCard just by using it. This is
especially true when you go through the on-line Introduction.
(On-line means presented by the computer, as opposed to
presented by this user’s guide.)
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mu Go through the on-line introduction:

1. Move the mouse until the Browse tool is on the Intro icon,
and click.

 

Intra (It’s near the screen’s left corner.) In a few seconds, the card in
Intro icon Figure 1-3 appears.

 

 

 

“ey ( What is HyperCard? )

 

{ Goback )

Figure 1-3
First card of the on-line Introduction

<a 2. Click the button labeled “What is HyperCard?”

During the introduction you might want to review a card you’ve
Previous card arrow already seen. To do that, click the left arrow button to go back

through the Introduction stack one card at a time.

“ You can always go back: Another way to see the previous card is
to press the Tilde key. Stacks in HyperCard often link to each
other (a concept you'll learn more about later). While the left
arrow brings you to the previous card in the stack you’re looking
at, the Tilde key brings you to the last card you saw, no matter
what stack it was in.

m= When you get to the card titled “What Next?” in the on-
line Introduction, click “Home to explore on my own”; then
come back to this guide and continue reading.

Browsing 5



 
 
 

Home
You should be back at the Home card, the card you saw when you
started HyperCard. You'll see Home more than any other card.
Home is your base of operations, the jumping-off point for all your
explorations in HyperCard.

Figure 1-4
Home card

The Home card, first card in the Home stack, is a visual directory
for your most important cards and stacks. Clicking one of the
pictures here brings you to the card that the picture represents.
(Each picture is actually a button.) In Chapter 2, you'll learn how to
add pictures representing your own cards and stacks to the Home
card.

To get back to Home at any time, choose Home from the Go menu.

“* About the Go menu: The Go menu is HyperCard’s navigation
panel. You can use it to go from one card to another within a
stack, to trace your way back through cards and stacks you’ve
already seen, and to get help whenever you need it. In the early
stages of working with HyperCard, you’re likely to use the Go

Go menu menu more than you'll use any other menu.
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In a few moments you'll use the Home card to move to the Address
stack. The Address stack is your personal telephone directory.

As you’re learning how to use the Address stack, you'll pick up a
valuable HyperCard skill—how to look for information by searching

Address icon for specific text rather than browsing from card to card.

 

 

 

Using the Address stack
The Address stack holds addresses and phone numbers. You look
for a specific name, address, or phone number using the Message
box.

m Open the Address stack and look for a name:

HyperCard comes with some sample Address cards; in this
exercise, you'll look for a card with the name Steve on it.

1. Click the button that looks like an address card.
The card in Figure 1-5 appears.

Figure 1-5
First card in Address stack
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Spinning beach ball

2. Choose Find from the Go menu.

The Message box appears near the bottom of the screen. (See

Figure 1-6.)

Figure 1-6
The Message box

3. Type Steve and press Return.

The insertion point is already positioned between quotation
marks for you. (You have to type between quotation marks for

in Figure 1-7 appears.

  

 

Find to work.) The pointer turns into a beach ball; it spins while
HyperCard looks for a card with the name “Steve” on it. The card

 
 

Figure 1-7
Finding a card

“ “Tt beeped at me!” If the Macintosh sounds a beep, reset the
Message box by choosing Find from the Go menu and once again
type what you want to search for. HyperCard beeps to let you
know it can’t find what you ask for. Sometimes this means that you
spelled something incorrectly, and sometimes it means that what
you asked for isn’t in the stack.
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HyperCard looks for the first card with text that starts with what you
typed, and puts a box around the word. Pressing Return again makes
HyperCard look for the next card with Steve on it.

m Look for part of a word or name:

HyperCard looks for what you ask, even if what you type is part of
another word. You can see this work if you type ST into the
Message box.

1. Reset the Message box by choosing Find from the Go menu
again.

Each time you choose Find, HyperCard highlights any old text
between quotation marks. The highlighted text will be replaced
by any new text you type.

2. Type ST into the Message box and press Return.

Press Return a few more times, and see the results you get.

Figure 1-8
Finding other words that start with ST

You can learn more about searching later by reading the section
called “Find” in Chapter 6.

Using the Address stack 9
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A quick browse/search recap
Find is another new way for you to get around in HyperCard. It’s
different from the other ways in that it’s more specific—you have to
know what words you want to find in order to use it.

You now know several ways to get around in HyperCard:

O click buttons with the Browse tool

O make choices from the Go menu

O search for a specific word using the Message box

 

 

 

Changing text
In this section you'll change the information on one of the cards.
(In the next section you'll personalize the Address stack by putting
in the names and phone numbers of people you know.)

m Use the Message box to reach a card; then change the
card:

1. Choose Find from the Go menu.
When the Message box is already visible, choosing Find resets
the Message box, highlighting anything you’ve typed between
quotation marks.

2. Type Scribble and press Return.

The beach ball spins while HyperCard looks for a card with the
word “Scribble” on it. (Figure 1-9 shows the card.)

3. Select the name “Throckmorton” by dragging across it.

Dragging is a standard Macintosh technique that you’re probably
already familiar with: Position the I-beam pointer at the
beginning of the word. Press and hold the mouse button while
you “drag” the pointer across the word. Release the mouse
button at the end of the word. If you’ve done this successfully,
“Throckmorton” is highlighted.

4. Type the name John.
The new name replaces the old one.
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Name and address goes here...

..perhaps with a comment or two.

Phone number goes here.

 

 

Figure 1-9
Changing an address card

You can select any text (except Paint text, described in Chapter 6)
by dragging. Then type new text to replace it.

For more details on editing text, see the section on the Edit menu in
Chapter 6.

 
 

 

Adding a card
You can personalize all the cards in the Address stack by editing out
the old text and adding new text. But you’ll probably find it easier to
create new cards to hold your information. You add a card to any
HyperCard stack by choosing New Card from the Edit menu. Try it
now.

= Add a new card to the Address stack:

1. Choose New Card from the Edit menu.

A new card appears, ready for you to add your own information.
(See Figure 1-10.)

2. Type your name and address.

3. Press the Tab key to move the insertion point to the phone
number line, and type your phone number.

The Tab key moves you from field to field on a card in the
Address stack. (A field is where you type text.) This card has three
fields—name and address, phone number, and date.

Adding a card 1]
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4. Choose New Card again and add the name, address, and
phone number of some close friend.

Or, if you want to get down to business right away, type in contact
information for your neighborhood pizza delivery restaurant or
some other vital service.

Figure 1-10
A new address card

Continue to add cards if you want. When you've finished, go on to
learn about how cards are arranged in a stack.

“ Don’t worry about alphabetical order: You can create a new card
wherever you want in the stack. In a few moments, you'll
alphabetize the stack with the click of a button.

 

How cards are arranged in a stack
When you choose New Card, HyperCard adds a new card to the
stack immediately after the one that’s on the screen.

If all the cards in a stack are created at the same time, they appear in
the order of their creation. If you choose New Card while you're
near the middle of the stack, that’s where the new card goes—in the
middle of the stack.
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Arrow to next card

Sort button

Go through the stack one card at the time to see the
stack’s “natural order”:

. Get to the first card in the stack by choosing First from the
Go menu.

. Click the right arrow (the one that points to the right, next
to the left arrow) to move through the stack, one card at a
time.
Eventually you'll come to the new cards you created. (Most cards

in the stack are alphabetized; your cards will probably be out of
order.)

. Keep clicking the right arrow until you come back fo the first
card in the stack.

Think of the cards in a stack as being looped on a ring; when you
reach the end, you start over again. (See Figure 1-11.)

Figure 1-11
Cards ringed in a stack

4. Sort the stack by clicking the Sort button.

A dialog box appears with buttons for sorting by first name or last
name. (See Figure 1-12.)

Figure 1-12
Sort dialog box

How cards are arranged in a stack 13



Quick View button

Important

5. Choose Last Name fo sort alphabetically by last name.
The beach balls spins while HyperCard completes the sort.

6. Go through the stack quickly by clicking the Quick View
button.

(Click the mouse to stop the display.) You'll see the new cards
you added sorted into their proper alphabetical place.

“ Getting rid ofunwanted cards: The Address stack comes with a
number of sample cards. You can eliminate the cards you don’t
want: move to an unwanted card and choose Delete Card from
the Edit menu.

 

You don’t have to save your changes; HyperCard does it for
you automatically. As a result, there is no Save command in
HyperCard. You'll read more about this in Chapter 6.

 

 

 

 

Explore the Help stack
Before you read any more of this book, explore the Help stack,
HyperCard’s ever-ready help system.

um Choose Help from the Go menu to get to the Help stack.

(See Figure 1-13.)

The Help stack briefly explains all of HyperCard’s features. It’s not
only an extremely useful information source that’s always available
but also an excellent example of the kinds of things you can do with
HyperCard.

’

To use the Help stack, click one of the tabs along the card’s bottom.
(Each tab is actually a button.)
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HyperCard
Help

 

Olntroduction

 

Introduction

 

 

Figure 1-13
Help stack’s first card

Click the Exit tab at the bottom of a card when you’ve finished using
Help; you'll return to the Address stack at the card that was on the
screen when you chose Help.

 

 

 

Recent: Seeing where you’ve been
When you used the Address stack, you saw how cards are arranged in
a stack—one after the other in a loop, as if they’re held together by a

ring. You clicked the left and right arrows to move from card to
card.

When you chose Help from the Go menu to get to the Help stack,
and later when you pressed the Exit button to come back to the
Address stack, you saw that you can move between stacks as easily as

you move between cards.

Recent: Seeing where you've been 15



Click any card to go to it. —————_
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As you go from card to card and stack to stack, HyperCard
automatically keeps a record of where you’ve been. Recent shows
(in miniature) up to the last 42 cards you looked at. It’s a great place
to go when you need to retrace your steps. (When you've passed
through more than 42 cards, the top row of Recent rolls off to make
room for a new row of cards at the bottom.)

mu Choose Recent from the Go menu.

(See Figure 1-14.)

 
Figure 1-14
Recent

“ Recent shows whatyou've seen: A stack might have hundreds of
cards in it, but if you looked at only three cards in that stack,
Recent shows only the three cards you looked at.

You can go directly back to any card represented in miniature in
Recent. Try it now.
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u Go directly to a card shown on Recent:

1. Click any card’s miniature picture.

(Each picture is actually a button.) You immediately go to that
card.

2. Choose Recent again on the Go menu.

A rectangle encloses the image of the card you went back to.

3. Click the image of the card you were on when you first
chose Recent.

  

hat you've learned sofar
In the short time you’ve used HyperCard, you’ve learned quite a lot.
Among other things, you know

OC how to use the Address stack

how to get from card to card and stack to stack using the Browse
tool

O

how cards are arranged in a stack

how to see where you’ve been, and how to go back there

how to search for text

how to use the Home card as your base of operations

yo

8

how to use several menu commands

You already know enough to use most of the stacks that come with
HyperCard and that are available for sale and for trade. (See
“Where to Get HyperCard Stacks” in the Preface for some specific
places to get more stacks.) Most stacks that require further
instructions have a card or two telling you what you need to know.

What you've learned so far 17



Browse tool

Go menu

 

How to get there from here
Here’s a quick summary of the ways you’ve seen so far to find your
way around HyperCard. They all come in handy at one time or
another.

Browse tool Click buttons with it to move to other cards.

Home Choose Home from the Go menu to reach
this graphical directory of stacks; then click
the button for the stack you want to go to.

Recent Choose Recent from the Go menu for a

pictorial summary of cards you’ve seen; then
click the picture of the card you want to go to.

First Choose First from the Go menu to get to the
first card in a stack.

Last Choose Last from the Go menu to get to the
last card in a stack.

Find Choose Find from the Go menu; then type
what you want to find and press Return.

“+ Not sure where the buttons are?Hold down the Command and
Option keys at the same time, and HyperCard lets you peek at
buttons on a card.

 

What to do next
You can continue to work with the Address stack; you can go on to
explore other stacks (Appendix B has a descriptive list of all the
stacks that come with HyperCard); or you can go on to Chapter 2 for
tutorials on customizing stacks to your own liking.

To explore more stacks or to go on to Chapter 2, be sure to start
from the Home card.

m Go back to the Home card.
You go back to the Home card by choosing Home from the Go
menu. (You'll learn more about the Home card in Chapter 3.)

“ Another way to get Home: Anytime you see a picture of a house
on a card, you can click the house to go to the Home card.
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Sometimes the waya stack looks isn’t to your liking. The picture you
see on a particular card isn’t suited to your purposes, ora field is in
an inconvenient place or its text is in a font or style that you don’t
like. This chapter shows you how to use HyperCard’s features to
customize cards and stacks.

“ Customizing isn’t required: You don’t have to customize a stack
to use it. These tutorials are for people who enjoy modifying
things to meet their specific tastes. It’s OK to leave stacks as they
are.

This chapter has two tutorials. The first, “Painting,” goes over some
of HyperCard’s features for editing pictures. You'll learn how to

0 copy pictures from one card to another

O edit the pictures you copy

O create new pictures using HyperCard’s painting tools

The second tutorial, “Authoring,” includes the basic elements of
stack creation. You'll learn how to

O create new stacks

0 copy pictures, buttons and fields from existing stacks to your new
stack

O Move buttons around on a card

The tutorials are separate. If you aren’t interested in authoring yet,
just do the Painting tutorial and go on to explore HyperCard.

 

 

 

Painting
HyperCard provides a variety of tools for changing the way a card
looks. Chief among these are the Paint tools; you use them to create
and to change pictures.



Paint tool at work  

 

 

 

 

 

  

Paint tools
 

 

   

 

Figure 2-1
Paint tool at work

 

Setting user level to see the Tools menu
You choose the tool you need from the Tools menu. To see the
Tools menu, you must tell HyperCard you're ready to use it.
(HyperCard keeps menus out of sight until you need them.)

You tell HyperCard that you’re ready to work with new tools by
changing your user level on the User Preferences card. It’s the last
card in the Home stack.

= Move to the User Preferences card of the Home stack:
1. Start from the Home card.
2. Choose Last from the Go menu.

The Last command brings you to the last card of the current
stack. The User Preferences card appears. (See Figure 2-2.)

Painting Zi



Figure 2-2
User Preferences card

HyperCard has five user levels. Each level incorporates everything
from previous levels, plus adds new abilities. When you first start
HyperCard, you're at the Typing level. At this level you can wander
through HyperCard’s stacks and do searches, and you have the
ability to make changes to text.

Now you need to be able to use the Paint tools—an ability that
comes with the next level.

u Click the button labeled Painting.

(HyperCard stays at your new level until you change it, even if
you quit HyperCard and restart.) A new menu appears in the
menu bar.
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 Ignore this for now —

Figure 2-3
Changing user levels

 

Changing the way a card looks
You use the Paint tools on the Tools menu to change a card’s
picture.

More about these tools - <—
in the next tutorial. SeTPR

Browse tool selected. ”
(It’s the one you're
using now.)

Paint tools

Figure 2-4
Paint tools
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HyperCard comes with a stack specifically included for you to
practice your painting on, the Quotations stack. You'll go to this
stack using a command that’s new to you—the Open Stack
command.

= Get to the Quotations stack:

1. Choose Open Stack from the File menu.

The directory dialog box appears, letting you select the stack you
want to work with.

Ls). Select Quotations and click Open.
o“ A quick diversion: The Quotations stack is a collection of

aphorisms and famous sayings. Guess the author of the
quotation, then click the “Who says?” button to see if you were
right. (Click it again to hide the answer.) When you want to stop
the game (or you run out of quotations), come back here.

 

Copying a picture from another card
Cards with pictures on them are visually more interesting than cards
with just text. You can adda picture to a card by copying an image
from another card, or by drawing a picture yourself.

Copying an image is a simple operation. To get some practice
doing it, you’ll copy the images of a loaf of bread and a jug of wine
froma card in the Art Ideas stack; then you'll paste the images onto
a card in the Quotations stack.

mu Copy an image from one card to another:
1. Start with the card in the Quotations stack that reads

“A book of verses underneath the bough.”

To find it, Choose Find from the Go menu, type book of
verses, and press Return. Your next step is to go to the Art
Ideas stack to copy pictures.
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Figure 2-5
Book of verses card

2. Choose Open Stack from the File menu.

The Directory dialog box appears so that you can choose the
stack you want to open. The Art Ideas stack is in the Idea Stacks

folder on the HyperCard Ideas disk. If you’re using HyperCard
from 3.5-inch disks, you'll have to replace the Help disk
currently in the drive with the HyperCard Ideas disk. To do that,
click the eject button on the Directory dialog box and swap
disks.

3. Select Art Ideas and click Open.

You're now at the first card of the Art Ideas stack.

4. Move to the card labeled “Restaurants, Food, Recipes.”

To get to this card, choose Find from the Go menu, type the
word Food, and press Return.
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Figure 2-6
Food card

Selection rectangle

Start dragging here.

Release the mouse button
when you've selected
what you wart.

26

5. When you find the picture you want, choose the Selection
tool on the Tools menu.

The Selection tool lets you select a part of a picture to work on.
(When you choose this tool, some new menu titles appear on
the Title bar; ignore them for now.)

. Drag diagonally across the images of the loaf of bread and
the bottle of wine to select them; then release the mouse
button.

The dotted lines move when you release the mouse button to
show that the selection is active. Don’t worry if you select too
much, you can edit it later. If you make a mistake, choose Undo
from the Edit menu and start dragging again.

Figure 2-7
Selecting a picture
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. Choose Copy Picture from the Edit menu.

What you copy goes onto the Clipboard, a holding place for cut
or copied text and graphics.

. Choose the Browse tool from the Tools menu.

. Choose Recent from the Go menu.

10. Go back to the Quotation card by clicking its image on
Recent.

 Click here to go back to Quotations.

Figure 2-8
Going back to the Quotations stack using Recent

i:

12.

13.

Choose Paste Picture from the Edit menu.

The material you copied to the Clipboard is pasted to the
Quotation card. (See Figure 2-9.)

Drag the pasted picture where you want it to go; then
click anywhere outside the picture to set it in position.

To drag the picture, move the pointer anywhere inside the
selected area, hold down the mouse button, and move the
mouse. If you make a mistake, choose Undo from the Edit
menu.

Experiment with the Paint tools to touch up your picture.
(See “Some Paint tool tips” in the next section.) Its OK to make
a mess; that’s what this stack is for. You can’t hurt any other
stack while you’re in this one.
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Paste it here.
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Figure 2-9
Pasting a copied image

You can paste as many pictures onto a card as you want. Use any of
the Paint tools to modify the picture, or paint your own picture from
scratch.

 

Using the Paint tools
This is a great time to experiment with the Paint tools.

m Add a new card or two to the Quotations stack:

1. Select the Browse fool.

2. Choose New Card from the Edit menu.

A new card appears.

3. Type your favorite quotation on the left page.

Press Tab to set the insertion point at the top of the page.

4. Click the Who Says button.

An empty box appears. (It’s actually a field—a place to hold
text—ready for you to type into.)

5. Click inside the box and type the name of the quotation’s
source or author.

When you’ve finished typing, click the Who Says button again to
hide the box.
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This draws thin,
free-form things.

Draw lines with this.

This erases mistakes.

Double-click this
to choose a new
brush shape.

Use this to fill in
a closed shape
you've already
drawn.

The more you spray,
the more the pattern
shows.

6. Construct a picture on the right page using the Paint tools.

(See “Some Paint tool tips,” below.) You can borrow from other
stacks to do it. Don’t worry if your name isn’t Rembrandt; this is
all just for practice (and for fun).

Some Paint tool tips

To select a Paint tool, just drag to the one you want on the Paint
menu and then experiment. Most tools start to work when you press
down the mouse button and drag, and stop when you release the
mouse button. Here are some tips on using Paint tools:

O Select a pattern from the Patterns menu to use with the Brush,
Bucket, and Spray tools.

O Choose Brush Shape from the Options menu and click the shape
you want. Each shape gives a different effect, so experiment with
them all.

O Use the Brush or Pencil for freehand work.

O The Eraser—erases.

Click to choose
a pattern for painting
or to fill in shapes.

Use these tools to
draw circles, squares,
rectangles, and other
shapes.

Choose a pattern
to work with these tools.

Figure 2-10
Using the Paint tools and Pattern menu
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Experiment with the other tools to see what they do.

“ Convert menus to palettes: You can “tear off’ both the Tools
menu and the Patterns menu so that you can have constant access

to them as you work. Just drag through them, past the bottom or
off to one side; then leave them where you want them. When they
get in your way, move them by dragging their top bars. Click
their close boxes to make them go away.

 

Figure 2-11
Tearing off a menu

 

Experiment time
Experiment for as long as you want with the Paint tools. Make a mess

on the screen. Create new quotation cards or modify old ones.
Practice copying graphics from other stacks.

“ A quick cleanup trick: If your screen gets really messy and you
want to clean it up, double-click the eraser on the Tools palette:
Everything you painted gets erased. If you double-click by
mistake, choose Undo from the Edit menu.
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You can read more about the Paint tools and what they do in the
“Tools Menu” section of Chapter 6, throughout Chapter 5, and in
the Menus section of the Help system.

= Go back to the Home card when you’ve finished
experimenting.

When you’re ready, go on to the final lesson, Authoring, and learn
how to create stacks of your own.

 

 

 

Authoring
You've learned how to get around in HyperCard, and you’ve had
some experience in changing text and graphics on a card. In this
section you'll learn HyperCard’s real power—changing how things
work.

“ You don’t have to be an author: It isn’t necessary for you to learn
how to changea stack radically in order to use HyperCard
effectively. You already have all the information you need to get
a great deal out of HyperCard. The rest of this chapter is for you if
have special needs that the stacks that come with HyperCard
don’t meet, or if you like to do things your own way.

You'll need to change your user level to becomea stack author.

m Change your user level to Authoring on the User Preferences
card:

1. Choose Home from the Go menu.

If you’ve come here directly from the previous tutorial, the
Home card is probably already on the screen.

2. Choose Last from the Go menu.

You move to the User Preference card, the last card in the Home
stack.

3. Click the button labeled Authoring.

A new title—Objects—appears in the menu bar. (See
Figure 2-12.) You’re now at the highest level that this guide
takes you to.
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Another new menu  

 A high user level

To Do icon

Figure 2-12
Moving up to Authoring

Before you continue, go back to the Home card.

m Choose Home on the Go menu.

“ A browsing shortcut: You can get to the Home card from User
Preferences by clicking the right arrow (the one pointing to the
right, next to the left arrow at the bottom of the card). Here’s
why: Home is the first card in the Home stack, and User
Preferences is the last card in the stack. Because you can think of
the cards in a stack as being on a ring, you can also think of the
first card in the stack as being after the last card. Try it.

 

Making a new stack from an existing one
You can make a new stack based on an old one.

When you make a new stack based on an existing one, the new stack
takes on the basic characteristics of the current card’s background.

In this exercise, you’ll make a new stack based on the To Do card.
(You type all the things you’ve got to do today on the To Do card.)

= Move fo the To Do card by clicking its icon.

The card in Figure 2-13 appears.
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You use the current stack’s
design for the new stack if
this box is checked.
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Figure 2-13
A To Do card

You'll use the basic design of this card for your new stack.

= Create a new stack based on the To Deo stack:

1. Choose New Stack from the File menu.

The directory dialog box appears, asking you to name the new
stack. (See Figure 2-14.)
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Figure 2-14
Making a new stack
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2. Type My To Do stack and click New.

When you choose New Stack from the File menu, you can use the
basic design of the card that’s on the screen for the new stack.
(You don’t copy any of the stack’s data, just the stack’s template.)

You now have a new stack, ready for you to modify and to fill with
information. (See Figure 2-15.)

Figure 2-15
First card in new stack

 

Moving buttons
Customizing a stack is a matter of deciding what you like and don’t
like about a design, and then changing the design. In this exercise,
you'll change the design by moving a button around.

= Move the Telephone button to the top-left side of the page:

1. Select the Button tool from the Tools menu.

(It’s the tool in the middle of the top row.) A box appears aroundit F

oa all the buttons on the card.

2. Move the pointer to the center of the Telephone button,
and press and hold the mouse button.
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. Drag the Telephone button to the left until it aligns with the
left edge.

. Release the mouse button.

The moving dotted line around the button lets you know the
button is still selected. (When you click another button or when
you select another tool, the dotted line goes away.)

The top of the card should look like Figure 2-16.

Figure 2-16
To Do card with Telephone button moved

When you move a button, the only thing that changes is its position,
what the button does remains the same.

 

Deleting buttons
Sometimes the buttons you find in a design don’t do what you want.
For this exercise, assume that the only button you want at the top
right of the card is the Home button.

Delete all but the Home button from the top of the card:

1. Select the Button tool from the Tools menu.

If you’ve been following along, you’ve already selected this tool.

. Click the Address stack button.

The box around the button changes to marching ants.

. Choose Clear Button from the Edit menu.

The button disappears.

. Repeat steps 1 and 3 for the rest of the buttons you want to
remove.
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Button Ideas button
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Copying buttons from another stack
In the Painting tutorial, you saw how to borrow pictures from other
cards to use on your own cards. You can borrow buttons in the same
way.

m Add a Help button by copying it from the Button Ideas stack:
1.

10.

Go to the Home card.

You can select the Browse tool, then click the Home button on
the top of the card you’re on.

. Click the Button Ideas icon.

(You might have to swap disks to get to this stack.) The card that
appears is actually an index.

. Click Text Buttons.

The card in Figure 2-17 appears.

. Select the Button tool.

Now you're ready to select a button and copy it.

. Click the button marked Help.

When you're using the Button tool, you click a button to select it
rather than to make it carry out an action.

. Choose Copy Button from the Edit menu.

. Get back to your To Do card using Recent from the Go
menu.

Your To Do card reappears. Now you can paste the button you
just copied.

. Choose Paste Button on the Edit menu.
The button you just copied appears.

. Drag the button where you want it to be.
A good place for it is next to the Home button. (See
Figure 2-18.)

Click the Browse tool to set the button in place.
Whenever you need help, you can click the Help button. (Try it
out, if you like. Press the Exit button at the bottom of any Help
card to get back.)
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Figure 2-17
Assorted buttons

 

Changing a field’s size and position
You add text to a card by typing into fields with the Browse tool
selected. The new To Do stack has three fields on it. To see them,
click the Field tool on the Tools menu.
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Figure 2-18
Help button pasted, fields visible
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You can change the size of a field or move it easily.

mu Change the size of the field on the right:

1. With the Field tool still selected, click anywhere within the
card’s right field to select the field.

2. Drag the lower right corner of the field to the left to make the
field narrower.

Make it about 1/3 the width that it is now.

mu Move the field you just changed by placing the pointer in its
center and dragging the field to the right.

Move it close to the right edge. (See Figure 2-19.)

Figure 2-19
Shrinking and moving fields
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Copying a field ae

Copyinga field is as easy as moving one. And as long as you’ve got
the room...

m Make a copy of the field on the right:

1. Select the field on the right by clicking it.

You know it’s selected because it’s surrounded by a moving
dotted line.

2. Choose Copy Field from the Edit menu.

3. Choose Paste Field from the Edit menu.

The pasted field is lying over the original.

4. Drag the copied field to the left.

Figure 2-20
Copying a field

You can also copy fields from other cards, just as you can copy
buttons and pictures.
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Background is the name for
common elements shared by a
number of cards.

This is what you'd see
on the screen—a
combination of the background
and the part unique
to a given card.

All this is on the background. ————

 

 

Cards versus backgrounds
A number of cards can share the same background. When you
chose New Stack to create the stack you’ve been working on, you
copied the background of the card that was on the screen at the
time. Figure 2-21 shows a card witha distinct background part.

 

 

This part changes
from card to card.

Figure 2-21
A background shared by a number of cards

Buttons, fields, and pictures can live on the background of a card,
or on the card itself. When they’re on the background, these
objects—buttons, fields, and pictures—are shared by all cards
associated with that background. When they’re on the card, they’re
specific just to that card.
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No card field on this card.
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Figure 2-22
Background versus card field

To see what this is about, you'll first have to make a new card for the
stack you’ve been working on.

m Make a new card for the stack by choosing New Card from
the Edit menu.

You'll notice that the Help button you pasted appears just on the
first card—it wasn’t duplicated when you chose New Card; and the
field you duplicated was only duplicated on the original card. You
created a card field and a card button, objects that work only on a
single card; contrast that with background fields and background
buttons, objects common to all cards that share a particular
background. (With the Browse tool selected, click the left arrow and
right arrow buttons at the bottom of the card to go back and forth
between cards.)
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 Background has
no Help button on it.

Copied button  

Duplicated field  

Background has  

only one field on if.

Diagonal lines tell you
that you're looking at
the background.

Figure 2-23
First card versus second card

The card on the right in Figure 2-23 is the one you just made with
New Card. Its features all come from the background.

= Look at the background for these cards:

1. Be sure you’re on the first card in the stack by choosing First
from the Go menu.

2. Choose Background from the Edit menu.

The background appears. (See Figure 2-24.)

Figure 2-24
Background

If you switch back and forth between the background and the card
by choosing the Background command several times, you’ll see
the button and the extra field disappear and reappear. (The
Background command is like a push-button light switch—if
you're looking at the card when you choose it, you switch to
the background; if you’re looking at the background when you
choose it, you switch to the card.) You can tell when you’re in the
background because the menu bar in the background has diagonal
stripes.
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“ You can edit backgroundfields and buttonsfrom the card: You
can make an existing background field or button smaller or
larger or delete it but you can’t create new background fields or
buttons unless you’re in the background. That’s why the field
you made smaller remains smaller when you look at the
background, and the buttons you deleted remain deleted.

To makea field, button, or picture common to a number of cards,
create it (or paste it or duplicate it) in the background.

You can move the duplicated field and the Help button from the
first card to the background. When you do that, the extra field and
the button will show on both cards, and on any new cards that you
create.

Lis

Move the duplicated field and the Help button to the
background:

With the Field tool selected, click inside the duplicated
field.

Be sure you're on the card and not in the background—you
shouldn’t see any diagonal lines in the Menu bar.

. Choose Cut Field from the Edit menu.

The field disappears.

. Choose Background from the Edit menu.

The background appears—you see the diagonal lines again.

. Choose Paste Field from the Edit menu.

The field reappears, now part of the background.

. Choose Background from the Edit menu again.
You're back at the card—the diagonal lines in the Menu bar
have disappeared.

. Select the Button tool and click the Help button.

You'll know it’s selected because a moving dotted line
surrounds it.

. Choose Cut Button from the Edit menu.

The button disappears.

. Choose Background from the Edit menu.

The background appears—you see the diagonal lines again.

Choose Paste Button from the Edit menu.

The button reappears, now part of the background.
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New Button button

10. Choose Background from the Edit menua final time.

You end up with all buttons and fields in the background. To prove
it, create a new card.

m Choose New Card from the Edit menu.

The new card will have two fields on the right side and a Help
button at the top.

“ A final note aboutfields: What you type ona field created in the
background changes from card to card, although the field’s size
and position remains constant on all cards associated with that
background. When you create a field on a card, the field stays just
with that card—and, of course, so does what you type in it.
Experiment by creating a few card fields in the stack you just
created to see what happens.

 

Experiment for a while
Continue working on this stack for a while. Make all the changes you
want. Don’t worry about messing things up; this stack is just for
practice.

m When you’ve finished experimenting, go back to the Home
card.

 

Connecting to the Home card
You've read here and in the first chapter that Home is your base of
operations. It makes sense, then, to put a button on the Home card
that gets you to the stack you just made. In this final exercise, you'll
create a new button for the Home stack, give it a name, and then
create a connection to your new stack.

= Create a link between the Home card and your To Do stack:
1. From the Home card, choose New Button from the Objects

menu.

HyperCard selects the Button tool and a button named New
Button appears selected in the middle of the Home card.

2. Choose Button Info from the Objects menu.
The dialog box in Figure 2-25 appears.
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Figure 2-25
Button Info dialog box

3. Type Things to do into the Button Name box.

The new name replaces the old name, New Button. (You'll find
details on the rest of this dialog box under “Button Info” in
Chapter 6.)

. Click LinkTo.

The dialog box in Figure 2-26 appears.

Figure 2-26
LinkTo dialog box

5. Choose Open Stack from the File menu.
The Directory appears.

. Select My To Do Stack and click Open.
The first card in the stack you just created appears.

. Click This Stack in the LinkTo dialog box.
HyperCard completes the link and returns you to the Home card.

. Drag the new button to a convenient place on the Home
card.
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9. Test your new button.

To do that, first select the Browse tool; then click the new button.
You immediately go to your new stack.

 

 
 

Where to go from here
This ends your tutorials on HyperCard’s basics. You know enough
now to get off to a great start. You can go on reading in this manual
to learn more about HyperCard or you can go off on your own,
browsing and editing as you like.

m To use the Help stack to learn more about tools:

1. Choose Help from the Go menu.

This gets you to the Help stack from anyplace in HyperCard.

2. Click the Menus tab at the bottom of the card.
You'll see the Menus card.

3. Click the Tools menu and explore.

To learn about a specific tool, just click its icon. (See
Figure 2-27.)

Figure 2-27
Exploring with the Help stack

Happy wandering!
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Warning

Chapter 3: Home

Home is HyperCard’s central stack. Each of its cards holds
information vital to HyperCard’s performance.

O The first card, Home, holds buttons that take you to the most
important cards in your collection.

O Three search path cards tell HyperCard where to find
applications, documents, and stacks that you use frequently.

O The User Preferences card lets you customize the way you interact
with HyperCard.

 

HyperCard will not operate without a Home stack. Do not
delete the Home stack.
 

 

 

 

Home card
No matter what other cards and stacks you have, you always have
Home. Most people use it as their starting place for moving around.
You'll find the Home card most useful if you create a button on it
linked to each new stack and to each of your favorite cards.

Figure 3-1
Home card



“ Creating a graphic button for Home: To create a graphic button,
first paint or paste a small picture on Home representing the new
stack; then cover that picture with a transparent button linked to the
new stack. Or you can use icons as buttons by clicking Icon in a

selected button’s Button Info dialog box and choosing from the
icons that appear. You can also copy predesigned buttons from
the Button Ideas stack. “Copying Buttons From Another Stack” and
“Connecting to the Home Card” in Chapter 2, and “Icon” in
Chapter 6, provide step-by-step instructions for these procedures.

For information on linking buttons, see “Button Info” in Chapter 6.

 
 
 

Search paths
A search path is the route HyperCard follows to retrieve a stack,
application, or document. When you tell HyperCard to open
a file—by clicking a button on the Home card, for example—
HyperCard follows its own preset search paths to find the file.

“+ Preset search paths: HyperCard first looks for the requested file
in the folder that’s currently active; next it looks in the folder that
the Help stacks are in, and then it looks on the root level of the
directory—that is, on the current disk among the files that aren’t
in any folders. Finally, it checks the search path cards to see what
route to follow.

If HyperCard can’t find a file you ask for, it displays a dialog box.
(See Figure 3-2.)

Figure 3-2
Dialog box for finding a file
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Important

Chapter 3: Home

As you click your way through the directory dialog box to locate a

file, HyperCard records your path. Once you’ve located the file,
HyperCard notes the volume and folder (and if necessary,
subfolder) in which the file resides, and records it on the
appropriate search path card in the Home stack. The next time you
ask for that file, HyperCard will know where to look for it without
having to ask you to find it.

 

HyperCard cannot work with a locked disk (or locked volume).
Make sure that any disk you want fo use is unlocked.
 

“+ Occasional housecleaning: HyperCard keeps a search path on
record until you erase it. It's a good idea to erase a search path
you use infrequently, freeing up that space on the search path
card. To erase a search path, just select it and choose Clear from
the Edit menu.

   

User Preferences
Set the User Preferences card to customize the way you interact with
HyperCard.

Figure 3-3
Setting preferences



Click the proper user level to match what you want to do with
HyperCard. The higher the user level you choose, the more power
HyperCard gives you:

Browsing Short File and Edit menus (Figure 3-4), plus
the Go menu. Use of the Browse tool.

Typing Same as Browsing, plus ability to edit text in
existing fields.

Painting Same as Typing, plus full File and Edit
menus (Figure 3-4), Tools menu (plus Paint,
Options, and Pattern menus whena Paint
tool is selected), use of all Paint tools (but
not Button and Field tools), Power Keys
option.

Authoring Same as Painting, plus Objects menu, use of
Button and Field tools.

Scripting Same as Authoring, plus ability to type into
Message box while it’s hidden (if the “Blind
Typing” option is chosen), plus ability to
write and edit scripts.

Browsing and Typing get short menus.

Painting, Authoring, and Scripting
get full menus.

Figure 3-4
Short and full File and Edit menus

User Preferences of



The Command key is marked by
a propeller-snhaped symbol, On
some Macintosh keyboards, the
key also has an Apple symbol,
and some Macintosh manuals
might call it the Apple key. Both
names refer to the same key.
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You can set one level now and change it to a higher one later, when
your HyperCard skills improve or when you feel comfortable
experimenting with more advanced abilities.

“ Userpreferences and stack protection: The preferences you set
here apply in a general way to all HyperCard functions. The
tools and commands you have at your disposal while you’re
using a specific stack, however, are based both upon the level
you set on User Preferences and on the specific stack’s
protection level. Whena stack is set for a different level of use
than is set on User Preferences, the lower setting has
precedence. (Lower means “closer to Browsing.”) See “Protect
Stack” in Chapter 6 for details.

For information about power keys, see “Power Keys” in Chapter 5
and Chapter 6.

For details about the Message box, see “Message” in Chapter 6.

For more information on scripts, see the HyperCard Script
Language Guide.

 
 

 

Ways to go Home
HyperCard provides several ways to get to the Home card:

Q choose Home from the Go menu

O press Command-H (Press the Command key and, while holding
it down, press H for Home)

O click the house icon that appears on most stacks

QO choose Message from the Go menu, type Go Home, and press
return.

All these methods work equally well.
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Field tool

Browse tool

HyperCard has two kinds of text: Paint text and regular text. You
create Paint text using the Paint Text tool; you’ll find details about it
in Chapter 6. This chapter covers regular text.

Creating regular text in HyperCard is a two-step process:

1. Use the Field tool to create the fields where text goes.

2. Use the Browse tool to type text into a specific field.

“ Watch yourpreference level: To edit text in a field, you must be
at the Typing level or higher on the User Preferences card in the
Home stack. To create or changea field, you must be at
Authoring level or higher.

In the section “Fields,” you'll learn about the places where you type
regular text. The section called “Creating Text” tells you about
entering and editing text, and how to move it from one place in
HyperCard to another.

 

 

 

Fields
Fields are the boxes in which you type text. You can create
background fields and card fields. A background field appears on
every card associated with a given background. It has the same size,
shape, and position on every card; what changes from card to card
is the text in a field. Fields can be empty in one card, but have text
in another. A card field appears only on the card where you create
it (although you can copya card field, and then paste it onto any
other card).
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No card field on this card.  

 Background fields are
common to a number
of cards.

 Card fields appear only
on a specific card.

Figure 4-1
Different kinds of fields

You can have as many fields on a card or background as will fit.
Fields can overlap one another to any depth.

“ Text can overlap, too: When fields overlap, the text within the
fields can also overlap if some of the fields are transparent.
Although you can create some interesting special effects this
way, you can also create quite an aesthetic mess. When you
overlap background fields and card fields, be sure to go through
each card associated with the background after you’ve entered
text to make sure things look the way they should.
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Move pointer here

 

Creating fields
You create fields by using the Field tool in the Tools menu.

 

and click.

Start where you want, ———___—

Drag diagonally
to createa field.

The field pointer -

is a crosshair.

Figure 4-2
Field tool in Tools menu

To create a field:

. Move to the card where you want the field to appear.

. To create a background field, choose Background from the
Edit menu.

. Choose New Field from the Objects menu.

A new field appears in the center of the screen. Alternatively,
move the pointer where you want the field to start; then press the
Command key and drag. (See Figure 4-3.)

. Choose Field Info from the Objects menu and make selections
as appropriate in the Fields dialog box.
The Fields dialog box is described in detail later in this chapter.

. Size the field appropriately.
See “Changing a Field’s Size,” later in this section. As you drag, a

dotted rectangle appears showing you how wide and how long the
field is; the lines in the rectangle show where the bottom of each
line of text will be.

Figure 4-3
Creating a new field by dragging
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Important

The dotted lines go away when you choose another tool. The top-
left and bottom-right corners define the size of the field; the lines
going across show you the text lines within the field.

“ Changing line spacing: You can change the amount of spacing
between lines by changing the number in the Height box of the
Text Style dialog box. See “Setting Text Properties,” later in this
chapter.

 

The most common mistake in creating a field is putting it on a
card when it’s supposed to be on a background. After you’ve
created one or more fields, flip to the next card; if the fields
you've just created are on that card too, you’ve created
background fields.

 

Placing and moving fields
You can place a field wherever you want, including on top of
another field.

 

= To movea field:

1. Select the Field tool from the Tools menu.

The Field tool appears highlighted in the Tools menu, showing
you that it’s selected.

2. Click inside the field you want to move fo select it.

The field becomes surrounded by dotted lines to show it’s
selected.

3. Drag the field by its middle.

When the field is where you want it, release the mouse button. When
you movea field, any text you’ve typed moves with it. HyperCard
won't let you move any part of the field off the card.
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Changinga field’s size

You can changea field’s size whether or not it has text in it. When
you change its size, any text in it wraps appropriately to conform
to the new size. If you shrink the size of a non-scrolling field such
that there’s not enough room for all the text, text typed toward the
bottom of the field becomes invisible. (It’s still there, though; if
you enlarge the field, the text becomes visible again.)

Narrow field shows Short field makes
wrapped text. some text invisible.

Figure 4-4
Changing a field’s size

Changing the size or shape of a background field changes it on every
associated card.

m To changea field’s size:

1. Select the Field tool.
2. Click inside the field to select it.

The selected field is surrounded by dotted lines.

3. Drag the field from one of its corners.

You'll probably want to look through any cards affected by the field
change to see how the text looks.
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Warning

 

Deleting a field
You can delete a field whether or not it has text in it.

= To delete a field:

1. Select the Field tool from the Tools menu.

2. Click inside the field to select it.

3. Choose Cut Field from the Edit menu.

Choose Clear Field to eliminate the field without affecting the
Clipboard (or press the Backspace or Clear key).

 

When you delete a field, you delete all its text along with it.
Nothing goes onto the Clipboard; it is all simply eliminated.
When you delete a background field, you irrevocably delete
text associated with that field in every card on which the field
appears. You cannot recover the lost text by choosing Undo
from the Edit menu.
 

 

Moving between fields
Knowing the position of a field on a card can be difficult
sometimes. Depending on the field style you’ve selected, empty
fields can be invisible when any tool other than the Field tool is
selected (although any text in them will still show).

= To move from one field to another in order to type text:

1. Select the Browse tool from the Tools menu.

2. Press the Tab key until you get to the field you want.

HyperCard first tabs through the background fields and then tabs
through the card fields of the current card.

When you click in a text-filled area of a field, the insertion point
appears wherever you click. When you click in an empty area of a

field, the insertion point appears at the start of that empty line.
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Tabbing goes from here...

..to here...

Tab order and layers

Pressing the Tab key moves the insertion point to the field with the
next higher field number.

Initially, field numbers are in creation order. The first field created
gets the number 1, the second fieldgets the number 2, and so on.
(A pasted field is treated as a newly created field, no matter what its
number on the card or background from which it was copied or
cut.) If the insertion point is in field number 3 and you press Tab,
the insertion point moves to field number 4; if there are only three
fields, the insertion point moves from field 3 to field 1.

..and finally back to here.

..to here...

Figure 4-5
Tab order

The layer is the order of the field relative to other fields on the
same card and background. When the visible card and background
have multiple fields, fields can lay over each other; the field created
most recently is ordinarily the topmost field, said to be on the front
layer. In Figure 4-5, field 1 is on the layer farthest away (or, if you
prefer, in the back), field 2 is closer, and the highest numbered
field, field 3, is on the frontmost layer. The lowest numbered field is

always farthest away; the highest numbered field is always on the
frontmost layer (or in front). In fact, you can think of the field
number as being the field’s layer number.

= To seea field’s number:

1. Select the Field tool from the Tools menu.

2. Click inside the field whose number you want fo see.

3. Choose Field Info in the Object menu.

Alternatively, just double-click in the field.
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This determines tabbing order.  

Figure 4-6
Field number, initially determined by creation order

Changing field tab order

You can change the tab order among background or card fields by
changing the field’s layer. (Figure 4-5 in the preceding section
illustrates layers.)

m To changea field’s layer:

1. Select the Field fool from the Tools menu.

2. Click inside the field whose layer you want fo change.
3. Choose Bring Closer or Send Farther from the Objects menu.

Each time you choose Bring Closer, the field gets closer to being
the frontmost layer with a correspondingly higher field number),
each time you choose Send Farther, the field moves to a farther
layer (with a correspondingly lower number). And as the layer
order changes, so does the tab order.

Duplicating a field
Duplicating a field makes an exact copy of the field (but it doesn’t
copy the text in the field).

= To duplicate a field:

1. Select the Field tool from the Tools menu.

2. Select a field by clicking inside it.

A dotted line surrounds the field, showing that it’s selected.

3. Choose Copy Field from the Edit menu.
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Type the name you want
for this field. (You can
change it any time
you want.)

4. Choose Paste Field from the Edit menu.
A copy of the selected field is created, laying on top of the
original. You need to drag the new field to where you want it.

5. Drag from within the new field.

“ Duplicating a field doesn’t copy text: When you duplicate a
field, you don’t duplicate the field’s text with it. To copy both a
field and the field’s text: First copy the field; then copy the text
and paste it to the new field.

 

Field names
Each field can have a name associated with it. You use field names
mostly for advanced HyperCard features such as constructing
scripts.

A field name can have any number of characters in it. You can use
any character in a field’s name.

= To namea field:

1. Select the Field tool from the Tools menu.
2. Select the field you want to work with by clicking Inside it.
3. Choose Field Info from the Objects menu (or just double-click

the field).

The dialog box in Figure 4-7 appears.

4. Type or change the field’s name; then press OK.

 

 

Figure 4-7
Naminga field
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“ Script writers take note: If you change the name ofa field, be
sure also to change its name everywhere else you refer to it. For
example, if you rename a field “Wrigley” and you use the old
name “Chester” in a script, the script won’t work properly—it
won't be able to find the field it needs.

 

Field styles

Fields can have five styles: transparent, opaque, rectangle, shadow,
or scrolling. You choose the style of a field by choosing an option
in the Field Info dialog box. (See Figure 4-8.)

“+ About scrolling: Scrolling adds a vertical scroll bar to the
selected field. You view text in a field with a scroll bar as you do
text in any scrollable Macintosh window. See the guide that came
with your computer for details.

 

Choose one of these -

styles for your field.
 

Figure 4-8
Choosing a field style

You can changea field’s style even after you’ve typed text into the
field. Just repeat the steps you used to choose the original style.
Figure 4-9 shows examples of field styles.
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Background shows through ——_-___—
transparent fields.

Scrolling field

Figure 4-9
Field styles

If you don’t choose a style, HyperCard uses Transparent.

 

Lock Text

Lock Text protects the text in a field from being changed. When you
check this option on the Field Info dialog box for a selected field,
text within the field cannot be altered in any way. (The pointer
doesn’t change to an I-beam when it passes over a locked field.)

To unlocka field (and to allow its text to be altered), uncheck Lock
Text.

 

Wide Margins and Show Lines
Wide Margins and Show Lines are options you can check in the Field
Info dialog box for a selected field. These options give you more
control over the look of your text fields. Wide Margins, which works
best when the field has a rectangle or shadow style, leaves more
space in the right and left margins. (As a result, text takes up more
space.)

64 Chapter 4: Text in HyperCard



These fields are the same size. ——

 
 

Shadow field,
wide margins

Shadow field,
no wide margins

Figure 4-10
Wide Margins

Show Lines lets you see where lines are as you type in text. Later, you
can click Show Lines again to hide the lines.

Show Lines in a shadowed Show Lines in an opaque field
field with wide margins

Figure 4-11
Show Lines

 
 
 

Creating regular text
Regular text goes inside fields that you’ve created. To create text,
first you use the Browse tool to set the insertion point inside the field
you want; and then you type.
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Select the Browse tool
to start typing text.

i
4 Fr,

Browse tool

 

Important

Warning

 

 

Figure 4-12
Selecting the Browse tool

 

Use the Browse tool, not the Paint Text tool, for entering text in
fields. Regular text is always editable in an unlocked field: Paint
text, however, is not editable once you have typed it and
clicked the mouse button.
 

 

Entering text
You use the keyboard to enter text in HyperCard. You must create a
field before you can type text. (See “Creating a Field,” earlier in this
chapter.)

= To enter text in a field:

1. Select the Browse tool from the Tools menu.
2. Click in the field where you want to type.

(The insertion point appears at the left edge of the line you
clicked on.)

3. Click where you want the new text to start.
Or select the text you want to replace.

4. Start typing.
Your new text is inserted at the insertion point, or replaces the
selected text.

 

When you tab to a field that already contains text, all the text
is selected. Typing at this point will wipe out all the old text in
the field, and replace it with what you type. To preserve the
old text, move the pointer where you want to begin typing,
and click.
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Fields without text in them are sometimes invisible, unless you tab
to a field, or you want to type ina field that already has some text in
it, you’ll have to estimate the field’s position (or choose the Field
tool to see where all the fields are).

If you type more text than will fit in a non-scrolling field, the
remaining text goes off the bottom of the field. But this invisible text
isn’t lost, it’s just hidden. To see the hidden text, make the field
bigger.

 Text goes beyond the
bottom of the field
and is hidden.

 Same text in the same field,
but with the field size extended.

Figure 4-13
Revealing hidden text

 

Moving and copying text
You can move and copy text from one part of a field to another, or
from one field to any other field anywhere in HyperCard.

You use the same cut-and-paste techniques for moving and copying
text in HyperCard as you use in all Macintosh applications. See your
owner's guide for details.

“ Uneditable text: If you can’t edit text, check the Field Info dialog
box for that field to see if Lock Text is checked. If the field is
unlocked, or if the text exists outside of a field, you’re dealing
with Paint text. To change Paint text, you must erase the old text
and create new text.
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Setting text properties :

You can determine how the text in each field looks by using the Text
Style dialog box.

= To set text properties:

1. Select the field you want to work with by clicking inside it.

Either the Browse tool or the Field tool must be active.

2. Choose Text Style from the Edit menu.
The dialog box in Figure 4-14 appears.

3. Set the properties as you prefer.
You can set font, size, style, alignment, and line spacing (line

 

 

 

 

height).

4. Click OK.

Scroll to the font you want; Click the size you want...
then click to select it.

| :

| ..Or type it here.

Check one or more styles ———————_}}
for all the text in a field
(or check nothing for plain text).

EL. ¢

The alignment you set ———————___ 4
works on all lines in the

|

same field. as oa |

v4 |

What you see is / This determines the spacewhat you'll get. between lines, in points.

Figure 4-14
Text Style dialog box

 

Important The properties you set affect all the text within a field. You
cannot, for example, make a single word bold unless it’s the
only word in the field.
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Font

You can use any font that’s on your startup disk. You can see all the
available fonts by scrolling through the list at the bottom of the Text
Style dialog box. The font of the text you’ve selected is highlighted.
a To change the font, just click the one you want.

A sample of what your text will look like appears in a box at the
lower right. When you’ve finished with the Text Properties dialog
box and click OK, the selected text appears in the new font.

m To return to your work quickly, double-click the font you
want.
The dialog box closes immediately, and the selected text appears
with all the properties you've set.

Style

Text can appear in bold, italic, underline, outline, shadow, or a

combination of any or all of these. If the field you’ve selected has
text in any style besides plain, the appropriate boxes are checked.

m To choosea style, click the appropriate check box or boxes
in the Text Style dialog box.

An X appears in each box you've clicked.

m To cancel a style choice, click in the check box again.

The X goes away.

A sample of what your text will look like appears in a box at the lower
right. When you've finished with the Text Styles dialog box, click
OK; the text appears in the new style.

All text in a given field has the same style or styles.

Align

You can set the text in a field to align to the left side of the field, to
the right, or to be centered within the field. The same alignment
setting works for all lines within a field; you can’t set each line
separately.
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Point is a printer’s term; one
point is equal to about 1/72 of
an inch.

mu To change the alignment, click the appropriate button.
A black dot shows in the button you've clicked.

When you click the OK box and go back to your work, the text will be
aligned properly.

Size

The box marked Size shows the size of the text in the field you've
selected. The number you see is the text’s size in points. Each
point is a single dot on the Macintosh screen.

* Preset size and style: When you start HyperCard, the preset size
and style is 12 point plain Geneva. The changes you make to size
and/or style remain in effect for all fields you create until you
change them or until you leave HyperCard. When you enter a
field you’ve already created, any new text takes on the size and
style of the rest of that field.

When you click a font name in the Text Style dialog box, all the sizes
that you have in the System file for that font come up in the
scrollable window to the right of the font list; the closest one to the
actual size of the text in the active field is highlighted. (If you haven’t
clicked on a font, the size you see is the size of the text in the active
field.) The highlighted size also appears in the Size box.
m To use a size other than the one highlighted, scroll to the

size you want and click it.
u To use a size not listed, replace the number in the Size box

with the size you want.
First select the old size by dragging across it in the size box; then
type the new one.

The highlighted size is the one that’s closest to the actual size of the
text in the active field.

Height

Height is the space allowed for each line in a field, expressed in
points. The number you see in the Height box of the Text Style
dialog box includes space for the height of the characters and the
space between lines, plus a couple of points for slack. HyperCard
sets this number automatically when the font size changes; but you
can set it by typing whatever number you want.
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mu To change Height, replace the number in the Height box
with a new number.

First select the old number by dragging across it; then type the
new one. The new number replaces the old one.

= To make lines touch or overlap, set the Height size lower
than the Font size.

The exact number varies from font to font; experiment until you
get the effect you want.

“ Top line can get chopped: You might lose some of the top line if
you set the Height size below the Font size.

 
 

 

Summary
In this chapter you learned about fields and text in HyperCard. You
saw (among other things) that

O all regular text appears in fields

O you create fields using the Field tool

O you can create fields both on a background and on a card

oO fields can be enlarged or made smaller, moved, copied, cut,
deleted, and pasted

O you enter text into fields using the Browse tool

O you can move, copy, cut, delete, and paste text

O all text within a field shares the same properties—font, size,

style, alignment, and line spacing

Chapter 6 has more details about text and fields. See especially
“Print Report” for information on printing text in fields, and “Field
Info” to read about protecting a field’s text from being changed.
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This chapter presents an overview of HyperCard’s graphic elements
and shows how the different elements can work together. (Chapter 6
tells you what tools and commands you have at your disposal for
creating pictures.)

Q “Menu Commands You Use With Graphics” provides a brief
frame of reference for using the Paint commands in different
menus to producea finished picture.

O “Power Keys” gives details on special states and commands you
execute from the keyboard.

O “Double-Clicking Paint Tools” summarizes what happens when
you double-click on certain tools.

O “Dragging With Modifier Keys” lists the effects of pressing
Command, Option, or Shift while you drag with different Paint
tools selected.

O “Special Effects” shows what happens when you combine several
features.

O “Importing Pictures” suggests ways to bring pictures into
HyperCard from outside sources.

 

 

 

Menu commands you use with graphics
To make finished pictures in HyperCard, you use commands from
several menus.

Q To create the basic picture elements—shapes, patterns,
contours—use the tools on the Tools menu and the patterns on
the Pattern menu.

O To borrow pictures from cards that already exist in the current or
other stacks, use the Copy and Paste commands from the Edit
menu.

Q To bring in a picture you created someplace else using
MacPaint® or a MacPaint-compatible application, or that you
brought into the computer using a digitizing camera, scanner,
or some other peripheral device, use the Import command
from the File menu. (You can also bring in pictures through
the Clipboard and the Scrapbook.)

Q To create a picture common to several cards, use the Background
command.

O To manipulate the picture and to do finish work—rotate parts of
it, bring up FatBits, and so on—use the commands in the Paint
menu.
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Power keys
When you choose Power Keys from the Options menu, striking a

single key does the work of selecting a specific menu command.

The Options menu is visible only when you’ve selected a Paint tool.

Table 5-1 showsa list of menu commands and their power-key
equivalents. (Each of these commands is described in detail in

 

 

Chapter 6.)

Table 5-1
Power keys

Command Key Menu

Darken D Paint
Draw Centered (on/off) Cc Options
Draw Multiple (on/off) M Options
Fill F Paint
Flip Horizontal H Paint
Flip Vertical Vv Paint
Grid (on/off) G Options
Invert I Paint
Lighten L Paint
Line size 1-4, 6, 8 Options
Opaque O Paint
Pickup P Paint
Revert R Paint
Rotate Left [ Paint
Rotate Right ] Paint
Select S Paint
Select All A Paint
Select black pattern B Patterns
Select white pattern Ww Patterns
Trace Edges E Paint
Transparent T Paint

Listed next are descriptions of a few power keys that need special
mention.
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Power key P: Making a graphic cookie cutter
Power key P chooses the Pickup command in the Paint menu. It
works like a cookie cutter. You drag a source image (the cookie
cutter) over the image whose pattern you want to pick up (the cookie
dough). HyperCard uses the outline of the source image as the
cookie cutter. Pressing power keyP is like pushing the cutter into the
dough—when you drag the cutter away again, it’s converted to the
pattern you moved it over.
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1. This is the shape with 2. This is the pattern
the pattern you want you want to use.
to change.

fi F

4 i)Bx

3. Select the shape and 4. Choose Pickup (or just
move it over the pattern. press P if power keys

are active).

—-

i]'

@ agi
5. Drag the shape away.

Figure 5-1
Source image picks up pattern of overlaid image

 

Power key S: Tightening the selection
Power keyS lets you lasso a picture that you’ve already selected with
the Selection tool. You can also press S to select an area you've just
drawn (or even erased) with another tool, once selected, you can
move it or fill it, or do whatever else you want with it.
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Use the Selection tool
to grab the general area...

 

..press power key S to separate
the graphic wheat from the chaff.

 

Figure 5-2
Refining a selection

Power keyS is especially useful when you want to select a specific
area quickly with no white space, or if your hand isn’t steady enough
to use the Lasso tool with precision.

 

Power key T: Turning a graphic transparent
Ordinarily when you draw or paste a graphic onto a card, the
graphic is opaque—that is, it totally covers what it’s drawn or pasted
over. Pressing power key T makes the graphic transparent so that
what it covers shows through.

 Pasted opaque
(default choice) = ee i

Pasted,
then power key T pressed

Pasted opaque with pattern ss . s 4

Pasted with pattern,
then power key T pressed

 

 

Figure 5-3
Opaque and transparent images
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Double-clicking Paint tools
Double-clicking on certain Paint tools enhances using those tools.
Here’s a list of the tools and what double-clicking does. (Chapter 6
tells you what each tool is for, and how to use it.)

 

 

Table 5-2
Effects of double-clicking Paint tools

Double-click ... Effect

Any pattern Bring up pattern editing dialog box
Brush Bring up Brush Shapes dialog box
Bucket Hide/show pattern menu
Curve Toggle Draw Filled command
Eraser Erase whole picture
Lasso Lasso every element in a picture
Lines Bring up line/border thickness dialog box
Oval Toggle Draw Filled command
Paint text Bring up Text Style dialog box
Pencil Set/cancel FatBits
Polygon Toggle Draw Filled command
Regular Polygon
Rectangle

Rounded Rectangle

Selection
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Bring up shape selection dialog box
Toggle Draw Filled command
Toggle Draw Filled command
Select whole picture



 
 
 

Dragging with modifier keys
Dragging with different tools selected has different effects,
especially if you’re pressing Command, Shift, or Option at the
same time. Table 5-3 shows you what happens. Tools that aren’t
listed aren’t affected by modifiers at all.

 

Shift Option
 

Table 5-3
Effects of modified dragging

Tool Command

Selection Select tightly
Lasso Lasso everything
Line No effect

Eraser Erase in white
Pencil Get/leave FatBits

Rectangle No effect

Curve No effect
Brush Erase what you

paint over
Spray Erase what you

spray over
Rounded Rectangle No effect
Polygon No effect

Oval No effect

Regular Polygon No effect

Move selection horizontal or vertical
Move selection horizontal or vertical
Draw at multiples of 15° angles

Erase straight horizontal or vertical
Draw straight horizontal or vertical
Draw square

No effect
Paint straight horizontal or vertical

Spray straight horizontal or vertical

Draw square with round corners

Draw at multiples of 15° angles

Draw circle

Rotate in 15° increments

Copy selection
Copy selection
Draw with pattern

No effect
No effect

Patterned border
Patterned border
No effect

No effect

Patterned border
Draw with pattern

Patterned border
Patterned border
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Special effects
In many cases, holding modifier keys down in combination with
choices from the Options menu makes combinations of effects.
Experiment with different combinations to see what happens.
(Figure 54 shows some examples.)

Use Command-Shift-Option-Drag
with Grid checked in the Options menu
to enlarge or shrink the selection
keeping the pattern consistent.

 

  

 

  

    

 

Draw Multiple Draw Multiple, with Draw Multiple with
and Draw Filled Rectangle, Grid on Circle tool, Grid and

Draw Center on, Shift
key held down

>...
PT:

ie

Draw Multiple, Draw Multiple with Draw Multiple with
Grid on Line tool, Shift key Line tool, Grid on

held down

Figure 5-4
Special effects
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Importing pictures
There are many products that create pictures compatible with
MacPaint. Some products let you create MacPaint pictures from
scratch, others let you digitize images using a video camera
attached directly to the Macintosh, and still others connect to the
Macintosh through an ImageWriter® printer. However you create
it, you can bring any MacPaint picture into HyperCard using the
Import Paint command on the File menu. Once you’ve imported a

picture, you can treat it as if you had created the imported image in
HyperCard.

“+ Try the Clipboard: Sometimes you might want to bring a non-
MacPaint picture into HyperCard—for example, something you
create using MacDraw or a similar application. Try copying the
picture to the Clipboard or to the Scrapbook first; then paste into
a HyperCard card.

 

Figure 5-5
Imported digitized image

“* Built-in screen shooter: To take a quick snapshot of the screen in
nearly any Macintosh application, press Command-Shift-3. This
keyboard command, built into your Macintosh’s System file,
stores a picture of the screen on disk under the name SCREEN 1,
where 7 is a digit from 0 through 9. (When you already have all 10

digits used, your Macintosh beeps and you can’t save more
pictures until you rename or erase some.)

Importing pictures 8]



 
 

 

Summary
In this chapter you saw how HyperCard’s graphic elements work
together. You learned

O which menu commands to use to perform specific tasks
Q how to use power keys instead of menu commands to perform

certain functions, and about the unique effects of certain power
keys

QO the effects of double-clicking Paint tools
O the effects of dragging with different Paint tools selected
Othe special effects that happen when you combine different

elements

Chapter 6 gives details for using all the Paint tools in the sections
called “Tools,” “Paint,” and “Options.”
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This chapter gives detailed descriptions of each command on all
the HyperCard menus. You can also find information on
commands in the Menus section of the on-line Help system.

“ General versus Paint tools: Throughout this chapter you'll see

references to General tools and Paint tools. General tools are
those tools that appear on the first row of the Tools menu; use
them for general HyperCard tasks (browsing, creating buttons
and fields, entering text). Paint tools are all the other tools on
the menu; use them to create and edit pictures. For details, see
“Tools menu” later in this chapter.

 

 

Tools IIE
General tools ™{C

Paint tools |

Figure 6-1
General and Paint tools

Menu items are described in the order that they would appear if
Scripting was checked in the User Preferences card of the Home
stack. (See “User Preferences” in Chapter 3.)

 

 

 

File menu
The File menu holds commands that save information to, or
retrieve information from, a disk. You can choose any command
on the file menu while you’re using a General tool (that is, any of the
tools on the top row of the Tools menu); while you’re using a Paint
tool, you can choose only Import Paint, Export Paint, or Quit
HyperCard.
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Important

 

The different File menus
The level set on the User Preferences card of the Home stack, in
conjunction with the protection level set for a particular stack,
determines which menu appears when you press File. If either level
is set to Browsing or Typing, you choose a command from the short
menu (far left in Figure 6-2). Otherwise you choose from the full
menu (middle in Figure 6-2). While you’re using a Paint tool, you
can choose only Import Paint, Export Paint, or Quit HyperCard
(far right in Figure 6-2) no matter how high your level is.

Browsing and Typing

Painting, Authoring,
Scripting

Paint tool selected

Figure 6-2
File menus

For information on user levels, see “User Preferences” in
Chapter 3. For information on individual stack protection,
see “Protect Stack” elsewhere in this chapter.

See “Tools Menu” later in this chapter for a description of the tools.

 

HyperCard has no Save command. HyperCard automatically
saves what you create whenever you switch from one card to
another. To save your stack under a different name, use the
Save A Copy command.
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New Stack...
New Stack puts away the current stack (making sure that all the work
you’ve done is saved) and creates a new one.

When you choose this command, HyperCard puts up a Directory
dialog box and asks you to name the new stack:

 You use the old stack’s
design for the new stack
if this box is checked.

Figure 6-3
Naming a stack

If you click New with the box next to “Copy current background”
checked, HyperCard creates a new stack with the background fields,
background picture, and background buttons (including all actions)
of the last viewed card in the previous stack. If “Copy current
background” is unchecked, the new stack is blank.

To choose this command you must be using a General tool.

 

Open Stack...
Open Stack (or Command-O) opens an existing stack for your use.
This command brings up the Directory dialog box and waits for you
to select a stack. When you’ve made your selection, HyperCard
closes the stack you were working with and saves any changes you
made; then it gets the stack you asked for. The first card in the
summoned stack appears on the screen.
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“* An Open Stack alternative: You can also open a stack by typing
Go stack name into the Message box and pressing either Return
or Enter. CYou get the Message box by choosing Message from
the Go menu.) For example, to get to the Art Ideas stack, type Go
Art Ideas and press Return.

To choose this command you must be using a General tool.

«* Where the stacks are: If HyperCard can’t find a stack, it will ask
you to tell it where it is. If the stack is on a 3.5-inch disk, you’ll
need to insert the disk into one of your drives. Stacks that come
with HyperCard are scattered among the HyperCard disks. See
Appendix B fora listing.

 

Save a Copy...
Save a Copy saves a copy of the stack you’re working on under a
new name. (You continue to work on the original stack.) Use it to
preserve a stack in its unchanged condition while you experiment
with new variations.

Figure 6-4
Saving a stack under a different name

HyperCard presets the name of the copy to “Copy of (original
stack name).” (The name is automatically selected; to change it,
just type the new name.)

To choose this command you must be using a General tool.
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Import Paint
Import Paint (available only when a Paint tool is selected) gets a
copy of a MacPaint-compatible document from the disk and pastes
it onto the current card.

When you choose Import Paint, the directory dialog box appears so
you can select a document using the hierarchical file system.
HyperCard pastes the imported document, starting at the imported
document’s upper-left corner, onto the card.

“ Somepictureprepping: You might want to do some preparation
work on a document before you import it. Make sure the part of
the document you want to paste is in the document’s upper-left
corner before you bring it into HyperCard. (You can’t scroll
documents in HyperCard).

For complete information on graphics in HyperCard, see “Paint
Menu,” “Tools Menu” and “Pattern Menu” later in this chapter,
and Chapter 5, “Graphics in HyperCard.”

 

Export Paint
The Export Paint command (available only whena Paint tool is
selected) takes a snapshot of the current card and saves the snapshot
as a MacPaint document.

Export Paint creates a MacPaint document from the card on the
screen and saves it to disk under the name you give it. The image of
the full-sized card gets saved, even if you’re using FatBits. If
Background is checked in the Edit menu, just the background
picture is saved.

HyperCard exports only card and background information. If you
have a tear-off menu on the screen, its image isn’t included with the
exported picture.

You can’t save buttons and actions using Export—you only save
an image of what’s on the screen (including images of buttons
and text).
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For complete information on graphics in HyperCard, see “Paint
Menu,” “Tool Menu” and “Pattern Menu” later in this chapter, and
Chapter 5, “Graphics in HyperCard.”

“ Quick exporting: To take a quick snapshot of everything on the
screen (including the menu bar and any torn off menus), press
Command-Shift-3. This keyboard command, built into your
Macintosh’s System file and available any time, saves a picture of
the screen under the name SCREEN 1, where 7 is a digit from 0
through 9. (When you already have all 10 digits used, your
Macintosh beeps; to make room for more, go to the Finder and
rename or delete some of the snapshots.) You can use this
shortcut in almost any Macintosh application, and later import
the picture into HyperCard using the Import Paint command.

 

Compact Stack
This command (available only when Painting, Authoring, or
Scripting is checked in the User Preferences card of the Home stack)
gets rid of free space in a stack. Free space gets introduced into a

stack each time you delete a card, background, field, or button; the
more free space in a stack, the slower and larger the stacks.

To see the amount of free space in a stack, look at the number
following the words “Free in Stack” in the Stack Info dialog box.
(Stack Info is an item in the Objects menu, available when
Authoring or Scripting is checked on the User Preferences card.)

To use this command, you must have a General tool selected.

 

Protect Stack
Protect Stack sets levels of protection for the information in, and
design of, the current stack. Use it to keep your personal stacks
private, or to limit the way people can use or change your stacks.
Choosing this command brings up the dialog box in Figure 6-5.
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Figure 6-5
Protect Stack dialog box

Can’t delete stack

When this box is checked, you can’t delete the stack.

Private Access

When this box is checked, you must type the proper password (as

determined by Set Password, below) before HyperCard lets you use
the stack at all.

Set Password

Click this button to set or change a password. You set a password
to restrict access to the Protect Stack dialog box (thus preventing
unauthorized changes) or to restrict access to the stack. The dialog
box in Figure 6-6 appears.
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These would match OK.

  

Warning

 

 

Enter new password here:
| per ee oeees caaenerr’ 

|Joe sent me |

 B.

| Verify new password here:
 

  

 

 

Figure 6-6
Password dialog box

Type the password you want to use into the “new password” text box;
then press Tab to move the insertion point to the “verify password”
text box, and type the password again to verify it.

Click None to cancel the password and to put the dialog box away.

When you use the password later, it must match character-for-
character the one you set. (Uppercase and lowercase letters don’t
have to match.)

 

iil

Enter new password here:

(J) e sent ne

 These don’t match!

Figure 6-7
Matching and nonmatching characters

When a password is set, you can’t get to the Protect Stack dialog box
without knowing the password. When Private Access is checked, you
must know the password to use the stack at all.

 

There’s no way to find out a password once it’s been set. If you
forget the password, you cannot get to the Protect Stack
dialog box again. If you’ve checked Private Access and you
forget your password, you won't be able to use the stack again
once you leave it.
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New Stack...
Open Stack... #0
Save a Copy...

Page Setup...
Print Card #¢P

Print Stack...
Print Report...

| Quit HyperCard #Q

Limit user level

The box you check here limits the commands and tools a user can
employ within the current stack. Whena limit you set here conflicts
with a limit set on the User Preferences card of the Home stack, the
lower of the two levels takes precedence. (Browsing is the lowest
level.) Table 6-1 shows the powers inherent in each level.

Table 6-1
Powers associated with each user level

 

Browsing

Typing

Painting

Authoring

Scripting

Undo #62

Cut 46H

Copy |
Paste Text #U
Clear

New Card #6 N

Delete Card
  

  

Browsing and Typing get short menus.

Figure 6-8
Short and full File and Edit menus
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Short File and Edit menus (Figure 6-8), plus
the Go menu. Use of the Browse tool.

Same as Browsing, plus ability to edit text in
existing fields.

Same as Typing, plus full File and Edit menus
(Figure 6-8), Tools menu (plus Paint, Options,
and Pattern menus whena Paint tool is
selected), use of all Paint tools (but not Button
and Field tools), Power Keys option.

Same as Painting, plus Objects menu, use of
Button and Field tools.

Same as Authoring, plus ability to write and
edit scripts.

New Stack... _ Undo #2 |

Open Stack... #0 /

Save a Copy... Cut aH |

Copy
Compact Stack Paste Text at
Protect Stack... Clear
Delete Stack...

New Card EN|
Page Setup... Delete Card

Print Card 46P Cut Card

Print Stack.. Copy Card
Print Report...

 
| Quit HyperCard #Q Background #B|

 

 

Painting, Authoring, and Scripting
get full menus.



 

Important When you restrict a user’s level to Browsing or Typing, Protect
Stack doesn’t appear on the File menu. (See far left, Figure 6-8.)
To get a full File menu no matter what the user level is set to

2 or (either in Protect Stack or on the User Preference card), hold
SS) down the Command key before you drag through the File menu.

 

“ Card and backgroundprotection: You can also protect each
card or background individually by checking the proper box in
the Card Info or Background Info dialog boxes. See “Card Info”
and “Bkgnd Info” elsewhere in this chapter, for the details.

 

Delete Stack
Delete Stack (available only when Painting, Authoring, or Scripting
is checked in the User Preferences card of the Home stack) removes
all the cards, background pictures, background buttons, actions,
and fields of the current stack. It’s as though you had dragged the
stack to the Trash in the Finder. Use it when you have no further use
for a stack.

HyperCard first asks you to confirm the deletion. After the stack is
deleted, you end up at the Home card. (See “Home” in Chapter 3.)

 H
Fie

3bi

987 = Us |
 fy?

 
 

 

Delete all 56 cards from stack
Harpo:HyperCard Stacks:Datebook ?

Pohris [ Delete | ff Cancel } ice
15 16 17 18 19 20 21
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Figure 6-9
Dialog box for deleting a stack

To choose this command you must be using a General tool.
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Landscape printing icon
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Page Setup
Page Setup lets you set paper size, orientation, and certain effects
for printing. You see this dialog box:

 

 

ImageWriter ]

Paper: @ US Letter > A4 Letter =
() US Legal ©) International Fanfold {Cancel
(> Computer Paper ee

 

 

Orientation Special Effects: (]
rat Oo No Gaps Between Pages
He

 
 

 

 

LaserWriter Page Setup

 

 

Paper: @ US Letter (> A4Letter Reduce or foo] :

  

 

US Legal (© B5 Letter Enlarge: (Sided) ° {Cancel )

Orientation Printer Effects: (Options |
1G [tes Font Substitution? Help
Ei Ea CJ Smoothing?

 
  

(] Faster Bitmap Printing?

Figure 6-10
Page Setup dialog box

“ LaserWriter smoothing orflipping slows printing: If you’re
using an Apple LaserWriter® with Smoothing checked in the
LaserWriter Page Setup dialog box, or with any of the flipping
options checked, printing is slowed down considerably. Print
a sample with Smoothing unchecked first to see if the results are
acceptable.

 

If you select the landscape printing icon for horizontal printing
on your LaserWriter, be sure to choose Faster Laser Printing. If
you don't, printing a stack will be extremely slow.
 

“ Some LaserWriterprinting features don’t work: The Reduce or
Enlarge feature doesn’t work for any printing in HyperCard. The
Invert option works correctly only when Fast Laser Printing is
turned off, but it takes an extremely long time to print.

To choose this command you must be using a General tool.
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Click here to change the
number of cards that will
appear on the page.

 

Print Card
Print Card (or Command-P) prints the current card using the
specifications you gave in Page Setup (except that cards are printed
full size, no matter what reduction or enlargement you specify). Use
it when you need a hard-copy version of any single card in any
HyperCard stack. To print all the cards in a stack, use Print Stack
(described immediately below).

To choose this command you must be using a General tool.

 

Print Stack...
Print Stack prints all the cards in the current stack in linear order.
(With a LaserWriter, Print Stack prints the cards in reverse order so
that the first card is on top of the pile in the output tray.)

To choose this command you must be using a General tool.

Print Stack brings up a dialog box. (See Figure 6-11.)

 

 

Print Stack... —
] Manual paper feed Copies:/ [| f O|

 

Fast laser printin —_————

4 — (Cancel_}
anaaem

Baooegan CL] No space between cards
S32 an &
Resis = (> Print one card per page
= °: (@) Print full size cards

 

 

©) Print half size cards
() Print quarter size cards

‘@) Standard format
(_) Split-page format

  
 

 

 

Header: By FZ) Seey ie)
 

      

 

Figure 6-11
Print Stack dialog box
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Manual paper feed

Check the box labeled “Manual paper feed” if you’re feeding the
paper by hand; HyperCard will stop the printer after each sheet and
wait for you to add more paper.

Fast laser printing/Darker printing

Check “Fast laser printing” on a LaserWriter printer to speed up
hard-copy production. It’s recommended for most printing jobs.

 

If you select the landscape printing icon in the Page Setup
dialog box for horizontal printing on your Laserwriter, be sure to
check “Fast laser printing.” If you don’t, printing a stack will be
extremely slow.

 

Check “Darker printing” on an Apple ImageWriter printer to print
darker (useful if your ribbon is old).

Click “No space between cards” to print cards close together (for
printing two cards or more per page).

Cards printed per page

Click one of the four choices to determine how many cards are
printed per page. Look in the minipage window to see how many
cards fit on a page. (The number varies with the options you’ve
chosen.)

Page formats

“Standard format” and “Split-page format” determine how cards
are spaced on a page when you print a stack.

“Standard format” prints cards evenly spaced on the entire page.
This choice leaves enough room on the left edge to put binder holes
in the printout.

“Split-page format” is for sheets that will be kept in a minibinder, it
spaces cards so that the printed sheet can be folded down the
middle without creasing any card’s image.
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 Standard format leaves room ————— — Punch holes at top
for binder holes on the left side and bottom...
of the page.

 —...and fold page on
dotted line to
prepare split-page
printouts for
mini-binders.

 

    
 

@ Standard format () Standard format ‘ a

© Split-page format @ Split-page format

Figure 6-12
Standard format and Split-page format

Header

Tab to the Header box and type what you want to appear as a
heading at the top of each sheet. Click the proper icon(s) after you
tab to add page numbers, the date, the current time, and/or the
stack name to the header. Click icons in the order you want them to
appear in the heading. (Use the space bar to separate them.) You
can preview what the header will produce by looking in the
minipage window.

Format remembered

Once you print a stack, HyperCard remembers the format and
header you used for that stack so you can use the same setup next
time you print.
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Print Report
Print Report gathers text out of fields from the cards in a stack and
prints a report, using the design you specify in the Print Report
dialog box. Use this command to get printed summaries of your
stacks in a form most useful to you.

To choose this command you must be using a General tool.

* Reports are based on a single stack: Each report is based on
information from a single stack. There is no way to combine
information from two separate stacks into a single report.

When you choose Print Report, the dialog box in Figure 6-13
appears.

 You can print up to 99 copies

 
 

Print report... Copies:[i_| Arrange fields in:
 Click in here to feed sheets

one ata time
 

(_] Manual paper feed © Labels
Darker printing @ Columns __ -
— © Rows: beanacal | :

ed

 

 For ImageWriter only

Click here to add page number,
time, date, and/or stack name

Print text fields from all cards:
C> in the entire ¢tack
@ With the current background

Which fields:

 
  

 
  

 

    

 

      What you type here goes
at the top of every page  

 

 

area code
time zone
region
locations

aa = Print the names of:
Header: Ey SB (C] Cards Fields

EW |

Figure 6-13
Print Report dialog box

You can print reports in three formats—labels, columns, or rows.
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Here’sa list of alternatives showing the various combinations of
fields that can appear in your reports. (You can use only the last
alternative for the column format.)

a

2
7O)->

B-@

O

all card fields in the stack

all background fields in the stack

all background and all card fields in the entire stack

all card fields from cards with the current background

all card fields from cards with the current background, plus all or
some of the current background fields

all or some fields from the current background

To a print a report based on one of these alternatives, you must click
buttons and check boxes on the Print Report dialog box in the
proper combination.

Table 6-2 shows you those combinations.

Table 6-2
Controlling the printout of a report
 

To print... Click this radio button ..and... Check only these boxes
 

All card fields in entire stack

All background fields in entire stack

All card fields & all background fields
in entire stack

All card fields of cards with current
background

*Selected background fields of cards
with current background

© In the entire stack Card fields

© In the entire stack & Background fields

© In the entire stack & Card fields
& Background fields

© With the current background & Card fields

© With the current background & Selected background fields

All card fields and selected background © With the current background & Card fields
fields of cards with current background & Selected background fields

“This is the only format available for printing in columns.
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When you check “Selected background fields,” you activate a

selection box from which you select fields to print from the current
background.

gw To select a field, click its name.

Use the Scroll bar to look through the list of field names.

u To select more than one field, hold down the Shift key as you
select each name.

m To deselect a field, click its name.

u To deselect a field when more than one are selected, hold
down the Shift key as you click.

Field printing order

The order in which you select fields determines their printing
order. On labels, the first field you select goes on the top line of the
label, the second field goes on the second line, and so on. In the
column format, the order in which you select fields determines
their left-to-right printing order. In the row format, the first field
you select goes on the top line of the card block, the second field
goes on the second line, and so on.

Labels

Clicking this button makes HyperCard print the fields you’ve
selected in a format suitable for labels. Each label contains text
from the fields of one card. HyperCard automatically centers the
text in each label.

You can change the number of labels per sheet and the size and
spacing of the labels by dragging on the highlighted parts of the
dialog box’s minipage window.

As you change the dimensions of labels by dragging in the
minipage window, HyperCard shows you the maximum number of
labels that will fit on a page. Changes you make in the position or
size of the labels are reflected in the measurements at the bottom
of the window, use the numbers that appear there as a guide. See
Figure 6-14.
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 Drag here to change
size of labels.

Field name appears here.  

 Drag here to control number
of labels on each sheet, plus
the spacing between labels.

Important

Figure 6-14
Print Report in label format

If text on a line in a field is too wide for a label, HyperCard wraps the
text onto the next line. If there are too many lines to fit on a label,
HyperCard prints what will fit.

“+ About LaserWriter labels: Only use labels made especially for
LaserWriters or photocopiers. Check “Larger Print Area” under
Options on the Page Setup dialog box for better centering of text
on the labels that run along the left and right edges of the page.

“ About ImageWriter labels: Use labels that are on 8.5-by-11-inch
tractor-feed pages.

Columns

In the column format, selected fields from the current background
are printed side by side in vertical columns across the page. Each
field has its own column. (See Figure 6-15.)

 

You must have “With the current background” checked for
the column format to work.
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If a column is too narrow for the entire contents ofa field to fit on
one line, HyperCard wraps the text to new lines as appropriate.

HyperCard won't let you select more fields than will fit across the
page. You can see how many will fit by looking at the minipage
window.

You can control the horizontal width of each column by dragging
the dashed separation lines.

If you check Cards under “Print the names of,” card names appear
in their own column on the far left. If you check Fields, field names
are printed across the top of the page above the appropriate
column. If a column is too narrow for the entire field nameto fit,
the field name is truncated.

Figure 6-15
Print Report in column format

Rows

In the Row format, information from each card is printed as a
block. Fields read vertically down the page for each card.
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The 3 row layouts

Here are the layouts.

You can choose among three different layouts to determine the
sequence of printing, and the amount of space across the page
that’s allocated to each block.

If you click on the left layout, each field’s information is printed
across the width of the page, each field below the previous one.
With the center and right layouts, HyperCard prints blocks of
information for two cards side by side. (See Figure 6-16.)

 

Drag here to change

:
 

printed field width.

The numbers refer to card
position in the stack

Figure 6-16
Print Report in row format

The card sequence in which the information is printed depends on
the layout order you select. If you select the layout order in the
center, reports appear beneath each other in the left column until
page bottom; The next card’s report appears at the start of the right
column. If you select the layout order on the right, the block reports
alternate left-right down the page. (See Figures 6-17 and 6-18.)

If you check Fields under “Print the names of” the name of each
field is printed to the left of the field’s contents. (If the field is
empty, HyperCard skips it and doesn’t print the field’s name.) You
can grab the vertical dotted line and drag it to adjust the width for
the name. Card names are printed at the top of each card’s block.

Card blocks are printed in the order that the cards appear in the
stack.
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Card Name
Name and Address

Phone Number
Date

Card Name
Name and Address

Phone Number

 

Card 1

Steve Aaron
2260 Oak Creek Drive

555-7806
2/23/87

Card2
Katie Aichler
9424 Middlefield Road

Card Name
Name and Address

Phone Number
Date

Card Name
Name and Address

Card 10
Emmett Cardenas
1919 Short Street
555-8487
2/23/87

Card 11

Joshua Carlson
6291 Elliot Street

 

 

555-4844 Phone Number 555-3109
Date 2/23/87 Date 2/23/87

Card Name: Card 3 Card Name Card 12
Name and Address: Martha Belion Name and Address: Karl Daly

8495 Jefferson St 1964 Lundy Ln
Phone Number: 555-0934 Christe, Texas
Daté 2/23/87 Phone Number (512) 555-8745

Date 2/23/87
Card Name: Card4
Name and Address: Marti Belisle Card Name Card 13

3703 Maude Ave Name and Address: Annette Darling
Phone Number: 555-8203 nN Pau ies Ave

tol, PennsylvaniaDate 5/26/87 ? ‘ =~sy, ony, Phoe™ \. (215) 555-0696 _--~ss Ce ~, N “7
~saze: Car, sSy z \, 2/23/87 en

“address a s oags Neo

Figure 6-17
Print report in row format, top to bottom order

Card Name Card 1 Card Name Card2
Name and Address: Steve Aaron Name and Address: Katie Aichler

2260 Oak Creek Drive 9424 Middlefield Road
Phone Number: 555-7806 Phone Number 555-4844
Date 2/23/87 Date 2/23/87

Card Name: Card 3 Card Name Card4
Name and Address: Martha Belion Name and Address: Marti Belisle

8495 Jefferson St 3703 Maude Ave
Phone Number 555-0934 Phone Number 555-8203
Date 2/23/87 Date 5/26/87

Card Name: Card § Card Name Card 6
Name and Address: Roger Benrey Name and Address: Loween Blank

9541 Mount Vernon Dr 6686 Martin Ave
Phone Number: 555-3005 Prairie, Texas
Date 2/23/87 Phone Number (214) 555-5456

Date 2/23/87

Card Name: Card 7 Card Name: Card 8
Name and Address: Richard Boyd Pies Name and Address: Shannon Browneoe 6686 Black Moup” 7814 Olive Ave
“-aag_Number: 555-6080 “~~ Phone Numbe“S. 555-1765 aoe ae Date: 2-7 S5y23/87 ee~.Bier al oe > ae

Figure 6-18
Print report in row format, left to right order
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Manual paper feed

Check the manual paper feed box if you’re feeding paper by hand,
HyperCard will stop the printer after each sheet and wait for you to
add more paper.

Header

Tab to the Header box and type what you want to appear as a

heading at the top of each sheet. Click the proper icon(s) after you
tab to add page numbers, the date, the current time, and the stack
name to the header. Click icons in the order you want them to
appear in the heading. (Use the space bar to separate them.) You
can preview what the header will produce by looking in the
minipage window.

Format remembered

Once you print a report, HyperCard remembers the format and
header you used for that stack’s report so you can use the same setup
next time you print.

 

Quit HyperCard
Quit HyperCard (or Command-Q) leaves HyperCard,
automatically saving any changes you’ve made.

 

 

 

Edit Menu
The Edit menu lets you change your work. Undo, Cut, Copy, Paste,

and Clear all work as they’re described in the owner’s guide that
came with your computer. The other commands are unique to
HyperCard.
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The different Edit menus
The level set on the User Preferences card of the Home stack, in
conjunction with the protection level set for a particular stack,
determines which menu appears when you press Edit. If either level
is set to Browsing or Typing, you choose a command from the short
menu (left in Figure 6-19). Otherwise you choose froma full menu
(right in Figure 6-19).

 

Figure 6-19
Short and full Edit menus

For information on user levels, see “User Preferences” in
Chapter 3. For information on individual stack protection, see
“Protect Stack” earlier in this chapter.

 

Undo
Undo (or Command-Z) undoes your last action on a card or
background. Use it when you make a mistake or when you change
your mind about some action.

With the Paint tools, pressing Tilde or Escape is the same as
choosing Undo.
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Cut
Cut (or Command-X) removes the selected information from the
card or background and puts it on the Clipboard. Use Cut when you
want to move something from one place to another.

Cutting a picture

When you're using a Paint tool, Cut affects either the background
picture or the card picture, depending on whether the Background
command in the Edit menu is checked or unchecked.

m To cuta picture:

1. Select the portion of the picture you want to cut.

Use either the Lasso or the Selection tool to do it. (See “Lasso”
and “Selection Tool” later in this chapter.)

2. Choose Cut from the Edit menu.

You can also press Command-X.

Cutting buttons and fields

When you cut a button, you also cut its associated actions. If you
paste the button, you paste its actions along with it.

 

Buttons and the pictures representing them are often separate.
This is always the case if a button is transparent. Remember to
cut and paste the picture as well as the button. (You'll have to
cut and paste them separately.)
 

When you cut a field, all text and attributes (field name, font, and so
on) belonging to that field are cut along with it. If you paste back that
field in the same or another stack, you also paste back its attributes,
but not its text.

m To cut a button or a field:

1. Select the button or field tool.

2. Click the specific button or field you want to cut.
3. Choose Cut from the Edit menu (or press Command-x).
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Cutting a card

= To cut a card:

1. Move to the card you want to cut.
2. Choose Cut Card from the Edit menu.

When you cut a card, you cut everything on it—picture, fields, text,
buttons, actions, and a copy of that card’s background.

Cutting a background

You can’t cut a background. To remove a background froma stack,
you must delete every card that uses that background. If there is only
one card in the stack, you must delete the stack.

Copy (or Command-C) makes a copy of the selected information
and puts it on the Clipboard. The selected information is left
unaffected (but whatever was on the Clipboard is replaced). If
you're using a Paint tool and nothing is selected, all the Paint
information is copied.

Copying a picture
When you're using a Paint tool, Copy gets its information from
either the background picture or the card picture, depending on
whether the Background command in the Edit menu is checked or
unchecked.

= To copya picture:

1. Select the portion of the picture you want to Copy.
Use either the Lasso or the Selection tool to do it. (See “Lasso”
and “Selection Tool” later in this chapter.)

2. Choose Copy Picture from the Edit menu.
You can also press Command-C.

3. Move to the card where you want the copied picture to
appear.

Moving between cards or stacks doesn’t affect what’s on the
Clipboard, the holding place for what you copied.

108 Chapter 6: Menu Commands



Important

4. Choose Paste Picture from the Edit menu.

Or press Command-V. The copied picture appears.

5. Drag the picture where you want it to be on the card.
6. Click anywhere outside the pasied area.

Copying buttons and fields

When you copy a button, you also copy its actions. If you paste the
button, you paste its actions along with it.

 

Buttons and the pictures representing them are often separate.
This is always the case if a button is transparent. Remember to
copy the picture as well as the button. (You'll have to copy
them separately.)
 

When you copya field, all you copy is the field itself; you don’t
copy the field’s text.

To copy a button or a field:

. Select the button or field tool.

. Click the specific button or field you want to copy.

. Choose Copy Button or Copy Field from the Edit menu (or
press Command-C).

4. Move to the card where you want the copied button or field
to appear.
Moving between cards or stacks doesn’t affect what’s on the
Clipboard, the holding place for what you copied.

5. Choose Paste Button or Paste Field from the Edit menu.
Or press Command-V. The copied button or field appears.

6. Drag the button or field where you want it to be on the
card.

7. Click anywhere outside the pasted area.

onND

—

Copying a card

m= To copya card:

1. Choose Copy Card from the Edit menu.
A copy of the current card is placed onto the Clipboard.
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2. Move to the card after which you want the copied card to
appear.
It can be in the current stack or in any other stack.

3. Choose Paste Card from the Edit menu.

Or press Command-V. The pasted card becomes the current
card.

To change a card’s position so that it’s first in a stack:

. Move to the card whose position you want to change.

. Choose Cut Card from the Edit menu.

. Choose First on the Go menu.o

ND

—

EB

Or press Command-1. The first card in the stack appears.

4. Choose Paste Card on the Edit menu.

Or press Command-V. The pasted card appears on the screen; it
is now the second card in the stack.

5. Choose First on the Go menu again.

Or press Command-1. The first card in the stack appears.

6. Choose Cut Card on the Edit menu.

The card you had originally set out to reposition is now first in the
stack.

7. Choose Paste Card on the Edit menu.

(Or press Command-V.) The original first card is now second in
the stack.

When you copy a card, you copy everything associated with
it—background, picture, fields, text, buttons, and actions.

Copying a background

You copy a background by copying the card that has the
background you want. (A copied card takes everything with it.)

To copy a background:

. Copy a card that has the background you want.

. Move to where you want the new background.

. Paste the copied card.

. Make new cards based on the copied card’s background.

. Delete the original pasted card.oa

hk

WN

—

You can’t replace an existing card’s background.
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Paste

Paste (or Command-V) takes a copy of the material that’s on the
Clipboard and puts it on the screen.

O If the material is regular text, it appears at the insertion point of a

field you’ve chosen.

O If the material is a picture, it appears at the screen position at
which it was cut.

O If the material is a field or button, it appears at the screen
position at which it was cut. (You can movea pasted selection by
dragging within the selection.) Pasted buttons and fields retain
all their original actions.

O If the material is a card, it appears after the current card in the
stack. A pasted card pastes its background as well (assuming the
background is different from the ones surrounding it).

When you're using a Paint tool, the material you’re about to paste
can be text or a picture. If the material is regular text (that is, text
created with the Text tool), shrinking the selection by dragging the
corners with the Command key pressed makes more or less of the
text appear. (The text wraps at the right border of the selection.)
The text becomesa picture after you’ve pasted it and clicked outside
the selected area.

Pictures are pasted in opaque; if you want the background to show
through, choose Transparent from the Paint menu after you’ve
pasted onto the card, but before you’ve clicked outside the pasted
area to make the changes complete.

Pasting a card in miniature

You can paste a picture of a card in miniature, like the cards that
appear when you choose Recent from the Go menu.

To paste a miniature:

. Choose Copy Card or Cut Card from the Edit menu.

. Move to the card where you want to paste the miniature.

. Press and hold the Shift key while you choose Paste Card.
Alternately, press Command-Shift-V.

onD

—

FF

The miniature appears selected in the center of the screen.

Note that this is a picture of a card—none of the actions from the
original card come with the miniature.
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Clear removes the selected information without putting it on the
Clipboard or affecting what’s already on the Clipboard.

When you’re using a Paint tool, Clear affects either the selected
background picture or the selected card picture, depending on
whether the Background command in the Edit menu is checked or
unchecked.

When the Message box is visible and the insertion point is not
visible, Clear empties the Message box and puts the insertion point
in it.

Pressing the Delete or Backspace key (or the Clear key on the
keypad) has the same effect as Clear.

 

New Card
New Card (or Command-N) adds a card to the current stack. The
new card automatically picks up the background picture,
background buttons, and fields of the card you’re looking at.

The new card is inserted immediately after the card you were
looking at. You end up looking at the card you just inserted.

= To make the new card the first one in the stack:

1. Choose First on the Go menu.
Or press Command-1. The first card in the stack appears.

2. Choose New Card on the Edit menu.
Or press Command-N. The new card appears on the screen; it is
now the second card in the stack.

3. Choose First on the Go menu again.
Or press Command-1. The first card in the stack appears again.

4. Choose Cut Card on the Edit menu.
The card you had originally set out to reposition is now first in the
stack.
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= If you want to place the cut card back into the stack, you need to
follow two more steps:

1. Move to the card you want to come immediately before the
one you've just cuf.

2. Choose Paste Card on the Edit menu.

Or press Command-V.

The pasted card appears on the screen in its new position in the
stack.

 

Delete Card P

Delete Card (or Command-Backspace or Command-Clear)
permanently eliminates the current card. Delete Card works exactly
like Cut Card, except that the deleted card does not go onto the
Clipboard and so cannot be pasted anywhere.

You can’t delete the last card in a stack. To delete the last card, use

Delete Stack from the Stack menu.

Cut Card
Cut Card (available only when Painting, Authoring, or Scripting is
checked in the User Preferences card of the Home stack) removes
the card on the screen, deletes it from the stack, and puts up the
next card in the stack. HyperCard doesn’t ask you to confirm the
cut—it just does it.

 

You can’t cut the last card in a stack. To cut the last card, use Delete
Stack from the Stack menu.

  

Copy Card
Copy Card (available only when Painting, Authoring, or Scripting
is checked in the User Preferences card of the Home stack) makes a

copy of the current card and puts it on the Clipboard. Whatever was
on the Clipboard is replaced.

When you copy a card, you copy everything associated with
it—background, picture, fields, text, buttons, and actions.
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Text Style

Text Style, or Command-T, (available only when Painting,
Authoring, or Scripting is checked in the User Preferences card of
the Home stack) lets you set text properties for the active field or the
active Paint text. (Paint text is text created using the Paint Text
tool.) Paint text is active until you

QO switch tools after you’ve typed,

O click the mouse,

O leave the card, or

0 switch into or out of the background.

A field is active if the insertion point is in it.

A dialog box appears, letting you choose text font, style,
alignment, size, and the height of each line in points.

Scroll to the font you want; Click the size you wart...
then click to select it. |

 

..or type it here.

—

 Check one or more styles
for all the text in a field
(or check nothing for plain text).

 

The alignment you set ——_—i
works on all lines
in the same field. eee

 

|

What you see is This determines the space
what you'll get. between lines, in points.

Figure 6-20
Text styles dialog box

 

See “Setting Text Properties” in Chapter 4 for more information.
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Important

 

Background
Background, or Command-B, (available only when Painting,
Authoring, or Scripting is checked in the User Preferences card of
the Home stack) lets you edit the background picture and create
background buttons and fields.

The background serves as a template; whatever’s in the background
is common to all cards associated with that background.

Background alone With transparent card picture

Figure 6-21
Background versus card picture

The background picture is hidden by any black or opaque portions
of the card picture. (You choose Transparent and Opaque from the
Paint menu, described later in this chapter.)

A background button works for all cards associated with that
background, unless it’s covered by a card button; a background
field appears in the same location on all cards associated with that
background, unless it’s covered by a card field.

 

The most common mistake in creating a button or a field is

putting it on a card when it’s supposed to be on a background.
After you've created one or more background buttons or fields,
choose Background again to get back to the Card level, and
flip to the next card; if the buttons or fields you've just created
are on that card too, you’ve succeeded.

 

When you’re working in a background, the menu bar is striped, and
a check mark appears to the left of the Background command in the
Edit menu. (See Figure 6-22.)
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Striped lines mean you're working
in a background as opposed
to working on a specific card.

 Edit checked

Figure 6-22
Menu bar striped while working in background

There’s no limit (beyond disk space) to the number of backgrounds
a stack can have.

 

 

 

Go menu
Use commands in the Go menu to navigate through stacks. You can
look through cards in the current stack, go back through cards and
stacks you’ve already seen, or immediately get to any stack
represented on the Home card.

Figure 6-23
Go menu

 

Back
The Back command (or Tilde, Esc, or Down Arrow) takes you to the
most recent card you’ve viewed. Keep choosing this command to
review up to the last 100 cards you’ve seen.
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After you’ve backed through cards, you can press the Up Arrow key
to come forward again through the reviewed cards.

When you’re using a Paint tool, use Command-Tilde (or
Command-Esc) instead of Tilde as a shortcut for the Back
commands. (Pressing Tilde alone in a Paint tool undoes your
last action.)

 

Home
Home (or Command-H) selects the Browse tool and takes you to
the Home card, the first card in the Home stack. The Home card is
special—it’s meant to hold buttons that bring you to the most
important cards in your collection.

Figure 6-24
Home card

To go to any stack represented on the Home card, click on its
picture. (Each picture is actually a button.)

For more details about the Home card and the rest of the Home
stack, see Chapter 3.
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Help
Help (or Command-?) takes you to the first card in the Help system.
The Help system describes everything in HyperCard, including
some features not covered in this manual. It is the ultimate source of
HyperCard information.

When you use Command-? as a shortcut to choosing Help, you
don’t have to press the Shift key.

 

Recent
Recent (or Command-R) lets you backtrack through any or all of the
last 42 cards you viewed.

When you look at a card, HyperCard puts a miniature picture of it
on Recent. To go back to that card, just click that card’s picture.

Although you might have looked at the same card several times,
Recent holds only one picture of it.

Click any image to go to that card.

Figure 6-25
Recent

118 Chapter 6: Menu Commands



You can go back through the last 100 cards you viewed in the order
that you viewed them by using the Back command (or by pressing
Tilde), described earlier in this section.

To return to the card you most recently viewed, click the picture of
the card with the box around it or press Return.

 

First

First CCommand-1 or Command-Left Arrow) takes you to the first
card in the current stack.

If you’re already at the first card, First does nothing.

 

Prev

Prev (Command-2 or Left Arrow) takes you to the previous card in
the current stack. If you’re at the first card in the stack, Prev wraps
you around to the last card in the stack.

“ Prev isn’t Back: Prev takes you to the previous card in the current
stack; Back takes you to the card you last looked at. The last card
you looked at might have been in another stack.

 

Next
Next (Command-3 or Right Arrow) takes you to the next card in the
current stack. If you’re at the last card, Next wraps you around to the
first card.
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Last

Last (Command—4 or Command-Right Arrow) takes you to the last
card in the current stack. Use last when you want to create a new card
at the end of the stack.

If you’re already at the last card, Last does nothing.

 

Find

Find (or Command-F) searches for text in the fields of the current
stack. Choosing Find brings up the Message box, as it appears in
Figure 6-26.

The insertion point comes up
between the quotation marks.

Figure 6-26
Message box

m= To search for text:

1. Choose Find from the Go menu.
2. Type what you want to find.

Or press the Command key as you select up toa line of
characters from any text field. (A box appears around the
text as you select it.)

3. Press Return or Enter.

HyperCard searches the current stack for a series of characters in
any field that begins with what’s in the Message box. HyperCard
looks for the first card that contains everything between the
quotation marks, even if the words appear in a different order.
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Matches what's in
the Message box.

 

Figure 6-27
Finding a name

Pressing Return after a search makes HyperCard repeat the search.

If you choose Find again after an initial search, HyperTalk selects
what you’ve typed between the quotation marks. To replace what's
in the Message box, just type something new.

“ Watch those quotation marks: The text that you want to find
must appear between quotation marks after the word “find.”

To cancel a search-in-progress, press Command-period (.).

If HyperCard can’t find the text, the Macintosh beeps.

Searching in a specific field

HyperCard automatically searches through all the fields on all the
cards in the current stack. You can limit the search to one specific
field.

= To limit the search to a specific field:
m Click after the last quotation mark and type a space, the

words in field, and the field number or name.

To search only card fields, type the words in card field and
the field name or number.

Figure 6-28 shows an example.
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Figure 6-28
Limiting the search

= To find the name or number ofa field:

m Click in the field with the Browse tool selected and choose
Field Info from the Objects menu.

Alternatively, take the following steps:

1. Click the Field tool.
To use the Field tool, you must have Authoring or Scripting
checked on the User Preferences card in the Home stack.

2. Click the field whose name or number you want to know.
3. Choose Field Info from the Objects menu.

Or just double-click in the field you’re interested in.

 Field number ber(2)

Figure 6-29
Finding out a field's number
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Message

Message (or Command-M) shows the Message box. Use the
Message box to send any one-line message to HyperCard.

m To send a message:

1. Make sure the insertion point is in the box by clicking in it.

2. Type the message.

3. Press Enter or Return.

Figure 6-30
Sending a message

m To stop a message-in-progress:

m Press Command-period (.).

To clear the Message box so you can use it again, do any of the
following:

O Choose Message box again from the Go menu.

O Press Command-M.

O Select all the text in it and press Clear or Backspace.

O Select all the text in it and type a new message.

To hide the Message box, click its close box (or press
Command-M).

To type messages into the Message box when the box isn’t visible,
check Blind Typing on the User Preferences card in the Home stack.

See Appendix A for a list of the most common HyperCard
messages.

For detailed information on all HyperCard messages and other
advanced HyperCard topics, see the HyperCard Script Language
Guide.
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Tools menu
You use tools to browse, to edit text and pictures, and to create and
change buttons and fields. You can have only one tool selected at a
time. One tool—any tool—must be selected.

yan oe

gn |
See

 

A,

ae Loss Tools menu

Figure 6-31
Tools in action

The Tools menu appears when Painting, Authoring, or Scripting is
checked on the User Preferences card in the Home stack.

The Tools menu holds the General and Paint tools. General tools
are on the menu’s top line; they control browsing, text creating and
editing, and button creating and selecting. Paint tools, which fill
the rest of the menu, control creating and editing pictures.

Browse OU oe

Eraser \

Selection we? +——§ Pencil
Brush 1 =. _une

 Lasso

 

 

 

 

      

 

 

Spray Rounded Rectangle
Bucket 2 resi Curve

Rectangle a i Oval

Paint Text Regular Polygon Polygon

Figure 6-32
Too! names
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 General tools ———

Paint tools ———————

1

You can “tear off” the Tools menu, creating a movable tools
palette.

m To create a movable Tools palette:

= Drag down through the menu, either past the bottom or
beyond either side.

You can also press Option-Tab to make a Tools palette appear
and disappear.

Put the palette wherever you want.

To put it away, click its close box. To move the palette around, grab
it by its top bar or by any edge. To select a tool, click it. (You can
also select a tool from the Tools menu in the Menu bar, even if you
have a palette torn off; the palette will reflect the menu selection.)

Close box
|

Drag here.

+—— Click any tool to select it.

 

Figure 6-33
Using the Tools palette

gu To select a tool, click inside the box that holds it.

The tool you select becomes highlighted in the menu, and,
depending on the tool you’ve selected, the shape of the pointer
might change.

Authoring or Scripting must be checked on the User Preferences
card in the Home stack if you want to select the Button tool or Field
tool.
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Browse tool

l-beam pointer

Button tool

 

Menu bar changes
When you choose one of the Paint tools, three new menus
appear—Paint, Options, and Patterns. (These menus are described
later in this chapter.) If the Objects menu was visible, it disappears;
it reappears (and the Paint, Options, and Patterns menus all go
away again) when you choose a General tool.

 

Browse tool
When you select the Browse tool, the pointer becomes a hand with
the first finger extended. Use the Browse tool to click buttons, to
edit text, and to select text for searching. The Browse tool converts
to an I-beam when it’s over editable text when any level except
Browsing is checked on the User Preferences card in the Home
stack.

In its I-beam shape, the pointer lets you type and edit text in fields
(described elsewhere in this chapter and in Chapter 4). Click in the
field where you want to type.

To learn about editing text in the Macintosh, see the owner’s guide
that came with your computer.

For detailed information about text and the fields that text appears
in, see Chapter 4 of this guide.

For a detailed tutorial on browsing and editing, see Chapter 1,

“Browsing and Editing.”

For information on typing text not limited to fields, see “Paint Text
Tool” later in this chapter.

 

Button tool
Use the Button tool to make new buttons or to see buttons that
already exist.

To use the Button tool, make sure that Authoring or Scripting is
checked on the User Preferences card in the Home stack.
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Important

When you choose the button tool, the buttons on the card and the

card’s background appear surrounded bya thin-lined box; a

selected button is surrounded by a moving dotted line.

Buttons enclosed
by thin-lined boxes

—— Selected button enclosed
by moving dotted line

Figure 6-34
Buttons with button tool selected

To create a button:

Choose New Button in the Objects menu.

Alternatively, select the Button tool; then press the Command
key and drag diagonally.

To create a button that appears automatically on all cards that
share a particular background:

. Choose Background from the Edit menu.

. Choose New Button in the Objects menu.

Alternatively, select the Button tool, press the Command key,
and drag diagonally.

 

The most common mistake in creating a button is putting it on
a card when it’s supposed to be on a background. Affer you've
created one or more buttons, flip to the next card; if the
buttons you've just created are on that card too, you've
created background buttons.
 

Le

2.

To select a button:

Select the Button tool.
Click the button you want to select.
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To size a selected button, drag by any corner.

To movea selected button, drag by any edge; or place the pointer
inside the button and drag.

To duplicate a selected button, press Option while you drag.

To copy a button, select it and choose Copy Button from the Edit
menu (or press Command-C).

To cut a button, select it and choose Cut Button from the Edit menu
(or press Command-xX).

To eliminate the button without affecting the Clipboard, select it
and choose Clear Button from the Edit menu (or press Backspace or
the Clear key).

“ Browse tool versus Button tool: You must be using the Browse
tool to click buttons. After you’ve created a button and you want
to test it, be sure to select the Browse tool first.

To bring up information about a particular button:

. Select the Button tool.

. Click the button you’re interested in.

. Choose Button Info from the Objects menu.
(Alternately, choose the button tool and double-click the button
you're interested in.) The Button Info dialog box appears. (See
Figure 6-35.)

on

—

 

Nameme

 

|

 

| LinkTo
|

ript j OK ] 3———

Figure 6-35
New Button dialog box
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Field tool

To see all the buttons on a card and the background when the Button
tool is not selected, press the Command key and the Option key at
the same time.

To read about labeled buttons and buttons with different shapes
(and to get detailed information about the dialog box in Figure
6-35), see “Button Info” in the Objects Menu section of this
chapter.

For information about scripts, see the HyperCard Script Language
Guide.

 

Field tool
Use the Field tool to create and change text fields. You can have
fields on a specific card as well as fields common to all cards
associated with a given background.

To use the Field tool, make sure that Authoring or Scripting is
checked on the User Preferences card in the Home stack.

You can have as many fields on a card or a background as will fit.
The number of lines in a field depends on that field’s physical size,
the point size of the text within the field, and on the height of a
single line within the field. (See the Height box in the Text
Properties dialog box, elsewhere in this chapter.)

To create a field, choose New Field from the Objects menu.
Alternatively, select the Field tool; then position the pointer and,
while holding down the Command key, drag diagonally.

= To create a field for every card associated with a particular
background:

1. Choose Background from the Edit menu.
2. Choose New Field from the Objects menu.

Alternatively, select the Field tool, press the Command key, and
drag diagonally.
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Important

Warning

 

The most common mistake in creating a field Is putting if on a
card when it’s supposed to be on a background. After you've
created one or more fields, flip to the next card; if the fields
you've just created are on that card too, you've created
background fields.
 

= To select a field:

1. Click the field tool to select it.

2. Click inside the field you want to select.

To size a selected field, drag by any corner.

To movea selected field, drag by any edge; or place the pointer
inside the field and drag.

To duplicate a selected field, press Option while you drag.

To copya field, select it and choose Copy Field from the Edit menu
(or press Command-C).

To cut a field and all its accompanying text, select the field and
choose Cut Field from the Edit menu (or press Command-X).

To eliminate the field without affecting the Clipboard, select it and
choose Clear Field from the Edit menu (or press Backspace or the
Clear key).

 

Deleting a background field also deletes all text in that field on
all cards sharing that background. Once you've deleted the
field, it and all its text are gone for good—you can’t undo the
deletion.
 

To bring up information about a particular field:

. Click the field tool to select it.

. Click the field you’re interested in.

. Choose Field Info from the Objects menu.

Or just double-click the field you’re interested in. The dialog box
in Figure 6-36 appears.

on

—

F

Alternatively, move the insertion point to the field you want to know
about and choose Field Info from the Objects menu.
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Field Name: [Phone Number |

Card field number: 2

Card field ID: 2

 

Style:
@ transparent

(] Lock Text ©) opaque

 

 

   
  

 

L] Show Lines © rectangle
(] Wide Margins ©) shadow
peacesion oh © scrolling
| font... |

[ Script... ] i OK ] [ Cancel |

Figure 6-36
New Field dialog box

For details about the dialog box in Figure 6-36, see “Field Info” later
in this chapter.

For information about fields and their uses, see “Fields” in
Chapter 4.

 

Selection tool
co 4

Use the Selection tool to select a rectangular area of a picture. Drag
ae diagonally to select.

oe To select the whole picture, double-click the Selection tool on the
torn-off Tools palette. (You can also choose Select All from the
Paint menu.)

To shrink the selection area to the outer perimeters of the object
you're selecting, press the Command key while you drag; when you
release the mouse button, the rectangle closes in and eliminates
extra white space.

Press the Command key
as you drag...

..to eliminate extra
white space in the
selection.

 

Figure 6-37
Eliminating extra white space in a selection
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For an even tighter selection, press Option as you drag (or
Command-S after you drag) to convert the rectangle to a lasso and
to close in on the selection’s dark dots.

* Select, but can’t drag: If you've selected a picture but you can’t
drag it, you've tried to select a background picture without being
in the background. Choose Background from the Edit menu and
try again.

To movea selection, position the pointer inside the selection until
the pointer changes to an arrow; then drag.

To movea selection straight up or down or directly left or right,
press Shift while you drag.

To make a copy ofa selection, press Option while you drag.

To make multiple copies, press Command-Option while you drag.
(Press the Option key plus a number between 1 and 8 before you
drag to control spacing between images.)

To stretch or shrink a selection, press Command while you drag
from a corner.

 

Original Shrunk Stretched

Figure 6-38
Shrunk and stretched selection

To stretch or shrink straight up and down or straight left and right,
drag from any edge.
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Lasso

Use the Lasso to select a specific part of a picture when the area’s too
small for the Select tool or when you need to scoot around

Lasso nonrectangular images.

  
Figure 6-39
Only the lassoed fish are selected

To use the Lasso, drag around the area you want. (The line trailing
out of the lasso’s tip shows you what you’re lassoing.) When you
release the mouse button, the lasso hugs the part of the picture it
surrounds and selects it. (The lasso shrinks until it finds black dots.)
The edges of the lassoed area will shimmer.

To lasso an area without shrinking around black dots, press Option
as you drag.

To lasso an area that has no breaks in it (one surrounded by an
unbroken line, or one composed entirely of connected black dots),
move the lasso’s tip into it, press the Command key, and click the
mouse. This technique is especially handy for selecting small areas.

To lasso each element in the picture (ignoring any unenclosed white
space), double-click the Lasso in the torn-off Tools palette.

To movea selection, position the lasso’s tip within the selection
until the lasso changes to an arrow; then drag.

. To movea selection straight up or down or directly left or right,
becomes to drag. press Shift while you drag.

Gr

To make a copy of a selection, press Option while you drag.
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To make multiple copies, press Command-Option while you drag.
(Press the Option key plus a number between 1 and 8 before you
drag to control spacing between images.)

 

Figure 6-40
Multiple copies

To stretch or shrink a selection, press Command while you drag
from an edge.

: ina Li E ; oe |

Figure 6-41
Stretched and enlarged
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Pencil

Brush

 

Pencil
Use the Pencil to draw thin (one dot wide) free-form lines. Most
people find it the most useful tool for doing detailed work in FatBits.

Pencil draws in the opposite color of the first place you press the
Mouse button. (See Figure 6-42.)

 

ae

Starting on black Starting on white
draws in white. draws in black.

Figure 6-42
Drawing the opposite color

To draw straight horizontal or vertical lines, press the Shift key while
you drag.

To work with FatBits, double-click on the Pencil on the torn-off
Tools palette (or press Command as you click with the Pencil
selected). Click to make a single dot; click on an existing dot to
erase it.

For information on FatBits, see “FatBits” in the Options menu
section of this chapter.

 

Brush

Use the Brush to paint with the current pattern. Bring up a dialog
box of brush shapes and sizes by choosing Brush Shape from the
Options menu (or just double-click Brush); then click the one you
want. Different shapes create different effects.
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Eraser

 

 

   

   

 

 

  
Figure 6-43
Different brush shapes create different effects when you paint

To paint straight vertical or horizontal lines, press Shift while you
drag.

To erase instead of paint with a brush shape, press Command while
you drag. Change the brush shape to change the shape of the
“brush-eraser.”

 

Eraser

The Eraser wipes out the part of a picture you drag over.

To erase the whole picture, double-click the Eraser. HyperCard
wipes out the picture, and then selects the tool you were using just
before you double-clicked the Eraser. (Choose Undo from the Edit
menu, or Revert from the Paint menu, if you double-click by
accident.)

“ Magic appearances: If you see a picture appearing under the
eraser as you drag the eraser over a card picture, you’re exposing
a covered background picture. To erase with white paint (which
prevents the background picture from appearing), press the
Command key as you drag.
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Line tool

 

Line tool
Use the Line tool to draw straight lines. Drag to draw lines in black;
press Option while you drag to draw lines in the selected pattern.
(See “Pattern Menu” later in this chapter.)

To change line thickness, choose Line Size from the Options menu
(or double-click the Lines tool on the torn-off Tools palette) and
click one of the choices. Or press 1 through8 (5 is the same as 4,

7 is the same as 6) with Power Keys checked on the Options menu
for lines that many dots wide. To keep the same line thickness, click
the highlighted choice.

 

Figure 6-44
Line and border width

To change the angle of a line, with the mouse button still pressed
move the mouse in another direction as you’re creating the line.

To constrain angle changes to 15° increments, press Shift while you
drag.

To draw a line centered on a given point, choose Draw Centered
from the Options menu before you drag.

To drawa line with a multiple image of itself, choose Draw Multiple
from the Options menu before you drag. (Press the Option key plus
a number between 1 and 8 before you drag to control spacing
between images.)

For information about power keys, see “Power Keys” in the Options
Menu section of this chapter.
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Spray tool

CJ
Rectangle tool

 

 

   
 

 

 
 

 
 

 

 

 

 

  

Line widths and pattern menu

 

Spray tool
Use the Spray tool to spritz paint onto the screen in the selected
pattern. The more you spray back and forth over the same area, the
more the pattern becomes apparent.

To spray straight vertical or horizontal lines, press Shift while you
drag.

To erase with the Spray tool, press Command while you drag.

 

Rectangle tool
The Rectangle tool draws rectangles. To draw black-bordered
rectangles, position the crossbar pointer where you want the
rectangle to start; then draw diagonally.

To change the thickness for a rectangle’s border before you draw it
choose Line Size from the Options menu (or double-click the Lines
tool) and click one of the choices.

?

To draw rectangles filled with the selected pattern, choose Draw
Filled from the Options menu.

To draw with borders in the selected pattern, press Option as you
Start to drag.

 

  
   4
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draw borders in
the current pattern.
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Figure 6-45
Rectangles with patterned borders
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Rounded Rectangle tool

To draw centered on a given point, choose Draw Centered from the
Options menu before you drag.

To draw borderless rectangles, choose Draw Filled from the
Options menu and hold down the Option key as you drag.

To draw multiple rectangles, choose Draw Multiple from the
Options menu before you drag. (Press the Option key plus a number
between 1 and 8 before you drag to control spacing between
images.)

To draw squares, hold down the Shift key while you drag.

 

Rounded Rectangle tool
The Rounded Rectangle tool draws rectangles with rounded
corners. To draw black-bordered rounded rectangles, position the
pointer where you want the rectangle to start; then draw diagonally.

To draw borders using the current pattern, hold down the Option
key while you drag.

Figure 6-46
Creating and combining rounded rectangles

To change border thickness, choose Line Size from the Options
menu (or double-click the Lines tool) and click one of the choices;
or press 1 through 8 with Power Keys checked on the Options menu
for increasingly thicker lines.
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To draw rounded rectangles filled with the selected pattern, choose
Draw Filled in the Options menu before you drag. (Double-click
this tool to toggle Draw Filled on and off.)

To draw centered on a given point, choose Draw Centered on the
Options menu before you drag.

To draw with a multiple image, choose Draw Multiple on the
Options menu before you drag. (Press the Option key plus a number
between 1 and8 before you drag to control spacing between
images.)

To draw squares with rounded corners, press Shift while you drag.

 

Bucket
Use the Bucket to fill solid black and enclosed white areas (including
the hollow parts of outlined and shadowed letters) with the selected
pattern.

Before After

Figure 6-47
Using the Bucket

If there are any gaps in the outline surrounding an area, paint will
spill out and fill the surrounding area as well. (You can use FatBits to
check for gaps.)
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Oval tool

 

 

 

 

 

 

Before After

Figure 6-48
Paint spilled in enclosed and unenclosed areas

You can’t use the Bucket to fill a dark area (as opposed to a black
area) with a lighter color. Instead, select the area and use Fill from
the Paint menu.

“ Cleaning up accidental spills: lf you accidentally fill your screen
with paint, immediately choose Undo from the Edit menu; then
check carefully for gaps in your drawing before using the Bucket
again.

“+ Bucket short cut: Double-click the Bucket to make the Patterns
palette appear and disappear.

 

Oval tool
The Oval tool draws oval shapes. To draw black-bordered ovals,
position the pointer where you want the oval to start; then drag
diagonally.

To draw borders using the current pattern, hold down the Option
key while you drag.

To draw circles, press Shift while you drag.

To draw centered on a given point, choose Draw Centered on the
Options menu before you drag.

To draw filled with the current pattern, choose Draw Filled on the
Options menu before you drag.
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Curve tool

To draw with a multiple image, choose Draw Multiple on the
Options menu before you drag. (Press the Option key plus a number
between 1 and 8 before you drag to control spacing between
images.)

To change border thickness, choose Line Size from the Options
menu (or double-click the Lines tool) and click one of the choices;
or press 1 through8 (5 is the same as 4, 7 is the same as 6) with Power
Keys checked on the Options menu for increasingly thicker lines.

 

Curve tool
Use this tool to draw free-form shapes. Drag to draw whatever shape
you want.

If you draw with Draw Filled checked from the Options menu,
HyperCard drawsa straight line connecting the starting and ending
points of the shape when you release the mouse button; then it fills
the shape with the selected pattern. (Double-clicking the Curve tool
toggles Draw Filled on and off.)

Curve tool, Curve tool,
Draw Filled unchecked Draw Filled checked

Figure 6-49
Drawing filled and unfilled shapes

To change border thickness, choose Line Size from the Options
menu (or double-click the Lines tool) and click one of the choices;
or press 1 through8 G is the same as 4, 7 is the same as 6) with Power
Keys checked from the Options menu for increasingly thicker lines.

To draw borders using the current pattern, hold down the Option
key while you drag.
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Paint Text tool
Use Paint Text to type text that’s part of the picture. Paint text is
especially useful as part of a background picture: use it for labels and

Paint Text tool titles that you want to show on many cards.

Set text attributes by choosing Text Style from the Edit menu or by
double-clicking the Paint Text tool. The settings you make stay in
effect until you change them, or until you restart HyperCard.

Press Return to move down to a new line.

Scroll to the font you want;
then click to select it.

 Click the size you wart...

..or type it here.

  

Check one or more styles ——
(or check nothing for plain text).

 

 

The alignment you set ————}}
works on alll lines.  

What you see ———__— This determines the space
is what you get. between lines, in points.

Figure 6-50
Text Style dialog box

 

Text you type using this tool is different from text you enter into
fields. You don’t create a field in which Paint Text appears—you just
position the cursor and click where you want the text to start, and
then type. As soon as you confirm what you've typed (by clicking,
choosing another tool, choosing Keep from the Paint menu, or
moving to another card), the text becomes part of the picture—its
attributes become fixed. To change an attribute or to edit text, you
have to erase the old text and start again.

“ Quick textpickup tip: To select text you’ve just finished typing,
press Command-S.
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Important You can’t use the Find command to search for Paint Text. To
HyperCard, Paint Text is just another picture. If you think that
you'll want to search later for what you’re typing now, create
a field and enter text using the Browse tool.
 

Each time you restart HyperCard, you reset the text attributes to
12-point plain Geneva with a line height of 16 dots, aligned left.
This doesn’t affect already-existing text.

 

Regular Polygon tool
The Regular Polygon tool creates polygons with regular sides.
Unlike the other shape-making tools, Regular Polygon always starts

Regular Polygon tool drawing the shape from the center outwards (whether Draw
Centered is checked or not on the Options menu).

fn

The shape gets drawn | a aud
from the center outward. \.

Figure 6-51
The Regular Polygon tool always draws as though you have
Draw Centered turned on.

To select the shape of the polygon, choose Polygon Sides from the
Options menu (or double-click the tool). When the dialog box
appears, click the shape you want. To keep the same shape, click the
highlighted choice.

 

 

 Click the shape you want to use. | 

   

   
 

Figure 6-52
Double-click the tool to select a shape
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Polygon tool

To create a shape, drag the mouse diagonally.

To rotate the shape, turn the mouse with the mouse button still
pressed as you're creating the shape.

To constrain movement to 15° increments, press Shift as you rotate.

To change border thickness, choose Line Size from the Options
menu (or double-click the Lines tool) and click one of the choices;
or press 1 through8 (5 is the same as 4, 7 is the same as 6) with Power
Keys checked on the Options menu for increasingly thicker lines.

To draw borders using the current pattern, hold down the Option
key while you drag.

To draw filled with the current pattern, choose Draw Filled from the
Options menu before you drag.

To draw with a multiple image, choose Draw Multiple from the
Options menu before you drag. (Press the Option key plus a number
between 1 and 8 before you drag to control spacing between
images.)

 

Polygon tool
Use this tool to create polygons with irregular sides. This tool works
differently from the others in that you don’t hold the mouse button
down to draw, and you double-click when you’ve finished the
shape.

To draw, position the mouse where you want to begin; then click
and release. Move the mouse until you’ve finished the first side,
then click; roll out the second side, then click again; continue until
you’ve finished all the sides, or double-click to end. (Clicking on
the beginning point also ends the shape.)

Figure 6-53
Using the Polygon tool
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HyperCard draws this line.

“+ Watch your double clicks: After you’ve started drawing, clicking
once on the starting point of the shape ends it. (Usually with this
tool, you double-click to end a shape.) But if you double-click on
the starting point after you’ve begun drawing, you'll end the first
shape and start a second one.

If the Draw Filled command in the Options menu is checked,
HyperCard drawsa straight line between the polygon’s starting and
ending points when you double-click to finish your polygon,
creating an enclosed shape. The shape is then filled with the current
pattern.

 

ES

Draw Filled unchecked Draw Filled checked

Figure 6-54
Creating an enclosed polygon

To draw borders using the current pattern, hold down the Option
key while you drag.

To change border thickness, choose Line Size from the Options
menu (or double-click the Lines tool) and click one of the choices;
or press 1 through8 (5 is the same as 4, 7 is the same as 6) with Power
Keys checked on the Options menu for increasingly thicker
borders.

To draw shapes constrained to 15 degree angles, start the polygon
with the Shift key pressed.

 
 
 

Objects menu
Use the Objects menu to create, examine, and change the actions of
and information about HyperCard objects—buttons, fields, cards,
backgrounds, and stacks.

To use the Objects menu, you must have the Browse, Button, or
Field tool selected.
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Figure 6-55
Objects menu

 

Button Info
Button Info brings up information about the selected button.

= To use the Button Info command:

1. Select the Button tool from the Tools menu.
2. Select the button you want to work with.

A button you've just created is automatically selected.

3. Choose the Button Info command from the Objects menu (or
double-click the button).

The dialog box in Figure 6-56 appears.

Figure 6-56
Button Info dialog box
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Button name

Type the name for this button into the Button Name box. If you
leave the box blank, your button will be nameless. If you just created
this button using the New Button command, the button is already
named “New Button.” Button name works with Show name,
described next.

Show name

Check the “Show name” box to have the button’s name appear on
the button. (Figure 6-57 shows how a button name appears with
different styles checked.)

Several buttons can have the same name; use the button ID,
described below, to distinguish between them.

Button number and layers

The button number line tells you whether the selected button is on
the card or on the background, as well as what layer it’s on. A button
that you’ve just created has the highest number, and is on the
frontmost layer on that card. The first button you create has the
number 1, the second button the number 2, and so on.

When you changea button’s layer, you change its number and the
numbers of all buttons whose layers are also changed. (See “Bring
Closer” and “Send Farther” later in this section.) When you delete a
button, the numbers of any buttons closer to the front are all
reduced by one.

Background buttons and card buttons are numbered separately. So
there can be both a background button anda card button with the
same number.

The highest number a background or card button can have is the
total number of buttons on that background or card; the lowest
number a background or card button can have is 1.

Button ID

Every button has a button ID unique in its stack. Unlike either the
button name or button number, the ID number is permanent and
unchangeable. When you delete a button, its ID number is
permanently retired from the stack. Advanced HyperCard creators
can use the ID number to create special button actions. See the
HyperCard Script Language Guide for detailed information.
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Style

Click one of these choices to set the style for the selected button.

i} “Transparent” makes the button transparent. Use this to make an
invisible button (perhaps one that goes over a picture), or one
that blends in with what’s behind it.

“Opaque” colors the button white. It’s like a white rectangle
without a border.

O “Rectangle” makes a white rectangle with a thin black border.

O “Shadow” makes a white rectangle with a drop shadow along the
right and bottom sides.

“Round rect” makes a standard Macintosh button, like the kind
you see in any dialog box.

“Check box” makes a square button with an opaque interior.

QO “Radio button” makes a small round button with an opaque
interior.

Figure 6-57
Button styles

Auto hilite

“Auto hilite” momentarily highlights any style button (except check
box and radio button) when you click it. A button in either check
box or radio button style toggles on and off when “Auto hilite” is
set. With “Auto hilite” unchecked, you receive no visual feedback
when you click a button. Figure 6-58 shows how each of the different
button styles are highlighted.
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(Check Box© ‘@ Radio Button

 

 

 
 Figure 6-58
Highlighting different styles

Icon...

Icon lets you use an icon as a button. Pressing this button brings up
the dialog box in Figure 6-59
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Figure 6-59

  
  Icon dialog box
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m To use an icon as a button:

1. Choose the Button tool.

2. Create a new button or select one that already exists.

Creating a new button automatically selects it.

3. Choose Button Info from the Objects menu.

Or double-click the button you want to work with.

4. Click the Icon button in the dialog box.

The dialog box in Figure 6-59 appears. If the button you’ve
selected is already an icon, its picture is highlighted in the dialog
box.

5. Click the picture of the icon you want to use as your button.

(Scroll through the choices, if necessary.) The icon whose
picture you click replaces the selected button on your card or
background.

The advantage of using an icon is that picture and button are
combined in one unit; this makes cutting, pasting, and moving
buttons easier.

When you use an icon, don’t use either the check box or the radio
button styles; otherwise, you won't see the icon.

LinkTo...

Press this to create a link for the button you’re creating. This option
is especially important because it’s the easiest way to establish
connections between cards and stacks. Once you’ve madea link,
pressing the button immediately moves you to the linked card or
stack.

LinkTo brings up a dialog box:

Go to destination, then aim link at

This Card This Stack Cancel |

 

Figure 6-60
Dialog box for making links
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Warning

m To set a link between the current card and any other card in any
stack:

1. Choose the Button tool.

2. Create a new button or select one that already exists.

Creating a new button automatically selects it.

3. Click Link To.

Using a button that already exists cancels any previous link you
might have set.

4. Go to the card you want to link to.

The dialog box stays on the screen while you’re looking for the
card. The card can be in the current stack or in any other stack.

5. Click the choice that reflects which card you want to go fo
when you press the button.
To link to the card you’re on, click “This Card.”

To link to the first card in the current stack (no matter what card
you’re on), click “This Stack.”

After you click, HyperCard brings you back to the card with the
selected button on it.

If the dialog box gets in your way, grab it by its top bar and drag it
where you want it to be.

 

Changing the name of a stack will break links you’ve made
between any card in the renamed stack and any other card in
any stack (including links within the renamed stack Itself).
When you change the name of a stack, be sure to redo all the
links.

 

Script

This feature, available only if Scripting is checked on the User
Preferences card in the Home stack, lets you write scripts that
control what happens when the selected button is pressed. See the
HyperCard Script Language Guide for details on this advanced
feature.
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Field Info
Field Info brings up information about the selected field. You can see

and change the field’s name, learn whether this is a background or a

card field, find out the field’s layer number (which tells you the layer
of the field relative to other fields on this card or background), make
the text in the field editable or locked, and determine the visual
characteristics of both the text in the field and of the field itself.

Ll.

2
3.

To use Field Info:

Select the Field tool from the Tools menu.
Select the field you want to work with by clicking in It.

Choose the Field Info command from the Objects menu.

Or just double-click the field. The dialog box in Figure 6-61
appears.

Figure 6-61
The Field info dialog box

4. Design the field.
QO Type or change the field’s name.

Click Lock Text to prevent the text in the field from being
changed. (Click it again to make the text editable.)

O Click Show Lines so that you can see where the lines are in a field.

QO Click Wide Margins to include extra space in the left and right
margins (useful for making text in fields easier to read).

Click the Font button to set or change the look of text in the field.
(See “Text Style” elsewhere in this chapter.)

Click one of the style buttons to set the look of the field itself.

. When you’re finished, click OK.
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Background shows through
transparent fields.

Scrolling field

Figure 6-62
Field styles

For more details on the features described here, see Chapter 4,
“Text in HyperCard.”

Field number

The Field number tells you what layer the field is on relative to other
fields. A field that you’ve just created has the highest number, and is
on the frontmost layer. The first field you create has the number 1,
the second field the number 2, and so on.

When you changea field’s layer, you change its number and the
numbers of all fields whose layers are also changed. (See “Bring
Closer” and “Send Farther” later in this section.) When you delete a
field, the numbers of any fields closer to the front are all reduced by
one.

Background fields and card fields are numbered separately. So
there can be both a background field anda card field with the same
number.

The highest number a background or card field can have is the total
number of fields on that background or card; the lowest number a
background or card field can have is 1. (For more details, see “Tab
Order and Layers” in Chapter 4, “Text in HyperCard.”)
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Field ID

Every field has a field ID unique in its stack. Unlike a field’s name or
number, the ID number is permanent and unchangeable. When
you delete a field, its ID number is permanently retired from the
stack.

“ Specialfield actions: Advanced HyperCard creators can use the
ID number to create special field actions. See the HyperCard
Script Language Guide for details on this advanced feature.

Script

This button (available only if Scripting is checked on the User
Preferences card in the Home stack) lets you write scripts
associated with the field. For details on scripts, see the HyperCard
Script Language Guide.

 

Card Info
The Card Info command brings up information about the current
card.

m To use the Card Info command:

1. Select any General tool from the Tools menu.
2. Choose the Card Info command from the Objects menu.

The dialog box in Figure 6-63 appears.

Figure 6-63
Card Info dialog box
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3. Type or change the card’s name, check a box, or click one
of the buttons.

Click Script to look at, create, or change the card’s script.

4. When you're finished, click OK.

Can’t delete card

When “Can’t delete card” is checked, you can’t remove the card
from the stack. (You can, however, delete the stack, taking the
protected card with it.) To allow the card to be removed, uncheck
the box by clicking in it.

For information on using scripts, including how to use card ID
numbers, see the HyperCard Script Language Guide.

Changing a card’s position in a stack
Card Number tells you the number of cards in the stack, and the
current card’s position in the stack.

To change a card’s position in a stack:

. Move to the card whose position you want to change.

. Choose Cut Card from the Edit menu.

. Move to the card you want to come immediately before the
one you've just cut.

4. Choose Paste Card from the Edit menu.
Or press Command-v.

oN

—

The pasted card appears on the screen.

To move a card to the first position in a stack requires several more
steps. You must first make the wanted card the second one in a
stack; then you have to move the first card in the stack out of the
way.
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To change a card’s position so that it’s first in a stack:

. Move to the card whose position you want to change.

. Choose Cut Card from the Edit menu.

. Choose First from the Go menu.

Or press Command-1. The first card in the stack appears.

. Choose Paste Card from the Edit menu.

Or press Command-V. The pasted card appears from the
screen, it is now the second card in the stack.

. Choose First from the Go menu again.
Or press Command-1. The first card in the stack appears.

. Choose Cut Card from the Edit menu.

Or press Command-X. The card you had originally set out to
reposition is now first in the stack.

. Choose Paste Card from the Edit menu.

Or press Command-V. The original first card is now second.

 

Bkgnd Info
Bkgnd Info brings up information about the current background.
You can see and change the background’s name, find out the
number of cards that share the background, and learn how many
fields and buttons this background has.

iL

2.

To use Bkgnd Info:

Select any General tool from the Tools menu.

Choose Bkgnd Info from the Objects menu.

The dialog box in Figure 6-64 appears.
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Figure 6-64
Bkgnd Info dialog box

3. Type or change the background’s name, check a box, or
click one of the buttons.

4. When you're finished, click OK.

Can’t delete background

When “Can't delete background?” is checked, you can’t delete the
last card with this background in a stack. (You can, however, delete
the stack—including the protected background). To deprotect the
background, uncheck the box by clicking in it.

For information on backgrounds, see “Background” earlier in this
chapter.

For information on using scripts, including how to use background
ID numbers, see the HyperCard Script Language Guide .
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The General tools are Browse,
Button, or Field.

Volume or disk

 

Stack Info
The Stack Info command brings up information about the selected
stack. You can see and change the stack’s name, learn the number
of cards in the stack and the amount of space the stack uses, and
read the name of the folder and disk the stack resides on.

m To use Stack Info:

1. Select any general tool from the Tools menu.

2. Choose the Stack Info command from the Objects menu.

The dialog box in Figure 6-65 appears.

 

 

Nested folder ———

where stack resides

Folder ————_——_—_—___—

 

 

Figure 6-65
Stack Info dialog box

3. Type or change the stack’s name or click one of the buttons.

4. When you're finished, click OK.

Stack Name

The name is the same as it appears in the Finder and in the
Directory dialog box. You change the stack’s name by typing in
the Stack Name box. Changing the name here also changes the
name in the Finder.
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Warning Changing the name of a stack will break links you’ve made
between any card in the renamed stack and any other card
In any stack (including links within the renamed stack itself).
When you change the name of a stack, be sure to redo alll
the links.

 

Where

The Where information tells you the full search path to where the
stack resides, starting with the disk and ending with the folder that
actually holds the stack. In Figure 6-65, the stack resides in the folder
called Scot’s stuff on the disk Harpo. A longer trail of names would
indicate that the stack is further nested within folders.

For more information on search paths, see “Search Paths” in
Chapter 3.

Free in Stack

Free in Stack tells you the amount of extra memory space in the
stack. (Extra space gets introduced into a stack each time you delete
a card, background, field, or button.) Sometimes the Free number
can be substantial, and the more extra space in a stack, the slower
will actions be carried out, and the larger will be the stack.

You can get rid of the extra space by using the Compact Stack
command from the File menu. When you choose Stack Info again,
Free in Stack will be zero K, and Size of Stack will likely be smaller.

 

Bring Closer
The Bring Closer command (or Command-plus) brings the
selected button or field one layer closer and increases its number to
reflect its current layer, relative to other buttons or fields. You’d
want to bring an object closer when a second object is covering it,
not allowing you to use the selected object.
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Three buttons, in the order
they were created

 

Using Bring Closer,
the farthest button
is now in the middle.

Figure 6-66
Moving a button closer

The highest number an object can have in any case is the total
number of objects of that type on a given card or background; the
lowest number an object can have is 1.

 

Send Farther

The Send Farther command (or Command-minus) puts the selected
button or field one layer further back and decreases its number to
reflect its current layer relative to other buttons or fields. You’d
want to move an object farther back when it’s covering a second
object. (You can’t use a covered object effectively).
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Choosing New Button several times
produces several new buttons
laid atop one another
(separated here for clarity).

 

New Button

This command automatically selects the button tool and creates a
new button named “New Button” in the rounded rectangle style.
The button appears in the center of the screen, selected so that you
can move it or size it easily.

 

The button tool is automatically — on
selected, so you see all buttons
on the card.

Figure 6-67
Making new buttons

To change the name of the button or to change the way it looks,
choose Button Info (described earlier in this section).

To create a new background button, first choose Background from
the Edit menu.

 

New Field
This command automatically selects the field tool and creates a new
transparent field. The field appears in the center of the screen,
selected so that you can move it or size it easily.

To name the field or to change the way it looks, choose Field Info
(described earlier in this section).

To create a new background field, first choose Background from the
Edit menu.

To read more about fields, see Chapter 4.
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New Background
New Background creates a new card with a new background in the
current stack. The new background has no fields or buttons and is
entirely blank.

For details about backgrounds, see “Background” and “Bkgnd Info”
earlier in this chapter.

 

 

 

Paint menu
The Paint menu commands work in conjunction with the Paint tools
to manipulate and change pictures. You can choose these
commands from the menu or, if you have Power Keys checked in
the Options menu, you can use keyboard equivalents.

The Paint menu appears only when you’re usinga Paint tool.

For information on the Paint tools, see “Tools menu” earlier in this
chapter.

  

7

]
ef

Figure 6-68
Paint menu
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Draw over existing card picture.

Choose Select to select
the shape you just drew.

Throughout this section, you'll see references to power keys. Power
keys let you choose menu commands from the keyboard. For
information on power keys, see “Power Keys” under the Options
menu section of this chapter.

 

Select
Select (or either power key S or Command-S) lassos the shape you
most recently drew. This command is particularly useful if you’ve
just drawn a shape very close to or actually touching another shape
and you need to move the new shape. (In fact, you can draw a new
shape on top of an old one, choose Select, and then drag the new
shape away.)

 

 

Now you can move  
or alter that shape.

When you let go of the object,
it becomes "set" into
the card picture.

 

Figure 6-69
Using Select

If you’ve selected a shape with the Selection rectangle, choosing
Select lassos the shape. If nothing is selected, Select lassos
everything (the same effect as double-clicking the Lasso tool).

The object stays selected until you select another tool, click the
mouse, or keep the shape. (see “Keep” later in this section.)
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Select the picture
to fill.

Choose Fill.

 

Select All
Select All (or either power key A or Command-A) selects the entire
picture. This has the same effect as double-clicking the Selection
tool.

To select the entire background picture, first choose Background
from the Edit menu; then choose Select All.

 

Fill

Fill (or power key F) colors the selected part of a picture with the
current pattern. This command is especially useful for quickly
changing the pattern of a large area.

 

 

 

Figure 6-70
Using Fill

For related commands see “Bucket” under “Tools Menu” and
“Draw Filled” under “Options Menu” elsewhere in this chapter.

 

Invert
Invert (or power key ID reverses the color of the dots in the selected
part of a picture, such that white dots become black and black dots
become white.

ih a cag see ces ea eo a Se a ey

 

Figure 6-71
Inverting a picture
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Warning When you invert a lassoed area that is not totally enclosed,
HyperCard paints white the unenclosed part of the lassoed
area; the whole image seems to disappear. To get the image
back, choose Undo from the Edit menu.

 

 

Pickup
Pickup (or power key P) is like a cookie cutter for images.

= To use Pickup:

1. Select an image.
2. Drag it over a second image.
3. Choose Pickup.

The first image picks up the pattern of the second.

4. Drag the first image away.

Behe

Sid
Saacnsams

W

 

1. This is the shape whose 2. This is the pattern
pattern you want to change. you want to use.

3 AJP teey cheer hPig Canta+N

  
3. Select the shape 4. Choose the Pickup 5. Drag the shape

and move it over command (or just away.
the pattern. press P if power keys

are active).

Figure 6-72
How Pickup works

See Chapter 5 for more examples using this command.
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Darken
Darken (or power key D) darkens the selected picture by randomly
turning white dots black. Each time you choose Darken, a few more
dots are changed.

/a—— \

by
Original Selected Darkened

Figure 6-73
Using Darken

 

Keeping power key D pressed repeats the action until you release the
key or until the selection is totally black.

 

Lighten
Lighten (or power key L) lightens the selected picture by randomly
turning black dots light. Each time you choose Lighten, a few more
dots are changed.

nnn
Original Selected Lightened

        
Figure 6-74
Using Lighten

Keeping power key L pressed repeats the action until you release the
key or until the selection is totally white.
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Trace Edges
Trace Edges (or power key E) outlines black areas in a picture or in
the selected part of a picture. Repeated tracing adds more outlines.

Original Edges Edges, twice Edges, three times

Figure 6-75
Untraced, single-traced, and multitraced areas

 

Rotate Left

Rotate Left (or power key [ ) turns the selected portion of a picture
90 degrees left.

Figure 6-76
Rotating an image to the left

 

Warning _ If any part of the picture moves off the screen during a rotation.
you'll lose that part permanently—Undo can’t save it. Try
Revert to get back the lost portion.
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Rotate Right
Rotate Right (or power key ] ) tums the selected portion of a picture
90 degrees right.

Figure 6-77
Rotating an image to the right

 

Warning _ If any part of the picture moves off the screen during a rotation,
you'll lose that part permanently—Undo can’t save it. Try
Revert to get back the lost portion.

 

 

Flip Vertical
Flip Vertical (or power key V) flips the selected portion of a picture
vertically.

Figure 6-78
Flipping an image vertically
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Flip Horizontal
Flip Horizontal (or power key H) flips the selected portion of a
picture horizontally about its center line.

 

Figure 6-79
Flipping an image horizontally

 

Opaque
Opaque (or power key O) makes the selected portion of a card
picture opaque. (You can’t see the portion of a background covered
by an opaque foreground.)

 

re
Fa

 

   

Selected image... ..dragged and made opaaque.

Figure 6-80
Opaque command

To see what part of a picture is opaque, press Option-O; the opaque
parts show as black.
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Transparent
Transparent (or power key T) makes the selected part of a card
picture transparent. (You can see the backgroundif it’s covered by a

transparent foreground.) Cards are transparent unless you make
them opaque.

Selected image... ..dragged and made transparent.

Figure 6-81
Transparent command

 

Keep
Keep (or Command-K) tells HyperCard that you want to keep the
changes you’ve made to a picture. (Until you tell it differently,
HyperCard assumes that you might want to throw away changes.)
Use Revert to go back to the most recently kept version of the
picture. (See “Revert” later in this section.)

Changing cards, switching to or from Background, or clicking a
General tool has the same effect as choosing Keep.

 

Revert
Revert (or power key R) restores the most recently kept version of
the picture (or the selected part of it), throwing away any changes
since the last Keep command or since you started painting on this
picture. (HyperCard accepts a picture when you choose Keep,
switch to or from Background, change cards, or click a General
tool.) It’s like Undo ona larger scale.
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Options menu
Commands on the Options menu modify the action of Paint tools.

Figure 6-82
Options menu

The Options menu appears only when you’re using a Paint tool. For
information on the Paint tools, see “Tools Menu” earlier in this
chapter.

Many of these commands work when you press the appropriate
power key. For information on power keys, see “Power Keys” later
in this section.

 

Grid
Grid (or power key G) constrains where picture elements line up
when you use many of the Paint tools. When Grid is on, you can
movea selection, draw, or type only at specific intervals. These
intervals are eight dots apart Gust under 1/8th of an inch).

A check appears next to Grid in the Options menu when this feature
is on.
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FatBits

FatBits (or Option-F) lets you zoom in ona section of a picture to do
close-in finish work and to edit your picture one dot at a time. Select
an area and choose FatBits to blow up that area; then edit using any
Paint tool. The tools work to scale.

A movable window in the lower-left corner shows you what effect
your editing changes have when the picture’s full-sized again. (To
move the little window, drag it by its title bar.)

 

Figure 6-83
FatBits

A check appears next to FatBits in the Paint menu when FatBits
is on.
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Moving the picture around

Pressing and holding the Option key in FatBits changes the tool
you're using to a hand. As you drag the hand, you move the picture
around so you can get to a part that might be outside your viewing
area. When you release the Option key, the pointer changes back to
the tool you were using.

If you choose FatBits without first selecting an area, HyperCard
zooms in on the part of the picture you last worked on. Hold down
the Option key and use the grabbing hand to move to the part of the
picture you want to work with.

To leave FatBits, choose the FatBits command again.

Entering and leaving FatBits quickly

You can use any of these short cuts to enter or leave FatBits:

O Press Option-F.

QO Double-click the Pencil tool.

Q Click in the small window.

O With the Pencil tool selected, press the Command key while you
click the mouse.

 

Power Keys
Power Keys lets you use the keyboard to evoke commands you’d
ordinarily choose from a menu. When you choose Power Keys,
pressing a single key (with or without the shift key pressed) does the
work of choosing a menu command with the mouse.

A power key modifies the way a particular tool acts. Table 6-3 shows
a list of the commands that power keys invoke.
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Table 6-3

 

 

Power keys

Command Key Menu

Darken D Paint
Draw Centered (on/off) Cc Options
Draw Multiple (on/off) M Options
Fill F Paint
Flip Horizontal H Paint
Flip Vertical Vv Paint
Grid (on/off) G Options
Invert I Paint
Lighten L Paint
Line size 1-4, 6, 8 Options
Opaque O Paint
Pickup P Paint
Revert R Paint
Rotate Left [ Paint
Rotate Right ] Paint
Select S Paint
Select All A Paint
Select black pattern B Patterns
Select white pattern WwW Patterns
Trace Edges E Paint
Transparent T Paint

If you need more details, see the description of the specific
command elsewhere in this chapter.

A check appears next to power keys in the Options menu when this
feature is on. To turn off power keys, choose Power Keys from the
Options menu again. (The check will disappear.)

You can use several power keys in combination to create spectacular
special effects. (Iry C and M with the Oval tool, for example.)

When you’re using the Paint Text tool, power keys are temporarily
disabled.
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Click to confirm current size
or click another size.

Power keys
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Line Size

You use Line Size to set the thickness of lines and borders.
Choosing this command brings up a dialog box:

 

Figure 6-84
Line sizes

To select a thickness, click on it (or use a power key equivalent). You
can also bring up the Line Size dialog box by double-clicking the
Line tool.

 

Brush Shape
Use Brush Shape to select a shape for the Brush. Each shape has a
different effect when you use it. To select a shape, move the pointer
to the shape you want; then click.

Figure 6-85
Brush Shapes dialog box

Double-clicking the Brush also brings up the Brush Shapes dialog
box. For details on the Brush tool, see “Tools Menu” earlier in this
chapter.
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Edit Pattern

Edit Pattern lets you edit the pattern currently selected on the
Pattern menu by clicking dots on or off. When you choose Edit
Pattern, the pattern editor appears. See Figure 6-86.

Figure 6-86
Pattern editor

To edit a pattern, move the pointer to the dot you want to change;
then click. Clicking where there is no dot adds one; clicking on an
existing dot takes the dot away.

Double-clicking a pattern on the Pattern palette also brings up the
pattern editor.

Using a nonstandard pattern

You can replace a pattern on the Pattern palette with any pattern on
the screen. (See Figure 6-87.)

= To use a pattern already on the screen:

1. Make sure the new pattern is on the screen.

2. Click the pattern on the Pattern palette to be replaced.

3. Choose Edit Pattern from the Options menu.

(Or double-click the pattern to be replaced if you’re using the
Pattern palette.) The pattern editor appears showing the selected
pattern.

4. Click anywhere on the new pattern in the picture.
The old pattern in the pattern editor is replaced by the new one.

5. Click OK.

The new pattern replaces the selected pattern in the Pattern
menu.
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   2 new pattern in the picture
( See ( a to place the pattern in the

editor.

Select a pattern to Bring up the pattern editor. The new pattern is saved
be replaced. with the stack when you

click OK.

Figure 6-87
Switching patterns

The new pattern is saved with the stack.

 

Polygon Sides

You use Polygon Sides to select a shape for the Regular Polygon
tool.

 

 

 Click the shape you want to use.  

   

 
   

 

Figure 6-88
Selecting a shape

You can also bring up this dialog box by double-clicking the Regular
Polygon tool.

For details on the Regular Polygon tool, see “Tools Menu” earlier in
this chapter.

 

Draw Filled
Draw Filled fills shapes as you draw them. It uses the current pattern
to fill the shapes.
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 Current pattern

Draw Filled not checked

Draw Filled checked

 

 

 

     
 

Figure 6-89
Using Draw Filled

The Tools menu looks different when Draw Filled is turned on.
The tools that it affects (Rectangle, Rounded Rectangle, Oval,
Curve, Polygon, and Regular Polygon) have slightly different
representations.(See Figure 6-90.)
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Draw Filled on Draw Filled off

Figure 6-90
Tools menu with Draw Filled turned on and turned off

“ Draw Filled short cut: Double-clicking any of the tools that Draw
Filled affects (except Regular Polygon) turns Draw Filled on and
off.

When Draw Filled is turned on, a check mark appears next to it in
the menu. To turn off Draw Filled, choose the command again.

Draw Filled with the Polygon tool

If Draw Filled is turned on while you’re using the Polygon tool,
HyperCard drawsa straight line between the polygon’s starting and
ending points when you double-click to finish your polygon. The
resulting enclosed shape is filled with the current pattern.
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HyperCard draws this line.  

ES

Draw Filled not checked Draw Filled checked

Figure 6-91
Creating an enclosed, filled polygon

Draw Filled with the Curve tool

If Draw Filled is turned on while you’re using the Curve tool,
HyperCard drawsa straight line connecting the starting and ending
points of the shape when you release the mouse button; then it fills
the shape with the selected pattern.

Curve tool with Draw Filled off Curve tool with Draw Filled on

Figure 6-92
Creating a filled, curved shape

 

Draw Centered
Draw Centered (or power key C) lets you draw out from a center
point. CYou usually draw lines, rectangles, and ovals starting from
an edge or corner.)
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Figure 6-93
Drawings made with Draw Centered checked

Draw Centered affects the following tools: Line, Rectangle,
Rounded Rectangle, Oval, Curve, Polygon, and Regular Polygon.

When Draw Centered is turned on, a check mark appears next to it
in the menu. To turn off Draw Centered, choose the command
again.

 

Draw Multiple
Draw Multiple (or power key M) draws multiple images as you drag
with the mouse.

Draw Multiple checked
in Options menu

 

Draw Multiple unchecked

Rectangle Rounded Rectangle Oval Regular Polygon

Figure 6-94
Drawing shapes with and without Draw Multiple checked
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Draw Multiple affects the following tools: Line, Rectangle, Rounded
Rectangle, Oval, and Regular Polygon.

When Draw Multiple is working, a check mark appears next to it in
the menu. To turn off Draw Multiple, choose it again.

 

 

 

Patterns menu
The Patterns menu is a palette from which you pick the pattern you
want to use for painting. Select the paint pattern you want to use to
fill shapes and Gif you specify) to draw borders. The menu can be
“torn off” and the palette placed anywhere on the screen.

Current pattern  

 

 

 

 

 

 

 

 

  

Figure 6-95
Torn-off Pattern palette

mu To create a movable Pattern palette:

mg Drag down through the menu, either past the bottom or
beyond either side.

Put the palette wherever you want by dragging. To move the palette
around, drag it by its top bar or by any edge. To put it away, click its
close box. If it gets stuck in an awkward place, just tear off a new
pattern palette; the old one disappears.
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Editing patterns
To edit a pattern, select the pattern you want to edit and choose Edit
Pattern from the Options menu (or double-click the pattern you
want to edit); when the pattern editor appears, click a dot to make
the dot go away or click where there is no dot to make one appear.
The new pattern is saved with the stack.

 

ae|g

eee

i {

OK ) (Cancel}
   

Figure 6-96
Pattern editor

To fill enclosed shapes with the selected pattern as you draw them,
check the Draw Filled command on the Options menu.

To fill enclosed shapes after you draw them, use the Bucket
(described earlier in this chapter).

To fill a selected area with the current pattern, choose Fill under
the Paint menu.

To draw borders in the selected pattern, press the Option key as

you drag.

“+ Patterns menu short cut: Press Tab with any Paint tool selected
or double-click the Bucket tool to make the Patterns palette
appear and disappear.
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Command key

Character key

As in all Macintosh applications, you issue many HyperCard
commands by making choices from menus. But HyperCard extends
what you can do by making many commands available from the
keyboard. In fact, there’s a whole range of commands that you can
issue only by pressing one or more keys and using the mouse at the
same time.

O “Command Key Menu Commands” gives a list of the commands
you execute by first pressing and holding down the Command
key and thena specific character.

O “Browsing” shows you how to get around the stacks and from card
to card quickly.

O “Text Editing” lists the keys to press to change fonts, type sizes,
styles, and so on.

QO “Paint Power Keys” lists the graphics commands you can issue
with a single keystroke.

O “Dragging With Modifier Keys” explains what happens if you
drag both with a particular tool selected and with the Command,
Option, or Shift key held down.

O “Miscellaneous keyboard shortcuts” lists the shortcuts that don’t
fit easily into other areas.

Because all these sections are really summaries, you'll also find
information about where to look for more help.

 
 
 

Command key menu commands
As you look at a menu, you'll see some commands followed by a
symbol and a character. The propeller-shaped symbol represents
the Command key. You can issue such a menu command by
pressing the Command key at the same time that you press the
specified character key.

KO“ Command or Apple: The Command key is marked by a propeller-
shaped symbol. On some Macintosh keyboards, the key also has
an Apple symbol, and some Macintosh manuals might call it the
Apple key. Both names refer to the same key.

The first chart shows the keyboard equivalent keys by menu; the
second chart shows them in alphabetic order by command name.
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Table 7-1
Keyboard equivalents by menu

 

 

 

 

Menu Keyboard equivalent Command

Edit Command-B Background (toggle)
Command-C Copy
Command-N New Card
Command-T Text Style
Command-V Paste
Command-X Cut
Command-Z Undo

File Command-O Open Stack
Command-P Print Card
Command-Q Quit HyperCard

Go Command-F Find
Command-H Home
Command-M Message (toggle)
Command-R Recent
Command-1 First
Command-2 Prev
Command-3 Next
Command-4 Last
Command-? Help
Command-Tilde (~) Back

Objects Command-plus (+) Bring Closer
Command-minus (-) Send Farther

Paint Command-A Select All
Command-K Keep
Command-S Select

Table 7-2
Keyboard equivalents by command

Command Keyboard equivalent Menu

Back Command-Tilde (~) Go
Background Command-B Edit
Bring Closer Command-plus (+) Objects
Copy Command-C Edit
Cut Command-X Edit
Find Command-F Go
First Command-1 Go
Help Command-? Go
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Table 7-2 (continued)
Keyboard equivalents by command

 

 

Keyboard equivalent Command Menu

Home Command-H Go
Keep Command-K Paint
Last Command-4 Go
Message Command-M Go
New Card Command-N Edit
Next Command-3 Go
Open Stack Command-O File
Paste Command-V Edit
Prev Command-2 Go
Print Card Command-P File
Quit HyperCard Command-Q File
Recent Command-R Go
Select Command-S Paint
Select All Command-A Paint
Send Farther Command-minus (-) Objects
Text Style Command-T Edit
Undo Command-Z Edit

For details on all these commands, see Chapter 6.

 

 

 

Browsing
You can use any of these keystrokes except Tilde (~) and Esc at any
time. To use Tilde or Esc for browsing, you must be using one of the
General tools. Whena Paint tool is selected, pressing the Tilde key
undoes the last Paint action; use Command-Tilde to move to the
most recently viewed card.

For combinations that require you to use the Command key, be sure
to press and hold down the Command key before you press the
second key.
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Table 7-3
Browsing from the keyboard

 

 

Destination Keyboard short cut

Help Command-?

Home Command-H

First card in stack

Previous card in stack

Next card in stack

Last card in stack

Retrace through cards viewed

Forward through retraced cards

Record of cards recently seen

Select Browse tool

Store current card’s location for
quick return (Many locations
can be stored)

Return to stored location
Cast in-first out order)

Next field on card

Previous field on card

Command-1 or
Command-Left Arrow

Command-2 or Left Arrow

Command-3 or Right Arrow

Command-4 or
Command-Right Arrow

Tilde (~), Esc, or Down Arrow

Up Arrow

Command-R

Command-Tab

Command—Down Arrow

Command-—Up Arrow

Tab

Shift-Tab

For a tutorial on browsing, see Chapter 1. For information on
creating buttons for browsing, see “Button Tool” and “New Button”
in Chapter 6.
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Text editing
You can use the combination keystrokes in Table 7-4 when you’re
using either the Browse tool or the Paint Text tool. Be sure to press
and hold down the Command key before you press the character
key.

 

 

Table 7-4
Text editing keys

Function Key combination

Font, next in system Command-Shift->
Font, previous in system Command-Shift-<
Text style dialog box Command-T
Space, less between lines Command-Option-<
Space, more between lines Command-Option->
Text size, larger Command->
Text size, smaller Command-<

For details on creating the fields in which regular (as opposed to
Paint) text appears, see Chapter 4. See Chapter 6 for information
on both regular and Paint text.

 

 

 

Paint power keys
Table 7-5, which also appears in Chapter 5, shows the Paint power
keys. You must be using a Paint tool with Power Keys checked in the
Options menu. “Toggle” after a command means that pressing the
same key turns the option off.
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Table 7-5
Power keys available when using Paint tools

 

 

Command Key Menu

Black pattern B Patterns
Darken D Paint
Draw Centered (toggle) C Options
Draw Multiple (toggle) M Options
Fill F Paint
Flip Horizontal H Paint
Flip Vertical Vv Paint
Grid (toggle) G Options
Invert I Paint
Lighten L Paint
Line size 1-4, 6, 8 Options
Opaque O Paint
Pickup P Paint
Revert R Paint
Rotate Left [ Paint
Rotate Right ] Paint
Select S) Paint
Select All A Paint
Trace Edges E Paint
Transparent T Paint
White pattern W Patterns

 

 

 

Dragging with modifier keys
Table 7-6 shows you what happens when you drag with different
tools selected and you hold down different modifier keys. Tools that
aren’t listed aren’t affected by modifiers.

For detailed information on all the tools, see Chapter 6.

Dragging with modifier keys 19]



Table 7-6
Effects of modified dragging

 

 

Tool With Command key With Shift key With Option key

Button Create button Move button horizontal or vertical ©Copy button
Field Create field Move field horizontal or vertical Copy field
Selection Select tightly Move selection horizontal

or vertical Copy selection
Lasso Lasso everything Move selection horizontal

or vertical Copy selection
Line No effect Draw at 15° angles Draw with pattern
Eraser Erase white Erase straight horizontal or vertical No effect
Pencil Get/leave FatBits Draw straight horizontal or vertical No effect
Rectangle No effect Draw square Patterned border
Curve No effect No effect Patterned border
Brush Erase what you Paint straight horizontal or vertical No effect

paint over
Spray Erase what you Spray straight horizontal or vertical No effect

spray over
Rounded Rectangle No effect Draw square with round corners Patterned border
Polygon No effect Draw at 15° angles Draw with pattern
Oval No effect Draw circle Patterned border
Regular polygon No effect Rotate in 15° increments Patterned border
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Miscellaneous keyboard short cuts
The following table lists keyboard short cuts that don’t fit easily into
other categories.

Table 7-7
Miscellaneous actions

 

Key or combination Effect
 

Command-Option*
selected)

Show all buttons (Browse or Button tool

Command-Shift-Option* Show all fields (Field tool selected)

Command-Backspace Delete current card



Table 7-7 (continued)
Miscellaneous actions

 

Key or combination Effect
 

Command-Period

Command-Space bar

Command-Tab

Command-Tilde (~)

Command-Shift-V

Command—Down Arrow

Command-—-Up Arrow

Option-D

Option-O

Option-Tab

Tilde (~)

Down Arrow

Up Arrow

Tab

Cancel current action (like Printing)

Hide and show menu bar

Select Browse tool

Go to most recent card displayed
(Paint tool selected)

Paste miniature card image (with card in
Clipboard)

Store current card’s location for quick
return (you can have many locations
stored)

Return to stored location
Cast in-first out order)

Show card picture (with Paint tool)

Show opaque areas (with Paint tool)

Toggle Tools palette

Same as Back command (General tool
selected)

Undo most recent action (Paint tool
selected)

Same as Back command (any tool
selected)

Come forward through reviewed cards

Toggle Patterns palette (Paint tool
selected)

Advance insertion point to next
background field (Browse tool
selected)

“Darker outlines indicate background fields or buttons.

Holding down the Command key before and as you drag through
the File menu shows the full file menu, even if Browsing or Typing is
clicked on the User Preferences card in the Home stack and/or in a
stack’s Protect Stack dialog.
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Common HyperCard
Messages

You can send a one-line command (called a message) to
HyperCard through the Message box. Use messages to save time
traveling through stacks, to launch other applications, and to
retrieve important information quickly.

m To send a message:

1. Choose Message from the Go menu.

Or press Command-M.

2. Type the message into the Message box.

Use the syntax shown in the message descriptions section that
follows.

3. Press Return.

You can also press Enter.

 
 
 

Message descriptions
This section describes the most common HyperCard messages that
you might type into the Message box. The syntax is in its simplest
form.
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Here’s an example for the Go message, followed bya list of ways you
could type the same message to get to the same place (the first card
of the Art Ideas stack):

Go Art Ideas
Go to Art Ideas
Go stack Art Ideas
Go to stack Art Ideas
Go to card 1 of stack Art Ideas

 

HyperTalk: The source of all messages
The material in this appendix represents a small subset of
HyperTalk™, HyperCard’s scripting language.

Using HyperTalk, you write scripts for buttons, fields, cards,
backgrounds, and stacks; these scripts give you much greater
control over HyperCard than is available using only the menu
commands. HyperTalk is an easy language to learn, and is
especially good as a first language for novice programmers.

For a complete description of HyperTalk, see the HyperCard Script
Language Guide, available from:

Apple Programmer’s and Developer's Association
290 SW 43rd Street
Renton, WA 98055
Telephone: (206) 251-6548

 

How to read messages
Here are some hints to help you read the messages in this appendix
and to use these messages:

O A message is all on one line.

O The first word of a message is its name. When a message is more
than one word, you'll find a note saying so.

OQ Words in italics stand for other words. For example, menultem
means the name of any item in any menu.

O Some parts are optional helper words; they appear in square
brackets (but don’t type the brackets into the Message box).

O The remaining part of a message is usually a description of
something (“with document,” for example).

O All words can be in capital or small letters.
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Date
The Date

The Long Date

This message puts the current date into the Message box in the form
mm/dd/yy:

Type The Date

You get 3/27/87

Alternatively, Long Date produces a full date:

Type The Long Date

You get Friday, March 27, 1987 (or whatever the date is, in this
form)

You must start this message with the word “The.”

 

DoMenu
DoMenu menultem

This message does menultem as if you had chosen the command
from a HyperCard menu:

Type DoMenu Home

You get the first card in the Home stack

(Home is on the Go menu.) You must type menultem exactly as it
appears in the menu. For example, to opena stack, type

DoMenu Open Stack...
The three dots are part of the menu item name.

 

Go
Go [to] description ofa card or stack

This message brings you to the designated card in the designated
stack. If you designate a stack without designating a card, you go to
the first card in that stack:

Type Go Art Ideas

You get the first card in the Art Ideas stack
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If the stack you specify isn’t in the Help Stacks folder or the
HyperCard Stacks folder, be sure to list the search path on the
appropriate card in the Home stack. (See “Search Paths” in
Chapter 3).

 

Hide

Hide tool window
Hide pattern window
Hide message
Hide menubar

This message hides what you tell it to. It's as though you'd clicked a
close box. Hide menubar hides the menu bar, giving you more
display space (as though you’d pressed Command-Space bar).

Type Hide tool window

You get Tools menu goes away

Also see Show, later in this appendix.

 

Open
Open application

Open document with application

This command opens the application you’ve named. If you name a
document, HyperCard opens that document with the application
you name.

Type Open Memo with MacWrite

You get the document Memo opened in MacWrite

If the document or application you specify isn’t at the top level
of the file hierarchy, be sure that the search path is listed on
the appropriate card in the Home stack. (See “Search Paths” in
Chapter 3).

When you quit the application, you end up back at the card you were
on when you sent the message.
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Last in, first out

First in, last out

 

Pop Card
Pop Card

This command retrieves a card you’ve marked with the Push
Card command (described later in this appendix). Once a card is

retrieved, you can’t get it back again using Pop Card unless you
mark it again using Push Card.

Pushed cards are popped in last-in, first-out order.

 

  

 

  

Figure A-1
Popping order

Pressing Command-Up Arrow does the same thing as sending a

Pop Card command.

“ Unfamiliar cardpopped: Occasionally when you issue a Pop
Card command, a card might appear that you didn’t push.
HyperTalk scripts can issue their own Push Card commands
as you browse through stacks; your Pop Card commands make
these pushed cards appear. Eventually, any card that you pushed
will also appear; just keep popping.

Also see Push Card, next in this appendix.
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Push Card
Push Card

This command lets you mark the card you’re working on for quick
retrieval later. Use this command to mark a card, wander through
the stacks (perhaps to find a graphic you want to paste onto the
marked card), and then retrieve the card again using the Pop
Card command.

You can push any number of cards for later retrieval.

Pushing Command—Down Arrow does the same thing as sending a

Push Card command.

Also see Pop Card, the immediately previous command in this
appendix.

 

 

Show

Show tool window
Show pattern window
Show message
Show menubar

This message shows what you tell it to. It’s as though you’d torn off a

palette, or chosen Message from the Go menu. Show menubar
makes the menu bar visible at the top of the window.

Type Show pattern window

You get The patterns palette on the screen

If you try to show something that isn’t hidden, nothing happens.

Also see Hide, earlier in this appendix.

 

Show Cards
Show cards
Show all cards
Show number of cards

This message shows the cards in the current stack in rapid
succession.
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Show cards shows all cards in the current stack repeatedly until
you click the mouse. Show all cards goes rapidly through the
stack once, starting and ending with the current card. Show
number of cards shows as many cards as you specify, starting
with the card following the current card.

Type Show 4 cards

You get next four cards in stack briefly on screen

To stop Show Cards at any point, click the mouse. The card
you’re viewing when you click the mouse remains on the screen.

 

Time

The Time
The Long Time

This message puts the current time into the Message box in the form
hh:mm AM or PM

Type The Time

You get 2:57 PM (or whatever time it is, in this form)

Alternatively, Long time includes seconds:

Type The Long Time

You get 2:57:23 PM

You have to start this message with the word “The.”
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HyperCard Disks

This appendix is a directory to the stacks and other files that come
with HyperCard. It tells you what files come with HyperCard, what
disk each document is on, and what each document is for.

 
 
 

HyperCard Startup
This disk holds the HyperCard application, the HyperCard Stacks
folder, and the following files:

General
System
ImageWriter

 

Macintosh II Do not use the System file on the HyperCard Startup disk fo run
the Macintosh Il, even though Its version number Is 4.1: it will
not work properly. Use whatever System Folder you currently
have to start up your computer.

 

The HyperCard Stacks folder holds the following stacks:

Address
Area Codes
Datebook
File Index
Home
Phone
Quotations
HyperCalc
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HyperCard & Stacks
The HyperCard & Stacks disk holds a duplicate copy of the
HyperCard application, a duplicate copy of the HyperCard Stacks
folder, plus a folder called More Stacks. More Stacks contains the
following stacks:

Book Shelf
Documents
Periodic Table
Plots
Slide Show

 

 

 

HyperCard Help
The HyperCard Help disk contains a single folder, Help Stacks. The
folder contains three stacks:

Help
Help Index
Help Samples

 

 

 

HyperCard Ideas
The HyperCard Ideas disk holds a single folder, Idea Stacks. The
folder contains five stacks:

Art Ideas
Button Ideas
Card Ideas
Clip Art
Stack Ideas
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About the provided HyperCard documents
Here’s a description of the documents that come with HyperCard,
and what you’d use them for:

Address

Area Codes

Art Ideas

Book Shelf

Button Ideas

Card Ideas

Clip Art

Datebook

Documents

File Index

Help

Help Samples

Help Index

A name and address file. Keep all your
important names and addresses here.

A listing of all the telephone area codes in
Canada and tne United States. You can look for
an area code if you know the city (or nearby
city), or you can find the city served by any
area code.

A collection of art you can use in your own
documents. Use these to help create pictures
and buttons.

An example of a graphic table of contents.

Library of working buttons. Cut and paste these
to your own documents.

Individual cards you might include in
documents that you create. (A card is
HyperCard’s fundamental unit of
information.)

Artwork you can use to dress up your own
HyperCard documents.

Monthly calendar, week-at-a-peek memo
book, plus a things-to-do list. Use it to organize
your daily chores and to keep track of
important meetings.

A collection of document examples.

A set of file cards for whatever you need to file.

On-line directions for using HyperCard. It
provides hints and tips for using all of
HyperCard’s features.

Part of the on-line Help system.

Part of the on-line Help system.
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Home

Periodic Table

Phone

Plots

Quotations

Slide Show

Stack Ideas

HyperCalc

A graphic directory of all the documents that
come with HyperCard. Use it as your “base of
operations.” You must have Home for
HyperCard to operate.

A listing in classic form of the chemical
elements.

A dialer for your telephone.

A demonstration of HyperCard’s ability to plot
information in different formats.

A collection of famous quotations, designed to
help you learn to use HyperCard.

A collection of clip art, digitally scanned into
the Macintosh.

Collection of cards to use as templates for
creating new stacks.

A mini-spreadsheet.

 

Important You must have the Home stack on the same disk as the
HyperCard application for HyperCard to operate. You can
remove all other stacks, but you must not remove the Home
stack.
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Apple key: See Command key.

background: That which is shared by a number
of cards; a card’s basic template. The background
is composed of the background picture,
background fields, and background buttons.

background button: A button that appears on,
and whose actions are the same for, all cards with
the same background. Contrast with card button.

background field: A field whose size, position,
and text attributes remain constant on all cards
associated with a particular background, but whose
text changes from card to card. Contrast with card
field.

background picture: A picture that applies to a
series of cards. You see the Background picture
by choosing Background from the Edit menu.
Contrast with card picture.

browse: To wander through HyperCard’s stacks.

Browse tool: The tool you use to click buttons and
to set the insertion point in fields.

button: Something that initiates a HyperCard
action (making a connection, launching an
application, starting a visual or sound effect,
and so on) when you click it. See also background
button, card button.

button action: That which happens when a button
is pressed.

Button tool: The tool you use to create, change,
and select buttons.

card: HyperCard’s basic entity—one screenful of
information.

card button: A button that appears on, and whose
actions apply to, a single card. Contrast with
background button.

card field: A field whose size, position, text
attributes, and contents are limited to the card
on which the field is created. Contrast with
background field.

card picture: A picture that applies to a specific
card. Contrast with background picture.

Command key: The key at the lower-left side of
the keyboard that has a propeller-shaped symbol.
On some keyboards this key also has an Apple
symbol and might be called the Apple key.

current: (adj.) The one you’re using now. For
example, the current card is the one you can see
on your screen.

field: The place where you type regular (as
opposed to Paint) text. Also, the tool you use
to create a field. HyperCard has two kinds of
fields—card fields and background fields.

Field tool: The tool you use to create, change,
and select fields.

General took Any HyperCard tool that isn’t a

Paint tool. The General tools are Browse, Button,
and Field.
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Home card: A special card that acts as a pictorial
index to stacks. Choose Home from the Go menu
to get to Home (or press Command-H).

HyperTalk: HyperCard’s built-in script language
for HyperCard users.

keyboard equivalent key: A key you press
together with the Command key to issue a menu
command.

layer: The order of a button or field relative to
other buttons or fields on the same card and
background. The object created most recently
is ordinarily the topmost object (that is on the

front layer).

MacPaint document: Document created by
the Macintosh MacPaint application, or any
application that creates MacPaint-compatible
graphics.

message: A command you send to HyperCard
through a script or through the Message box.
Some examples of HyperTalk messages are Go,
Show, Hide, Pop Card, and Push Card.

on-line help: assistance you can get from an
application program while it’s running. In this
user’s guide, on-line help refers to HyperCard’s
disk-based Help system.

Paint text: Text you type using the Paint Text tool.
Paint text can appear anywhere, while regular
text must appear in a field created with the Field
tool. When you finalize Paint text by clicking, it
becomes part of a picture.

Paint tool: Any HyperCard tool you use to make
pictures. Tools include Lasso, Brush, Spray,
Eraser, Paint Text, and many others.

palette: The name for a tear-off menu when
it’s been torn off. A palette remains visible on
the screen so you can use it without having to
pull down the menu. HyperCard has two
palettes—Tools and Patterns.
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picture: Any graphic or part of a graphic created
with a Paint tool. Also, an imported MacPaint
document or part of a MacPaint document.

point: In printing, the measurement of the height
of a text character; one point is about 1/72 of an
inch. When you select a font, you can also select a

point size, such as 10-point, 12-point, and so on.

power key: One of a number of keys on the
Macintosh keyboard you can press to initiate a
menu action whena Paint tool is active. Power key
are enabled when you choose Power Keys from thi
Options menu or you check Power Keys in the Use
Preferences card in the Home stack.

Recent: A special dialog box that holds pictorial
representations of the last 42 unique cards viewed
Choose Recent from the Go menu to get the dialo;
box.

regular text: Text you type inside a field. You us«
the Browse tool to set an insertion point in a field
and then type. Regular text is editable and
searchable, while Paint text is not.

script: A series of commands written in
HyperTalk and associated with a particular
object.

search path: The route the computer must follow
to retrieve a file you ask for.

stack: A group of cards based on the same theme
A HyperCard document. See also card.

tear-off menu: A menu that you can convert to a
palette by dragging the pointer beyond the
menu’s edge. HyperCard has two tear-off
menus—Tools and Patterns.

text field: See field.



text property: A quality or attribute of a

character’s appearance. Properties include style,
font, and size.

tool: An implement you use to do work.
HyperCard has tools for browsing through cards
and stacks, creating text fields, editing text,
making buttons, and creating and editing pictures.

user level: The setting on the User Preferences
card in the Home stack that lets you use
HyperCard’s tools and abilities. Five user levels
are available: Browsing, Typing, Painting,
Authoring, and Scripting.
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A
Address stack (tutorial) 7, 14. See

also card(s); stack(s)
addresses, searching for 7-10.

See also Address stack
alignment 100-101, 114. See also

Text Style command
alphabetical order, cards and

stacks 13. See also Sort
angles, changing and constraining

137. See also Line tool
Apple key. See Command key
Art Ideas stack 24-25
authoring (tutorial) 31-46

on User Preferences card 51

B

Back command (Go menu)
116-117

background(s) 115-116.
See also Background
command; Bkgnd Info

buttons. See background buttons
changing (Bkgnd Info

command) 157-158
copying 86, 110-111
creating 115-116, 163
cutting 108
definition of 40
deleting 93, 130, 158
fields. See background fields
names, changing 158
New Card command and 112

 

Index

pictures. See background
pictures

selected in printing 99
stripes on Menu bar 115-116
versus cards 40-44

background buttons 41, 115-116,
162

covered by card buttons 115
creating 115-116, 162

Background command (Edit
menu) 115-116

background fields 115, 162
changing 58
creating (Background

command) 56, 162, 115
deleting 130
description of 41, 54, 115-116
numbers 154
versus card fields 44

background pictures 40-44
editing (Background

command) 115-116
erasing (Eraser) 136
selecting 165

Backspace key, clearing selected
data with 112

Bkgnd Info command (Objects
menu) 157-158. See also
background(s)

Can’t delete background 158
blowing up pictures. See FatBits

command
borderless rectangles 139

borders 145. See also Line Size,
Line tool; Oval tool; Regular
Polygon tool

changing 137, 138, 145, 176
drawing with current pattern 145

filled with current pattern 145
in patterns 183

Bring Closer command (Objects
menu) 61, 160-161

Browse tool 4, 18, 59, 65-66
creating editable text with 54,

65-66
selecting (Home command) 117
versus Button 128

browsing 3-5, 124. See also
Browse tool

keyboard commands for
188-189

on User Preferences card 51
powers associated with 92
recap of 10
shortcut for 32
tutorial 3-6

Brush Shape command (Options
menu) 135, 176

Brush (Tools menu) 135-136.
See also Brush Shape; painting;
Paint tools

dragging with modifier keys 79
erasing with 136
painting straight or horizontal

lines with 136

painting with current pattern 135
Bucket 140-141
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button(s) 147-152. See also
background buttons; Button
Info; Button tool; icons;
pictures

activating 4
background 40-44, 115, 162
Browse tool and 126
Card, 415 115
copying 109, 128
creating (New Button

command) 162
cutting (Cut Button

command) 128
deleting (Clear Button

command) 35, 128
Help, adding 36
highlighted 149-150
icons used as 150-151
information about (Button Info

command) 147-152
layers 148
linking 151-152
moving 34-35, 128, 160-161
moving dotted line around 35
names of (Button Info

command) 148
numbers 148
opaque 149
Pasting (Paste command) 111
rectangle 149
rounded rectangle 149
selecting 35, 127-128
shadowed 149
shapes of 149
sizing 128
style of (Button Info

command) 149
Telephone 34-35
transparent 107, 149
viewing 18

Button Ideas 36
Button Info command (Objects

menu) 147-152. See also
button(s); Button tool

Auto hilite 149-150
Button ID 148
Button name 148
Button number and layers 148
dialog box 147
Icon 150-151
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Script 152
Show name 148
Style 149
LinkTo 151-152

Button tool (Tools menu) 126
Button tool, versus Browse

tool 128

Cc

cameras 74, 81
canceling actions. See cutting;

deleting; Undo command
card(s). See also Home; stack(s),

User Preferences card
adding 11-12, 112-113
buttons. See card buttons
canceling actions on (Undo

command) 106
copying 113, 109-110, 111
creating 41, 112-113
cutting (Cut Card

command) 108, 113
definition of 3
deleting 93, 113, 156
directory of. See Home
examples of 4
fields. See card fields
first card, selecting (First

command) 119
linking 151-152
moving 156-157
moving between. See Go menu
names of (Card Info

command) 156
numbers 156
pasting 111
position in stack 12-14
printing 95-96
reviewing. See Recent
saving snapshot of (Export Paint

command) 88-89
searching. See Find command
search path 49
sharing pictures among 74
To Do 32-33
versus backgrounds 40-44

card buttons 41, 115, 129
card fields 41, 54

cover background fields 115

numbers 154
versus background fields 44

Card Info command (Objects
menu) 155-157

Can’t delete card 156
Card number 156
changing card position in

stack 156-157
description of 155
dialog box 155

changes, saving 105, 171
changing. See also specific topic

address cards 10-11
angles 137. See also Line tool
backgrounds 157-158
cards 23-24, 156-157
column width 102
fields 37-38, 58, 61, 63-64,

129-131, 154
fonts 69, 153
menu bar 126
passwords 90-91
stacks 87, 152
tab order 61
text 10-11, 68-71
user level 31, 50-52
label size 100-101

circles, Oval tool and 141
cleaning paint spills 141
Clear Button command (Edit

menu) 35, 128
Clear command (Edit menu) 50,

112
Clear Field command (Edit

menu) 130
Clear key (keypad) 112
clicking (mouse technique) 4
Clipboard 26, 27

Copy command and 108, 113
Cut command and 107
importing graphics with 81
non-MacPaint pictures and 81
pasting from 111
pictures and 74
unaffected by Clear

command 112
unaffected by Delete Card

command 113
columns, printing 102. See also

printing; Print Report



Command key 186
commands. See also keyboard

commands; messages; power
keys or specific topic

Back (Go menu) 116-117
Background (Edit menu)

115-116
Bkgnd Info (Objects menu)

157-158
Bring Closer (Objects menu)

160-161
Brush Shape (Options menu)

176
Button Info (Objects menu)

147-152
Card Info (Objects

menu) 155-157
Clear (Edit menu) 112

Clear Button (Edit menu) 128
Clear Field (Edit menu) 130
Compact Stack (File menu) 89
Copy (Edit menu) 108-110
Copy Button (Tools menu) 128
Copy Card (Edit menu) 113
Copy Field (Edit menu) 130
Copy Picture (Edit menu)

108-109
Cut (Edit menu) 107-108
Cut Button (Edit menu) 128

Cut Card (Edit menu) 113

Cut Field (Edit menu) 59
Darken (Paint menu) 167
Delete Card (Edit menu) 113
Delete Stack (File menu) 93
Draw Centered (Options menu)

180-181
Draw Filled (Options menu)

178-180
Draw Multiple (Options menu)

181-182
Edit Pattern (Options menu)

177-178
Export Paint (File menu) 88-89
FatBits (Options menu) 173-174
Field Info (Object menu)

153-155
Fill (Paint menu) 165
Find (Go menu) 120-122
First (Go menu) 119
Flip Horizontal (Paint menu) 170

Flip Vertical (Paint menu) 169
Grid (Options menu) 172

Help (Go menu) 118
Home (Go menu) 117
Import Paint (File menu) 88
Invert (Paint menu) 165

Keep (Paint menu) 171

Last (Go menu) 120
Lighten (Paint menu) 167
Line Size (Options menu) 176
Message (Go menu) 123

New Background (Objects
menu) 163

New Button (Objects menu) 162

New Card (Edit menu) 112-113
New Field (Objects menu) 162

New Stack (File menu) 86
Next (Go menu) 119
Opaque (Paint menu) 170

Open stack (File menu) 86-87
Page Setup (File menu) 94
Paste (Edit menu) 111
Paste Button (Edit menu) 36
Paste Card (Edit menu) 113

Paste Field (Edit menu) 62
Paste Picture (Edit menu) 27
Pickup (Paint menu) 166
Polygon Sides (Options menu)

178
Power Keys (Options menu)

174-175
Prev (Go menu) 119
Print Card (File menu) 95
Print Report (File menu) 98-105
Print Stack (File menu) 95-97
Recent (Go menu) 118-119
Revert (Paint menu) 171

Rotate Left (Paint menu) 168
Rotate Right (Paint menu) 169
Save, lack of 85
Save a Copy (File menu) 87
Select (Paint menu) 164

Select All (Paint menu) 165

Send Farther (Objects
menu) 161

Stack Info (Objects
menu) 159-160

Trace Edges (Paint menu) 168
Transparent (Paint menu) 171
Undo (Edit menu) 106

Compact Stack command (File
menu) 89, 160

connecting. See linking
Copy Card command (Edit

menu) 111, 113
Copy command (Edit menu) 74,

108-110
copying backgrounds 110
copying buttons and fields 109
copying cards 109-110
copying pictures 108-109

Copy Field command (Edit
menu) 39, 61, 130

copying. See also specific topic
backgrounds 110-111
buttons 36-37, 109, 128
cards 109-110, 113

fields 39, 61-62, 109, 130
from Clipboard (Paste

command) 111

pictures 108-109,
text 67

Copy Pictures command (Edit
menu) 108-109

creating. See also specific topic
backgrounds 115, 163

buttons 49, 115, 124, 126-128,
162

fields 55-57, 115, 124,
129-131, 162

movable Tools palette 125

shapes 144

stacks 86
text 65-71

Curve tool (Tools menu) 79, 142,

180
customizing, tutorial 19-46
Cut Button command (Edit

menu) 128
Cut Card command (Edit

menu) 111, 113
Cut command (Edit

menu) 107-108
Cut Field command (Edit

menu) 59
cutting. See also deleting; erasing

cards 108, 113
buttons 107, 128
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D

Darken command (Paint
menu) 167

date, headers and 97, 105
Date message 197
default

field style 64
text attributes 144

Delete Card command (Edit
menu) 113

Delete key, clearing selected data
with 112

Delete Stack command (File
menu) 93

deleting. See also cutting; erasing
backgrounds 93, 130, 158
buttons 35, 128
cards 14, 93, 113, 156
fields 59
stacks 93
without inserting on

Clipboard 112
dialog boxes

Background Info 158
Brush Shape 176
Button Info 147
Card Info 155

Directory 86
Edit Pattern 183
Field Info 153
Line Size 176
New Button 128
New Field 131
Page Setup 94
Password 91
Polygon Sides 178
Print Report 98
Print Stack 95
Stack Info 159
Text Style 68
“Where is?” 49

digitized images, importing 81
digitizing cameras 74
Directory dialog box 86
disk-based help. See Help system
disk drives. See hard disk drives;

3.5-inch disk drives
disks, HyperCard xviii, 203-204
documentation, advanced xxii
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documents, HyperCard 205-206.
See also file(s); stack(s)

DoMenu message 197
dots, changing 135, 165, 167,

177. See also painting
double-clicking (mouse

technique) 78
dragging (mouse technique) 10-11

modifier keys and 191-192
problems with 132

Draw Centered command (Options
menu) 180-181

Draw Filled command (Options
menu) 178-180

Curve tool and 180
Polygon tool and 179-180
short cut for 179

drawing. See painting; pictures or
specific command or tool

Draw Multiple command (Options
menu) 181-182

duplicating. See copying

E

edges, tracing 168
Edit menu 105-116. See also

commands or specific
command

description of 105
short and full 51, 106

editing (tutorial) 17-18. See also
Specific topic

patterns 177, 183
pictures 29
text 66-67, 124, 126, 190

Edit Pattern command (Options
menu) 177-178, 183

entering text 51, 66-67, 126,
143. See also text

Eraser 79, 136. See also erasing;
painting

erasing. See also cutting; deleting;
editing or specific topic

background pictures 136
dots 135
pictures 136
stack contents 93
with Brush 136
with Spray tool 138

Export Paint 88-89

F

FatBits command (Options
menu) 173-174

field(s) 54-65. See also
background fields; card fields;
text fields

active Paint 114
background 40-44, 54, 115,

130, 154, 162
card versus background 44, 54,

115, 154
changing 37-39, 58, 61, 63-64,

129-131, 154
clearing (Clear Field

command) 130
copying 39, 61-62, 109, 130

Copy command (does not copy
text) 109
Copy Field command 61-62

creating (New Field
command) 56-57, 115, 124,
129-131, 162

cutting (Cut command) 107
definition of 11, 54-55
deleting 59, 93
designing (Field Info

command) 153
ID 355
information about (Field Info

command) 130-131, 153-155
invisible 59
layers 60-61
locking and unlocking 64
moving 38, 57, 160-161
moving between 59-60
names 62-63, 103
New Card command and 112
number of lines in 129
numbers (Field Info

command) 60-61, 153-154
overlapping 55
pasting (Paste command) 60,

10757 f11
placing 57
printing 100-103
searching in a specific (Find

command) 121-122



selected, moving dotted line
and 39

selecting 130
setting text properties for (Text

Style command) 114
size, changing 58
style, changing 63-64
tab order and 60-61
text and 67-70, 129-131
transparent 162
viewing 67
wrapping in 58

Field Info command (Objects
menu) 130-131, 153-155

description of 153
Field ID 155
Field number 154

Lock Text 64, 153
Script 155
Show Lines 153
Wide Margins 153

field numbers, changing 61
Field tool (Tools menu) 56, 67,

129-131
file(s). See also HyperCard disks;

System file; text
copying xviii
exporting (Export Paint

command) 88-89
importing MacPaint-compatible

files 88
retrieving 49

File menu 84-105. See also
commands or specific
command

description of 84
short and full 51, 85

Fill command (Paint menu) 165.

See also filling pictures
filling pictures. See also Bucket,

Draw Fill; Fill; painting
areas with selected patterns 140
borders with current pattern 145

Draw Filled command
and 178-180, 183

Fill command and 165
Find command (Go menu) 8-9,

120-122. See also searching
description of 8-9, 18
can’t use with Paint Text 144

Message box 8
quotation marks and 8
searching for part of a word or

name 9
searching specific field 121-122

Finder
stack icons and 4
startup disks and xvii
version number of xvi

First command (Go menu) 13, 18,

1125-119
Flip Horizontal command (Paint

menu) 170
Flip Vertical command (Paint

menu) 169
fonts, changing (Field Info

command) 69, 153
formats

column 101-102
printing 98-105
row 102-104
page 96-97. See also printing;

Print Report command
free-form shapes. See Curve tool

G
General tools. See also Browse

tools; Button tool; Field tool
Bkgnd Info command and 157
description of 124
versus Paint 84

getting started (tutorial) 2-3
Go menu 6, 116-123. See also

commands or specific
command

Go message 197-198
graphics. See painting; Paint tools;

pictures
Grid command (Options menu) 172

H

hard disk drives
installing HyperCard on xviii-xix
starting up from 2

headers 97, 105. See also printing;
Print Report command

height, text 70-71
Help button, adding 36

Help command (Go menu) 14, 118

Help disk. See HyperCard disks
Help stack (tutorial) 14-15
Help system xxi, 4-5, 14-15,

118. See also Stackware
Hide message 198
hiding Message box 123

Home 3, 6-7, 47-52
creating button for 49
definition of 6
going to (Home command) 18,

52, 117
linking to a stack 44-46
search paths 49-50
stack. See Home stack
tutorial 6-7
User Preferences and 50-52

Home command (Go menu) 18,

52; 117,

Home icon 18
Home stack 6, 47-52

dangers of deleting 48
User Preferences and 50-52

horizontal pictures 170
horizontal printing 94, 96
HyperCard. See also specific topic

commands to. See messages
customizing (tutorial) 19-46
disks xvii, 203-204
installing xvii—-xix
introduction to xv—xxii
LaserWriter and xvii
messages 195-201
MultiFinder and xvi
package contents xvii
quitting 105
user levels in 22-23, 50-52
What you need to use xvi, xvii

HyperCard icon 2

I, J

icons. See also button(s)
Address 7
as buttons 150-151
Browse 4
Button Ideas 36
Home 18
HyperCard 2
Intro 5
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Quick View 14

Sort 13

Stack 4
TO*DoO 32

ID, Button. See Button Info
command

ID, Field. See Field Info command
Ideas disk. See HyperCard disks
images. See pictures, shapes
ImageWriter 81, 101
importing pictures 74, 81, 88. See

also pictures
MacPaint-compatible files 88

Import Paint command (ile
menu) 81, 88

insertion point, setting 65, 66
installing HyperCard xviii-xix
Intro icon 5

Invert command (Paint menu) 165
invisible fields and text 58-59

K

Keep command (Paint menu) 171
keeping changes. See saving
keyboard commands 185-193.

See also power keys
browsing 188-189
editing text 190
modifier keys 79
table of (by command) 187-188
table of (by menu) 187

keyboard equivalents.
See keyboard commands

keyboard short cuts (misc. table
of) 192-193

keypad, Clear key on 112
keys

Backspace 112

Clear (keypad) 112

Command 186
Delete 112

modifier 79-80, 191-192
power 75, 190-191
Tab 59-61, 193

L

labels 100-101
Landscape Printing icon 96
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LaserWriter xvii
features that don’t work with

HyperCard 94
labels and 101

Print Stack command and 95
smoothing or flipping 94

Lasso (Tools menu) 79, 133-134
lassoing 76-77, 133-134. See also

selecting
area that has no breaks 133
area without shrinking around

black dots 133

copying selections 133
inverting lassoed areas, danger

of 166
making multiple copies 134
moving selections 133
shapes (Select command) 164

Last command (Go menu) 21, 18,
120

layer(s)
button 148
front 60
moving buttons and fields one

layer closer or
farther 160-161

numbers, field 154
order of 60-61
tab 60-61

layouts, printing 103. See also
printing; Print Report
command

Lighten command (Paint
menu) 167

limiting user levels 92
Line size 13, 138, 145, 176
Line tool (Tools menu) 79, 137
lines

cut off text 71
drawing 137. See also painting;

tool(s) or specific tool
height 71
number of in fields 129
spacing 57
thickness of (Line Size

command) 137, 176
viewing (Field Info

command) 64-65, 153
linking

buttons 151-152

cards, link broken when renaming
stacks 160

Home and stack 44
LinkTo 45, 151-152
Lock Text 64, 67
locking

fields 64
text 153

M
MacPaint 74, 81, 88
manual paper feed 96, 105
margins, wide (Field Info

command) 64-65, 153
memory

requirements xvi
space in stacks (Stack Info

command) 160
Menu bar 126, 115-116
menus. See also commands;

keyboard commands or
specific menu

converting to palettes 30
power keys and 75
tear-off 30, 125

Message box, displaying and
hiding 123

Message command (Go menu) 123

messages 195-201
Date 197
DoMenu 197

Go 197-198
Hide 198
Open 198
Pop Card 199
Push Card 200
Show 200
Show Cards 200-201
Time 201

miniature cards, pasting 111

mistakes, correcting (Undo
command) 106. See also
cutting; deleting; editing;
erasing; problems

modified dragging. See dragging;
modifier keys

modifier keys 79-80
effects of (table) 192

mouse techniques 4, 10-11, 78



movement, constricting (Regular
Polygon tool) 145

moving
between fields 59-60
between stacks and cards 18

buttons 34-35, 128, 160-161
cards 112, 156-157
fields 38, 57, 160-161
pictures 27, 132, 133
text 57, 67
through stacks 116-123

MultiFinder, HyperCard and xvi
multiple images, drawing 137, 139,

140, 142, 145, 181. See also
Draw Multiple

N

names. See also renaming
background, changing 158
button 148
card 102, 156
field 62-63, 102

searching for 7
sorting 13. See also Sort
stack 85, 86, 159-160

New Background command
(Objects menu) 163

New Button command, dialog
box 1262

New Card command (Edit
menu) 11-12, 41, 112-113

New Field command (Objects
menu) 56, 129-130, 162

New Stack command (File
menu) 86

Next command (Go menu) 119
numbers

button 148
card 156
card layer 154

field 60, 154

version, System file and
Finder xvi

le

Object menu 146-163. See also
commands or specific
command

objects, list of 146
on-line help. See Help system
on-line information services xxi
Opaque command (Paint

menu) 170
opaque

buttons 149
field style 63
pictures 77, 170

Open message 198
Open Stack command (File

menu) 24, 25, 86-87
Options menu 172-183. See also

commands or specific
command

orientation, setting 94
outlines, tracing 168
Oval tool (Tools menu) 79,

141-142
overlapping text and fields 55

P

page
formats 96-97. See also printing
numbers, in headers 97, 105

size 94
Page Setup command (File menu)

94
painting 74-82, 124, 131-146,

163-183. See also specific
command or tool

border 183
Brush and 135-136
Bucket and 140-141
centered on given point 75,

141, 180-181
circles (Oval tool) 141-142
cleaning screen 30
Curve tool and 142

Draw Centered command
and 180-181

Draw Filled command
and 178-180

Draw Multiple command
and 181-182

Eraser and 136
filling pictures 140-141,

178-180
free-form shapes 142

from a central point 180
Line tool and 137
on User Preferences card 51
Oval tool and 141-142
paint spills 140-141
Paint text 54
Paint Text tool and 143-144
patterns 177, 182
Pencil and 135
Polygon tool and 145-146
power keys 75-77, 190-191
powers associated with 92
Rectangle tool and 138-139
Regular Polygon tool and

144-145
Rounded Rectangle tool and

139-140
Spray tool and 138
text in pictures (Paint Text

tool) 143-144
tutorial 20-31

Paint menu 163-171. See also
commands or specific
command

Paint text. See also painting; Paint
Text tool

active 114
can’t use Find with 144

identifying 67
setting text properties for (Text

Style command) 114

Paint Text tool (Tools menu) 66,
143-144

Text Style command and 114
Paint tools. See also tool(s) or

specific tool
Clear command and 112
Cut command and 107

description of 20, 23, 124
double-clicking 78
dragging with modifier keys 78
pasting and 111

tips on 29-30
versus General tools 84

palettes 30, 125. See also painting
paper feed, manual 96, 105. See

also Print Report
passwords 90-91
Paste Button command (Edit

menu) 36, 111

Index 217



Paste Card command (Edit
menu) 111, 113

Paste command (Edit menu) 74,
111

Paste Field command (Edit
menu) 39, 62

Paste Picture command (Edit
menu) 27, 111

pasting
buttons 36, 111
cards 111, 112-113
fields 39, 62, 107, 111
MacPaint-compatible files 88
pictures 27, 111

Patterns menu 29, 74, 182-183.
See also commands; painting;
patterns or specific command

description of 182
editing patterns 183
short cut for 183
tearing off 30

patterns, changing 165, 177-178,
183. See also filling; painting;
pictures

Pencil (Tools menu) 29, 79,
135. See also painting; Paint
tools

peripheral devices. See disk drives,
digitizing cameras; printers;
scanners

Pickup command (Paint menu) 76,
166

pictures. See also icons; painting;
Paint tools; patterns or specific
topic

background 40-44, 115-116,
136, 165

basic elements 74
Brush Shape command and 176
changing 124

saving changes (Keep
command) 171

throwing away changes (Revert
command) 171

clearing (Clear command) 112
copying 24-28, 108-109
cutting (Cut command) 107
darkening 167
erasing (Eraser) 136

218 Index

filling (Draw Filled
command) 178-180

from Clipboard 74
from Scrapbook 74
Home card 6
horizontal 170
importing (import Paint

command) 81, 88
lassoing 76-77
lightening 167
Line Size command and 176
lining up elements in (Grid

command) 172
MacPaint 81
menu commands 74
moving 27
multiple (Draw Multiple

command) 181-182
non-MacPaint 80
opaque 77, 170
pasting (Paste command) 111
patterns, changing 165,

177-178, 183
rotating 168-169
selecting 76-77, 131-134, 165
sharing among cards 74
shrinking (Selection tool) 131
special effects 80
text as part of (Paint Text

tool) 143-144
tracing edges of 168
transparent 171

zooming in on (FatBits
command) 173-174

points, text size and 70
Polygon Sides command (Options

menu) 144, 178
Polygon tool 144-146,

178-180. See also Regular
Polygon tool

Pop Card message 199
power keys 77, 174-175

Paint 190-191
table of 75, 175, 191

Power Keys command (Options
menu) 75, 174-175. See also
power keys

preset search paths 49
Prev command (Go menu) 119
Previous card button 5

Print Card command (File
menu) 95

printers. See ImageWriter;
LaserWriter

printing 95-105
cards 95-96
columns 101-102
controlling printouts 99
darker 96
fast 96
field names in columns 102

field order 100
format remembered 97, 105
horizontal 94, 96
labels 100-101
manual paper feed 96, 105
page formats 96-97
page setup for 94
reports 98-105. See also Print

Report command
rows 102-104
slowed by smoothing or

flipping 94
stacks 95-97

Print Report command (File
menu) 98-105

Columns 101-102
controlling printouts 99
dialog box 98
field combinations for 99
Field printing order 100
Format remembered 105
Header 105
Labels 100-101
Manual paper feed 105
Rows 102-104

Print Stack command (File
menu) 95-97

Cards printed per page 96
dialog box 95
Fast laser printing/darker

printing 96
Format remembered 97
Headers 97
Manual paper feed 96
Page formats 96

Private access, stacks and 89-90
problems, common

changing card positions 156-157
changing backgrounds 115, 158



creating buttons 115, 127

creating fields 57, 115, 130
deleting cards 156
deleting background 158

dragging pictures 132

modifying background
pictures 158

Protect Stack command (File
menu) 89-93

Can’t delete 90
Private access 90
Set password button 90
viewing full File menu with 93

Push Card message 200

Q
Quick View icon 14

quitting HyperCard 105
quotation marks, Find command

and 8, 120-121
Quotation stack, adding to 24, 28

R

Recent command (Go
menu) 15-17, 118-119

rectangle field style 63
Rectangle tool (Tools menu) 79,

138-139. See also Rounded
Rectangle tool

rectangles 138-140
Regular Polygon tool 79, 144-145,

178. See also Polygon tool
removing. See cutting; deleting;

editing; erasing
renaming. See also names

pictures 81

stacks 87, 159-160
reports, printing. See Print Report

command
restoring last picture saved 171

restricting user levels 92
Revert command (Paint

menu) 171

reviewing cards. See Recent
Rotate Left command (Paint menu)

168

Rotate Right command (Paint
menu) 169

rotating shapes (Regular Polygon
tool) 145

Rounded Rectangle tool 79,
139-140. See also Rectangle
tool

rows, printing 102-104. See also
printing; Print Report
command

S

Save a Copy command (File
menu) 87

Save command, lack of 85
saving

background 88-89
card snapshots 89
changes (Quit HyperCard

command) 105

patterns 178, 183
pictures 171

stacks 85, 86, 87
scanners 74
Scrapbook, pictures and 74
screen

losing part of rotated pictures
on 168-169

removing cards from (Cut Card
command) 113

snapshots of 81, 88-89
Script button (Field Info

command) 152

scripting
on User Preferences card 51

powers associated with 92
scripts xxii, 51, 62-63, 92, 152

Button Info command and 152

changing field names in 63
scroll bar, vertical 63
scrolling field style 63
searches, electronic. See Help

system
searching for text (Find

command) 7-10, 120-122
search paths 49-50
Select All command (Paint

menu) 131, 165
Select command (Paint menu) 164

selecting. See also specific topic
buttons 127-128
fields 130
pictures 76-77, 131-132, 133,

134, 166. See also lassoing
shapes 144, 178
text 126, 143

Selection tool 26, 131, 76-77
Send Farther command (Objects

menu) 61, 161

sending a message (Message
command) 123, 195-201

setting passwords 90-91
shadow field style 63
shapes. See commands, pictures or

specific topic
short cuts

Draw Filled command 179

keyboard (table of) 192-193
opening stacks 87
Patterns menu 183
screen snapshots 89
selecting text 143

Show Cards message 200-201
Show Lines (Field Info

command) 64-65
Show message 200
shrinking pictures (Selection

tool) 131-132, 134

sizing buttons 128
snapshots

card 88-89
screen 81

software. See disks, system
software

Sort icon 13-14
space, eliminating. See shrinking
spacing, line 57
special effects 80
Spray tool (Tools menu) 79, 138

stack(s). See also cards or specific
topic

adding cards to (New Card
command) 112-113

Address 7-9
arrangement of cards in 12-14
Art Ideas 24-25
authoring 31-46
backgrounds, unlimited number

of 116
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blank 86
Button Ideas 36
card position in 12-13
central. See Home
changing 87
changing card position in (Card

Info command) 156-157
compacting (Compact Stack

command) 89
creating 32-34, 86. See also

authoring
customizing tutorial 19-46
definition of 4
deleting (Delete Stacks

command) 93
deleting extra space in (Stack

Info command) 160
directory of 6, 86
free space in (Stack Info

command) 160
Home stack 48
linking Home to 44-46
location of 87, 203-204
moving through 15, 18,

116-123. See also Go menu
names of 1-5, 152, 159-160
opening (Open Stack

command) 24, 86-87
printed summaries of (Print

Report command) 98-105
printing (Print Stack

command) 95-97
protecting (Protect Stack

command) 52, 89-93
Quotation 24
removing cards from (Cut Card

command) 113
renaming 159-160
retrieving (Recent

command) 118-119
saving 85, 86, 87
search path for 49, 160
searching for text in (Find

command) 120-122
sorting 13-14. See also Sort

button
viewing 13

Stack icon 4
Stack Info command (Objects

menu) 159-160

220 Index

description of 159
dialog box 159
Free in Stack 160
Stack name 159-160
Where 160

Stacks disk. See HyperCard &
Stacks disk

Stackware, definition and sources
of xxi. See also Help system

Starting up 2-3
Startup disk. See HyperCard

Startup disk
startup files xvii
stretching picture selections 132,

134
style

button 149
field 63-64
text 69, 114

System file, version number of xvi
system software xvi-xvii

T

Tab key 11, 59-61, 193
tab order 60-61
tear-off menus 30
telephone numbers 7, 11. See

also Address stack
text 65-71

alignment of 69-70, 114
Browse tool and 126
changing 10-11, 68-71
copying 67, 109
default attributes 70, 144
editing 65-66, 124, 126, 190
entering 66-67, 126, 143
finding 7-10, 120-122
fields and 54-65, 129-131. See

also field(s); Field tool
fonts, changing 69, 153
height 70-71
hidden, viewing 67
kinds of 54
lines cut off 71
locking 64, 67, 153
moving 67
outside a field 67
overlapping 55
Paint 54,67, 114

pasting (Paste command) 107,
VW

properties of 68-71
regular 65-71
searching for (Find

command) 7-10, 120-122
selected 66
selecting 126, 143
Show Lines 64-65
size 70
style 69
typing 54
uneditable 67
Wide Margins 64-65
wrapping 58

Text Style command (Edit
menu) 68-71, 114

3.5-inch disks, starting up
from 2-3

time in headers 105
Time message 201
To Do card 32-33
tool(s)

Browse 4, 18, 54, 59, 65-66,
117, 128

Brush 135-136
Bucket 140-141
Button 34-35, 126, 128
Curve 142
Eraser 136
Field 37, 56-62, 67, 129
General. See General tools or

specific tool
Lasso 133-134
Line 137
menu bar changes and 126
modifying. See Power Keys
names of 124

Oval 141-142
Paint. See Paint tools or specific

tool
Paint Text 66, 143-144
Pencil 135

Polygon 145-146
Rectangle 138-139
Regular Polygon 144-145
Rounded Rectangle 139-140
selecting 125
Selection 26, 76-77, 131

Spray 138



switching, Paint text and 114 Vv

Tools menu. See also General version numbers, System file and
tools; Paint tools; tool(s) or Finder xvi
specific tool vertical pictures 169

description of 124-126
tearing off 30

Tools palette, movable 125, W, X, Y
182. See alsotool(s); painting “Where is?” dialog box 49

Trace Edges command (Paint Wide Margins 64-65
menu) 168 wrapping text 58, 101, 102

Transparent command (Paint
menu) 171

transparent z
buttons 149 zooming in on pictures. See
fields 63, 162 FatBits command
pictures 77, 171

tutorials 246
adding a card 11-12
Address stack 7-9
arranging cards in stacks 12-14
authoring 31-46
browsing 3-5
changing text 10-11
getting started 2-3
Help stack 14-15
Home 6-7
limiting 44—46
painting 20-31
Recent 15-17
searching 7-9

Typing level 22. See also User
Preferences card; user levels

typing text. See entering text; text

U

Undo command (Edit menu) 26,
106

user groups xxii
user levels 22-23, 50-52

changing 31
limiting 92
powers associated with 92
setting 50-52

User Preferences card 48, 50-52,
85

Index 22)
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6. HyperCard. Quick ReferenceCard
 

 

 

 

 

 

 

 
  

User preference levels
Browsing Short File and Edit menus, plus the Go menu. Use of the Browse

tool.

Typing Same as Browsing, plus ability to edit text in existing fields.

Painting Same as Typing, but with full File and Edit menus and use of Tools
menu (plus Paint, Options, and Pattern menus whena Paint tool
is selected). Use of all Paint tools (but not Button and Field tools),
plus Power Keys option.

Authoring Same as Painting, plus Objects menu. Use of Button and Field
tools.

Scripting Same as Authoring, plus ability to type into Message box while it’s
hidden Gf proper option checked), and ability to write and edit
scripts.

 



 
 
 

How HyperCard works: An overview

 

| Bernie Squire
 

| Paula Bailey
 

Primo Acme
 A button that takes

you to the next card
 A button that takes

you to the previous card  

 

 

 A button that takes you
to another stack

 Another stack

    
  

Bernie Squire

Paula Bailey
 

Primo Acme

    ro Card field

 Stack

 

 

 

 

  

President, 33
Acme Dot
Company Wx, 

 

Card picture

 

  
Staff _J

 

Card button

 

All this is on the background

This part changes from
card to card

On the screen you see
a combination of the
background and the part
unique to a given card  
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Background picture

 

 

   

 

    

Background fields
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Name : Bernie Squire
 

Position: [Sales Rep.

Empl.No: [234

Building: [D-3 Hormestead :
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Background button



 
 
 

Browsing from the keyboard
 

Destination

Help

Home

First card in stack

Previous card in stack

Next card in stack

Last card in stack

Retrace through cards viewed

Forward through retraced cards

Record of cards recently seen

Select Browse tool

Store current card’s location for
quick return

Return to stored location
Cast in-first out order)

Next field on card

Keyboard short cut

Command-?

Command-H

Command-1 or
Command-Left Arrow

Command-2 or Left Arrow

Command-3 or Right Arrow

Command-4 or
Command-Right Arrow

Tilde (~), Esc, or Down Arrow

Up Arrow

Command-R

Command-Tab

Command—Down Arrow
(Many locations can be stored)

Command-Up Arrow

Tab

 



 

 

 

Text editing
 

 

Function Keyboard short cut

Font, next in system Command-Shift->
Font, previous in system Command-Shift-<
Text style dialog box Command-T
Space, less between lines Command-Option-<
Space, more between lines Command-Option->
Text size, larger Command->
Text size, smaller Command-<

 

 

 

Power keys available when using Paint tools
 

 

Command Key Menu

Black pattern B Patterns
Darken D Paint
Draw Centered (toggle) CG Options
Draw Multiple (toggle) M Options
Fill ie Paint
Flip Horizontal H Paint
Flip Vertical MY Paint
Grid (toggle) G Options
Invert I Paint
Lighten c Paint
Line size 1-4, 6, 8 Options
Opaque e) Paint
Pickup es Paint
Revert R Paint
Select S Paint
Select All A Paint
Trace Edges E Paint
Transparent i Paint
White pattern Ww Patterns
Rotate Left [ Paint
Rotate Right ] Paint

 



 
 

 
 

Keyboard equivalents by command
 

Key

Background
Bring Closer

Copy
Cut
Find
First
Help
Home
Keep
Last
Message
New Card
Next
Open Stack
Paste
Prev
Print Card
Quit HyperCard
Recent
Select
Select All
Send Farther
Text Style
Undo

Command

Command-B
Command-plus
Command-C
Command-X
Command-F
Command-1
Command-?
Command-H
Command-K
Command-4
Command-M
Command-N
Command-3
Command-O
Command-V
Command-2
Command-P
Command-Q
Command-R
Command-S
Command-A
Command-minus
Command-T
Command-Z

Menu

Edit
Objects
Edit
Edit
Go
Go
Go
Go
Paint
Go
Go
Edit
Go
File
Edit
Go
File
File
Go
Paint
Paint
Objects
Edit
Edit

 



 
 
 

Miscellaneous keyboard short cuts
 

Key or combination

Command-Period

Command-Space bar

Command-Tab

Command-Tilde (~)

Command-Shift-V

Command—Down Arrow

Command-Up Arrow

Option-D

Option-O

Option-Tab

Tilde (~)

Down Arrow

Up Arrow

Tap

 

Effect

Cancel current action (ike printing)

Hide and show menu bar

Select Browse tool

Go to most recent card displayed
(Paint tool selected)

Paste miniature card image (with
card on Clipboard)

Store current card’s location for
quick return (you can have many
locations stored)

Return to stored location Cast
in-first out order)

Show card picture (with Paint tool)

Show opaque areas (with Paint tool)

Toggle Tools palette

Same as Back command (General
tool selected),
undo most recent action (Paint tool
selected)

Same as Back command (any tool
selected)

Come forward through reviewed
cards

Toggle Patterns palette (Paint tool
selected),
Advance insertion point to next
background field (Browse tool
selected)

Holding down the Command key before and as you drag through the File menu
shows the full file menu, even if Browsing or Typing is clicked on the User
Preferences card in the Home stack and/or in a stack’s Protect Stack dialog.

 



 

 

 

Effects of modified dragging
 

Tool

Button
Field
Selection
Lasso
Line
Eraser
Pencil
Rectangle
Curve
Brush
Spray
Rounded Rectangle
Polygon
Oval
Regular polygon

With Command key

Create button
Create field
Select tightly
Lasso everything
No effect
Erase white
Get/leave FatBits
No effect
No effect
Erase what you paint over
Erase what you spray over
No effect
No effect
No effect
No effect

 

With Option key

Copy button
Copy field
Copy selection
Copy selection
Draw with pattern
No effect
No effect
Patterned border
Patterned border
No effect
No effect
Patterned border
Draw with pattern
Patterned border
Patterned border

 

Tool

Button
Field
Selection
Lasso
Line
Braser
Pencil
Rectangle
Curve
Brush
Spray
Rounded Rectangle
Polygon
Oval
Regular polygon

With Shift key

Move button horizontal or vertical
Move field horizontal or vertical
Move selection horizontal or vertical
Move selection horizontal or vertical
Draw at 15° angles
Erase straight horizontal or vertical
Draw straight horizontal or vertical
Draw square
No effect
Paint straight horizontal or vertical
Spray straight horizontal or vertical
Draw square with round corners
Draw at 15° angles
Draw circle
Rotate in 15° increments

 



 

 

 

Your own notes
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Please contact your authorized Apple dealer when you have questions about your Apple products. Dealers are

trained by Apple Computer and are given the resources to handle service and support for all Apple products. If
you need the name of an authorized Apple dealer in your area, call toll-free: 800-538-9696.

Would you like to tell Apple what you think about this product? After you have had an opportunity to use this

product, we would like to hear from you. You can help us to improve our products by responding to the

questionnaire below and marking the appropriate boxes on the card at the right with a #2 lead pencil. If you

have more than one response to a question, mark all the boxes that apply. Please detach the card and mail it to

Apple. Include additional pages of comments if you wish.

. How would you rate the HyperCard software overall? (4=poor. . .6=excellent)

. How long have you used HyperCard? (4=less than 1 month, 2=2-6 months, 3=over 6 months)

. How did you acquire HyperCard? (4=packaged with computer, 2=purchased separately)

. Where did you purchase HyperCard? (4=dealer, 2=corporate purchase, 3=education purchase, 4=university,

5 =government purchase, 6=Certified Developer Program, 7=other)

. How much experience have you had with computers? (4=none. . .6=extensive)

. Which Apple computer are you using with HyperCard? (4=Macintosh Plus, 2=Macintosh SE, 3=Macintosh II)

. Where is HyperCard used most often? (4=work, 2=home, 3=school, 4=other)

. How often do you use HyperCard with your computer? (A=never. . .6=always)

_ At what level are you using HyperCard? (4=browsing, 2=typing, 3=painting, 4=authoring, 5=scripting)

At what level do you expect to use HyperCard eventually? (4=browsing, 2=typing, 3=painting, 4=authoring,

5=scripting)

How easy is HyperCard to use? (4=difficult. ..6=very easy)

How did you learn to use HyperCard? (4=Hypercard User's Guide, 2=HyperCard Help Stacks, 3 =training class,

4=friend, 5=other)

Does HyperCard meet your expectations? (4=not at all. ..6=exceeds expectations)

How would you rate the HyperCard User’s Guide overall? (A=poor. . .6=excellent)

How would you rate the HyperCard Help Stacks overall? (4=poor. . .6=excellent)

Please describe any errors or inconsistencies you may have encountered. (Page numbers would be helpful.)

What suggestions do you have for improving HyperCard?

Thanks for your time and effort. 030-3218-A
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. How would you rate the HyperCard software overall? (4=poot

. How long have you used HyperCard? (4=less than 1 month, 2

. How did you acquire HyperCard? (4=packaged with compute

. Where did you purchase HyperCard? (4=dealer, 2=corporate

. How much experience have you had with computers? (4=non

. Where is HyperCard used most often? @=work, 2=home, 3=

. How often do you use HyperCard with your computer? (4=n¢

. At what level are you using HyperCard? (4=browsing, 2=typir

Please contact your authorized Apple dealer when you have qu

trained by Apple Computer and are given the resources to han
you need the name of an authorized Apple dealer in your area

Would you like to tell Apple what you think about this produc
product, we would like to hear from you. You can help us to i
questionnaire below and marking the appropriate boxes on the

have more than one response to a question, mark all the boxes

Apple. Include additional pages of comments if you wish.

5=government purchase, 6= Certified Developer Program, 7=

Which Apple computer are you using with HyperCard? (4=Mq

At what level do you expect to use HyperCard eventually? (4=

5 =scripting)

How easy is HyperCard to use? (4=difficult. ..6=very easy)

How did you learn to use HyperCard? (4=Hypercard User's Gi

4=friend, 5=other)

Does HyperCard meet your expectations? (4=not at all. . .6=¢

How would you rate the HyperCard User’s Guide overall? (A=

How would you rate the HyperCard Help Stacks overall? (=p

Please describe any errors or inconsistencies you may have en

What suggestions do you have for improving HyperCard?

 

   

 
Thanks for your time and effort.
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