




























































































































































































































































































































































































































































When you choose

the Button tool... ... rectangles appear around the buttons.

 

Stack Kit Home
©1990 Apple Computer, Inc.

 

 

 ; |
Readymade Buttons,

 

  
Readymade Fields a Templates |

|HyperTalk Reference

 

 

 

 

 

 

 

Power Tools | Background Art
 

 
   

 

Figure 4-20 Locating buttons with the Button tool

= Some stacks have hidden buttons. To “peek” at all the

buttons on the current card and background—including any

hidden buttons—choose the Button tool from the Tools

menu, then press and hold the and Option keys. Gray

rectangles appear around all the buttons:

When you choose the Button tool

and press $8-Option, gray rectangles

outline the visible buttons. . .

 

 

  

 

  

   
  

.,.and theCallsReceived ‘

hidden buttons.
Jan30,1990 9:36AM

 

(480) 555-5678 x23455
 

Figure 4-21 Peeking at all the buttons—both visible and hidden
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Changing
the appearance

of a button

Changing the size
of a button

202

Once you've created or copied a button, you can change its
appearance by resizing it, changing its style, adding text or an
icon to it, or changing or removing its text or icon. This section
explains how to make a button look the way you want it to.

* Note: You can change the appearance of both card buttons
and background buttons while you’re working in the card
layer. You don't have to be in the background layer to modify
background buttons. +

To resize a button, follow these steps:

1. Choose the Button tool (©) from the Tools menu.

2. Click the button you want to resize to select it.

A moving dashed line surrounds the selected button.

3. Drag from any corner of the button:

 

  
: — ec from any corner

to resize the button.

Figure 4-22 Changing a button’s size

To resize the button in one dimension only—either
horizontally or vertically—hold down the Shift key while you
drag from
a corner.
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* Creatinga standard-size button: Ifyou hold down the Shift key
while you resize a Rounded Rectangle button, HyperCard
automatically makes the button a standard height (the same
height as the buttons produced by the New Button command). +

Choosing a button’s style A button can have any one of seven styles. Examples of the seven
button styles are shown in the following figure, along with the
names of the styles:

 

|___ The background shows
through transparent buttons.

     
 

 

Rectangle
  | — These kinds of buttons

are all opaque.

 

 

 

 
 

 

The background shows
|___ through the text part of

these buttons, but not
through the button part.    

 

Figure 4-23 The button styles

To set the style for a button, follow these steps:

1. Choose the Button tool (©) from the Tools menu.

2. Click the button to select it.
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3. Choose Button Info from the Objects menu.

The Button Info dialog box appears:

 

 

Button Name: | |
 

Card button number: 8

Card button ID: 25

  

] Show Name Style:
CJ Auto Hilite © Transparent

© Opaque
@ Rectangle
© Shadow
© Round Rect
© Check Box
© Radio Button

Script... {ok J [ Cancer |
 

   

Figure 4-24 The Button Info dialog box

4. Choose a style for the button:

 

 

 

Style: Makes the button transparent,

Makes the button opaque (white), (> Transparent with no visible border.

with no visible border. Tas) ia Makes the button opaque (white),

Makes the button opaque @®) Rectangle with a thin black border.

(white), with a shadow along the ——} Shadow
right side and bottom. © Round Rect Mile: a conned

Makes a small square button _____¢{) Check Bou rectangular button.

with an opaque interior. (> Radio Button Makes a small round button

with an opaque interior.

OK } Cancel

 

   

 

Figure 4-25 Choosing a button’s style
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Adding, changing,
or removing

button text

Setting the style
of button text

For a button with an icon, don’t choose either the check box
or the radio button style—ifyou do, you won't see the icon.

5. Click OK.

To add, change, or remove button text, follow these steps:

1. Choose the Button tool (©) from the Tools menu.

2. Click the button you want to change to select it.

A moving dashed line surrounds the selected button.

3. Choose Button Info from the Objects menu while the
button is selected.

The Button Info dialog box appears.

4. Type the text you want to display on the button; or press
Delete or Backspace, ifyou want to delete the text.

You can also remove the text from the button by clicking the
Show Name check box to deselect it.

5. Click OK.

You can change the font, style, or size of the text that’s displayed
on a button using either of the following methods:

» Choose commands from the Font and Style menus.

» Select options in the Text Style dialog box.

To set the style of a button’s text using the Font and Style
menus, follow these steps:

1. Choose the Button tool (©) from the Tools menu.

2. Click the button you want to change to select it.

A moving dashed line surrounds the selected button.
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3. Choose from the Font and Style menus to set the font,
style, and size of the button’s text.

stuie
“Plain —

 

 

 

 
   
 

Future q

sai gen Choose one or more

Choose a font. __}v Geneva Usiariine styles. . check mark

A check mark Helvetica Outline aespene |

appears next to | Garamond Light! talic Shadow eee earn
the selected font. ImageWriter Condense Plain to remove all

Ivy League Extend other styles.

LED Group —
London
McCloud 9 —+ Choose a point size

MerrionSquare 10 for the button’s text.

Monaco 12 |__ The best sizes for the
New York 14 the selected font
Oblige “18 appear in outline.
Palatino CF
Relief
San Francisco Other... ——— Choose Other to select

a point size not shown.  
 

Figure 4-26 The Font and Style menus

The button’s text is displayed in the font, style, and size
you've chosen.

* Note: You can't change the style of the text that’s displayed on
a button with an icon. +

To set the style of a button’s text using the Text Style dialog box,
follow these steps:

1. Choose the Button tool (©) from the Tools menu.

2. Click the button you want to change to select it.

A moving dashed line surrounds the selected button.
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3. Choose Text Style from the Edit menu, or press 3-T.

The Text Style dialog box appears.

4. Choose from the options in the Text Style dialog box:

Click to select the font you want.

(Or double-click to select the font

and return to your work quickly.)

 

 

 

 

   

 
 

 

   
  

Click to select or Button Text Style Click t select
valec Style: a a font size

deselect one or yle: rescue
more text styles. = phe an

(Select nothing (underline | jmagewriter on

for plain text). LC) Outline iva
he ¢ TT [] Shadow a

The sample text LED
7 sep ( Condense L
in the lower-right Flextend ondon

corner of this .
dialog box shows a _ conten |__ To use a font

the effect of the @ eo New York size not listed,

selected style(s). © Center Oblige type it here.

Right Palatino© Righ

  

  This determines how the text This shows what your

will be aligned on the button. text will look like.

Figure 4-27 The Text Style dialog box

5. Click OK.

The button’s text is displayed in the font, style, and size

youve chosen.

Chapter 4: Working with Buttons 207



208

Assigning, changing, To assign a new icon to a button, assign a different icon to a

or removing an icon button, or remove a button’s icon, follow these steps:

1.

Bes

Choose the Button tool (©) from the Tools menu.

Double-click the button you want to change.

The Button Info dialog box appears.

. In the Button Info dialog box, click Icon.

The Icon dialog box appears.

in the following figure:
. Select an icon for the button, or remove the icon, as shown

 

 

Icon 1D: 0 (none)
 

 
 

 

 

 

To display an

icon on the

button (or
assign the

button a

different icon),

click to select

the icon you

want.

|__ Scroll, if
necessary, to

find the icon

you want to

 display on the
 

Figure 4-28

5.

> See also:

Click OK.

 Click here if you want to
remove the button’s icon.

Setting and removing an icon

Your button displays the icon you've chosen.
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Linking information To create a link between related pieces of information, you
create a button and link it to another card or stack. When you
click a button that’s linked to another card, that card appears
immediately. Links are one way. To move back and forth
between two cards, you need two links—one in each direction:

 7
 t

kL
 

 

   
   

    

 

SEE Home f)
ale

 

 

 

 

 

oe" Addresses

eam oo &
=e:
    

 

 

 

TAddresses I
 

 
 

  
 

Figure 4-29 Two links that take you from one stack to another and back again

You can link a button to a card or stack using any of the
following methods:

a Use the LinkTo box.

a Write a short script.

a Use the New Link to Stack command in the standard Home
stack (as described in “Customizing Your Home Stack” in
Chapter 2).

a Use the special linking tools in the Readymade Buttons stack.
(These tools are described in the Readymade Buttons stack.)
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\ Important: If you use the LinkTo method to link a button

Using the LinkTo method

You can close the

LinkTo box without
creating a link by

clicking the close box
or the Cancel button.

that already has a link, the new link completely replaces the
previous one. &

To use the LinkTo method for linking a button to any card or
stack, follow these steps:

1. Choose the Button tool (©) from the Tools menu.

2. Double-click the button you want to link.

The Button Info dialog box appears.

3. In the Button Info dialog box, click LinkTo.

The LinkTo box appears:

  

 

  

  

Link to:  

 

aN
[ This Card | [ This Stack } [ Cancel j

 

 

  

Figure 4-30 Using the LinkTo box to create a link

* Note: The LinkTo box works differently than a standard
Macintosh dialog box. You don’t respond right away when
you see the LinkTo box. First you use HyperCard’s
navigation methods (such as the Go menu commands)
to locate the card or stack to which you want your
button linked. +
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4. Before you click a button in the LinkTo box, go to the card

you want to link the button to.

The LinkTo box doesn’t disappear—it stays on the screen

while you move from card to card.

If the LinkTo box gets in your way, you can move it:

You can move

Link to: the LinkTo box
by dragging

from here.

 

 

[ This Card | [ This Stack ] [ Cancel |
 

 

Figure 4-31 Moving the LinkTo box

5. When you’re looking at the card or stack you want to link
the button to, click the option in the LinkTo box that
reflects where you want the button to take you.

Click This Card ifyou want to link the button to the current
card.

Or click This Stack to link the button to the first card in the

current stack (no matter which card you're looking at).

After you click one of these options, HyperCard returns you

to the card that contains the button you've just linked. The
button is still selected.

Ifyou want to test your new link, choose the Browse tool from
the Tools menu and click the button. It should take you to the

card you've just linked it to. If it doesn’t, repeat the LinkTo
procedure or try the scripting procedure described in the next

section, “Scripting a Link.”
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Scripting a link As an alternative to using the LinkTo box, you can write a script
that links a button to another card or stack. (To do this, you
must have your user level set to Scripting, as explained in “User
Levels and Options” in Chapter 1).

Once you know the steps involved in scripting a link, this
method can be faster and more straightforward than using the
LinkTo box to create a link.

Follow these steps to script a link:

1. Ifyou’re linking the button to a specific card, find out the
card’s name, number, or ID.

To find the card’s name, number, or ID, go to the card and
choose Card Info from the Objects menu.

The Card Info dialog box appears. Make a note of the card’s
name, number, and ID:

 

Card Name: [Stack Kit } |__ The card’s name

Card number: 2 out of 9
bara ie: gece The card’s number

The card’s ID

 

 

Contains 0 card fields.
Contains 6 card buttons.

(J Card Marked
(J Don’t Search Card
[J Can’t Delete Card

Script... OK | Cancel
  

   

Figure 4-32 — Finding out a card’s name, number, and ID
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2. Go to the card that contains the button for which you're
creating a link.

3. Press and hold the 3% and Option keys while you click the
button once.

The button’s script opens. It should look like this:

 

SSS script of card button id
an mousellp

 

end mousellp

Figure 4-33 Opening a button’s script

4. If there’s any text in the script other than the text shown in
Figure 4-33, don’t go any further.

The additional text indicates that the button is designed for
another purpose. Unless you’re familiar with HyperTalk, it’s
best to close the script by clicking its close box, and create or
find another button to link.
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5. If the script looks like the one shown in Figure 4-33, type
any of the following, substituting the card name, card
number, card ID, or stack name for the card or stack you
want to link the button to:

 

Script of card button — Takes you to the
card with theon mousellp

go to card “card name" specified name.
end mousellp

   

 

 

 
 

 Takes you to the

card with the

specified number,

   

Ea
on mousellp

go to card 4
end mousellp

Script of card button

  

 

 

 
 

 

    

oO Script of card button —‘akes you to the
card with theon mouselip

go to card ID 8 specified ID.
end mouselp

  

 

 

 
 

 

  

Er] Takes you to the
stack with theon mousellp

go to stack “stack name" specified name.
end mouselp

 

Script of card button

  

 

 

 
 

Takes you to the

Script of card button = card with the
specified card

 

   

HUHEa

on mouseUp :

go to card “card name" in stack “stack name— name in the stack
end mouseUp with the specified

stack name.

   

 

 
 

Figure 4-34 Scripting a link
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Adding a

visual effect

6. When you're finished, press Enter.

If you want to test your new link, choose the Browse tool from
the Tools menu (if it isn’t already selected) and click the button.
It should take you to the card you've just linked it to. If it
doesn't, check your script for typos and make sure the card
name, number, or ID matches the one you've typed in the script.

You can add visual effects to HyperCard buttons to make
movement between cards and stacks more noticeable and
visually interesting. For example, you can adda visual effect that
produces an image of a Venetian blind closing as you move from
one card to another. Or you can adda visual effect that makes
one card seem to fade away gradually as the next one appears.

To add a visual effect to a button, follow these steps:

1. Choose the Button tool (©) from the Tools menu.

2. Double-click the button.

The Button Info dialog box appears.

3. In the Button Info dialog box, click Effect.
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4. Choose a visual effect for the button:

 

; Effect for card button ID 25:
The name of the selected —tHoisual effect checkerboard

visual effect appears here.

 

Click one of these 

 

    

 

  

    

barn door open Speed: to select a speed
barn door close O Fast nal for the visual
checkerboard @ Normal |__ effect—that is,
dissolve © Slow how quickly theIris open © Uery Slow :  effect appears and

disappears when
you click the

(Cancel } button.

iris close
scroll left
scroll right
scroll up
scroll down

   
   
    

    

 Click an item in this list to select
a visual effect for your button.

Figure 4-35 Selecting a visual effect

5. Click OK.

To test the new visual effect, choose the Browse tool from the
Tools menu and click the button. You see the visual effect as you
go to the card that the button’s linked to.

«+ Note: You wont see the visual effect unless the button is
linked to another card or stack. “Linking Information,” earlier
in this chapter, explains how to link a button to another card
or stack. +

To find out what all the visual effects do, you can experiment by
repeating this procedure to assign different visual effects to
buttons.

\ Important: If you’re using more than one monitor with your
computer, and the card window is divided between two
monitors, you won't see any visual effect. \
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Making a button You can design a button so that it highlights momentarily wheng snug, y
highlight when you click it. Such a button is helpful when you’re using a stack,

because it provides visual feedback that you’ve clicked the

Follow these steps to create a button that highlights when you
click it:

1. Choose the Button tool (©) from the Tools menu.

2. Double-click the button.

The Button Info dialog box appears.

3. In the Button Info dialog box, click the Auto Hilite check

box to select it.

4. Click OK.

Auto Hilite works as just described for a button of any style,

except for a check box or radio button. When Auto Hilite is

selected for a check box or radio button, clicking the button
once highlights it and leaves it highlighted. Clicking the button
again removes the highlight.

With the Auto Hilite option turned off, you receive no visual

feedback when you click a button.
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These highlight
for only a—

moment when
you click them.

Making a button
appear highlighted

on certain cards

The figure that follows shows how the different kinds of buttons
highlight when Auto Hilite is turned on.

Rectangle

es
Figure 4-36 Highlighting buttons of different styles

These stay highlighted
until you click them again.

 

Normally, when you click a background button for which Auto
Hilite is turned on (in the Button Info dialog box), the button
becomes highlighted on every card with that background. And a
background button for which Auto Hilite is turned off never
becomes highlighted when you click it.

However, background buttons have an additional option called
Shared Hilite. When Shared Hilite is turned off, the highlight of
the button can vary from card to card. This allows the button to
appear highlighted on some cards, and not on others—which
can be useful for signifying that something is true for some cards
but not for others. (Check boxes and radio buttons are
particularly good for this purpose.)
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To allow a background button’s highlight to vary from card to
card, follow these steps:

1. Choose the Button tool (©) from the Tools menu.

2. Click the button whose highlighting you want to vary from
card to card to select it.

3. Choose Button Info from the Objects menu.

The Button Info dialog box appears.

4. Click the Shared Hilite check box to deselect it.

When a background button is first created, this option is

turned on.

 

 

Button Name: i
 

Bkgnd button number: 1

. . Bkgnd button ID: 2
Click Auto Hilite

a. CJ Show Name Style:
to select it. —}&] Auto Hilite @ Transparent

Click Shared Hilite —__ [J Shared Hilite © Opaque

to deselect it. © Rectangle

© Round Rect
(Effect... } O Check Box

© Radio Button

{ Script... | {| ok [cancer |
 

 

   

Figure 4-37 Varying a button’s highlighting from card to card

5. Click the Auto Hilite check box to select it, if it isn’t
already selected.

6. Click OK.

Ifyou want the button to appear highlighted on any particular
card, you have to go to that card and click the button.
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Naming a button You can give a button a name when you want to display text on
it, or ifyou want to be able to address the button by name
through scripts or the Message box.

Follow these steps to name a button:

1. Choose the Button tool (©) from the Tools menu.

2. Click the button you want to name to select it.

3. Choose Button Info from the Objects menu.

Or double-click the button. The Button Info dialog box
appears.

4. Type a name for the button:

 Type the button

name here. Button Name: |[gittea Tis med

Bkgnd button number: 12

Bkgnd button ID: 39

 

 

To display the ___[ show Name Style:
name on the (J Auto Hilite @ Transparent
button. click —J Shared Hilite © Opaque

© Rectanglehere to select

  

Shad
Show Name. peta ie

© Check Box
© Radio Button

Script... lf OK et Cancel |
 

  
 

Figure 4-38 Naming a button

It’s best to give the button a name that communicates
its purpose.

5. If you want the button’s name to appear on the button,
click the Show Name check box to select it.
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Click OK.

Script writers take note: Ifyou change the name of a button, be

sure to change its name everywhere you refer to it in a script,
too. For example, ifyou rename a button “Today” and you use

the old name “Yesterday” in a script, the script won't work
: : ;

properly—it won't be able to find the button it needs. +

Moving a button You can place a button wherever you like on the card or
background. To reposition a button on the card or background,
follow these steps:

around on a card
or background

. Choose the Button tool (©) from the Tools menu.

. Click the button you want to move to select it.

Whether the button is in the card layer or the background
layer, you can select it from the card layer.

A moving dashed line surrounds the selected button.

. Drag from the middle of the button, or from one of its
edges (not a corner):

 

ie Le Drag from the

oe 3 fe middle to move

the button.

 

   

Figure 4-39 Repositioning a button on the card

To constrain the field’s movement to horizontal or vertical
directions only, hold down the Shift key while you drag from
the middle of the button.
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You can select and move only one button at a time.

\ Important: After you reposition a background button, it’s a
good idea to look through the cards on which the button
appears, to see how the cards look. A

When elements HyperCard puts different kinds of elements in different layers,
overlap as shown in the following figure. Together, all these layers make

up the card you see.

Background picture
an   

  

  

 

   

Background

Card picture
P Card buttons

and fields

ay — i when you look

  at the card

     

 

The background picture i
is fixed in a layer by
itself—it’s always : |
behind the background : oo :

buttons and fields and The card picture is also Ley
all the card elements. fixed in a layer by |oo

itself—it’s always
behind the card buttons
and fields, and in front
of all the background
elements.

Figure 4-40 —HyperCard’s layers
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As shown in Figure 4-40, background buttons and fields go in a

different layer than card buttons and fields. Within each of these

layers, HyperCard places each new button or field you add
(whether you've created it or copied it) in front of the element
added before it. (In front ofmeans “closer to you.”)

HyperCard also assigns numbers to the buttons and fields as you
add them. The first field you add is field number 1, the second is

field number 2, and so on. Likewise, the first button you add is

button number 1, the second is button number 2, and so on. The
numbers reflect how far away the elements are from you—the
farther away an element is, the lower its number. (These numbers
appear in the Button Info and Field Info dialog boxes.)

Although HyperCard numbers the buttons and fields separately,

it places each new element immediately in front of the previous
element (within the same layer), whether it’s a button or field.

This was added first.

This was added second.

This was added third.

This was added fourth.

 

    

  
 

This was added fifth.

This was added sixth. 

Figure 4-41 Background button and field layers and numbers
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Reordering buttons

HyperCard numbers the card buttons and fields separately from
the background buttons and fields. The card elements are always

in front of all the background elements (as shown in Figure 4-40).

This layering of buttons and fields becomes evident when the
elements overlap. Elements that are closer to you can obscure

elements that are farther away. If this happens, you can either
move the elements apart so they don’t overlap, or you can try
either of the following:

= Reorder the buttons and fields. (You can move any button or
field closer or farther, within its layer).

us Make some of the elements transparent, so you can see other
elements through them. (Buttons, fields, and graphics can all

be made transparent or opaque.)

The following sections describe these solutions.

Overlapping buttons and fields can cause visual and functional
problems in your stack. For example, a button that’s covered by
a field (or another button) won't respond when you try to click
it. To solve the problem of overlapping buttons and fields, you
can reorder them to bring the ones you need to see and use into
full view.

Important: The buttons and fields in the card layer are always

in front of the background buttons and fields. Although you can

reorder the background buttons and fields relative to one

another, you can never move them closer to you than any of the

card elements. (You can, however, make card elements

transparent so you can see through them to the background
elements, as explained in the next section.) A
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To move a button closer or farther (relative to the other buttons
and fields in the same layer), follow these steps:

1. Choose the Button tool (©) from the Tools menu.

2. Click the button you want to move closer or farther to
select it.

A moving dashed line surrounds the selected button.

3. Choose Bring Closer from the Objects menu to move the
button forward one position, or choose Send Farther to
move it back one position.

Each time you move a button back one position relative to
another button in the same layer, its number (in the Button
Info dialog box) decreases by 1. Each time you move a button
forward one position relative to another button in the same

layer, its number increases by 1.

Note that a button’s number may not change every time you
use the Bring Closer or Send Farther commands to change its
position. For example, if a field lies between button 3 and
button 4, you'd have to move button 4 back two positions
(with the Send Farther command) before it would become
button 3.
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Making a button opaque
or transparent

You can also move the selected button all the way to the front
or all the way back using these $-key shortcuts:

To do this... Press

Send the button to the back $8-Shift- — (minus)
Bring the button to the front 3¢-Shift-+ (plus)

4. Repeat step 3 until the button is where you want it.

5. Choose the Browse tool (*) to deselect the button.

As you reorder buttons, the numbers of all the affected buttons
change to reflect their new positions. Each button’s number
(shown in the Button Info dialog box) reflects its front-to-back
position, relative to the other buttons in the same layer. (The
button that’s farthest away is button number 1. The closer a
button is to the front relative to other buttons in the same layer,
the higher its number.)

The commands Bring Closer and Send Farther work the same way
on a selected field, as described in “Reordering Fields” in Chapter 5.

When you want to be able to see background or card elements
through a button that covers them, you can make the button
transparent. Conversely, when you want to give a button more
prominence, you can make it opaque.

Follow these steps to make a button Opaque or transparent:

1. Choose the Button tool (©) from the Tools menu.

2. Click the button you want to change to select it.
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3. Choose Button Info from the Objects menu.

Or double-click the button. The Button Info dialog box
appears.

4. Choose an appropriate button style to make the button
opaque or transparent:

 

 

Button Name: |
 

Card button number: 8
Card button 1D: 25 Choosing this style

makes the button
 

—] Show Name Style: :

[Auto Hilite © Transparent — transparent.
© Opaque
(@ Rectangle
© Shadow |__ Choosing any of

(Effect... 4 tne sil these styles makes
—— © Radio Button the button opaque.

(LinkTo... } (See Figure 4-23.)
 

Script... OK Cancel

  
 

Figure 4-42 Making a button opaque or transparent

5. Click OK.

Copying a button You can duplicate a button on the same card, or copy a button
to another card, background, or stack. When you copy a button,
you also copy its attributes—it’s style, name, icon, script, and so

on.

-\ Important: To copy a button and a graphic that shows through
it, you have to copy the picture and the button separately. (This
is not the case for a button with an icon.) Follow the
instructions given here to copy the button. See Chapter 6 for
instructions on copying a graphic. A
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Copying a button To duplicate a button on the same card or background, follow
on the same card _ these steps:

1. Choose the Button tool (©) from the Tools menu.

2. Click the button you want to copy to select it.

You can select the button from the card layer, whether it’s a

card button or a background button.

A moving dashed line surrounds the selected button.

3. Press and hold the Option key while you drag the button.

As you drag, you create an exact duplicate of the button. If
the original is a background button, the duplicate is a

background button. If the original is a card button, the
duplicate is a card button.

To constrain the new button’s movement to horizontal or
vertical directions only, hold down the Shift key while you
drag from the middle of the field.

Copying a button to another To copy a button to another card or background, follow these steps:

card or background 1. Choose the Button tool (©) from the Tools menu.

2. Click the button you want to copy to select it.

3. Choose Copy Button from the Edit menu, or press 38-C.

This makes a copy of the selected button (including its script)
and puts it on the Clipboard. (This button replaces the last
item you cut or copied; the Clipboard can only hold one
item at a time.)
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4. Go to the card or background where you want the button
to appear.

Use the arrow keys or commands in the Go menu to navigate
between cards while the Button tool is selected.

Ifyou’re not sure whether to put the button in the card layer

or the background layer, see “Adding a Button to a Card or
Background” at the beginning of this chapter.

5. Choose Paste Button from the Edit menu, or press #-V.

This takes a copy of the button that’s on the Clipboard, puts
it on the current card or background, and selects it.

Ifyou've copied a background button to the card layer of the
same card, the copy is pasted directly over the original. To see

the original, you have to drag the copy to move it.

6. While it’s still selected, drag the button to where you want it.

Important: The most common mistake in copying a button is

putting it in the card layer when you want it in the background
layer. (To find out whether the button is in the background
layer, press $8-B to see just the background elements.) Ifyou put
a button in the card layer by mistake, see the next section,
“Moving a Button from the Card to the Background.” A

After you copy a button from another card or stack, it’s a good
idea to test the button to make sure it works properly. To test

the button, choose the Browse tool and click the button. If
clicking the button produces an unfamiliar message (for
example, a message that begins with “Can’t Understand . . .” or
“Never heard of . . .”), see “Copying Parts From Other Stacks”

in Chapter 2 for advice on how to proceed.
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Moving d button It’s easy to put a button in the card layer by mistake when youfrom the card to _ intend to put it in the background. If this happens, you can
move the button from the card layer to the background layer (of
the same card) by following these steps:

the background

1.

2.

Choose the Button tool (©) from the Tools menu.

Click the button you want to move to select it.

A moving dashed line surrounds the selected button.

. Choose Cut Button from the Edit menu, or press 3-X.

This removes the button from the card and puts it on
the Clipboard.

. Go to the background layer.

Choose Background from the Edit menu, or press $-B.

. Choose Paste Button from the Edit menu, or press 3-V.

This takes a copy of the button that’s on the Clipboard, puts
it in the current background, and selects it. The pasted
button appears in the same position from which it was cut.

- While it’s still selected, drag the button to where you want it.

Since you can’t see the elements in the card layer while you're
working in the background, you might not be able to tell
whether you're putting the button in the right place. If this
happens, you can press $-B again to go back to the card layer,
and then select and drag the button from the card layer.
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Moving a button Follow these steps to move a button from the background layer
from the background to the card layer of the same card:

to the card 1}:

2.

Choose the Button tool (©) from the Tools menu.

Click the button you want to move to select it.

A moving dashed line surrounds the selected button.

. Choose Cut Button from the Edit menu, or press 3¢-X.

This removes the button from the background and puts it on
the Clipboard.

. If you’re in the background layer, go to the card layer by
pressing 3-B.

Ifyou’re already in the card layer, skip this step.

. Choose Paste Button from the Edit menu, or press 38-V.

This takes a copy of the button that’s on the Clipboard, puts
it on the current card, and selects it. The pasted button
appears in the same position from which it was cut.

While it’s still selected, drag the button to where you want it.
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Moving a button You can move a button to another card in the same stack, or to a

to another card card in another stack. When you move a button, its attributes—it’s

or background
style, name, icon, scripts, and so on—move with it.

-\ Important: To move a button and a graphic that shows through
it, you have to move the picture and the button separately. (This
is not the case for a button with an icon.) Follow the
instructions given here to move the button. See Chapter 6 for
instructions on moving graphics. A

Follow these steps to move a button to another card or
background:

bs

a
Choose the Button tool (©) from the Tools menu.

Click the button you want to move to select it.

A moving dashed line surrounds the selected button.

. Choose Cut Button from the Edit menu, or press $-X.

This removes the selected button from the current card and
puts it on the Clipboard.

. Go to the card or background where you want to put
the button.

Use the arrow keys or commands in the Go menu to navigate
between cards while the Button tool is selected.

Ifyou're not sure whether to put the button in the card layer
or the background layer, see “Adding a Button to a Card or
Background” at the beginning of this chapter.
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Opening a

button’s script

5. Choose Paste Button or from the Edit menu, or press #-V.

This takes a copy of the button on the Clipboard, puts it on
the current card or background, and selects it.

6. While the button is still selected, drag it to where you want
it on the card.

Important: The most common mistake in moving a button is

putting it in the card layer when you want it in the background
layer. (To find out whether a button is in the background, press

$8-B to see just the background elements.) Ifyou put a button in
the card layer by mistake, see “Moving a Button from the Card
to the Background,” earlier in this chapter. “

After you move a button from another card or stack, it’s a good
idea to test the button to make sure it works properly. To test

the button, choose the Browse tool and click the button. If
clicking the button produces an unfamiliar message (for
example, a message that begins with “Can’t understand . . .” or
“Never heard of . . .”), see “Copying Parts From Other Stacks”

in Chapter 2 for advice on how to proceed.

Looking at the script of a button (if it has a script) is a good way
to learn about how the button works. (To look at a button’s
script, you must have your user level set to Scripting.)

Here are four ways to open a button’s script:

a With the Browse tool or Button tool selected, press and hold
the 3 key and the Option key while you click the button.

» With the Button tool selected, press and hold the Shift key
while you double-click the button.
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= Choose the Button tool from the Tools menu, click the
button to select it, and hold down the Shift key while you
choose Button Info from the Objects menu.

= Choose the Button tool from the Tools menu, double-click the
button to open the Button Info dialog box, then click Script.

To close a script, simply click its close box.

To learn about HyperCard scripts, read the HyperTalk Beginner's
Guide.

Deleting 4 DULLON: «Yoneda Vemova a. button froma stack by following these steps:

1. Choose the Button tool (©) from the Tools menu.

2. Click the button you want to delete to select it.

3. Choose Clear Button from the Edit menu, or press Delete
or Backspace.

A Warning: Once you've deleted a button with the Clear Button
command (or with the Delete or Backspace key), the button’s
gone for good—you can't undo the deletion. a
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Chapter 5

 

WorkingWithText
andFields

aie is an important component of HyperCard stacks. In most

stacks, text is used to communicate the function of the stack,

either alone or in combination with graphics. Text is also the

primary content of many stacks—particularly stacks designed

for managing large amounts of information.

Most of the text in stacks is contained in fields, which are

rectangular areas on a card where you can type and edit text
easily. This chapter gives instructions for working with fields. To
do the tasks in this chapter, you must have your user level set at

least to Authoring. For some of the tasks, your user level must be

Scripting. Whena task requires the Scripting level, the

instructions say so. (The section “User Levels and Options” in
Chapter 1 tells you how to set your user level.)



Adding text When you want to adda text element to a stack, you can choose
from three different kinds of text:

mw Text that’s stored in a field

= Text that’s attached to a button

a Paint text

For most purposes, it’s best to use fields to add text to a stack.
Field text is easy to edit—you can select any part of the text ina
field and change it, move it, copy it, or delete it. You can also
move field text around on a card by selecting and dragging the
field. And you can search for specific text in fields. The Shared
Text option allows you to create a background field that displays
the same text on every card—which means you can create text
labels made up of editable (field) text.

In addition to their linking powers, buttons can be useful for
adding text labels to a card or background. A button can’t hold
much text, and you can’t edit button text from the card. (To
change the text on a button, you have to rename the button.)
But button text is easy to move around on the card, because it
moves when you move the button. Chapter 4 tells you how to
create a button with text.

Paint text can’t be edited. Once you finish typing Paint text, it
“dries.” To change it, you have to erase it and retype it. Paint
text is useful for adding a permanent label to a graphic. And you
can create special effects with Paint text using commands in the
Options menu (for example Slant, Distort, and Perspective),
which appears whenever a Paint tool is selected. Chapter 6
describes Paint text.
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Paint text in the card layer

 

Giant Chaco Peccary

   
This wild pig lives only

=e, inthe Chaco region of Field text
Paraguay. Roads and —
farming are destroying its 4 a a

habitat. Because it is so that changes
"rare and elusive, science vA

~ kKnows little about it. from card
to card

Where does itlive?

 

  
 

 A background button
that displays text

Figure 5-1 Different kinds of text

Adding a field To create a place for text, you can adda field to a card or
to a card background. Whenever you adda field, you need to decide

: whether you want to put it in the card layer or the background
OI background layer. To decide where to put the field, consider where you want

the field to appear, and where you want its text to appear:

a Ifyou want the field and its text to appear only on one card,

put the field in the card layer.

« Ifyou want the field to appear on every card in the stack, but
you want to be able to type different text into the field on
each card, put the field in the background layer.

» Ifyou want the field to appear on every card in the stack, and
you want it to display the same text on each card, put the
field in the background layer and turn on the Shared Text
option in the Field Info dialog box.
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» Ifyou wanta field to appear on some of the cards in the stack,
but not all of them, consider creating a different background
for those cards and putting the field in that background only.
(“Creating a New Background” in Chapter 3 explains how to
add a background toa stack.)

A background field appears in the same location on all the cards
that share the background.

To add a field to a background, you must be in the background layer;
to add a field to a card, you must be in the card layer. To go to the
background layer, press $-B. When you're in the background layer,
stripes appear in the menu bar. Ifyou press 38-B repeatedly, you move
back and forth between the card layer and the background layer.

Y See also: + “The Card Layer Versus the Background Layer” in Chapter 2

* “Creating a Field” in this chapter

The Tools for TKesedewadk fields and field text, you need both the Field tool

working with fields and the Browse tool.

Use the Field tool
for creating and
manipulating fields.

 

 
 

 

 Use the Browse tool for
entering and editing text
(in addition to browsing).

Figure 5-2 The tools for working with fields
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Copying
readymade fields

To make it easy to alternate between the tools, you can “tear off”
the Tools menu to create a movable Tools palette. To do this,
drag down through the menu and past the bottom or beyond
either side. (For an illustration of this, see Figure 2-12.)

You can use the following 3-key shortcuts to choose the tools
you need for working with fields:

To choose this tool... Press

The Browse tool 38-T ab

The Field tool 38-Tab-Tab-Tab

} See also: “Using HyperCard’s Tools” in Chapter 2

HyperCard comes witha special stack—called Readymade
Fields— that contains interesting and useful fields you can copy
and paste into your stacks. The readymade fields have pre-
programmed scripts that can add power and versatility to your
stacks.

The Readymade Fields stack includes different fields that
automatically display the date, the time, the current card
number, or calendar months, fields that expand or shrink when
you click them, fields that perform calculations on values you
type into them, fields that sort their text alphabetically, fields
that perform metric conversions, and much more.
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You don't need to know HyperTalk to make these fields
work—you just need to understand what they do, so that you
can use them appropriately in your stacks. These fields are
designed to work in virtually any stack. They don’t depend on
your stack’s structure in any way.

 

 

A field that always displays the Fields that convert
current date: measures you type in them:

| Thu Janit1990 | sale
Feet/Meters: .3048 meter

Yards/Meters: .8361 meter

A field that always displays the Miles/Kilometers: -9434 km
current card number: Farenheit/Centigrade:

card 8 of 15

A field that always displays the current
month’s calendar when you click it:

A field that always displays the
 

 

 

current time: Tanvery 1990
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Fields that can perform calculations
on numbers you type in them:

 

5 {ai
545

a

oman

I

Total: 345 Average.

        

Figure 5-3. Some readymade fields
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Copying readymade fields can make stack building easier and
save you a lot of time. If you see a field you like in the
Readymade Fields stack, there’s no sense in reinventing it—copy
it and paste it into your stack.

Follow these steps to copy one of the readymade fields:

1. Open the Readymade Fields stack.

2. Go to the card that has the field you want to copy.

3. Choose the Field tool () from the Tools menu (or click it
on the Tools palette).

The pointer changes to an arrow (n).

4. Click the field you want to copy to select it.

A moving dashed line surrounds the selected field.

5. Choose Copy Field from the Edit menu, or press 3-C.

This puts a copy of the selected field (including its script) on
the Clipboard.

6. Go to the card or background where you want to put the
copied field.

Use the arrow keys or commands in the Go menu to navigate
between cards while the Field tool is selected.

Ifyou're not sure whether to put the field in the card layer or
the background layer, see “Adding a Field to a Card or
Background” near the beginning of this chapter.

7. Choose Paste Field from the Edit menu, or press 38-V.

This takes a copy of the field that’s on the Clipboard, puts it
on the current card or background, and selects it.

8. While the field is still selected, drag it to where you want it
on the card.
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\ Important: The most common mistake in copyinga field is

putting it in the card layer when you want it in the background
layer. (To find out whether a field is in the background, press

38-B to view just the background elements.) Ifyou put a field in
the card layer by mistake, see “Moving a Field From the Card to
the Background,” later in this chapter.

Ifyou want to enter text in the field after you've copied it,
choose the Browse tool, then click in the field and type.

* Cant type in thefield? Make sure you're working in the card
layer. If you see stripes in the menu bar (indicating that you're
working in the background layer), press $-B to return to the
card layer. +

Y See also: “Changing the Appearance of a Field” in this chapter

Creating a field To create a new field, follow these steps:

1. Go to the card or background where you want to put the
field.

Ifyou’re not sure whether to put the field in the card layer or
the background layer, see “Adding a Field to a Card or
Background” near the beginning of this chapter.

2. Make sure you have one of the General tools selected.

The Browse tool (%), the Button tool (©), or the Field tool
(&) will work.
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3. Choose New Field from the Objects menu.

This automatically selects the Field tool and creates a new,

Rectangle-style field. The field appears in the center of the card

window and is selected, so you can move it or resize it easily.

 

 

 

 

 

Figure 5-4 A field created with the New Field command

* Another method: You can create a new, transparent field by
choosing the Field tool, then pressing and holding the # key

while you drag diagonally. +

Choose the Field tool,
hold down the key,

and drag from here . . .

 

... to here.
 

Figure 5-5 Dragging to create a new field

You can have as many fields on a card or a background as will
fit. Fields can overlap to any depth.
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\ Important: The most common mistake in creatinga field is

Entering and editing
text in a field

putting it in the card layer when you want it in the background
layer. (To find out whether a field is in the background, press
3-B to view just the background elements.) Ifyou put a field in
the card layer by mistake, see “Moving a Field From the Card to
the Background,” later in this chapter. \

LY See also: “Changing the Appearance of a Field” in this chapter

Entering and editing text in a HyperCard field is just like
working with any other Macintosh text. You can click anywhere
in the field and begin typing, delete text with the Delete or
Backspace key, and drag to select text for copying, cutting, or
clearing. You can also copy text to and froma field via the
Clipboard. This allows you to move text between fields and to
and from other applications.

« Where's thefield? A transparent, empty field is invisible when
the Field tool isn’t selected. This makes it difficult to locate
the field when you're ready to enter text into it. One way to
locate the field is to move the Browse tool around—the
pointer turns into an I-beam when it’s over an editable field.
Another way to locate a transparent field is to press Tab
repeatedly—this highlights the editable fields on the current
card and background, one ata time. +

To enter and edit field text, follow these steps:

1. Choose the Browse tool (%) from the Tools menu.
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4,

. Move the Browse tool over the field you want to edit.

The Browse tool pointer turns into an I-beam (I) when it’s
over an editable field. Ifyou don’t see the I-beam pointer,
read the next section, “Where’s the I-Beam Pointer?”

. Click inside the field to position the insertion point where
you want to enter or edit text.

Or, ifyou want to replace existing text in the field, select the
text you want to replace.

Ifyou click in an empty field, the insertion point appears at

the left edge of the line you click.

Start typing.

Ifyou type more text than will fit in a non-scrolling field, the
remaining text goes off the bottom of the field. But this text isn’t
lost, it’s just hidden from view. To see the hidden text, make the

  

 

 

 

   

 

field bigger:

‘Ifyou type more text.
If you type more ithan will fit ina :

text than will ‘field, you can't see it.
fit ina field, you until you enlarge the
dan't coo it until ‘field.

To see text you've .. enlarge the field by
typed beyond the choosing the Field tool from
borders of a field. . . the Tools menu and then

dragging from any corner.

Figure 5-6 Revealing hidden text
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Where’s the
I-beam pointer?

Preventing text
wrap in a field

If the Browse tool doesn’t turn into an I-beam (1) when you
move it over a field, the reason could be any of the following:

The field is locked. To unlock the field, follow the instructions
in “Locking and Unlocking a Field,” later in this chapter.

The Shared Text option is turned on in the Field Info dialog
box and you’re working in the card layer rather than the
background layer. Press $-B to go to the background layer.
(See “Making Field Text Appear on Every Card,” later in this
chapter, for more information about the Shared Text option.)

The Shared Text option is vot turned on in the Field Info
dialog box and you’re working in the background layer rather
than the card layer. Press 38-B to return to the card layer.

Your user level is set to Browsing. For instructions on changing
the user level, see “User Levels and Options” in Chapter 1.

The text you're trying to edit is either Paint text or button
text—not field text. To see whether it’s field text, choose the
Field tool from the Tools menu and click the text. If the area
becomes selected (surrounded by a moving dashed line), it’s
field text—otherwise, it’s not. See Chapter 4 for information
about changing the text on a button, or Chapter 6 for
information on changing Paint text.

Normally when you type in a field, your text wraps when it
reaches the right side of the field—that is, words that won't fit
completely on the line move to the next line. However, you can
choose not to have the text in a field wrap. When you use this
feature, you won't see the text you type beyond the right side of
the field unless you press Return to move from line to line.
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Click here to prevent text
from wrapping in

a field as you type.

Clicking Don’t Wrap
again to deselect it

allows the text to wrap
and reveals any text

that was typed beyond
the field’s right border. _]_1 Don’t Wrap © Scrolling

Here’s how to prevent text from wrapping ina field:

1. Choose the Field tool (&) from the Tools menu.

2. Click the field to select it.

3. Choose Field Info from the Objects menu.

Or double-click the field. The Field Info dialog box appears.

4. Click the Don't Wrap check box to select it.

 

 

Field Name: | |

Card field number: 1

Card field ID: 2

 

(Lock Text Style:
CO Show Lines @ Transparent
(] Wide Margins © Opaque
CJ Auto Tab © Rectangle
—] Fixed Line Height © Shadow

CJ Don’t Search

Script... | OK Cancel
 

   

Figure 5-7 Preventing text from wrapping ina field

5. Click OK.

Text won't wrap as you type in the field, and it disappears from
view if you type beyond the right edge. However, any text you’ve
typed beyond the right side of the field is there. You can recover

it by turning off Don’t Wrap or enlarging the field.
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Using the arrow keys
to move through text

  

Moves the insertion
point left through text

Ifyou turn on Don’t Wrap for a field that already has text in it,
HyperCard puts all the text on the first line of the field (the text
extends beyond the right edge of the field) unless you’ve pressed
Return at the end of each line while entering the text. The text
that was below the first line disappears from view, but it’s still in
the field. You can see it again by turning off Don’t Wrap.

Normally, the arrow keys move you through cards. However,
when the Arrow Keys in Text option is selected (on the
Preferences card in your Home stack), you can use the arrow
keys to move the insertion point through text while you’re
typing in fields. This makes text editing easier.

Moves the Moves the insertion point
insertion point down through lines in a field,
right through ~—_or to the end of the line in the
text Message box    

Moves the insertion point
up through lines ina field,
or to the beginning of the
line in the Message box

 

Figure 5-8 Moving through text when Arrow Keys in Text is turned on and the
insertion point is blinking in a field or the Message box

When Arrow Keys in Text is turned on and the insertion point is
blinking in a field or the Message box, you use the Option key
with the arrow keys to move through cards in a stack.

Y See also: “The Arrow Keys in Text Option” in Chapter 1
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Moving from one field
to another

 

While you’re entering text into fields, you can move from one
editable field to the next by pressing Tab. When you press Tab,
HyperCard takes you to the field with the next higher field
number. (Field numbers are assigned to fields in the order you
add them. The first field you add is field 1, the second is field 2,
and so on.) If the insertion point is in field 3 and you press Tab,
the insertion point moves to field number 4; if there are only
three fields, the insertion point moves from field 3 to field 1:

to here. . .

Pressing Tab takes

you from here. ..  
  

  

 

to here...
  

 

 

 

.. and finally
back to here.

Figure 5-9 — Tabbing order

Pressing Shift-Tab moves you backwards through the fields.
Locked fields are excluded—you can’t Tab toa locked field.
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A Warning: When you tab to a field that already contains text, all the
text is selected. Typing at this point will erase all the old text in the
field and replace it with what you type. To preserve the old text and
add new text to it, click in the field where you want to type. 4

A field’s number (which determines the field’s position in the
tabbing order) appears in the Field Info dialog box. Choose the
Field tool from the Tools menu and double-click the field to see

the Field Info dialog box:

 

Field Name: |[agtuiE iy
 Bkgnd field number: 11 This number

Bkgnd field 1D: 84 determines the
rl Leck lent style: field’s position in

(1 Show Lines @ Transparent the tabbing order.
(] Wide Margins © Opaque
(CJ Auto Tab © Rectangle
{J Fixed Line Height © Shadow
(J Don’t Wrap © Scrolling
(J Don’t Search
(J Shared Text

(ok) (Cancer _)
 

   

Figure 5-10 Checkinga field’s number

If you have both card fields and background fields on the card,
pressing Tab takes you from one field to the next, according to
the following sequence:
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Figure 5-11 Tabbing through background fields and card fields

For an explanation of how fields get numbered, or ifyou want
to change the order in which the Tab key moves the cursor from
field to field, see “Reordering Fields,” later in this chapter.

If the Auto Tab option is selected in the Field Info dialog box,

you can press Return (instead ofTab) when the insertion point
is in the last line of the field to go the next field.

To select the Auto Tab option for a field, follow these steps:

1. Choose the Field tool (&) from the Tools menu.

2. Double-click the field.

3. Click Auto Tab to select it.

4. Click OK.

oe Note: Auto Tab doesn’t work for a scrolling field. +
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Undoing your typing To undo typing mistakes while you’re editing field text, you can

do any of the following:

a Erase text to the left of the insertion point, one character at a

time, by pressing Delete or Backspace.

= Drag to select the incorrect text and retype it, or press Delete
or Backspace to erase it.

= Choose Undo from the Edit menu, or press 3-Z. Undo
undoes your last text editing (or stack editing) operation.

Choosing the look You can determine the look of field text in two different ways:

of field text
= You can set the default text format—including the font, size,

style, alignment, and line spacing—for the field as a whole.

= You can set the font, style, and size for individual characters,

words, or phrases in the field.

The default text format options you choose for the field apply to
the whole field. All text you type in the field has these attributes
unless you style it individually.

Setting the font, style, and alignment of a field

To choose the default text format for a field, follow these steps:

1. Choose the Field tool (3) from the Tools menu.

2. Select the field by clicking it.

3. Choose Field Info from the Objects menu.

Or double-click the field. The Field Info dialog box appears.
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4. Click Font.

The Text Style dialog box appears.

« Another method: Alternatively, you can open the Text Style
dialog box by clicking to select the field (with either the Field
tool or the Browse tool), then choosing Text Style from the
Edit menu (or pressing 3-T). +

5. Choose from the options in the Text Style dialog box to set
the default text format for the field:

Click to select the font you want.

 

 

 

   

 

 

 

  
   

  

  

(Or double-click to select the font Click to select a font size
and return to your work quickly.) (measured in points).

Click to select or deselect
one or more text styles. Field Text Style Defaults: This number

(Select nothing for plain id a Geneva a] =) determines the
text.) The sample text in the a a . Helvetica 28 space between

lower-right corner of this (] Underline scan nil 74 lines, HyperCard
dialog box shows the effect C) Outline Ivy League 18 sets this number

of the selected style(s). | e sewn» Lee 20 automatically
FP titeas London 24 |] Line when you select a

(Group McCloud +] height: font size, but you
See “Grouping Text,” later PJ | hal cam |__ can change it.

in this chapter, for an sige Neal ¥ark
explanation of this style. © Center Oblige To use a font

LO Right Palatino Sample size not listed,

type it here.

The alignment you select applies This shows what your
to all the lines in a field. text will look like.

Figure 5-12 Setting the default text format for a field

6. When you're finished, click OK.

The text in the field appears in the new default format, and
any new text you type in the field acquires the same format.

bhwit Ov
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Ifyou set one font size for a field and change it to a larger size

later, the tops of the characters may disappear. You can fix this
by turning off the Fixed Line Height option in the Field Info
dialog box. This allows the line height of the field to vary to
accommodate the size of your text.

Here's a shortcut for setting just the font, size, and style fora
field:

1. Choose the Field tool (&) from the Tools menu.

2. Click the field to select it.

3. Choose from the Font and Style menus to set the default
font, style, and size for the field.

These choices are reflected in the Text Style dialog box for the
field.

* Preset size and style: The preset size and style for new
HyperCard fields is 12-point plain Geneva. +

Setting the font and style for individual pieces of text

You can change the font, style, and size for individual characters
in a field, overriding the field’s default settings for those
characters. Here’s how:

1. Choose the Browse tool (*) from the Tools menu.

2. Drag with the I-beam pointer (J) to select the text you want
to change.

Ifyou don’t see the I-beam pointer, consult the section
“Where’s the I-beam Pointer,” earlier in this chapter.
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3. Choose from the Font and Style menus to set the font,
style, and size of the selected text.

 

 

 

 

 
 

   

Future “Plain —

Garamond Bold
CI font Gavarnie rite
choose a font. —_L nderline
A check mark . a Ontline os one -remote

appears next to | GaramondLight! talic Shadow sar A oe mark

the selected font. ImageWriter Condense si tees — =
Ivy League Extend selected styles. Choose

LED Group _| Plain to remove all

London _ other styles.

McCloud 9

MerrionSquare 10 Choose a point

Monaco 12 size for the text.

New York 14 The best sizes for

Oblige “18 the selected font

Palatino at} : appear in outline.

hi dahon Other... —}— Choose Other to

select a point size

not shown.   

Figure 5-13 Setting the font, style, and size of the selected text

Alternatively, you can choose Text Style from the Edit menu,
or press $-T’, and set the style of the selected text through the
Text Style dialog box.
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You can use the following -key shortcuts while you’re working
with individual pieces of field text:

To do this... Press

Select all the text in the field 98-Shift-A
Bold the selected text 3€-Shift-B
Condense the selected text 3-Shift-C
Restore the selected text to the field’s
default text format #-Shift-D
Extend the selected text 98-Shift-X
Change the selected text to the next
font (alphabetically) 9¢-Shift-F
Group the selected text $¢-Shift-G
Italicize the selected text 3€-Shift-I
Outline the selected text 38-Shift-O
Underline the selected text 3-Shift-U
Make the selected text a smaller font size 98-Shift-<
Make the selected text a larger font size 38-Shift->
Decrease the field’s line height 38-Shift- — (minus)
Increase the field’s line height 3¢-Shift- + (plus)

Z\ Important: Ifyou set varying text sizes within a field, make sure
the Fixed Line Height option is turned off in the Field Info
dialog box. This allows the line height of the field to vary to
accommodate the different sizes of text. When you click Fixed
Line Height to deselect it, the Show Lines option in the Field
Info dialog box automatically turns off (if it’s turned on).

256 Chapter 5: Working With Text and Fields



Making field text
appear on
every card

Restoring text to the default format

After you've formatted individual pieces of text in a field (as

described in the previous section, “Setting the Font and Style for
Individual Pieces ofText”), you can restore the text to the
default text format for the field (as set in the Text Style dialog
box). Follow these steps:

1. Choose the Browse tool (») from the Tools menu.

2. Drag with the I-beam pointer (1) to select the text you want
to change.

Ifyou don’t see the I-beam pointer, consult the section
“Where’s the I-beam Pointer,” earlier in this chapter.

3. Press 3-Shift-D.

The selected text is restored to the default font, style, and size

that are set for the field.

You can create a background field that displays the same text on
every card by using the Shared Text option in the Field Info
dialog box. (This option appears only in the Field Info dialog
box for background fields.) This allows you to create an editable
text label that appears on every card in the background. Because

it can be edited so easily, a field text label is easier to manage
than a Paint
text label.

To get the same field text to appear on every card, follow these

steps:

1. Create a background field.

See “Creating a Field,” earlier in this chapter, for instructions.

2. Choose the Field tool (&) from the Tools menu.
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3. Double-click the field.

The Field Info dialog box appears.

. Click the Shared Text check box to select it.

. Click OK.

. Choose the Browse tool (*) from the Tools menu.

N

DO

WW

és

. Go to the background layer (ifyou’re not already there) by
pressing 3-B.

8. Click in the field and type the text you want to display on
every card.

9. When you're finished, choose Background from the Edit
menu, or press $-B, to return to the card layer.

When the Shared Text option is turned on fora field, you can
enter or edit text in the field only while you're in the
background layer. If you’re in the card layer, you won't see the I
beam pointer when you move the Browse tool overa field for
which the Shared Text option is turned on.

Ifyou turn off Shared Text, the text you've entered in the
background layer disappears from view, and you can edit the
field only from the card layer.

You can think of background fields as having (potentially) two
different layers of text, which appear and disappear as you
change the Shared Text setting:

= When you turn on Shared Text, any text you’ve entered in
the background layer appears, and text you've entered in the
card layer disappears.

a When you turn off Shared Text, any text you've entered in
the background layer disappears, and text you’ve entered in
the card layer appears.
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Locating fields

« Note: If the Shared Text option is turned on fora field, the

Don’t Search option is turned on automatically. This means

that HyperCard won't search in the field when you ask it to
look for specific text. +

Many of the fields in stacks are easy to locate right away—but some

are harder to find. You can use either of the following methods to

locate all the fields on the current card and background:

= Choose the Field tool from the Tools menu. Lines appear in all

the fields (except scrolling fields, which havea visible scroll bar):

When you choose __... lines appear

the Field tool. . . in the fields.
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Figure 5-14 Locating fields with the Field tool
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a While the Browse tool is selected, you can “peek” at both the
buttons and fields by pressing and holding the 3, Shift, and
Option keys. (Gray rectangles appear around the buttons and
fields.) Then, while you’re still holding down the $ and
Option keys, release the Shift key—the dotted rectangles
around the fields disappear. Pressing and releasing the Shift
key repeatedly (while holding down the 8 and Option keys)
makes the field rectangles appear and disappear.

Dotted rectangles outline the
fields in the card layer.

 

|__ Thick gray

rectangles outline
the fields in the

background layer.

  

 Callection Catalog Weer Varmpi packet i
 

 

i Composition:
‘Color:

 

 
 

      

 

 

'Dates from: 886-1890
‘Dimensions: 2 3 18
Weight: 3.1bs.
 

Figure 5-15 Peeking at fields

Changing Once you've created or copied a field, you can change its
the appearance appearance by resizing it, changing its style, adding margins, or

f A field displaying lines in it. This section explains how to make a field
O look the way you want it to.

« Note: You can change the appearance of both card fields and
background fields while you’re in the card layer. You don't
have to be in the background layer to modify background
fields. +

Y See also: “Choosing the Look of Field Text” in this chapter
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Changing the size of a field You can change the size of a field whether or not it has text in it.
When you changea field’s size, any text in it wraps appropriately
to conform to the new size.

To resize a field, follow these steps:

1. Choose the Field tool () from the Tools menu.

2. Click the field you want to resize to select it.

A moving dashed line surrounds the selected field.

3. Drag from any corner of the field:

 

  
ae vob. __ Drag from any corner

region to resize the field.
 

Figure 5-16 Changinga field’s size

To resize the field in one dimension only—either horizontally
or vertically—hold down the Shift key while you drag from
a corner.

If you shrink a non-scrolling field so that there’s not enough
room for all the text, the text at the bottom of the field
disappears from view. However, the text is still there—ifyou
enlarge the field, the text becomes visible again.

A Important: After you've resized a background field, you should
look through any cards affected by the field change to see how
the text looks. A
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Choosinga field’s style A field can have any one of five styles: transparent, opaque,
rectangle, shadow, or scrolling. (The style of a field has no bearing
on the style of its text.) Examples of the five field styles are shown
in the following figure, along with the names of the styles:

 

The background shows through
transparent fields.

 

 

 

 

The scroll bar becomes gray

when the text runs off the

bottom of the field.

 

 

   

  

 

 

 

 

  

Figure 5-17 The field styles

To set the style for a field, follow these steps:

1. Choose the Field tool (&) from the Tools menu.

2. Click the field to select it.

3. Choose Field Info from the Objects menu.

Or just double-click the field. The Field Info dialog box
appears.

4, Choosea style for the field:
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Makes the field transparent,

with no visible border.

 

 

Field name: ard

Bkgnd field number: 1

Bkgnd field ID: 7 | _ Makes the field opaque (white),

 

 

 

shew Lines style: without a visible border.

Hs — hele pa ale Makes the field opaque (white),

(] Auto Tab © Rectangle with a thin black border.
CJ Auto Line Height © Shadow
[1] Don’t Search © Scrolling Makes the field opaque (white),
C] Shared Text with a shadow along the right

side and bottom.
 

| Script... | { OK ] [ Cancel ]
 

   

Makes the field opaque, with a

border anda scroll bar along
the right side.

Figure 5-18 Choosing a field style

5. Click OK.

« About scrolling: Choosing the Scrolling option addsa vertical
scroll bar to the selected field. You view text in a field with a

scroll bar the same way you view text in any scrollable
Macintosh window. (For details about scrolling in windows,
see the documentation that came with your Macintosh.) +

You can use this procedure to change any field’s style, even after
youve typed text into the field.

Adding margins Adding margins to a field makes the text easier to read. When
you add margins toa field, you get extra space on the right and
left sides of the text in the field. (As a result, text takes up more
vertical space.)
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To add margins to a field, follow these steps:

1. Choose the Field tool (&) from the Tools menu.

2. Click the field to select it.

3. Choose Field Info from the Objects menu.

Or just double-click the field. The Field Info dialog box appears.

4, Click the Wide Margins check box to select it:

 

Bkgnd field number: 5

Bkgnd field ID: 8

(J Lock Text Style:
CO Show Lines @ Transparent

Click here to add i—[x] Wide Margins © Opaque

margins. Click | [) Auto Tab © Rectangle
again to remove EJ Fixed Line Height © Shadow

(1 Don’t Wrap © Scrolling
the margins. Fidon't Seerch

CJ Shared Text

(Script...}Script... { OK ] [ Cancel |
 

   
 

Figure 5-19 Adding margins toa field

 
 

5. Click OK.

Wide Margins is Wide Margins is

selected in the not selected in the
Field Info dialog Field Info dialog
box for this field. box for this field.

    
 

Figure 5-20 Shadow fields with and without margins
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Displaying lines in a field

4 (CJ Lock Text «4 Style:
Click here to See 4 _F] Show Lines @ Transparent

the lines in a field. —X] Wide Margins © Opaque

Click again to hide C futo Tab © Rectangle
the lines [1] Fixed Line Height © Shadow

: (J Don't Wrap © Scrolling

You can display lines in a field. This is useful for making a

transparent field visible so you can see where to type in it.

To display lines in a field, follow these steps:

1. Choose the Field tool () from the Tools menu.

2. Click the field to select it.

3. Choose Field Info from the Objects menu.

Or just double-click the field. The Field Info dialog box
appears.

 

Bkgnd field number: 5

Bkgnd field 1D: 8

(Don’t Search
(] Shared Text

[ Script... | lf OK | [ Cancel ]
 

 

   

4. Click the Show Lines check box to select it:

Figure 5-21 Displaying lines in a field
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5. Click OK.

 

 

 

 

Show Lines is Show Lines is not
selected in the selected in the
Field Info dialog Field Info dialog
box for this field. box for this field.

 

 

     

Figure 5-22 Rectangle fields with and without lines

« Note: You can’t display lines in a scrolling field. +

Naming a field Each field can have a name associated with it. You use field
names mostly for referring to fields through scripts or the
Message box.

A field name can have any number of characters in it, and you
can use any character in a field’s name.

Follow these steps to namea field:

1. Choose the Field tool (3) from the Tools menu.

2. Click the field you want to name to select it.

3. Choose Field Info from the Objects menu.

Or double-click the field. The Field Info dialog box appears.
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4. Type a name for the field:

 

Bkgnd field number: 1 name here.

Bkgnd field 1D: 7

C Show Lines Style:
—] Wide Margins @ Transparent
(4 Lock Text © Opaque
(] Auto Tab © Rectangle
(] Auto Line Height © Shadow
CJ Don’t Search © Scrolling
(C] Shared Text

[ Script... | { OK ] [ Cancel ]
 

 

   

Figure 5-23 Naming a field

5. Click OK.

+ Script writers take note: Ifyou change the name ofa field, be

sure to change its name everywhere you refer to it in a script,
too. For example, ifyou rename a field “Wrigley” and you use

the old name “Chester” in a script, the script won't work
properly—it won't be able to find the field it needs. +
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Moving a field You can place a field wherever you like on the card or background.
around on a card To reposition a field on the card or background, follow these steps:

or background 1. Choose the Field tool (&) from the Tools menu.

2. Click the field you want to move to select it.

Whether the field is in the card layer or the background layer,
you can select it from the card layer.

A moving dashed line surrounds the selected field.

3. Drag from the middle of the field, or from one of its edges
(not a corner).

 

Drag from the
mle ee middle region to

move the field.

 

   

Figure 5-24 Repositioning a field on the card

To constrain the field’s movement to horizontal or vertical
directions only, hold down the Shift key while you drag from
the middle of the field.

4. Click anywhere outside the field to deselect it.

Or choose the Browse tool.

You can select and move only one field at a time.

‘\ Important: After you reposition a background field, it’s a good
idea to look through the cards on which the field appears, to see

how the cards look. A
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When elements
overlap

HyperCard puts different kinds of elements in different layers,

as shown in the following figure. Together, all these layers make

up the card you see.

Background picture

Background  

  

Band pictute Card buttons

and fields

What you see

when you look
at the card

   

The background picture }\\is fixed in a layer by ae sae oy we -
itself—it’s always Ain EduOe ei | veSia
behind the background ot a \o. [ =
buttons and fields and The ard picture is also |LE,i. if;_—
all the card elements. D oaks my tee

fixed in a layer by

itself—it’s always Sal
behind the card buttons

and fields, and in front
of all the background

elements.

Figure 5-25 HyperCard’s layers

As shown in Figure 5-25, background buttons and fields go in a

different layer from the card buttons and fields. Within each of
these layers, HyperCard places each new button or field you add

(whether you've created it or copied it) in front of the element

added before it. (Jn front of means “closer to you.”)

Chapter 5: Working With Text and Fields 209



HyperCard also assigns numbers to the buttons and fields as you
add them. The first field you add is field number 1, the second is
field number 2, and so on. Likewise, the first button you add is
button number 1, the second is button number 2, and so on. The
numbers reflect how far away the elements are from you—the
farther away an element is, the lower its number. (These numbers
appear in the Button Info and Field Info dialog boxes.)

Although HyperCard numbers the buttons and fields separately,
it places each new element immediately in front of the previous
element (within the same layer), whether it’s a button or field.

This was added first.

This was added second,
 

 

  

  

Field 1Merrit re ree This was added third.

This was added fourth,

Field 2

 

 

    
  

This was added fifth.

This was added sixth.   
Figure 5-26 Background button and field layers and numbers

HyperCard numbers the card buttons and fields separately from
the background buttons and fields. The card elements are always
in front ofall the background elements (as shown in Figure 5-25).
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Reordering fields

This layering of buttons and fields becomes evident when the

elements overlap. Elements that are closer to you can obscure

elements that are farther away. If this happens, you can either
move the elements apart so they don’t overlap, or you can try
either of the following:

= Reorder the fields and buttons. (You can move any field or
button closer or farther, within its layer).

s Make some of the elements transparent, so you can see other
elements through them. (Buttons, fields, and graphics can all

be made transparent or opaque.)

The following sections describe these solutions.

Overlapping fields and buttons can cause visual and functional
problems in your stack. For example, you can’t edit the text in a

field that’s covered by a button (or another field). To solve the

problem of overlapping fields and buttons, you can reorder them
to bring the ones you need to see and use into full view.

Important: The fields and buttons in the card layer are always

in front of the background fields and buttons. Although you can

reorder the background fields and buttons relative to one

another, you can never move them closer to you than any of the

card elements. (You can, however, make card elements

transparent so you can see through them to the background
elements, as explained in the next section.) 4
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To movea field closer or farther (relative to the other fields and

buttons in the same layer) follow these steps:

1. Choose the Field tool () from the Tools menu.

2. Click the field you want to move closer or farther to select it.

A moving dashed line surrounds the selected field.

3. Choose Bring Closer from the Objects menu to move the
field forward one position, or choose Send Farther to move
it back one position.

Each time you movea field back one position relative to
another field in the same layer, its number (in the Field Info
dialog box) decreases by 1. Each time you movea field
forward one position relative to another field in the same

layer, its number increases by 1.

Note that a field’s number may not change every time you
use the Bring Closer or Send Farther commands to change its
position. For example, if a button lies between field 4 and
field 3, you'd have to move field 4 back two positions (with
the Send Farther command) before it would become field 3.

You can also move the selected field all the way to the front
or all the way back using these $-key shortcuts:

To do this... Press

Send the field to the back 38-Shift - — (minus)
Bring the field to the front 38-Shift - + (plus)
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Making a field opaque
or transparent

4. Repeat step 3 until the field is where you want it.

5. Choose the Browse tool (*) to deselect the field.

As you reorder fields, the numbers of all the affected fields change

to reflect their new positions. Each field’s number (shown in the

Field Info dialog box) reflects its front-to-back position, relative to

the other fields in the same layer. (The field that’s farthest away is

field number 1. The closer a field is to the front relative to the

other fields in the same layer, the higher its number.)

Tabbing order is affected: As the fields’ numbers change, so

does the tabbing order—that is, the order in which you move

through the fields when you press Tab—because the tabbing

order depends on the field’s numbers. (See “Moving From

One Field to Another,” earlier in this chapter, for more

information about the tabbing order.) +

The commands Bring Closer and Send Farther work the same

way ona selected button, as described in “Reordering Buttons”
in Chapter 4.

When you want to be able to see background or card elements

througha field that covers them, you can make the field
transparent. Conversely, when you want to give a field more

prominence, you can make it opaque.

Follow these steps to make a field opaque or transparent:

1. Choose the Field tool (&) from the Tools menu.

2. Click the field you want to change to select it.

3. Choose Field Info from the Objects menu.

Or double-click the field. The Field Info dialog box appears.
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4. Choose an appropriate field style to make the field opaque
or transparent:

 

Field Name: |WEETE ii

Bkgnd field number: 1

Bkgnd field ID: 1

 

(J Lock Text Style: ; ;[] Show Lines @ Transparent |_ Choosing this style makes

(J Wide Margins © Opaque the field transparent.
CJ Auto Tab © Rectangle
ClFixed Line Height © Shadow FE secu any of these styles

S eats peel © Scrolling makes the field opaque.
[7] Shared Tent (See Figure 5-17.)

(_Font..._] |

Script... | OK } Cancel
 

   

Figure 5-27 Making a field opaque or transparent

5. Click OK.

Copying da field You can duplicate a field on the same card, or copy it to another
card, background, or stack. When you copya field, you also copy
its attributes—its name, style, script, text format settings, and so

on. You can copya field either with or without its contents.

Copying afield Follow these steps to duplicate a field without its text on the
onthe same card same card:

1. Choose the Field tool (&) from the Tools menu.
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Copying a field
to another card or

background

25 Click the field you want to copy to select it.

You can select the field from the card layer, whether the field
is in the card layer or the background layer.

A moving dashed line surrounds the selected field.

. Press and hold the Option key while you drag the field.

As you drag, you create an exact duplicate of the field. If the
original is a background field, the duplicate is a background
field. If the original is a card field, the duplicate is a card
field. However, you can’t duplicate the field’s text using this
method. You have to use the procedure described in the next
section to copy the text along with the field.

To constrain the new field’s movement to horizontal or
vertical directions only, hold down the Shift key while you
drag from the middle of the field.

To copya field with or without its text to another card or
background, follow these steps:

1.

2.

fs

Choose the Field tool (&) from the Tools menu.

Click the field you want to copy to select it.

Choose Copy Field from the Edit menu, or press 3-C.

This makes a copy of the selected field (including its script)
and puts it on the Clipboard. (This field replaces the last
item you cut or copied; the Clipboard can only hold one
item at a time.)

. Go to the card or background where you want to put the
field.

Use the arrow keys or commands in the Go menu to navigate
between cards while the Field tool is selected.
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Ifyou’re not sure whether to put the field in the card layer or
the background layer, see “Adding a Field to a Card or
Background” near the beginning of this chapter.

5. If you want to paste both the field and the text that was
visible when you copied the field, press and hold the Shift
key and choose Paste Field from the Edit menu, or press
$8-Shift-V.

Otherwise, to copy just the field without its text, choose
Paste Field from the Edit menu, or press 3-V.

This takes a copy of the field that’s on the Clipboard, puts it
on the current card or background, and selects it. If you’ve
copied the field and its text from the card layer to the
background layer, you won't see the text until you return to
the card layer (at the end of this procedure).

Ifyou've copied a background field to the card layer of the
same card, the copy is pasted directly over the original. To see

the original, you have to drag the copy to move it.

6. While it’s still selected, drag the field to where you want it.

7. If you’ve copied the field and its text from the card layer to
the background layer and the text isn’t visible, choose
Background from the Edit menu, or press $-B, to return to
the card layer and see the text.

Important: The most common mistake in copyinga field is

putting it in the card layer when you want it in the background
layer. (To find out whethera field is in the background, press
3€-B to view just the background elements.) Ifyou put a field in
the card layer by mistake, see the next section, “Movinga Field
From the Card to the Background.”
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Movinga field
from the card

to the background

It’s easy to put a field in the card layer by mistake when you
intend to put it in the background. If this happens, you can

move the field from the card layer to the background layer (of
the same card) by following these steps:

1. Choose the Field tool (&) from the Tools menu.

2. Click the field you want to move to select it.

A moving dashed line surrounds the selected field.

3. Choose Cut Field from the Edit menu, or press $#-X.

This removes the field from the card and puts it on
the Clipboard.

4. Go to the background layer.

Choose Background from the Edit menu, or press 38-B.

5. Ifyou want to move the field and its text, press and hold
the Shift Key and choose Paste Field from the Edit menu,

or press $-Shift-V.

Otherwise, to move just the field without its text, choose

Paste Field from the Edit menu, or press $#-V.

This takes a copy of the field that’s on the Clipboard, puts it
in the current background, and selects it. The pasted field
appears at the same position from which it was cut. Ifyou’ve

pasted the text along with the field, you won't be able to see

the text until you return to the card layer (at the end of this
procedure).

6. While it’s still selected, drag the field to where you want it.

Since you can’t see the elements in the card layer while you're

working in the background, you might not be able to tell
whether you're putting the field in the right place. If this

happens, you can press $-B again to go back to the card layer,

then select and drag the field from the card layer.
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7. If you’ve pasted the text along with the field, choose
Background from the Edit menu, or press 3-B, to return to
the card layer and see the text.

Moving d field frOM Follow these steps to movea field from the background layer to
the background the card layer of the same card:

to the card 1. Choose the Field tool (&) from the Tools menu.

2. Click the field you want to move to select it.

A moving dashed line surrounds the selected field.

3. Choose Cut Field from the Edit menu, or press 3-X.

A dialog box like this appears:

 

Delete this field and its text trom
all 2 cards of this background? ; ": Click Delete to confirm that

Delete { Cancel } you want to cut the field.

 

 

   

Figure 5-28 — Confirmation dialog box for cutting a background field

Click Delete in the dialog box to remove the field from the
background and put it on the Clipboard.

4. Ifyou're in the background layer, go to the card layer by
pressing 3-B.

Ifyou’re already in the card layer, skip this step.
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5. Ifyou want to move the field and its text, press and hold
the Shift Key and choose Paste Field from the Edit menu,

or press 38-Shift-V.

Otherwise, to move just the field without its text, choose

Paste Field from the Edit menu, or press 3#-V.

This takes a copy of the field that’s on the Clipboard, puts it
on the current card, and selects it. The pasted field appears at

the same position from which it was cut.

6. While it’s still selected, drag the field to where you want it.

Moving a field You can move a field to another card in the same stack, or to a

to another card or card in another stack. When you movea field, its attributes—its

b k d style, name, scripts, and so on—move with it. You can move a

ACKZTOUNC geld either with or without its text.

Follow these steps to movea field to another card or background:

1. Choose the Field tool (&) from the Tools menu.

2. Click the field you want to move to select it.

A moving dashed line surrounds the selected field.

3. Choose Cut Field from the Edit menu, or press $#-X.

If the field is a background field, a dialog box like this appears:

 

Delete this field and its text from
all 2 cards of this background? . ;

ad Click Delete to confirm that
a .

Delete | Cancel } you wantto cut the field.
 

 

  
 

Figure 5-29 Confirmation dialog box for cutting a background field
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6.

J

Click Delete to remove the selected field from the current
card and put it on the Clipboard.

- Go to the card or background where you want to put the
field.

Use the arrow keys or commands in the Go menu to navigate
between cards while the Field tool is selected.

Ifyou're not sure whether to put the field in the card layer or
the background layer, see “Adding a Field to a Card or
Background” near the beginning of this chapter.

. Ifyou want to move the field and its text, press and hold
the Shift Key and choose Paste Field from the Edit menu,
or press 3$-Shift-V.

Otherwise, to move just the field without its text, choose
Paste Field from the Edit menu, or press #-V.

This takes a copy of the field that’s on the Clipboard, puts it
on the current card or background, and selects it. The pasted
field appears at the same position from which it was cut. If
youve moved the field and its text from the card layer to the
background layer, you won't see the text until you return to
the card layer (at the end of this procedure).

While the field is still selected, drag it to where you want it.

Ifyou've moveda field and its text from the card layer to
the background layer and the text isn’t visible, choose
Background from the Edit menu, or press 3-B, to return to
the card layer and see the text.
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‘\ Important: The most common mistake in copyinga field is

putting it in the card layer when you want it in the background
layer. (To find out whethera field is in the background, press

38-B to view just the background elements.) If you puta field in
the card layer by mistake, see “Moving a Field From the Card to
the Background,” earlier in this chapter.

Locking and You can locka field to prevent content changes to its text.
unlocking 4 field Locking a field does not, however, prevent changes to the default

text format of the field.

To locka field, follow these steps:

1. Choose the Field tool (&) from the Tools menu.

2. Click the field to select it.

3. Choose Field Info from the Objects menu.

Or just double-click the field. The Field Info dialog box appears.

4. Click Lock Text to select it:

 

Field Name: |Gitetr ati
Bkgnd field number: 1

Bkgnd field 1D: 1

Click here to prevent | - | ack Text Style:
changes to the text in (C Show Lines @ Transparent

the field. Click Lock (] Wide Margins © Opaque

Text again to unlock [)futoTeb © Rectangle
He Hela Miaka th C)Fixed Line Height © Shadow

the held, ma ing € (C1) Don’t Wrap © Scrolling
text editable. (Don’t Search

(1 Shared Text

Cx}
   

Figure 5-30 Locking a field
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Grouping text

5. Click OK.

When the Browse tool passes over a locked field, it doesn’t
change to the I-beam pointer (J). This lets you know that you
can’t edit the field.

Ifyou want to unlocka field to allow text changes, click Lock
Text again in the Field Info dialog box to deselect it (as shown in
Figure 5-30).

Whena field is locked, each individual word of text in the field
has the potential to behave much like a button. By writing a

script, you can make something happen whena user clicks a

word in the field.

You can also make any group ofwords or characters in a field
respond in the same way toa single click in any part of that
group of text. What happens when you click text, whether or
not it’s grouped, depends on the scripts in the stack.

To group text so that it will respond as one unit to a click, first
make sure the field is unlocked (as described in the previous
section, “Locking and Unlocking a Field”). Then follow these

steps:

1. Choose the Browse tool (*) from the Tools menu.

2. Drag with the I-beam pointer (J) to select the text you want
to group.

Ifyou don’t see the I-beam pointer, consult the section
“Where’s the I-beam Pointer,” earlier in this chapter.

3. Choose Group from the Style menu, or press 3¢-Shift-G.

To make grouped text responsive to clicks, you must write a

script. (See the HyperTalk Reference stack for more
information.)
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Excluding d field The Find command (in the Go menu) allows you to search for
from text searches specific text in the fields of a stack. You can prevent HyperCard

from searching in any particular field during text searches.
Follow these steps:

1.

Ds

Choose the Field tool (*) from the Tools menu.

2. Click the field to select it.

3.

4. Click the Don’t Search check box to select it.

Choose Field Info from the Objects menu.

Clicking Don’t Search again deselects it.

Click OK.

If you want to turn off the Don’t Search option to allow
HyperCard to search in the field, simply deselect the option
(as explained in step 4).

Y} Seealo: ° “Excluding Card and Background Fields From Text
Searches” in Chapter 3

¢ “Excluding Background Fields From Text Searches” in
Chapter 3
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Deleting a field You can delete a field whether or not it has text in it. When you
delete a field, any text contained in the field is deleted too.

Follow these steps to delete a field:

1. Choose the Field tool () from the Tools menu.

2. Click the field you want to delete to select it.

3. Choose Clear Field from the Edit menu, or press Delete
or Backspace.

If the field is a background field, a dialog box like this appears:

 

Delete this field and its text from
all 2 cards of this background? : :i Click Delete to confirm that

[ Delete | [| Cancel ]] you want to delete the field.
 

 

 

   

Figure 5-31 Confirmation dialog box for deleting a background field

A Warning: Once you've deleted the field with the Clear Field
command (or with the Delete or Backspace key), the field and
all its text are gone for good—you can’t undo the deletion.
Deleting a background field also deletes all text in that field on
all cards sharing that background. «
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Chapter 6

 

WorkingWithGraphics

Ce! help communicate what a stack is for and how it
works. The graphics described in this chapter include lines,
shapes, patterns, pictures, and Paint text—any graphic element
that you create or manipulate with the Paint tools.

This chapter explains how to do the following:

= Create graphics yourself using the Paint tools.

= Copy graphics from another stack (or the same one).

« Import graphics from MacPaint® (or a MacPaint-compatible
application).

To do the tasks in this chapter, you must have your user level set

at least to Painting. (The section “User Levels and Options” in
Chapter 1 explains how to set your user level.)
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Adding graphics Each card can have its own unique graphics in the card layer in
toa card addition to background graphics it shares with other cards.

Whenever you add a graphic element toa stack, you need to
decide whether you want it in the card layer or the background
layer. To decide where to put the graphic, consider where you
want It to appear:

or background

If you want the graphic to appear on every card in the stack,
put it in the background layer. A background graphic appears
in the same location on all the cards that share the
background.

Ifyou want the graphic to appear on only one card, add it to
the card layer.

If you want the graphic to appear on some of the cards in the
stack (but not all of them), consider creating a different
background for those cards and putting the graphic in that
background only. (“Creating a New Background” in Chapter
3 explains how to add a background to a stack.)

To add a graphic to a background, you must be in the
background layer; to add a graphic to a card, you must be in the
card layer. To go to the background layer, press 3-B. When
you're in the background layer, stripes appear in the menu bar. If
you press 3-B repeatedly, you move back and forth between the
card layer and the background layer.

Y See also: + “The Card Layer Versus the Background Layer”
in Chapter 2

¢ “When Elements Overlap” in this chapter
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The tools To create and work with graphics, you use the Paint tools in the
for working Tools menu.

with graphics

 

 

 

|__ The Paint tools.
 

 

 

      

Figure 6-1 HyperCard’s tools

The functions of the Paint tools are described briefly in the
figure that follows. Detailed instructions for using these tools are

given in this chapter.
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The Selection tool
is for selecting

graphics.

The Brush paints

with the current
pattern.

The Spray tool is

for spritzing paint
onto the screen in
the current pattern.

The Bucket fills
enclosed areas and

solid black areas

with the current

pattern.

The Paint Text tool
is for typing text
that’s part of a

graphic.

 

   

 

   

 

   

 

   

 

 
O

 

Figure 6-2 What the tools are used for

 

The Lasso is for
selecting non-
rectangular
graphics.

The Eraser erases

the part of a

graphic you drag

it over.

The Rectangle tool
draws rectangles.

The Oval tool
draws ovals

and circles.

The Regular

Polygon tool
creates polygons
with equal sides.

 

   

 

   

 

   

 

   

 

   

The Pencil

draws thin,

free-form lines.

The Line tool
draws straight

lines.

The Rounded

Rectangle tool
draws rectangles

with rounded
corners.

The Curve tool
draws free-form
lines and shapes.

The Polygon tool
creates polygons
with unequal

sides.

To make it easy to alternate between the tools, you can “tear off”
the Tools menu to create a movable Tools palette. To do this,
drag down through the menu past the bottom or beyond either
side. (For an illustration of this, see Figure 2-12.) While you
have the Tools palette open, you can select a tool just by clicking
it on the palette. This makes it easy to switch back and forth
between different Paint tools.
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When you choose one of the Paint tools, three new menus appear:

Paint, Options, and Patterns. (The Objects, Font, and Style menus
disappear temporarily while you’re working with the Paint tools.)

These three menus appear when you
have one of the Paint tools selected.

 

@ File Edit Go Tools Paint Options Patterns
 

 

 

Collection Catalog
 

 

 

Object:

Composition:
Color:
Dates from:
Dimensions:
Weight:

Other Information:
Excellent condition 1/25/9:

  

 

 

 

 

 

 

 

 

Purchase Price: 4!

Current Value: 65¢
Date Purchased: 5/13/78

  
 

 

 

  

Place Purchased: Tempe, Arizona
 

 

Purchase receipt location: Under “Investments”  
    

 

 

     
 

 Selected Paint tool

Figure 6-3 Menus that accompany the Paint tools

The Paint and Options menus contain commands for creating
and manipulating graphics. These commands are described
throughout this chapter.
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The Patterns menu contains patterns you can use to fill shapes and
draw borders. For easy access to the patterns, you can tear off the
Patterns menu the same way you tear off the Tools menu—drag
down through the menu past the bottom or beyond either side.

 

You can close the

Patterns palette
by clicking here.

Options BiapaGigne   

 

To move the

palette, drag

from here.
 

  

 
 

 

 
 

 

  
 

 

  

To tear off the Patterns menu, Click any pattern
drag beyond the bottom or to select it.

side of the menu.

Figure 6-4 Tearing off the Patterns menu

« A shortcut: Whenever you have a Paint tool selected, you can

make the Patterns palette appear and disappear quickly by
pressing Tab or double-clicking the Bucket on the Tools
palette. +

Chapter 6: Working With Graphics



Selecting a graphic

The Patterns palette works like the Tools palette—to select a

pattern, just click it. “Creating Your Own Patterns,” later in this

chapter, explains how you can add your own patterns to this palette.

} Seealso: * “Using HyperCard’s Tools” in Chapter 2

¢ “Using Power Keys” in this chapter

¢ “Using Modifier Keys With Paint Tools” in this chapter

* “Double-Clicking Paint Tools” in this chapter

Before you can modify, move, or copy a graphic, you must first

select it. There are many different ways to select a graphic. The

method you use depends on the shape and size of the particular

graphic element(s) you want to select. This section explains all

the methods for selecting graphics.

To select a graphic, you must be working in the same layer as the

graphic. If the graphic is in the background layer, you can only

select it from the background layer. If it’s in the card layer, you

can only select it from the card layer. Ifyou try to select a

graphic and it doesn’t become selected, chances are the graphic is

in the background layer and you’re working in the card layer.

(It’s also possible that the element you're trying to select is

actually a button or field. Chapters 4 and 5 explain how to select

buttons and fields.)
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Once you've selected a graphic, it stays selected until you choose
a tool or click outside the selection.

* Icons are selected differently than graphics: Remember that an
icon is part of a button—to select an icon, you have to select
the button that displays it. If you’re not sure whether a

particular element is an icon ora graphic, choose the Button
tool (©) from the Tools menu, click the element, and drag it.
If a moving dashed line appears around the element and you
can move it by dragging, it’s an icon. Chapter 4 gives
instructions for working with buttons and icons. +

Selecting a rectangular area To select a rectangular graphic element or a rectangular area of a

292

picture, follow these steps:

1. Go to the card or background that contains the graphic
element or the area you want to select.

Pressing 38-B takes you to the background layer. (When
you're in the background layer, stripes appear in the menu
bar.) Ifyou press 3¢-B repeatedly, you move back and forth
between the card layer and the background layer. If you don’t
see the graphic you want while you're in the background
layer, the graphic is in the card layer.

. Choose the Selection tool (3) from the Tools menu.

Or click it on the Tools palette. The pointer changes to a

crosshair (-+).

- Move the crosshair pointer to one corner of the area you
want to select.
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4, Drag diagonally to the opposite corner of the area.

A moving dashed line surrounds the selected area.

+ Fora tighter selection: To eliminate extra white space from
the selection, press the # key while you drag; when you
release the mouse button, the moving dashed line snaps in
to select the smallest rectangular area surrounding the
graphic. +

Press and hold the —_
3 key and drag

diagonally with
the Selection tool

from here...
  

... to here. The moving dashed line
snaps around the graphic

to eliminate extra white
space from the selection.

Figure 6-5 Eliminating extra white space in a rectangular selection

Ifyou select too much or not enough, you can deselect the
graphic by clicking on the card outside the selection, then select

the graphic again.
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Selecting a

nonrectangular area
To select a nonrectangular graphic element or a nonrectangular
area of a picture, follow these steps:

1. Go to the card or background that contains the graphic
element or the area you want to select.

Pressing 38-B takes you to the background layer. (When
you're in the background layer, stripes appear in the menu
bar.) Ifyou press 3-B repeatedly, you move back and forth
between the card layer and the background layer. If you don’t
see the graphic you want while you're in the background
layer, the graphic is in the card layer.

. Choose the Lasso (©) from the Tools menu.

Or click it on the Tools palette. The pointer turns into a

lasso.

. Drag around the graphic you want to select:

The tip of the line
trailing out of the
Lasso determines
what you select.

 

Figure 6-6 Selecting a nonrectangular area
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You don’t need to drag completely around the graphic;
HyperCard will complete the selection by drawinga straight
line between the point where you start dragging and the
point where you stop. (But if you stop too soon, you might
miss part of the graphic you want to select.)

When you release the mouse button, the edges of the selected

graphic shimmer. If there was any white space surrounding
the graphic, it’s eliminated from the selection:

The edges of the

selected graphic
shimmer.

 

Figure 6-7 Only the lassoed graphic is selected

o* Ifyou want to include the surrounding white space: To lasso a

graphic without eliminating the surrounding white space,

press the Option key while you drag with the lasso. This
selects exactly the area you drag around. +

Ifyou select too much or not enough, you can deselect the
graphic by clicking on the card outside the selection, then select

the graphic again.
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Selecting an individual There are several ways to select a single graphic element without
graphic element any of the white space that surrounds it—including the method

described in the preceding section, “Selecting a Nonrectangular
Area.” This section describes two additional methods.

Use the following technique when you want to select a specific
graphic element quickly and exclude the surrounding white
space, or if your hand isn’t steady enough to use the Lasso with
precision:

1. Go to the card or background that contains the graphic you
want to select.

Pressing 3-B takes you to the background layer. (When
youre in the background layer, stripes appear in the menu
bar.) If you press 3-B repeatedly, you move back and forth
between the card layer and the background layer. If you don’t
see the graphic you want while you're in the background
layer, the graphic is in the card layer.

2. Choose the Selection tool (3) from the Tools menu.

Or click it on the Tools palette. The pointer changes to a

crosshair (-).

3. Move the crosshair pointer to one corner of the graphic.

4. Press the Option key while you drag diagonally to the
opposite corner of the graphic.

Or choose Select from the Paint menu (or press $8-S) after
you drag to the opposite corner. This automatically chooses

the Lasso and selects the graphic.
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Press and hold the —_,
Option key and drag

diagonally with the

Selection tool
from here. . .

|
1

1

i
i
|

 

 ... to here. The selected graphic

shimmers.

Figure 6-8 — Selecting an individual graphic element

If you select too much or not enough, click on the card outside
the selection to deselect the graphic, then select it again.

You can use the following technique to select a graphic element
that has no breaks in it—that is, one that’s composed entirely of
connected black dots or surrounded by an unbroken line. This
technique is useful for selecting small, solid graphic elements.

1. Go to the card or background that contains the graphic you
want to select.

2. Choose the Lasso from the Tools menu.

3. Move the Lasso’s tip into the graphic.
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Selecting the graphic
you've just created

4. Press the 3 key while you click the graphic.

co
Select the graphic The edges of the
by 8-clicking it selected graphic
with tip of shimmer.
the Lasso.

Figure 6-9 — Selecting a solid graphic element

Immediately after you drawa single graphic element (and before
you click anywhere), you can select the element you’ve just
created by choosing Select from the Paint menu or pressing %-S.
The Select command selects only the graphic element you’ve
created since the last time you pressed the mouse button. (Ifyou
haven't just created a new graphic, the Select command selects
all the graphics in the layer in which you’re working.)

This technique is particularly useful if you’ve just drawn a shape
very close to or actually touching another shape, and you need
to move the new shape. You can even draw a new shape on top
ofan old one, choose Select, and then drag the new shape away
without changing the old shape.

You can also use the Select command to select an area you ve
just erased.

If the Power Keys option is turned on (and the Message box is
hidden), you can press S instead of choosing Select. (“Using
Power Keys,” later in this chapter, explains the Power Keys
option.)

Chapter 6: Working With Graphics



Selecting all the
graphic elements on a

card
or background

When you're in the

card layer and you
choose Select from
the Paint menu, all ”

the card graphics

become selected

(their edges

shimmer) .. .

  

When your card or background picture is made up of several

individual graphic elements, you might want to select them all
at once to make changes to them or to copy or move them. This
section explains how to select all the graphic elements in the
current layer, excluding the white space between them.

To select all the individual graphic elements on the card or
background, first make sure you're in the layer that contains the
graphics you want to select. Pressing $-B takes you to the
background layer. (When you're in the background layer, stripes

appear in the menu bar.) Ifyou press $-B repeatedly, you move

back and forth between the card layer and the background layer.

Ifyou don’t see the graphics you want while you're in the
background layer, they’re in the card layer.

Select all the graphic elements in the current card layer or
background layer by using one of these methods:

= Choose Select from the Paint menu, or press $#-S.

= Double-click the Lasso on the Tools palette.

= Ifthe Power Keys option is turned on (and the Message box
is hidden), press S. (“Using Power Keys,” later in this chapter,

explains the Power Keys option.)

 

Art Bits  clicka category:
 

 N

2a Beasts

FE) Buildings

GS Nature and science

4% Odds and ends
    

*\% communicationand media Fe People

eS HyperCard miscellany ei, Small treasures

‘ ae Icon ideas Se Transportation

 

=} Macintosh miscell

_— ... but the background
graphics don’t.

 
Stack Gverview Horne

 

Figure 6-10 — Selecting all the graphic elements in the current layer
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Selecting the When you want to copy, delete, or change the entire card
entire card picture picture or background picture (for example, by filling it with a

or background picture pattern), you can select the whole picture at once in one
rectangular selection the size of the card. This section explains
how to select the whole picture in the current layer, including all
the graphic elements and the white space between them.

To select an entire picture, first make sure youre in the layer that
contains the picture. Pressing 38-B takes you to the background
layer. (When you're in the background layer, stripes appear in
the menu bar.) Ifyou press 38-B repeatedly, you move back and
forth between the card layer and the background layer. Ifyou
don’t see the picture you want while you're in the background
layer, it’s in the card layer.

Select the entire picture by using one of these methods:

= Choose Select All from the Paint menu, or press $-A.

= Double-click the Selection tool on the Tools palette.

= Choose the Lasso from the Tools menu, then press the % key
while you click the card or background.

= Ifthe Power Keys option is turned on (and the Message box
is hidden), press A. (“Using Power Keys,” later in this
chapter, explains the Power Keys option.)

= Choose the Selection tool from the Tools menu and drag
diagonally from one corner of the card or background to the
Opposite corner.

A moving dashed line surrounds the selected card or background
picture. T’o deselect the picture, click anywhere on the card or
background, or choose a tool from the Tools menu.
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Copying graphics The easiest way to get great art into your stacks is to copy
that come with graphics that already exist. Copying graphics can simplify the

stack-building process. HyperCard comes with several stacks
HyperCard that contain graphics you can copy and paste into your stacks:

a The Art Bits stack is filled with all kinds of illustrations. The
first card in this stack lists categories of graphic images. To see

graphics in a particular category, click the category name.

a The Background Art stack contains graphics for stack
backgrounds.

a The Scanned Images stack contains graphics that have been

digitized using a scanner so they can be viewed on a Macintosh.

 

Figure 6-11 Some graphics from the Art Bits stack

When you see a graphic you like in one of these stacks, copy it
and paste it into your stack. Follow these steps:

1. Open one of the stacks that contains graphics—Arrt Bits,
Background Art, or Scanned Images.

2. Go to the card that has the graphic you want to copy.
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Undoing your
mistakes

3. Select the graphic you want.

For instructions on selecting a graphic, see “Selecting a

Graphic,” earlier in this chapter.

4. Choose Copy Picture from the Edit menu, or press 3-C.

This puts a copy of the selected graphic on the Clipboard.

5. Go to the card or background where you want to put the
graphic.

You can use the arrow keys or commands in the Go menu to
navigate between cards while you have the Selection tool or
Lasso selected.

Ifyou’re not sure whether to put the graphic in the card layer
or the background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chapter.

6. Choose Paste Picture from the Edit menu, or press 38-V.

This takes a copy of the graphic that’s on the Clipboard, puts
it on the current card or background, and selects it.

7. While the graphic is still selected, drag it to where you want
it on the card.

The graphic is opaque right after you paste it. If you want to be
able to see through the graphic to the elements behind it, select
it and choose Transparent from the Paint menu.

Y} See also: “Changing the Appearance of a Graphic” in this chapter

Ifyou make a mistake while you're working with the Paint tools
and commands, you can undo your last operation by choosing
Undo from the Edit menu (or pressing 3-Z, Esc, or Tilde) before
you do anything else.
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Painting with the
Brush, Bucket, and

Spray tool

Painting with the Brush

You can erase a mistake by choosing the Eraser from the Tools

menu and dragging over the graphic. You must be working in
the background layer to erase a background graphic and in the

card layer to erase a card graphic. To erase in a straight

horizontal or vertical line, press Shift while you drag.

} See also: »* “Reverting to the Last Version of a Graphic” in this

chapter
¢ “Saving the Graphics on a Card or Background” in

this chapter
¢ “Deleting a Graphic” in this chapter

Three of the tools in the Tools menu are analogous to everyday

painting implements. These tools work much like the

implements they represent:

= The Brush (4) works like a paint brush.

a The Spray tool (‘8) works like a can of spray paint.

a The Bucket (&) works like a bucket full of paint.

You can use these tools in conjunction with patterns in the

Patterns menu. This section explains how.

The Brush works like a paint brush—it leaves a swath of “paint”
in its path. You can use the Brush to paint an area with a

pattern. (HyperCard’s default pattern is black.)

Follow these steps to paint with the Brush:

1. Go to the card or background where you want the paint.

Ifyou’re not sure whether to put the paint in the card layer or

the background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chapter.
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2. Choose the Brush (4) from the Tools menu.

Or click it on the Tools palette. The pointer changes to the
current Brush shape (°).

3. Drag where you want to paint.

Paint (in the current pattern) appears where you drag. To
paint in a straight horizontal or vertical line, press and hold
the Shift key while you drag.

RD* To erase with the Brush: You can erase any existing paint in
the path of the Brush by pressing and holding the # key
while you drag. +

Ifyou want to paint with a different pattern, choose the pattern
you want from the Patterns menu (or click it on the Patterns

palette) before you drag with the Brush.

If you want to paint (or erase) with a different brush shape,

choose Brush Shape from the Options menu or double-click the
Brush on the Tools palette. The Brush Shape dialog box appears:

 

Click a brush shape to

m6e@-. |hlUKlCl!U select it. After you select a

brush shape, this dialog

box disappears. The

pointer changes to

brush shape you select.

8 ® = os I

   

 A box appears around the

selected brush shape.

Figure 6-12 The different brush shapes
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Brush shape

Painting with
the Spray tool

The different brush shapes create different effects when you
paint. The following figure shows some examples:

 

 

 

 

 |___ Effect

 

 

 

    

Figure 6-13 The different brush shapes create different effects

The Spray tool works like a can of spray paint—it “spritzes”
paint onto the screen in the selected pattern.

Follow these steps to paint with the Spray tool:

1. Go to the card or background where you want the paint.

Ifyou're not sure whether to put the paint in the card layer or
the background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chapter.

. Choose the Spray tool (@) from the Tools menu.

Or click it on the Tools palette. The pointer changes to the
Spray tool pointer (°*).

. Drag where you want to paint.

Spray paint, in the current pattern, appears where you drag.

The more you spray back and forth over the same area, the
more the pattern becomes apparent. (Some patterns don’t
show up until you’ve thoroughly covered an area.)
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Filling an area
with a pattern

To paint in a straight horizontal or vertical line, press and
hold the Shift key while you drag.

* To erase with the Spray tool: You can erase any existing
paint in the path of the Spray tool by pressing and holding
the # key while you drag. +

If you want to spray with a different pattern, choose the pattern¥ pray p Pp

you want from the Patterns menu, or click it on the Patterns
palette, before you drag with the Spray tool.

You can fill any area on a card or background with a pattern by
using either the Bucket (in the Tools menu) or the Fill
command (in the Paint menu). Before you fill an area, you can
choose the pattern you want to fill it with.

This section describes two different methods for filling an area.

The method you use depends on whether the area you want to
fill is completely enclosed.

oOo Filling shapes: If you know before creating a shape that you
want to fill it with a pattern, you can fill the shape
automatically as you draw it. For instructions, see “Drawing a

Shape Filled With a Pattern,” later in this chapter. +

Filling an enclosed area

When you want to fill an area that’s completely enclosed—that
is, completely surrounded by an outline—follow these steps:

1. Go to the card or background that contains the enclosed
area you want to fill.

If the outline enclosing the area is in the background layer, go
to the background layer. If it’s in the card layer, make sure
you're in the card layer. If the outline is composed ofseveral
different graphic elements, they must all be in one layer.
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Pressing 38-B takes you to the background layer. (When

youre in the background layer, stripes appear in the menu

bar.) Ifyou press 3-B repeatedly, you move back and forth
between the card layer and the background layer.

2. Choose the pattern you want from the Patterns menu.

Or click it on the Patterns palette.

3. Choose the Bucket (&) from the Tools menu.

Or click it on the Tools palette. The pointer changes to the

Bucket.

4. Move the Bucket pointer so that the tip of the stream pouring

from it is within the enclosed space you want to fill, then click:

This is the part of the Bucket

that dispenses paint.
 

Outline-etyle Paint text

Figure 6-14 — Positioning the Bucket pointer to fill an area

If there are any gaps in the outline that encloses the area you

want to fill, paint will spill out and fill the surrounding area,

too. If this happens, immediately choose Undo from the Edit
menu, or press $-Z, Tilde, or Esc. Then check carefully for gaps

in the outline before using the Bucket again.
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Enclosed area

 

   
     

Figure 6-15 Paint spills out of an unenclosed area

2,* To checkforgaps: You can magnify the graphic to check for
gaps in its outline by using the technique described in
“Magnifying a Graphic for Editing,” later in this chapter. +

Filling an unenclosed area

To fill an area that’s not completely enclosed by an outline or
other graphics, follow these steps:

1. Go to the card or background that contains the area you
want to fill.

Pressing $-B takes you to the background layer. (When
youre in the background layer, stripes appear in the menu
bar.) If you press $-B repeatedly, you move back and forth
between the card layer and the background layer.

2. Choose the pattern you want from the Patterns menu.

Or click it on the Patterns palette.

3. Select the graphic element or the area you want to fill.

Ifyou want to fill a specific graphic element, you can select it
with either the Selection tool or the Lasso, as explained in
“Selecting an Individual Graphic Element,” earlier in this
chapter. If you want to fill a blank area, select it with the
Selection tool, as explained in “Selecting a Rectangular Area,”
earlier in this chapter.

308 Chapter 6: Working With Graphics



Creating your
own patterns

4. Choose Fill from the Paint menu.

The selected area fills with the current pattern.

  
Select the graphic you want to fill. . . ...and choose Fill

from the Paint menu.

Figure 6-16 Using the Fill command

If the Power Keys option is turned on, you can press F instead of
choosing Fill. (“Using Power Keys,” later in this chapter,
explains the Power Keys option.)

You can change any pattern in the Patterns menu or replace it
with a pattern of your own creation. When you change or create

a pattern, the new pattern is saved with the stack you’re working
in. It appears in the Patterns menu every time that stack is

active.

To change or create a pattern, follow these steps:

1. Choose the pattern you want to change from the Patterns
menu.

Or click it on the Patterns palette.
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2. Choose Edit Pattern from the Options menu.

Or double-click the pattern you want to change on the
Patterns palette. The Edit Pattern dialog box appears.

3. Edit the pattern.

 

 

 

 

 

 

   

  

This is the editing _]
area. You can click to ;

draw and erase the sivntrenteseess

little squares that
make up the pattern. oe |
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 As you edit the pattern in the

editing area to the left, this While the Edit Pattern dialog box
shows you how the pattern is open, you can click any pattern

will look. on the Patterns palette to make it
appear in the dialog box.

Figure 6-17 Editing a pattern

4. Click OK to save the new pattern.

The new pattern takes the place of the one that was selected

in the Patterns menu.

Using a pattern that You can replace a pattern in the Patterns menu with a pattern
appears on the card _ that appears anywhere on the card. Follow these steps:

1. Choose the pattern you want to replace from the Patterns
menu.

Or click it on the Patterns palette.
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2. Choose Edit Pattern from the Options menu.

Or double-click the pattern you want to replace on the
Patterns palette. The Edit Pattern dialog box appears,

displaying the selected pattern.

3. Click on the card to select the pattern you want to add to
the palette.

The pattern you click replaces the pattern in the Edit Pattern

dialog box.

4. Click OK to save the pattern.

The new pattern replaces the one that’s selected in the
Patterns menu.
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If you click a pattern on

the card while the Edit
Pattern dialog box is open,

and then click OK in the

Edit Pattern dialog box... the pattern you've clicked
replaces the selected pattern
in the Patterns menu.

 

Figure 6-18 Replacing a pattern in the Patterns menu
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Drawing lines
and shapes

Drawinga line
or a free-form shape

The Tools menu includes tools for drawing lines and shapes—
including circles, ovals, rectangles, polygons, and free-form
shapes. This section explains how to create lines and shapes with
these tools.

 

 

 

 

 

 

 

 

 

    

ye |e -—1 — for drawingblA\~ et = lines and shapes.

QIO|O aie
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Figure 6-19 — Tools for drawing lines and shapes

} Seealo: + “Drawing Shapes With Patterns and Different Line Widths”
in this chapter

* “Creating Special Graphic Effects” in this chapter
* “Changing the Appearance ofa Graphic” in this chapter

To drawa straight line or a free-form line or shape, follow
these steps:

1. Go to the card or background where you want the line
or shape.

Ifyou're not sure whether to put it in the card layer or the
background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chapter.

2. If you want to drawa straight line, choose the Line tool (~)
from the Tools menu.

Or, to draw a free-form line or shape, choose the Curve tool (©)
from the Tools menu. The pointer changes to a crosshair (+).
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3. Drag where you want to draw the line or shape.

 

Figure 6-20 Lines and free-form shapes

If you’re using the Line tool, you can draw a straight line at a

15° angle from horizontal, or at an angle that’s a multiple of
15°, by pressing the Shift key while you drag. To change the
angle of a straight line while you’re drawing it, change the
direction of the mouse as you drag.

When you use the Line tool, you can drawa straight line from
its center point by first turning on the Draw Centered option.
To turn on Draw Centered, choose it from the Options menu.
When Draw Centered is turned on, a check mark appears next
to it in the menu. To turn off Draw Centered, choose it again.
(If the Power Keys option is turned on and the Message box is

hidden, you can also press C to turn Draw Centered on or off.
“Using Power Keys,” later in this chapter, explains the Power
Keys option.)

* Using the Pencil: The Pencil allows you to draw thin lines
and free-form shapes, too. For a discussion of the special
characteristics of the Pencil, see “Drawing in Inverse,” later
in this chapter. +
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Drawing circles, ovals, To drawa circle, oval, or rectangle, follow these steps:

and rectangles 1. Go to the card or background where you want the shape.

Ifyou're not sure whether to put it in the card layer or the
background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chapter.

2. Ifyou want to draw an oval or circle, choose the Oval tool
(©) from the Tools menu.

Or, to drawa rectangle or square, choose either the Rectangle
tool (C1) or the Rounded Rectangle tool (©) from the Tools
menu. (The Rounded Rectangle tool draws rectangles and
squares with rounded corners.)

The pointer changes to a crosshair (+).

3. Drag diagonally to draw the shape.

To drawa circle, oval or
rectangle, select the

appropriate tool, then =
drag diagonally from

one corner .

. to the

opposite
corner.

Figure 6-21 Drawing circles, ovals, and rectangles

To drawa perfect circle or square, press the Shift key while
you drag.
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Drawing a regular polygon

To move the shape around on the card while you're drawing

it, press 3 before you release the mouse button. This allows

you to drag the shape anywhere on the card. You can release

the 3 key to continue creating the shape, then press the %#

key again to move the shape. Once you've released the mouse

button, you have to select the shape before you can move it.
(“Selecting a Graphic,” earlier in this chapter, explains how.)

To draw a shape from the center outwards, first turn on the Draw

Centered option by choosing it from the Options menu. When

Draw Centered is turned on, a check mark appears next to it in the

menu. To turn off Draw Centered, choose it again. (If the Power

Keys option is turned on and the Message box is hidden, you can

also press C to turn Draw Centered on or off. “Using Power Keys,”

later in this chapter, explains the Power Keys option.)

To draw a regular polygon (one whose sides are all the same

length), follow these steps:

1. Go to the card or background where you want the polygon.

Ifyou’re not sure whether to put it in the card layer or the

background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chapter.

2. Choose the Regular Polygon tool (©) from the Tools menu.

The pointer changes to a crosshair (+).

3. Ifyou want to select the number of sides for your polygon,
choose Polygon Sides from the Options menu.

Or double-click the Regular Polygon tool on the Tools

palette. The Polygon Sides dialog box appears.
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This step and the next step are optional. If you don’t select

the number of sides before you draw the polygon, it will be

either a square (the default shape) or the last shape you
selected in the Polygon Sides dialog box.

4. Click the shape that corresponds to the polygon you want
to draw:

Click a shape to indicate how many sides you want the

polygon to have. (The shape you select will remain in
effect until you change it by selecting a different shape.)
After you click a shape, this dialog box disappears.

 

 

 

Cvenk <7 Op 2a wy, A box appears around
the selected shape.   

   

Figure 6-22 Choosing the number of sides for a polygon

5. Drag diagonally to draw the polygon.

The polygon is

drawn from the

center...

 

... outward.

Figure 6-23 Drawing a regular polygon
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Drawing an
irregular polygon

To move the polygon around on the card while you’re drawing
it, press 3 before you release the mouse button. This allows you
to drag the shape anywhere on the card. You can release the #%

key to continue creating the polygon, then press the $ key
again to move the shape. Once you've released the mouse

button, you need to select the shape before you can move it.
(“Selecting a Graphic,” earlier in this chapter, explains how.)

To rotate the polygon while you're drawing it, drag with a

circular motion. Ifyou press Shift while you drag with a

circular motion, the polygon rotates only in 15° increments,
which makes it easier to position at exactly the angle you want.

With the Regular Polygon tool, the shape is always drawn from
the center outwards, whether or not Draw Centered is checked

in the Options menu.

To draw a polygon whose sides aren't necessarily the same

length, follow these steps:

1. Go to the card or background where you want the polygon.

Ifyou’re not sure whether to put it in the card layer or the
background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chapter.

. Choose the Polygon tool (@) from the Tools menu.

The pointer changes to a crosshair (+).

. Click at the point where you want to begin the first side of
the polygon.

The Polygon tool works differently from the other
tools—you don’t hold down the mouse button to draw.
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4. Without holding down the mouse button, move the
crosshair pointer to draw one side of the polygon.

You can draw the side of the polygon at a 15° angle from
horizontal, or at an angle that’s a multiple of 15°, by pressing
the Shift key while you move the mouse. To change the angle
of the side while you're drawing it, change the direction of
the mouse as you drag.

5. When the side of the polygon is the length you want it,
click to fix it in place.

6. Repeat steps 4 and 5 for each additional side of the polygon.

7. To finish the shape, click on the starting point.

Alternatively, you can double-click or press 38-Z at any point
to stop drawing, whether or not the shape is complete.
(Pressing 3-Z also deletes the line that was drawn since you
last clicked.)

8. Draw this side
by moving the

pointer without
9. Click here to holding down the
finish the shape. , mouse button. 7. Click here. 6. Draw this side by

 

1. Click here moving the pointer
to start the without holding

shape. down the mouse  — button.

2. Draw this side by 5. Click here.

moving the pointer
without holding

down the mouse

button. 3. Click here.

 

 4. Draw this side by
moving the pointer
without holding down
the mouse button.

Figure 6-24 Drawing an irregular polygon
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Drawing in inverse You can use the Pencil to create free-form lines and shapes and

touch up graphics.

To draw with the Pencil, just choose it from the Tools menu and

drag where you want to draw. The Pencil draws in the opposite

color of the place where you begin to drag:

 

If you start dragging If you start dragging

on black, the Pencil on white, the Pencil

draws in white. draws in black.

Figure 6-25 Drawing in the opposite color

To drawa straight horizontal or vertical line with the Pencil,

press the Shift key while you drag.

The Pencil can only draw thin solid lines (black or white) and

shapes and pictures composed of thin solid lines. It can’t draw

thick lines, or shapes and lines that have patterns.
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Drawing shapes
with patterns and

different line widths

Drawing a shape
filled with a pattern

320

This section explains how to create lines and shapes that have

patterns, and lines and shape borders in varying line widths.
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Figure 6-26 The tools for drawing with patterns and different line widths

When you know before creating a shape that you'll want it filled
with a pattern, you can fill the shape automatically as you draw
it. Follow these steps:

1. Choose the pattern you want the shape to have from the
Patterns menu.

Or click it on the Patterns palette.

2. Choose Draw Filled from the Options menu to turn it on.

When Draw Filled is turned on, a check mark appears next to
it in the menu. (Choosing Draw Filled again turns it off.)

* A shortcut: You can also turn Draw Filled on or off by
double-clicking any of the shape tools on the Tools palette
(except the Regular Polygon tool). +
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The Tools menu looks different when Draw Filled is turned on:

 

  

  

|___ A pattern appears

inside the shape tools.
  

 

         

The Tools menu The Tools menu
when Draw Filled when Draw Filled
is turned off is turned on

Figure 6-27 The Tools menu with Draw Filled turned off and turned on

3. Draw the shape.

Choose the tool for the shape you want to draw from the
Tools menu, then drag to draw the shape. (See “Drawing
Lines and Shapes,” earlier in this chapter, if you want more
detailed instructions.)

When you finish drawing the shape, it automatically fills
with the selected pattern.

* Draw Filled with the Curve tool and Polygon tool: If Draw
Filled is turned on while you're using the Curve tool or the
Polygon tool, HyperCard draws a straight line connecting
your starting and ending points when you finish drawing;

othen it fills the shape with the selected pattern. +
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Drawing with
different line widths

HyperCard draws
this line.

 

—
Using the Curve tool Using the Curve tool
with Draw Filled with Draw Filled
turned off turned on

Figure 6-28 Creating a filled, curved shape

HyperCard draws
this line.

 

Using the Polygon —_Using the Polygon
tool with Draw tool with Draw
Filled turned off Filled turned on

Figure 6-29 Creating an enclosed, filled polygon

* Filled shapes without borders: To drawa filled, borderless
shape, turn on Draw Filled, then hold down the Option key

2while you draw the shape. +

Before you drawa line or shape, you can select the thickness of
the line or the shape’s border. Follow these steps:

1. Choose Line Size from the Options menu.

Or double-click the Line tool on the Tools palette. The Line
Size dialog box appears.
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2. To select a line thickness, click it:

 Click the line that represents

| | i j t the line width you want. After
you click a line width, this

dialog box disappears.   

hy box appears around the

selected line width.

Figure 6-30 Line widths

3. Draw the line or shape.

Choose the tool for the line or shape from the Tools menu,
then drag to draw the shape. (See “Drawing Lines and Shapes,”

earlier in this chapter, ifyou want more detailed instructions.)

* A shortcutfor selecting line widths: When the Power Keys

option is turned on (and the Message box is hidden), you can

type a number from | to 8 to select a line width while any
Paint tool is selected. (“Using Power Keys,” later in this
chapter, explains the Power Keys option.) #

1 Ds 3 4or5 6or7 8 ——Powerkeys

Note: These power keys don’t
work when the Line Size

dialog boxis open.

Figure 6-31 The power keys for choosing line widths
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Drawing lines and borders To drawa line that has a pattern, or a shape with a patterned
with patterns border, follow these steps:

1. Choose the pattern you want from the Patterns menu.

Or click it on the Patterns palette.

2. Choose the tool for the line or shape you want to draw.

The Line tool or any of the shape tools will work. (You can’t
drawa patterned line with the Pencil).

3. Press and hold the Option key while you draw the line
or shape.

See “Drawing Lines and Shapes,” earlier in this chapter, if
you want more detailed instructions.

 

WE

  

   

  

Figure 6-32 Lines and shape borders with patterns

* Filled shapes without borders: If the Draw Filled option is
turned on and you press the Option key while you draw a

shape, you createa filled, borderless shape. +
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Moving a graphic You can place a graphic wherever you like on a card or
around on a card background. To reposition a graphic on a card or background,

follow these steps:
or background

to move.

Pressing $-B takes you to the background layer. (When
you're in the background layer, stripes appear in the menu
bar.) If you press $8-B repeatedly, you move back and forth
between the card layer and the background layer.

. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives

instructions.

. Position the pointer over the selected graphic so that it
changes to the arrow pointer.

. Drag the selected graphic.

1. Go to the card or background that has the graphic you want

To move the graphic straight horizontally or vertically, press

and hold Shift while you drag.

» Can't drag the graphic? Ifyou think you’ve selected a

graphic but you can’t drag it, you might be trying to move

a background graphic from the card layer. Press #-B and

try again. Ifyou still can’t drag it, it’s either a button or a

field. (Chapters 4 and 5 explain how to move buttons and

fields.) *

Important: After you reposition a background graphic, it’s a

good idea to look through the cards on which the graphic

appears, to see how the cards look. “

Chapter 6: Working With Graphics



Creating special You can use the Paint tools in combination with one or more of
graphic effects the commands in the Options menu to create a variety of special

effects. This section shows examples of the effects you can create.

Drawing in multiples You can draw multiple lines or shapes using the Draw Multiple
option in the Options menu.
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Figure 6-33 The tools you can use with the Draw Multiple option

To draw multiple lines or shapes in a single stroke, follow
these steps:

1. Choose Draw Multiple from the Options menu to turn it on.

When Draw Multiple is turned on, a check mark appears

next to it in the Options menu. (Choosing Draw Multiple
again turns it off.)

2. Drawa line or shape.

Choose the tool for the line or shape you want from the
Tools menu, then drag to draw the shape. (See “Drawing
Lines and Shapes,” earlier in this chapter, if you want more
detailed instructions.)
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Draw Multiple
turned off

Draw Multiple
turned on

Draw Multiple
and Draw Centered

turned on

Rounded Regular

Rectangle Oval Polygon
Line tool Rectangle tool tool tool tool

 

  
 

 

Figure 6-34 Drawing shapes with and without Draw Multiple

To control the spacing between the multiple images, press the
Option key in combination with a number from1 to 9 before
you drag. The higher the number you type, the farther apart the
images will be.

 

 gy) 2 =n oO
 

   
         

 

  

Option-3 Option-5 — Option-7_— Option-9

Figure 6-35 Varying the spacing between images for the Draw Multiple option

If the Power Keys option is turned on (and the Message box is

hidden), you can press M to turn Draw Multiple on or off. (The
Power Keys option is explained in “Using Power Keys,” later in
this chapter.)
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Aligning graphics You can use HyperCard’s Grid option to help you line up

graphic elements and position them more precisely. To turn on

the Grid option, choose it from the Options menu. (When Grid
is turned on, a check mark appears next to it in the menu.

Choosing Grid again turns it off.)

When Grid is turned on, the movement of the pointer is

constrained to an invisible grid whose lines are 8 pixels apart

(just under one-eighth of an inch). As you draw graphics with
the Line tool and shape tools, or drag graphics to move them
around, they'll be aligned to this invisible grid. The grid also

constrains the movement of the Selection tool as you select

graphics and the movement of the I-beam as you try to position
the insertion point to type Paint text.

The Grid option is most helpful for aligning graphics that were

created with the Grid option turned on. Ifyou create graphics

with Grid turned off and then turn Grid on, HyperCard will
have a difficult time aligning the graphics because their sizes and

positions won't conform to the grid’s intervals.

 

 If the grid were visible, it
would look like this. The

graphics you create

while the Grid option is

turned on are aligned to

the grid.

 

 

 

 

 

 

 

 

 

 

 

                        

Figure 6-36 Aligning graphics with the grid
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Combining options
for unique effects
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Figure 6-37 The tools affected by the Grid option

You can use Grid in combination with other options in the

Options menu to create a variety of effects, as shown in the next

section, “Combining Options for Unique Effects.”

If the Power Keys option is turned on (and the Message box is

hidden), you can press G to turn Grid on or off. (“Using Power

Keys,” later in this chapter, explains the Power Keys option.)

You can create some interesting visual images when several

options in the Options menu are turned on at the same time.
And you can add to the variety by holding down various

modifier keys while you draw with different options turned on.

Experiment with different combinations to see what happens.
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Adding Paint text

 

Regular Polygon Oval tool, Shift key
tool, Draw Filled pressed, Grid turned
turned on, Draw on, Draw Centered

Multiple turned on turned on, Draw
Multiple turned on

Zz ff

Line tool, Shiftkey Rectangle tool, Grid

 

 

      
 

        
 

pressed, Draw turned on, Draw
Multiple turned on Centered turned on,

Draw Multiple
turned on

Figure 6-38 — Special effects

Oval tool, Grid turned

on, Draw Centered

turned on, Draw
Multiple turned on

ke
Line tool, Grid
turned on, Draw
Multiple turned on

Paint text is text you create with the Paint Text tool. It looks like
the text you type in fields, but you use the Paint tools to create,

move, copy, and change Paint text, just as you would with any

other graphic.
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Paint text is especially useful when you need to include text as

part of a picture—for example, as a picture title or labels—or
whenever you want text to behave more like a picture than text.
You can select both a picture and Paint text at once with the
same tool and use the same commands on them. And you can

create special effects with Paint text by using commands in the
Paint and Options menus (for example, Rotate, Slant, Distort,
and Perspective). To add Paint text to a card or background,
follow these steps:

1. Go to the card or background where you want the Paint
text.

Ifyou’re not sure whether to put it in the card layer or the
background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chapter.

2. Choose the Paint Text tool (A) from the Tools menu.

The pointer changes to an I-beam ({).

3. To select a font and style for the text, choose Text Style
from the Edit menu, or press $-T.

Or double-click the Paint Text tool in the Tools palette. You
see the Text Style dialog box.

The preset format for Paint text is 12-point plain Geneva
witha line height of 16 points.
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4. Choose from the options in the Text Style dialog box:

Click to select the font you
want. (Or double-click to

select the font and return to

your work gia!

Click to select

a font size

(measured This number
points). determines the

 

Click to select or
deselect one or

more text styles.

(Select nothing for
plain text). The 1

sample text in the

lower-right corner
of this dialog box

shows the effect of
the selected

styles(s).

 

Paint Text Style

_Style:

 

 

space between

lines of text.

HyperCard sets 
 

   

 

 

   

  

Figure 6-39

  

Geneva 9 { OK )[] Bold Helvetica 10 this number

Clitalic |__| HyperCharacters automatically
Cl Underline |) Garamond Light 14i bye when you select a(] Outline 1 mageWriter 18 oe oo

Shadow | ivy Leagan 20 font size, but you
Condense i ny ahs rin eeri Entend LED 24 || Line can change it by

L London | height typing a new
McCloud |__ number here.

Align: MerrionSquare 2]
@ Left Monaco x To use a font
© Center New York _ 7
© Right Obliqe Senwte size not listed,

z type it here.

The alignment you select applies This shows

to each line you type. (You start a what your text
new line by pressing Return.) will look like.

Selecting a font, style, and size for Paint text

The choices you make in this dialog box stay in effect until
you change them, or until you restart HyperCard. (The
preset format is restored when you restart HyperCard.)

. Click where you want to position the insertion point and
begin typing.

While you're typing, you can press Delete or Backspace to
delete one character to the left of the insertion point. And
you can press Return to start a new line of text.
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Turning field text
into Paint text

As long as the insertion point is still blinking, you can change

the font, style, and size of the text you're typing by choosing

Text Style from the Edit menu and changing the settings in
the Text Style dialog box. All the text you’ve typed since you
last clicked—or since you last pressed Enter—is changed to

the new font, style, and size.

As soon as you click anywhere, choose another tool, choose

Keep from the Paint menu, switch into or out of the

background, or move to another card, the text becomes part of
the picture—its attributes become fixed. To change the text or

its attributes, you have to erase it and start again.

« Quick textpickup tip: To select Paint text you've just finished

typing, press $-S immediately, before you click anywhere. +

Important: You can’t use the Find command to search for Paint

text. To HyperCard, Paint text is just another graphic. Ifyou
think that you'll want to search later for what you're typing now,

create a field and enter the text in the field using the Browse

tool. (See Chapter 5 for instructions on entering field text.) A

You can turn existing field text into Paint text, ifyou decide that

you'd like to make it part of a picture. Follow these steps:

1. Choose the Browse tool from the Tools menu.

The pointer becomes an I-beam (I) when you move it over

the field. (If you don’t see the I-beam, consult “Where's the I-
beam Pointer” in Chapter 5.)

2. Drag (with the I-beam) to select the field text you want
to change.
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3. Choose Copy Text from the Edit menu, or press $-C.

Or, ifwant to remove the text from the field, choose Cut
Text from the Edit menu, or press $-X.

4. Choose any Paint tool from the Tools menu.

5. Go to the card or background where you want the text.

Ifyou’re not sure whether to put it in the card layer or the
background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chapter.

6. Choose Paste Text from the Edit menu, or press 3-V.

The copied text appears in the center of the card, surrounded
by a moving dashed line:

To move the selected You can change the shape of the selection
text, drag any part of it. by pressing the 38 key and dragging from

a comer. (The text wraps at the right
border of the selection.)

Figure 6-40 Turning field text into Paint text

While the text is still selected, you can format it by choosing
Text Style from the Edit menu (or pressing 3-1’) and changing
the settings in the Text Style dialog box. The text becomes part
of the picture after you click outside the selected area.
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When elements
overlap

HyperCard puts different kinds of elements in different layers,

as shown in the following figure. Together, all these layers make
up the card you see.

Background picture

Background
buttons and fields

    

   

= ca picture Card buttons
and fields

What you see

when you look
at the card

The background picture
is fixed in a layer by ane
itself—it’s always ae
behind the background ee
buttons and fields and

all the card elements. The card picture is also |= > (}
fixed in a layer by a
itself—it’s always [—
behind the card buttons
and fields, and in front
of the background
elements.

Figure 6-41 HyperCard’s layers

As shown in Figure 6-41, the graphics in the card layer (referred
to collectively as the cardpicture) are behind all the buttons and
fields in the card layer, but they’re in front of all the elements in
the background layer. This means graphics in the card layer can
obscure the background elements, but they can be obscured by
the buttons and fields in the card layer.
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Making a graphic opaque
or transparent

Graphics can also obscure one another. Graphics in the background
layer (referred to collectively as the backgroundpicture) can get lost
behind graphics in the card layer, and a graphic that you've created

recently can cover graphics that were drawn earlier in the same layer.

When elements overlap so that some graphics obscure, or are

obscured by, other elements, you can either rearrange the elements

so they don’t overlap, or you can make some of the elements

transparent so you can see other elements through them. “Moving a

Graphic Around on a Card or Background,” later in this chapter,
explains how to reposition graphics on the card or background. The
next section explains how to make graphics opaque or transparent.
(Chapters 4 and 5 give instructions for rearranging buttons and
fields and making them opaque or transparent.)

When you want to be able to see elements that are obscured by a

graphic, you can make the graphic transparent. Conversely,
when you want to make a graphic more prominent, you can

make it opaque.

Follow these steps to make a graphic opaque or transparent:

1. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, givesg g
instructions.

2. Choose Transparent from the Paint menu to make the
graphic transparent.

Or choose Opaque from the Paint menu to make the graphic
opaque.
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A graphic ... made opaque
element... and moved

Figure 6-42 Making a graphic opaque

 

A graphic ... made transparent
element... and moved

Figure 6-43 Making a graphic transparent

When you first create or paste a graphic, it’s opaque—that is, it
covers the graphics beneath it. You can make the new graphic
transparent by choosing Transparent immediately after you create
it (before you click anywhere)—or, ifyou've pasted it, by
choosing Transparent while it’s still selected. Transparent will
affect just the graphic you've created since the last time you
pressed the mouse button if nothing else is selected.

If the Power Keys option is turned on, you can also press O to
make the selected graphic opaque, or press T to make it
transparent. (“Using Power Keys,” later in this chapter, explains
the Power Keys option.)
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Changing HyperCard includes many commands and options for changing
the appearance the look ofan existing graphic—including commands that let

. you edit a picture pixel by pixel and commands for flipping a
of a graphic graphic upside down or backwards. This section describes all the

ways you can modify graphics and Paint text.

} Seealo: ° “Using Power Keys” in this chapter
* “Using Modifying Keys With Paint Tools” in this chapter
* “Double-clicking Paint Tools” in this chapter

Magnifying a graphic You can zoom in on a section of a picture to do close-in finish
for editing work and edit your picture one pixel (dot) at a time. Follow5 yOUurP: p

these steps:

1. Ifyou want to work on a particular part of the picture,
select that part of the picture.

“Selecting a Graphic,” earlier in this chapter, gives
instructions.

2. Choose FatBits from the Options menu.

Or double-click the Pencil on the Tools palette. (Or press
Option-F)

Alternatively, you can zoom in on a particular part of the
picture by choosing the Pencil and pressing the % key while
you click on the part of the graphic you want to edit.

HyperCard zooms in on the part of the graphic you’ve
selected (or $-clicked with the Pencil) and magnifies it. (If
nothing is selected and you haven't 8-clicked anything with
the Pencil, HyperCard zooms in on the graphic you were just
working with, or on the center of the card, if you weren't
working on any graphics.)
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3. Edit the graphic.  
You can move this

window by dragging
from here.

  

When the Pencil is

selected, you can

add or remove a

You can close

this window by

clicking its close

box. (This doesn’t

turn off FatBits.)

 

just by clicking.
 

 
This window displays an actual-size

version of the graphic. As you make

changes to the magnified graphic,

this shows you how the graphic will
actually look.

Figure 6-44 Editing a graphic with FatBits turned on

You can use any of the Paint tools to modify the graphic—

they all work at the magnified scale.
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Ifyou want to edit a different part of the picture, press

Option and drag the magnified graphic with the hand
pointer («"):

pee

  sits

:

PPE

ba

ar

Ee

nd

 

  

 

 

As you drag the card To see a different section
with the hand pointer, of the card, press Option
this window shows you while you drag the card
the actual-size version with the hand pointer.
of the part of the card
you're looking at.

Figure 6-45 Moving to a different section of the magnified picture

4. When you're finished editing the graphic, turn off FatBits
by choosing it again from the Options menu.

You can also turn off FatBits by doing any of the following:

ws Click in the little window that shows the actual-size
version of the graphic.

s Double-click the Pencil on the Tools palette.

a Press Option-F.

as With the Pencil selected, 3¢-click on the magnified picture.

= Choose the Browse tool (*), the Button tool (©), or the
Field tool (&) from the Tools menu.
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Changing the size To resize a graphic, follow these steps:

of a graphic 1. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives instructions.

2. Press the 38 key while you drag from a corner or an edge of
the selected graphic to resize it:

©
The original oe x
graphic ok oy

1

1

To resize it '

proportionately, To make it wider, narrower, '
1

press 38-Shift taller, or shorter, press

and drag froma and drag from an edge.

corner.

Figure 6-46 _ Resizing a graphic

* Can't drag the graphic? Ifyou think you've selected a

graphic but you can’t drag it, you might be trying to resize

a background graphic from the card layer. Press #-B and

try again. Ifyou still can’t drag it, it’s either a button or a

field. (Chapters 4 and 5 explain how to move buttons and

fields. +
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Changing the pattern
of a graphic

There are three ways to change the pattern of a graphic:

a Use the Fill command to fill the graphic with a different pattern.

= Use the Bucket to “pour” a different pattern into the graphic.

a Use the Pickup command to give the graphic the same
pattern as another graphic on the card.

Using the Fill command to change a graphic’s pattern

Using the Fill command is the most reliable way to change the
pattern of a graphic. To change the pattern of a graphic using
the Fill command, follow these steps:

1. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives instructions.

2. Choose the pattern you want from the Patterns menu.

Or click it on the Patterns palette.

3. Choose Fill from the Paint menu.

The selected graphic acquires the selected pattern.

Patterns

 

   

  
 

 

 

The original 1. Select the 2. Choose a pattern. 3. Choose Fill from
graphic graphic. the Paint menu.

Figure 6-47 Assigning a new pattern to a graphic
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Ifyou’ve just created a graphic element and you haven't clicked
anywhere, the Fill command works on the new element (that is,

just the element you've created since you last pressed the mouse

button) ifyou haven't selected anything else.

If the Power Keys option is turned on, you can press F instead of
choosing Fill. (“Using Power Keys,” later in this chapter,
explains the Power Keys option.)

Using the Bucket to change a graphic’s pattern

You can use the Bucket to change the pattern of a graphic.

However, this technique works best when you want to fill a solid
black area with a lighter pattern. Ifyou try to use this technique
to fill a lightly patterned area with a darker pattern, the results

will be unpredictable; the pattern might change, but not
necessarily to the one that you've selected. Ifyou try to use this
technique to fill a dark (non-black) area with a lighter pattern,
you might not see any change at all.

Important: Use the Bucket to change a graphic’s pattern only if
the graphic is solid black or completely enclosed. Otherwise,
paint might spill out and fill the surrounding area. \

To change a graphic’s pattern with the Bucket, follow these

steps:

1. Go to the card or background that contains the graphic.

Pressing 8-B takes you to the background layer. (When
youre in the background layer, stripes appear in the menu
bar.) Ifyou press $-B repeatedly, you move back and forth
between the card layer and the background layer.

2. Choose the pattern you want from the Patterns menu.

Or click it on the Patterns palette.
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3. Choose the Bucket (&) from the Tools menu.

Or click it on the Tools palette. The pointer changes to a bucket.

4. Move the bucket pointer so that the tip of the stream

pouring from it is within the graphic, then click:

This is the part of the Bucket

that dispenses paint.

 

Figure 6-48 Positioning the bucket pointer to fill a graphic

Ifpaint spills out into the surrounding area, immediately choose

Undo from the Edit menu, or press #-Z, Tilde, or Esc.

Using the Pickup command to change a gréphic’s pattern

To give a graphic the same pattern as another graphic on the

card, follow these steps:

1. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives

instructions.

2. Drag the selected graphic to the part of the card that has the

pattern you want to give the graphic.

See Figure 6-49.
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3. While the graphic is still selected, choose Pickup from the
Paint menu.

The selected graphic picks up the pattern of the graphic behind
it, or the image that’s behind it, whether or not it’s a pattern.

Leave the graphic selected. Don’ click outside the selection.

4. Drag the selected graphic away.

 

1. Select the 2. Move the selected 3. Choose Pickup 4. Drag the

graphic (its graphic over the from the Paint graphic away.

edges will pattern you want menu.

shimmer). to give it.

Figure 6-49 — Using the Pickup command to change a graphic’s pattern

« Ifit doesn't work: Ifyou've selected a graphic in the card layer

and it doesn’t acquire the pattern that’s behind it when you
choose Pickup (or if it disappears), the pattern is probably in
the background layer. A graphic can only pick up a pattern
that’s in the same layer. If there’s no pattern behind the
graphic in the same layer, the graphic turns white. +

If the Power Keys option is turned on, you can press P instead of
choosing Pickup. (“Using Power Keys,” later in this chapter
explains the Power Keys option.)
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Inverting a graphic

Making a graphic
darker or lighter

To reverse the colors of a graphic so that white becomes black
and black becomes white, follow these steps:

1. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives
instructions.

2. Choose Invert from the Paint menu.

  
1. Select the graphic. 2. Choose Invert from the Paint menu.

Figure 6-50 Inverting a graphic

Ifyou've just created a graphic element and you haven't clicked
anywhere, the Invert command works on the new element (that
is, just the element you've created since you last pressed the
mouse button) if you haven't selected anything else.

If the Power Keys option is turned on, you can press I instead of
choosing Invert. (“Using Power Keys,” later in this chapter
explains the Power Keys option.)

To darken or lighten a graphic, follow these steps:

1. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives
instructions.
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2. Choose Darken from the Paint menu to make the graphic
darker, or choose Lighten to lighten it.

Choosing the Darken command darkens the selected graphic
by randomly turning white pixels black. Choosing the
Lighten command randomly turns black pixels white. Ifyou
choose either of these commands repeatedly, more pixels are

changed each time.

 

The original graphic 1. Select the graphic. 2. Choose Darken from
the Paint menu.

Figure 6-51 Darkening a graphic

rr OF
The original graphic 1. Select the graphic. 2. Choose Lighten from

the Paint menu.

 

Figure 6-52 Lightening a graphic

If you’ve just created a graphic element and you haven't clicked
anywhere, the Darken and Lighten commands work on the new
element (that is, just the element you've created since you last
pressed the mouse button) ifyou haven't selected anything else.
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If the Power Keys option is turned on, you can press D instead

of choosing Darken, or L instead of choosing Lighten. Pressing

and holding D makes the selected graphic darker and darker

until it’s totally black; pressing and holding L makes it lighter

and lighter until it’s totally white. (“Using Power Keys,” later in

this chapter, explains the Power Keys option.)

Outlining a graphic To outline a graphic, follow these steps:

1. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives instructions.

2. Choose Trace Edges from the Paint menu.

An outline appears around the parts of the selected graphic

that were originally black. Each time you choose Trace Edges,

another outline is added.

« Note: If the graphic is mostly black, the first time you

choose Trace Edges, the graphic may seem to invert—that
is, the black parts turn white and the white parts turn
black. Each subsequent time you choose Trace Edges, an

outline is added around each black part of the graphic. +

oS ©
The original Trace Edges Trace Edges Trace Edges

graphic once twice three times

  
Figure 6-53 Repeated use of the Trace Edges command
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Ifyou’ve just created a graphic element and you haven't clicked

anywhere, the Trace Edges command works on the new element

(that is, just the element you've created since you last pressed the

mouse button) ifyou haven't selected anything else.

If the Power Keys option is turned on, you can press E instead of
choosing Trace Edges. Pressing and holding E keeps adding

outlines. (“Using Power Keys,” later in this chapter, explains the

Power Keys option.)

Rotating a graphic 90° To rotate a graphic 90°, follow these steps:

1. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives instructions.

2. Choose Rotate Left from the Paint menu to rotate the

selected graphic 90° to the left, or choose Rotate Right to

é rotate it 90° to the right.

 

Figure 6-55 Rotating a graphic to the right 90°
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Flipping a graphic
vertically or horizontally

Ifyou've just created a graphic element and you haven't clicked
anywhere, the Rotate Left and Rotate Right commands work on the
new element (that is, just the element you’ve created since you last
pressed the mouse button) ifyou haven't selected anything else.

If the Power Keys option is turned on, you can press [ (the left
bracket key) instead of choosing Rotate Left, or ] (the right bracket
key) instead ofchoosing Rotate Left. Ifyou press and hold one of
these power keys, the graphic keeps rotating. (“Using Power Keys,”
later in this chapter, explains the Power Keys option.)

“Slanting, Rotating, or Distorting a Graphic,” later in this chapter,
explains how to rotate a graphic in increments smaller than 90°.

To flip a graphic vertically or horizontally, follow these steps:

1. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives
instructions.

2. Choose Flip Vertical from the Paint menu to flip the
selected graphic vertically, or choose Flip Horizontal te flip
it horizontally.
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Figure 6-57 Flipping a graphic horizontally

If you've just creatéd a graphic element and you haven't clicked
anywhere, the Flip Vertical and Flip Horizontal commands work
on the new element (that is, just the element you've created since

you last pressed the mouse button) ifyou haven't selected
anything else.

If the Power Keys option is turned on, you can type V instead of
choosing Flip Vertical, or type H instead of choosing Flip
Horizontal. If you press and hold one of these power keys, the
graphic keeps flipping. (“Using Power Keys,” later in this
chapter, explains the Power Keys option.)
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Slanting, rotating, You can slant or add perspective to a graphic, or rotate or distort

or distorting a graphic _ it. Follow these steps:

1. Select a rectangular area with the Selection tool (£3).

You must select the area as described in “Selecting a Rectangular

Area,” earlier in this chapter. (A Lasso selection won't work.)

2. From the Options menu, choose Rotate, Slant, Distort, or
Perspective.

Choose the command that describes the effect you want to
create with the graphic. A rectangle with handles appears

around the selected graphic. (The handles indicate a different
kind of selection than the moving dashed line; when a graphic
has handles around it, you can’t do the things with it that you'd
ordinarily expect to be able to do with a selected graphic.)

3. Drag the handles to change the graphic’s appearance:

Drag the handles

é/StanE,A) to change the

ss appearance of

EPSP

 

 
the graphic.

 

Figure 6-58 The effects of the Rotate, Slant, Distort, and Perspective commands
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Using power keys

The handles remain around the graphic until you click
outside it. You can drag the handles as many times as you like
to create the effect you want. When you're finished, click
outside the graphic.

These commands work with all graphics, including Paint text.
Experiment with them to see what kinds of effects you can

create. (You can return a graphic to its original state by choosing
Undo—or pressing #-Z, Esc, or Tilde—no matter how many
times you've dragged its handles.)

The Power Keys option lets you use specific keys on the
keyboard to modify the selected graphic or turn options on and
off—pressing a single key does the work of choosing a menu
command.

To turn on the Power Keys option, click the Power Keys check
box on the Preferences card in the Home stack. (The Power
Keys option is available at the Painting level and higher user

levels.) You can also turn on Power Keys by choosing it from the
Options menu, which is visible whenever a Paint tool is selected.
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When Power Keys is turned on, a check mark appears next to it
in the menu. To turn off Power Keys, choose it again. You'll find
examples of the use of the power keys in earlier sections of this
chapter. All the power keys and their effects are shown in the
following table:

 

Command Power key Menu

Black pattern B Patterns

Darken D Paint

Draw Centered (on/off) C Options

Draw Multiple (on/off) M Options

Fill E Paint

Flip Horizontal H Paint

Flip Vertical V Paint

Grid (on/off) G Options

Invert I Paint

Lighten L Paint

Opaque O Paint

Pickup RB Paint

Revert R Paint

Rotate Left [ Paint

Rotate Right ] Paint

Select S Paint a
Select All A Paint

Trace Edges E Paint

Transparent T Paint

White pattern W Patterns

 

* Note: When you're using the Paint Text tool, the power keys

are temporarily disabled. +
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Using modifier keys
with Paint tools

When you hold down modifier keys—Command, Shift, or
Option—while you drag with different Paint tools, you alter
the effects of some of the tools. The following table shows you
how. (Paint tools that aren’t affected by the modifier keys at all
aren't listed.)

 

 

 

Modifier key

Tool Command Shift Option

Selection Select tightly Move selection horizontally or vertically Duplicate selection

Lasso Lasso everything Move selection horizontally or vertically — Duplicate selection

Line No effect Draw at 15° angles Draw with pattern

Eraser Erase in white Erase straight horizontally or vertically No effect

Pencil Enter/leave FatBits Draw straight horizontally or vertically No effect

Rectangle No effect Draw a square Patterned border

Curve No effect No effect Patterned border

Brush Erase what you Paint straight horizontally or vertically No effect

paint over

Spray Erase what you Spray straight horizontally or vertically No effect

spray over

Rounded Rectangle No effect Draw square with round corners Patterned border

Polygon No effect Draw at 15° angles Patterned border

Oval No effect Drawa circle Patterned border

Regular Polygon No effect Rotate in 15° increments Patterned border
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Double-clicking
Paint tools

and patterns

You can double-click certain Paint tools on the Tools palette
(and patterns on the Patterns palette) as a shortcut for choosing
menu commands. The following table shows the effects of
double-clicking Paint tools and patterns.

Double-click . . .

Any pattern
Brush
Bucket
Curve tool
Eraser

Lasso

Line tool
Oval tool
Paint Text tool
Pencil
Polygon tool
Regular Polygon tool
Rectangle tool
Rounded Rectangle tool
Selection tool
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To do this

Bring up Edit Pattern dialog box
Bring up Brush Shape dialog box
Hide/show Patterns menu
Turn on/off Draw Filled option
Erase entire picture
Lasso every element on current
card/background
Bring up Line Size dialog box
Turn on/off Draw Filled option
Bring up Text Style dialog box
Turn on/off FatBits
Turn on/off Draw Filled option
Bring up Polygon Sides dialog box
Turn on/off Draw Filled option
Turn on/off Draw Filled option
Select entire picture



Saving the graphics
ona card

or background

Reverting to the
last Version
of a graphic

While you're working on the graphics on a particular card or
background, the changes you make to the graphics are stored in
a temporary location—theyre not automatically saved on your
disk, as are your other changes. (HyperCard assumes that you
might decide to throw away your graphics changes, so it doesn’t
save them automatically along with everything else. This gives

you the freedom to experiment with the Paint tools and then get

back your original graphics.)

To save all the graphics on the current card or background,
choose Keep from the Paint menu (or press $-K).

There are two other ways to save all the graphics on the current
card or background:

= Switch to or from the background layer by pressing $-B.

= Go to another card.

When you leave the card or switch to or from the background
layer, HyperCard saves the graphics on the card or background
you're leaving.

While you’re working with graphics, you can get back the last
saved version of the graphics on the current card or background
by choosing Revert from the Paint menu. Choosing Revert
restores the version of the graphics you had on the current card
or background before you last saved them (by using the Keep
command, leaving the card, or switching to or from the
background layer, as explained in the preceding section, “Saving
the Graphics on a Card or Background”).

* Revert is differentfrom Undo: Revert undoes all the changes

you've made to the graphics on the current card or
background since they were last saved, whereas Undo undoes
only the most recent unsaved change. +
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Copying a graphic

Copying a graphic
on the same card

You can also restore a portion of the last saved version of the picture
on the current card or background by selecting the part you want
to restore and choosing Revert. (“Selecting a Graphic,” earlier in
this chapter, includes instructions for selecting part of a picture.)

The Revert command is most useful when youre creating graphics
in stages. Once you complete a stage and it’s just the way you want
it, you can “freeze” it with the Keep command. Then you can begin
work on the next stage, confident that your last stage is saved and
that you can start over from that point, if necessary.

If the Power Keys option is turned on (and the Message box is
hidden), you can press R instead of choosing Revert. (“Using Power
Keys,” earlier in this chapter, explains the Power Keys option.)

This section explains how to duplicate a graphic on the same card
and how to copy a graphic to another card, background, or stack.

To make a copy of a graphic on the same card or background,
follow these steps:

1. Go to the card or background that has the graphic you want
to duplicate.

Pressing $6-B takes you to the background layer. (When
you're in the background layer, stripes appear in the menu
bar.) If you press 3-B repeatedly, you move back and forth
between the card layer and the background layer. If you don’t
see the graphic you want to copy while you're in the
background layer, the graphic is in the card layer.

Chapter 6: Working With Graphics



2. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives instructions.

3. Position the pointer over the selected graphic so that it
becomes the arrow pointer.

4, Press and hold the Option key while you drag the selected

graphic.

As you drag, you create an exact duplicate of the graphic. To
move the copy straight horizontally or vertically, press and
hold Shift while you drag.

« Cant drag thegraphic? Ifyou think you've selected a graphic

but you can’t drag it, you might be trying to duplicate a

background graphic from the card layer. Press $8-B and try
again. Ifyou still can’t drag it, it’s either a button ora field.

(Chapters 4 and 5 explain how to move buttons and fields.) +

You can make multiple copies of the graphic by pressing

8-Option while you drag. A trail of copies follows the
pointer. (You can preset the spacing between each image in
the trail by pressing Option along with a number from 1 to 9

before you drag. The larger the number you type, the greater

the spacing between the copies.)

 

Option-1 pressed Option-7 pressed

before dragging before dragging

Figure 6-59 Making multiple copies

Chapter 6: Working With Graphics 359



300

Copying a graphic
to another card
or background

To copy a graphic to a different card or background, follow
these steps:

1. Go to the card or background that has the graphic you want
to copy.

Pressing 38-B takes you to the background layer. (When
youre
in the background layer, stripes appear in the menu bar.) If
you press 3-B repeatedly, you move back and forth between
the card layer and the background layer. If you don’t see the
graphic you want while you’re in the background layer, the
graphic is in the card layer.

. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives
instructions.

. Choose Copy Picture from the Edit menu, or press 3¢-C.

This puts a copy of the selected graphic on the Clipboard.

. Go to the card or background where you want to put the
graphic.

You can use the arrow keys, the Navigator palette, or
commands in the Go menu to navigate between cards while
you have the Selection tool or the Lasso selected.

Ifyou’re not sure whether to put the graphic in the card layer
or the background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chapter.
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Moving a graphic
from the card

to the background

5. Choose Paste Picture from the Edit menu, or press #-V.

This takes a copy of the graphic that’s on the Clipboard, puts
it on the current card or background, and selects it.

The graphic is pasted in the same position it was copied
from. If there’s a button or field in the same location, the
pasted graphic will be hidden behind it (as explained in
“When Elements Overlap,” earlier in this chapter). You
might have to move the button or field to see the graphic.

6. Ifyou want to reposition the graphic, drag it to where you
want it while it’s still selected.

A graphic is opaque right after you paste it. Ifyou want to be

able to see through the graphic to the elements behind it, select

it and choose Transparent from the Paint menu.

Important: The most common mistake in copying a graphic is

putting it in the card layer when you want it in the background
layer. (To find out whether the graphic is in the background
layer, press $8-B to see just the background elements.) Ifyou put
a graphic in the card layer by mistake, see the next section,
“Moving a Graphic from the Card to the Background.”

It’s easy to put a graphic in the card layer by mistake when you
intend to put it in the background. If this happens, you can

move the graphic from the card layer to the background layer (of
the same card) by following these steps:

1. Go to the card that has the graphic you want to copy.

You must be in the card layer to move a card graphic. (If you
see stripes appear in the menu bar, you're in the background
layer. Press $8-B to go to the card layer.)
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2. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives
instructions.

3. Choose Cut Picture from the Edit menu, or press $#-X.

This removes the graphic from the card and puts it on the
Clipboard.

4. Go to the background layer.

Choose Background from the Edit menu, or press $8-B.

5. Choose Paste Picture from the Edit menu, or press 3-V.

This takes a copy of the graphic that’s on the Clipboard, puts
it in the current background, and selects it.

The graphic is pasted in the same position it was copied
from. If there’s a button or field in the same location on the
background layer, the pasted graphic will be hidden behind it
(as explained in “When Elements Overlap,” earlier in this
chapter). You might have to move the button or field to see
the graphic.

6. Ifyou want to reposition the graphic, drag it to where you
want it while it’s still selected.
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Moving a graphic To move a graphic to a different card or background, follow

to another card ‘hese steps:

or background 1. Go to the card or background that has the graphic you want
to move.

Pressing 98-B takes you to the background layer. (When
you're in the background layer, stripes appear in the menu

bar.) Ifyou press 38-B repeatedly, you move back and forth
between the card layer and the background layer. Ifyou don’t

see the graphic you want while you're in the background

layer, the graphic is in the card layer.

2. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives

instructions.

3. Choose Cut Picture from the Edit menu, or press $#-X.

This removes the graphic from the card and puts it on the

Clipboard.

4. Go to the card or background where you want to put the

graphic.

Use the arrow keys or commands in the Go menu to navigate

between cards while the Selection tool or the Lasso is

selected.

Ifyou’re not sure whether to put the graphic in the card layer

or the background layer, see “Adding Graphics to a Card or

Background” at the beginning of this chapter.
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5. Choose Paste Picture from the Edit menu, or press 38-V.

This takes a copy of the graphic that’s on the Clipboard, puts
it on the current card or background, and selects it.

The graphic is pasted in the same position it was copied
from. If there’s a button or field in the same location, the
pasted graphic will be hidden behind it (as explained in
“When Elements Overlap,” earlier in this chapter). You
might have to move the button or field to see the graphic.

6. If you want to reposition the graphic, drag it to where you
want it while it’s still selected.

A graphic is opaque right after you paste it. If you want to be

able to see through the graphic to the elements behind it, select

it and choose Transparent from the Paint menu.

-\ Important: The most common mistake in moving a graphic is

putting it in the card layer when you want it in the background
layer. (To find out whether the graphic is in the background
layer, press 3-B to see just the background elements.) If you put
a graphic in the card layer by mistake, see the preceding section,
“Moving a Graphic from the Card to the Background.”
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Importing d oraphic There are many products you can use to create pictures that are

compatible with MacPaint. Some products let you create

MacPaint pictures from scratch; others let you digitize images

using a scanner or video camera attached directly to the
Macintosh. However you create it, you can bring any MacPaint
picture into HyperCard by following these steps:

1. Make sure you have one of the Paint tools selected.

2. Choose Import Paint from the File menu.

A directory dialog box appears.

3. Use the directory dialog box to locate and open the file
containing your MacPaint picture.

HyperCard pastes the imported picture onto the current card
or background, starting with the upper-left corner of the
imported picture.

2,* Preparing to import a picture: Before you import a MacPaint
picture, make sure the part of the picture you want to paste is

in the document’s upper-left corner; or make sure the card
you want to paste it on is large enough to accommodate the
picture, including any blank space that’s in the upper-left
corner of the picture. “Changing the Size of a Stack’s Cards”
in Chapter 2 explains how to adjust the card size.

Once you've imported a picture, you can work with it just as if
you'd created it in HyperCard.

« Bringing in graphics via the Clipboard: You can also bring a

non-MacPaint picture into HyperCard—for example,
something you create using MacDraw® or a similar
application—via the Clipboard or Scrapbook. Copy the
picture to the Clipboard or the Scrapbook first; then paste it
onto a HyperCard card using the Paint Picture command in
the Edit menu. +
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Exporting a

snapshot of a card
or background

You can take a snapshot of the current card or background and
save it as a MacPaint document by using the Export Paint
command in the File menu. (This command is available only
whena Paint tool is selected.) Follow these steps:

1. Choose Export Paint from the File menu.

A directory dialog box for savinga file appears.

2. Use the directory dialog box to specify where you want the
MacPaint file saved and type a name for the file.

3. Click OK.

Export Paint creates a MacPaint document that contains the
image of the current card and background (and all their elements)
and saves it on a disk under the name you give it. The image of
the full-sized card gets saved, even ifyou’re using FatBits.

Ifyou're in the background layer, just an image of the
background is saved.

HyperCard exports only a picture of the card and background
information. The saved picture has none of the functional
attributes of the card—for example, the scripts aren't saved with
the picture. Ifyou havea palette, the Message box, the FatBits
window, or the Scroll window open on the screen, their images
arent included with the exported picture.

* Note: If the card image is too large to fit in a MacPaint file, it
gets clipped along the bottom and the right side. +
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Creating da miniature You can create a miniature picture of a card, like the miniatures you
picture ofacard se when you choose Recent from the Go menu. Follow these steps:

1.

2
3.

Go to the card you want a miniature picture of.

Choose Copy Card from the Edit menu, or press 3-C.

Go to the card or background where you want to put the
miniature picture.

. Press and hold the Shift key while you choose Paste Card
from the Edit menu.

Or press 3¢-Shift-V.

The miniature appears selected in the center of the card window.

Note that this is just a picture of a card—none of the normal
card attributes or scripts from the original card are pasted with
the miniature.

Deleting a ofaphic To delete a graphic, you can use any of the following techniques:

To delete a new graphic just after you add it (before you click
anywhere else), press Delete, Backspace, or Clear, or choose

Clear Picture from the Edit menu. This is not reversible; you
can’t bring back a graphic that was deleted immediately after
it was added.
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s To delete any graphic, first select it (by using one of the
techniques described in “Selecting a Graphic,” earlier in this
chapter). Then press the Delete, Backspace, or Clear key, or
choose Clear Picture from the Edit menu. If you delete a

selected graphic by mistake, you can bring it back by
immediately choosing Undo from the Edit menu or pressing
3-Z, Tilde, or Esc.

To erase any graphic, choose the Eraser (&) from the Tools
menu and drag over the graphic. (To erase a background
graphic, you must be working in the background layer. To
erase a card graphic, you have to be in the card layer.) To
erase in a straight horizontal or vertical line, press Shift while
you drag.

2* The background revealed: If you see a picture appearing
under the Eraser as you drag it over a card picture, you're
exposing a part of the background that was covered by an
opaque card picture. If you don’t want the background
elements to show, you can cover them by pressing the
key as you drag with the Eraser. (This “erases” with white
paint.) Of course, you can go to the background layer and
delete the elements, but first check to make sure they
aren't needed on the other cards that share the
background. *

To erase the entire picture on the current card or background,
double-click the Eraser on the Tools palette. This wipes out
the picture on the current card or background, then selects
the tool you were using just before you double-clicked the
Eraser. This technique is useful for cleaning up your screen
after you've been experimenting with the Paint tools. (If you
double-click the Eraser by accident, choose Undo from the
Edit menu immediately, or press 3-Z, Esc, or Tilde.)
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Chapter 7

Printing

ils chapter explains how to print the information in a stack.

You can print a single card, specific cards in a stack, an entire

stack, the contents of a field, or a report that displays the
contents of specific fields. You can also create different report
templates for a stack and copy and paste report templates from
one stack to another.

Ifyou're familiar with HyperTalk, you have even more printing
options—for example, you can print a specific rectangular area

of a card, a range of consecutive cards, or a document from
another application. The HyperTalk Reference stack describes

these options. (They aren’t covered in this chapter.)

You can do all the tasks described in this chapter no matter what
your user level is set to.
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Preparing to print Before printing with HyperCard, you must have the appropriate
printer driver (also called printing resource) for your printer in
your System Folder and make sure your printer’s icon is selected
through the Chooser desk accessory. The documentation that
came with your computer describes how to install printer drivers
and how to use the Chooser.

Once you have the appropriate printer driver installed and
selected, you can give HyperCard information about your paper
and printing preferences before you print by using the Page
Setup command.

* Note: You don’t need to use the Page Setup command each
time you print. If the settings in the Page Setup dialog box
reflect your paper size and printing preferences, you don’t
need to use the Page Setup command until you want to
change the settings. +

To change the settings in the Page Setup dialog box, follow these
steps:

1. Make sure you have one of the General tools selected.

The Browse tool (s), the Button tool (©), or the Field tool
(&) will work.

2. Choose Page Setup from the File menu.

The Page Setup dialog box appears. The options in this
dialog box vary, depending on what kind of printer and
which version of system software you have.
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Click the —]
option that

describes

the size of
your paper.

3. Select the options you want in the Page Setup dialog box:
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Paper:

Reduce or
00 ik

Enlarge: Loo}
Orientation

EN
| Print

 

 

 

US Letter © A4 Letter
IOUS Legal OBS Letter ©| Tabloid

 

 

Printer Effects: (Options|]
&] Font Substitution?
El Text Smoothing?
& Graphics Smoothing?
& Faster Bitmap Printing?

|__ Click here for
additional
options.

 

 

 

 

  
 

 

Print For information

vertically horizontally about these

options,
click Help.

ImageWriter (« )
Paper:| @US Letter Oa Letter

Uspeal biewe © International Fanfold

|__ These options aren’t

available for the

 ImageWriter.
 

 

 

Orientation Special Effects: (1) fait Rijusied “_+—
(1 38 % Reduction

e —N (No Gaps Between Pages

Print Print

vertically horizontally

Figure 7-1

4. Click OK.

Selecting options in the Page Setup dialog box

The options you select in the Page Setup dialog box are saved

with the current stack. They’re in effect when you print the

stack (or any part of it) using the Print Field, Print Card,

Print Stack, or Print Report commands.

You can change the Page Setup settings at any time by repeating

this procedure.
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Printing a single card To print a single card in a stack, follow these steps:

1. Go to the card you want to print.

2. Make sure you have one of the General tools selected.

The Browse tool (s), the Button tool (©), or the Field tool
() will work.

3. Choose Print Card from the File menu, or press 3-P.

HyperCard prints the current card according to the settings
youve selected in the Page Setup dialog box.

Printing df) To print all the cards in the current stack, follow these steps:

entire stack 1. Make sure you have one of the General tools selected.

The Browse tool (s), the Button tool (©), or the Field tool
(&) will work.

2. Choose Print Stack from the File menu.

The Print Stack dialog box appears.
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This shows you
the layout of the

printed page.

To space the

cards, drag any

card image other
than the one in
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corner.

To add text to the

header, type here.

3. Select the options you want in the Print Stack dialog box:
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to insert a tab

between items in

the header. (Use
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item or to align it
flush right.)

add the date, time,
stack name, and/or
page number to
the header.

Figure 7-2 Printing an entire stack

dimensions shown
to view the page

below.margins, card size,

or card spacing

(at the right).

« Ifyou have a LaserWriter: When the Precision Bitmap
Alignment (4% reduction) option is selected in the
LaserWriter Page Setup dialog box, the measurements you see

for Margins, Size, and Spacing in the Print Stack dialog box
(in Figure 7-2) will be slightly larger than they'll be on the
printed page. +
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4. Click Print.

The Print dialog box appears. The options in this dialog box

vary, depending on what kind ofprinter and which version of
system software you have. These options are described in the

documentation that came with your computer.

 

LaserWriter “Saunalriter || NTR” (o« )

Copies:[I] Pages: @ All © From: To:
Cancel

 

Cover Page: &)No (© First Page © Last Page

Paper Source: @ Paper Cassette © Manual Feed

Print: @ Color/Grayscale © Black & White

 

 

ImageWriter
 

 

Quality: © Best @ Faster © Draft
Page Range: @) All © From: || To: Cancel

Copies: fd

Paper Feed: @ Automatic () Hand Feed

   

Figure 7-3 Examples of the Print dialog box for different printers

5. Select the options you want in the Print dialog box and

click OK.

HyperCard prints the cards in the current stack according to
the settings you've selected in the Page Setup dialog box, the

Print Stack dialog box, and the Print dialog box.

Once you print a stack, HyperCard remembers the format and

header you used for that stack. The next time you print the same

stack with the Print Stack command, the same format and

header will be displayed in the Print Stack dialog box.
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Printing specific Cards To print specific cards in the current stack, follow these steps:

1. Mark the cards you want to print, using any of the
techniques described in “Marking a Card” in Chapter 3.

2. Make sure you have one of the General tools selected.

The Browse tool (*), the Button tool (©), or the Field tool
() will work.

3. Choose Print Stack from the File menu.

The Print Stack dialog box appears.

4, Select the options you want in the Print Stack dialog box.

See Figure 7-2 for explanations of these options.

5. Click “Marked cards” as shown here:

Click here to print only the

marked cards in the stack.

ee Print|Stack a
i All cards

 

 

 
 

 

> Marked cards

Print order: rH
Printed card size:[Full__|

 

 

 

 

 
  

Figure 7-4 Printing only the marked cards in the stack
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Printing the text in a

376

specific field

6. Click Print.

The Print dialog box appears (as shown in Figure 7-3). The
options in this dialog box vary, depending on what kind of
printer and which version of system software you have. These

options are described in the documentation that came with
your computer.

7. Select the options you want in the Print dialog box and
click OK.

HyperCard prints the marked cards in the current stack

according to the settings you've selected in the Page Setup

dialog box, the Print Stack dialog box, and the Print dialog box.

Once you've printed specific cards in a stack, HyperCard
remembers the format and header you used for that stack. The
next time you print the same stack with the Print Stack command,
the same format and header will be displayed in the Print Stack

dialog box. However, you need to tell HyperCard each time you
want to print only the marked cards in a stack (by clicking
“Marked cards” in the Print Stack dialog box). Otherwise, it
assumes you want to print all the cards in the stack.

To print the text that appears in a specific field on a particular
card or background, follow these steps:

1. Go to the card that has the text you want to print.

2. Make sure you have one of the General tools selected.

The Browse tool (*»), the Button tool (©), or the Field tool
(3) will work.

3. Choose Print Field from the File menu.

The Print Field dialog box appears.
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4. Select the field whose text you want to print:
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Figure 7-5 Printing the contents of a specific field

5. Click OK.

HyperCard prints the text in the specified field according to
the settings you've selected in the Page Setup dialog box and
the Print Field dialog box. Ifyou’re printing a background
field that contains different text on every card, HyperCard
prints only the text that appears in the field on the current
card.
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Printing a repor{ HyperCard allows you to prepare custom reports that display the

field text in a stack in any way you like. You can create and save

up to 16 report templates for a stack. (You could, for example,

create a table-style report template, a template for printing the

results of calculations, and a template for printing labels—all for
the same stack.) You can also copy and paste report templates

from one stack to another.

You can control the appearance and placement of each element

in a report—including the font, size, and style of the text.

(Reports contain no graphics.) Ifyou haven't created any report

templates for a stack, you can still print a report for the stack

using HyperCard’s default report template.

To print a report from the current stack, follow these steps:

1. Make sure you have one of the General tools selected.

The Browse tool (*), the Button tool (©), or the Field tool
(&) will work.

2. Choose Print Report from the File menu.

The Print Report dialog box appears.

3. Ifyou've created a report template you want to use, choose

its name from the Reports menu.

Or, ifyou want to print using HyperCard’s default report
template, skip this step.

Ifyou want to create your own report template now, click
Cancel and go to the next section, “Creating a Report
Template.”
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4. Click “Marked cards” ifyou want your report to include
only text from the marked cards in the stack.

“Marking a Card” in Chapter 3 explains how to mark cards.

Or, ifyou want to print text from all the cards in the stack,

skip this step. (“All cards” is the preset option. When it’s
selected, text from all the cards will print.)

Click here to print only from the

marked cards in the stack.

 

SSS Print Report “Untitled Report” —————————

@ All d (ear)

| | | bs, siete
| | | Print order: [Ot

 

 

  

  
 

 

 

Figure 7-6 Printing a report that includes text from marked cards only

5. Click Print.

The Print dialog box appears (as shown in Figure 7-3).

6. Select the options you want in the Print dialog box and
click OK.

These options are described in the documentation that came

with your computer.

HyperCard prints text from the cards in the current stack

(either all the cards or just the marked cards, depending on
what you specified in step 4) according to the settings you’ve
selected in the Page Setup and Print dialog boxes, and the
current report template (shown in the Print Report dialog
box).
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Creating a report To create a report template for the current stack, follow these

template steps

1. Make sure you have one of the General tools selected.

The Browse tool (s:), the Button tool (©), or the Field tool
(&) will work.

2. Choose Print Report from the File menu.

The Print Report dialog box appears.

3. Choose New Report from the Reports menu.

HyperCard prompts you to type a name for the new report
template:

 Type a name for your
new report template Report Name:

f OK ] [ Cancel }

 

 

 

   

Figure 7-7 Naming a report template
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4. In the Print Report dialog box, set up the layout for your
report:

You can change the

margins by dragging

either corner handle.  

To resize the cells,

drag from here.

Each of these cells

Click here to print successive cards’

cells from the top of the printed page
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time, stack name, between items in margins, cell size,

and/or page the header. (Use _ or cell spacing (at

number to the tabs to center an _ the right).

header. item or to align it
flush right.)

Figure 7-8 Setting up the layout for a report

Ifyou can’t decide on a layout now, go on to step 5. You'll
have another chance to use this dialog box to set up or adjust

the layout later in this procedure.

+ Ifyou have a LaserWriter: When the Precision Bitmap
Alignment (4% reduction) option is selected in the

LaserWriter Page Setup dialog box, the measurements you see

for Margins, Size, and Spacing in the Print Report dialog box

(in Figure 7-8) will be slightly larger than they'll be on the

printed page. It’s a good idea to turn off the Precision Bitmap
Alignment option before printing a report. +
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5. Choose Report Items from the Edit menu, or press #-E.

Or double-click any cell in the Print Report dialog box.

The Report Items dialog box appears. This dialog box allows

you to specify what text you want in your report by adding
report items. The report items you specify will print for each

card.

The ruler reflects the unit of measurement

you selected from the pop-up menu in the

Print Report dialog box.  
 

 

fd Live eel erat rd ee ore eu toescs ee ris eB
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area reserved for a

cell (one card’s text).

 

When the cells are

larger than the area

shown in this

dialog box, these

scroll bars

| __ become active.

  

 

  
 

 

    

Figure 7-9 The Report Items dialog box

6. Choose New Item from the Items menu, or press #-N.

A small rectangle appears, outlined by a moving dashed line
to indicate that it’s selected. This rectangle represents one

item of your report.

7. While the item is still selected, double-click it, or choose

Item Info from the Items menu.

The Item Info dialog box appears.
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8. Specify the contents of the item:

You can type a text string or a HyperTalk expression
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DaCkgroun qe ca Background fields: L{]Font NC] Size menus become

the report item. Title Geneva i 2
morning meetings |_| Lr styte faa active when you
afternoon meeting Pie
age et td ueek a cho oo turn on Font or
month calendar Bi ttatic Size. Press and

OO Badertiag Align: :
: Ol aetiine @ Left hold the mouse

print in the number OCléxtend to choose anew

of columns specified font or size.

here. (The text won't
appear in columns in Select Font, Style, and/or Size to format the text

the Report Items

dialog box, but it will
print in columns.)

 
string—or to override the text format of the

specified field—in the box labeled “Contents of
item.” (The font, style, and size you choose here

affect only the printed report—not the field itself.)

Figure 7-10 Specifying the contents and appearance of an item

Ifyou want the item to be the contents of a card field, you
must specify the card field (by its name, number, or ID) by
typing a HyperTalk description of the card field in the box
labeled “Contents of item.” For example, you could type any
of the following to specify a card field:

card field "Name"
card field 5

card field ID 7
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You can also define an item to be any text you want by
simply typing the text between quotation marks in the
“Contents of item” box. Or you can define the item to be a

particular word or words froma field—or any text or value
you can describe with HyperTalk—by typing the appropriate
HyperTalk expression in the “Contents of item” box. Here
are some examples:

"This text will appear in every cell."
word 2 of background field "Name"
first line of background field "Name"
word 1 to 5 of background field "Job"
the number of this card

See the HyperTalk Reference stack for more information
about HyperTalk expressions.

9. Click OK.

You return to the Report Items dialog box. The small
rectangle contains the text you specified in the Item Info
dialog box and is still selected. To resize the item, drag it
from any corner; to move it, drag it from the middle.

You can cut, copy, and paste items in the Report Items dialog
box using commands in the Edit menu. You can also

duplicate an item by pressing Option while you drag it. (To
drag the item in a straight line horizontally or vertically, press

the Shift key while you drag.)

10. Repeat steps 6 through 9 ifyou want to add more items to
your report.

11. When you've added all the items you want, click OK to
return to the Print Report dialog box.

12. Refine your layout in the Print Report dialog box, ifyou like.

See Figure 7-8 for instructions.
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13.

14.

Click “Marked cards” if you want your report to include
only the text from the marked cards in the stack.

Or, if you want to print text for all the cards in the stack,

skip this step. (“All cards” is the preset option. When it’s
selected, text from all the cards will print.)

Click Print.

A dialog box like this appears:

 

 

Save changes to report template “Weekly
Appointments” in the stack?

  

Figure 7-11 Saving a report template

15.

16.

Click Yes or press Return to save your new report template.

The Print dialog box appears.

Ifyou want to print a report now (using the current
template), select the options you want in the Print dialog
box and click OK.

Otherwise, click Cancel in the Print dialog box.

HyperCard prints text from the cards in the current stack
(either all the cards or just the marked cards, depending on
what you specified in step 13) according to the settings
you've selected in the Page Setup and Print dialog boxes, and
the template you’ve defined in the Print Report, Report
Items, and Item Info dialog boxes.
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« To print mailing labels: \fyou want to print mailing labels,

you can use the Mailing Labels template in the Addresses

stack (which comes with HyperCard). Ifyou want to print
mailing labels from a stack other than the Addresses stack,

copy the Mailing Labels template using the procedure
described in the next section, “Copying or Moving a Report
Template to Another Stack.” Ifyou like, you can customize

this template by following steps 4 through 13 in this section.

Ifyou’re printing on a LaserWriter, be sure to use o7ly labels

made especially for LaserWriters or photoeopiers. +

Copying Or moving Ifyou have a report template for one stack that you think would
q report template to work well in another stack, you can copy or move it by

following these steps:
another stack

1. Go to the stack that has the template you want to copy or
move.

2. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (©), or the Field tool
(3) will work.

3. Choose Print Report from the File menu.

4, From the Reports menu, choose the report template you
want to copy or move.

5. Choose Copy Report from the Edit menu ifyou want to
copy the report template.

Or choose Cut Report ifyou want to move it.

6. Click Cancel to close the Print Report dialog box.

7. Go to the stack to which you want to add the report
template.

8. Choose Print Report from the File menu.
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Renaming a

report template

9. Choose Paste Report from the Edit menu.

The layout of the pasted report template appears in the Print
Report dialog box and its name appears in the Reports menu.

10. Click Print ifyou want to print a report using this template
now.

Or click Cancel ifyou want to use this template later. The
dialog box for saving a report template appears.

11. Click Yes to save the template with the current stack.

You might have to redefine the report items (for example,

change the field names in the Item Info dialog box for each

item) so that the template works in the new stack. Follow the

instructions in the preceding section, “Creating a Report
Template,” for defining report items.

To renamea report template, follow these steps:

1. Go to the stack that has the template you want to rename.

2. Make sure you have one of the General tools selected.

The Browse tool (*), the Button tool (©), or the Field tool
(3) will work.

3. Choose Print Report from the File menu.
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4. Choose the report template you want to rename from the
Reports menu.

5. Choose Report Name from the Edit menu.

A dialog box like the following appears:

 

Type a new name for the Report Neme:

template here. . moe ee Weekly Appointments |

_.. then click OK. OK

 

 

 

 

   

Figure 7-12 Renaming a report template

6. After you've typed a new name for the template, click OK.

Deleting ad fepor€ To delete a report template froma stack, follow these steps:

template 1. Go to the stack that has the template you want to delete.

2. Make sure you have one of the General tools selected.

The Browse tool (*), the Button tool (©), or the Field tool
(3) will work.

3. Choose Print Report from the File menu.

4. Choose Delete Report from the Edit menu.

A confirmation dialog box appears for deleting the report
template.

5. Click OK to delete the report template.
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Appendix

What'sNewinHyperCard2.0

de appendix describes the features that are new in
HyperCard 2.0. Ifyou’re familiar with an earlier version of
HyperCard, this appendix will give you an idea ofwhat to look
for in HyperCard 2.0. Cross-references point you to sections
in this book where you'll find more detailed information. This
appendix doesn’t describe the new scripting features.

To review all of HyperCard’s new features quickly, click the
Find Topics button in both the HyperCard Help stack and the
HyperTalk Reference stack, type new features, and press Return.

You can have several stacks open at once—as many stacks as

your computer's memory will allow.

Y} See: “Opening More Than One Stack at a Time” in Chapter 1

Each stack opens in a window that you can resize and move
around on the screen.

Y} See: “Moving and Resizing the Card Window” and “Viewing Large
Cards” in Chapter 1
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Browsing

Card sizes can vary from stack to stack. Your stack can have very
large cards, very small cards, or cards ofvirtually any size in
between. (All the cards in a stack are the same size.) You can
specify any size for the stack’s cards when you create the stack,
and change the size of a stack’s cards at any time.

Y See: “Making a New Stack” and “Changing the Size of a Stack’s Cards”
in Chapter 2

You can revent users from S eekin at the buttons and fieldsPp §
ina stack,

Y See: “Preventing Users from Peeking at Buttons and Fields” in Chapter 2

You can prevent users from stopping scripts that are running in
the stack (using %-.).

Y See: “Preventing Users from Stopping Scripts” in Chapter 2

You can convert any stack built in an earlier version of HyperCard
to the 2.0 file format. Then you can use the stack and modify it
exactly as if it had been created in HyperCard 2.0.

Y See: “Openinga Stack Built in an Earlier Version of HyperCard” in
Chapter 1

HyperCard has a new palette—the Navigator palette—with
icons you can click to move around in stacks. Its icons represent
commands in the Go menu.

Y See: “Using the Navigator Palette” in Chapter 1

In some stacks, you can click text in fields to make things
happen, such as going to another card.

} See: “Clicking Text to Move Around” in Chapter 1
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Buttons

Field text

 

Choosing the Browse tool while you're in the background layer
no longer returns you to the card layer. You can work with the
Browse tool and stay in the background layer. When you're
ready to return to the card layer, press 3¢-B.

You can change the font, size, and style of a button’s text.

Y See: “Setting the Style of Button Text” in Chapter 4

You can vary the highlight of a background button from card to
card.

Y} See: “Making a Button Highlight When It’s Clicked” and “Making a

Button Appear Highlighted on Certain Cards” in Chapter 4

Using the Icon Editor, you can create and edit your own icons
and copy and paste icons easily between stacks (without using a

resource editor).

Y\ See: “Creating and Modifying Icons” in Chapter 4

You can format individual characters, words, and phrases of text
in a field with different fonts, styles, and sizes.

Y\ See: “Choosing the Look of Field Text” and “Setting the Font and Style
for Individual Pieces ofText” in Chapter 5

A background field can now display the same text on every card
on which the field appears.

Y See: “Making Field Text Appear on Every Card” in Chapter 5

You can style a string of contiguous text in a field so that it
responds as one unit to a user’s click. Clicking text can do the
same kinds of things that clicking buttons can do.

Y See: “Grouping Text” in Chapter 5
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Graphics

Printing

You can prevent text from wrapping in a field.

Y See: “Preventing Text Wrap in a Field” in Chapter 5

Before you ask HyperCard to search for specific text in a stack
(using the Find command), you can exclude specific fields from
the search. This can speed your search when you're looking for
text in a very large stack.

Y See: « “Excluding Card and Background Fields from Text Searches
and “Excluding Background Fields from Text Searches” in
Chapter 3

° “Excluding a Field from Text Searches” in Chapter 5

There are four new commands in the Options menu for
manipulating graphics to create special graphic effects—Rotate,
Slant, Distort, and Perspective.

Y See: “Slanting, Rotating, or Distorting a Graphic” in Chapter 6

You can define and store up to 16 different templates in a stack
for printing reports. Items in a report can include text strings
you specify, field text in the stack, and HyperTalk expressions.
You can also copy and paste report templates from one stack to
another.

} s.. “Printing a Report” and “Creating a Report Template” in Chapter
o.

You can print the contents of an individual field.

Y See: “Printing the Text in a Specific Field” in Chapter 7

You can mark specific cards in a stack and perform operations
on them all at once (such as printing them).

} See: “Marking a Card” in Chapter 3 and “Printing Specific Cards” in
Chapter 7
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authoring Creating or modifying buttons, links,
fields, cards, backgrounds, and stacks using the
Button tool, the Field tool, and commands in
the Objects menu. Also refers to the user level
that allows you to use the Button Tool, the Field
tool, and the Objects menu.

background A type of HyperCard object; a
template shared by a number of cards. Each
card with the same background has the same
background picture, background fields,
background buttons, and background script
in its background layer.

background button A burton that is common to
all cards sharing a background. Compare with
card button.

background field A field that is common to all
cards sharing a background; its size, position, and
default text format remain constant on all cards
associated with that background, but its text can
change from card to card. Compare with card
field.

Glossary

 

background layer The layer behind the card layer,
containing all the elements of the background. You
see the elements of both layers when you look at a
card, as if the card layer were a transparent layer in
front of the background layer. The background
button or background field created most recently is
the topmost object in the background layer (that is,
closest within the background layer to the front of
the screen). The background picture is behind
(farther from the front of the screen) the objects in
the background layer.

background picture The graphics in the
background layer; the entire picture that is
common to all cards sharing a background. You
can see and edit the background picture by
choosing Background from the Edit menu.
Compare with card picture.

browse To explore HyperCard stacks by clicking
buttons and using the Go menu.

Browse tool (sh) The tool you use to click
buttons and to position the insertion point in
fields.
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button A type ofHyperCard object; a “hot spot”
on a card or background that responds when you
click it according to the instructions in its script.
For example, clicking a right arrow button with
the Browse tool can take you to the next card.

The tool you use to create,
change, and select buttons.

card A type ofHyperCard object; a rectangular area
that can hold buttons, fields, and graphics. All
cards in a stack are the same size. Each card is a
composite of two layers—a foreground layer,
called the card layer, and a background layer.
You see the elements ofboth layers when you
look at a card, as if the card layer were a
transparent layer in front of the background
layer. Each layer can contain its own buttons,
fields, and graphics.

card button A button in the card layer of a
specific card. Compare with background button.

card field A field in the card layer of a specific
card; its size, position, text attributes, and
contents are limited to the card on which the
field is created. Compare with background field.

card layer The layer in front of the background
layer. You see the elements of both layers when
you look at a card, as if the card layer were a
transparent layer in front of the background
layer. The card button or card field created most
recently is the topmost object in the card layer
(that is, closest within the card layer to the front
of the screen). The card picture is behind (farther
from the front of the screen) the objects in the
card layer and in front of all the elements in the
background layer.

card picture The graphics in the card layer of a
specific card. Compare with background picture.
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Current (adj.) The card, background, or stack
you're looking at now. For example, the current
card is the one you see in the active window
on your screen.

field A type of HyperCard object; a container in
which you type field text. HyperCard has two
kinds of fields—card fields and background fields.

field text Text that appears in a field. Field text can
be edited and searched, while Paint text cannot.

Field tool (E3) The tool you use to create,
change, and select fields.

General tools The tools that appear in the top
row of the Tools menu: the Browse tool (*),
the Button tool (9), and the Field tool (&).

Home cards The first five cards in the standard
Home stack, designed to hold buttons that take
you to stacks, applications, and documents.

HyperTalk HyperCard’s built-in script language
for HyperCard users.

link A short script, usually in a button but
potentially in any HyperCard object, that
allows you to move immediately to a specific
card in a stack, to an application, or to a
document. For example, clicking a button that
contains a link to your Addresses stack takes
you immediately to the first card of that stack.

Message A string of characters sent to an object
from a script or the Message box, or that
HyperCard sends in response to an event.
Messages that come from the system—from
events such as mouse clicks, keyboard actions, or
menu commands—are called system messages.
Examples of messages are help and
mouseuUp.
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Message box A special container that you use to
send messages to HyperCard.

MultiFinder a multitasking operating system for
Macintosh computers that makes it possible to
have several applications open at the same time,
so that you can perform one task while the
computer performs another. For example,
MultiFinder allows you to work on a HyperCard
stack while the computer prints out a document
from a word-processing application.

object An element of the HyperCard environment
that can have a script associated with it and that
can send and receive messages. There are five
kinds of HyperCard objects: buttons, fields,
cards, backgrounds, and stacks.

Paint text Text you type using the Paint Text tool.
Paint text can appear anywhere, while field text
must appear in a field created with the Field tool.
When you finalize Paint text by clicking, it
becomes part of a card or background picture and
cannot be edited except by erasing it and starting
over. Unlike field text, Paint text can’t be searched.

Paint tools Any of the HyperCard tools you use

to create graphics. The Paint tools are all the
tools below the top row in the Tools menu.

palette A small window that displays icons or
patterns you can select by clicking. You can
open two of HyperCard’s palettes, the Tools
palette and the Patterns palette, simply by
“tearing off” their respective menus. To see the
Navigator palette, type palette
"navigator" in the Message box. See also
tear-off menu.

picture Any graphic or part of a graphic, created
with a Paint tool or imported from an external
file, that is part ofa card or background.

pixel Short for “picture element”; a single dot on
the screen.

point In printing, the unit of measurement of the
height of a text character; one point is one pixel
(about /2 of an inch). When you select a font,
you can also select a point size, such as 10-
point, 12-point, and so on.

power key One of a number of keys on the
Macintosh keyboard that you can press to
invoke a menu command whena Paint tool is

active and the Message box is closed. To turn on
the power keys, choose Power Keys from the
Options menu or select the Power Keys option
on the Preferences card in the Home stack.

Preferences card The last card in the Home
stack, where you can set your user level and
select or deselect the Blind Typing, Power Keys,
and Arrow Keys in Text options.

Recent A special dialog box that holds miniature
representations of up to the last 42 unique cards
viewed. Choose Recent from the Go menu to
get the dialog box.

resource fork The part of a file that contains
resources such as fonts, icons, sounds, and so on.

SCript A collection of instructions written in
HyperTalk and associated with a particular
object. You use the script editor to add to and
revise an object’s script. Every object has a script,
even though some scripts are empty (that is, they
contain nothing).

script editor A large window in which you can
type and edit a script. The title bar of the script
editor describes the object to which the script
belongs. You can use the Edit menu, the Script
menu, and keyboard commands to edit text in
the script editor. See also object.
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scripting The act ofwriting scripts; writing
programs in HyperTalk. Also refers to the user
level that allows you to look at and change
objects’ scripts.

search path When you opena file from within
HyperCard, HyperCard attempts to locate the
stack, document, or application you want by
searching the folders listed on the appropriate
Search Paths card in the Home stack. Each line
ona Search Paths card indicates the location of
a folder, including the disk name (and folder
and subfolder names, if any). This information
is called a search path. Items in a search path are
separated by a colon, like this: my disk:
HyperCard folder:my stacks:

Search Paths cards Three cards in the Home stack
used to store information about the location of
stacks, documents, and applications that you open
while Hypercard is running. See also search path.

shared text Field text that appears on every card
in a background. Shared text can be edited only
from the background layer. Text in shared text
fields can’t be searched.

stack A type of HyperCard object that consists of
a collection of cards; a HyperCard document.

system message A message sent by HyperCard
to an object in response to an event such as a
mouse click, keyboard action, or menu
command. Examples of HyperCard system
messages are mouseUp and doMenu.

tear-off menu A menu that you can remove from
the menu bar by dragging the pointer beyond
the side or bottom edge of the menu.
HyperCard has two menus that can be torn off:
the Tools menu and the Patterns menu. When
torn off, these menus are referred to as palettes.
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Tools palette The palette that you can “tear off”
the Tools menu.

user level A HyperCard setting, ranging from
1 to 5, that determines which of HyperCard’s
capabilities are available. You select the user
level on the Preferences card in the Home
stack. Each user level makes all the options from
the lower levels available, and also gives you
additional capabilities. The five user levels are
Browsing, Typing, Painting, Authoring, and
Scripting.

write-protected stack A stack for which
Can’t Modify Stack is selected in the Protect
Stack dialog box; a stack for which Locked is
selected
in the stack’s Get Info box in the Finder; or a

stack on a locked medium—a locked disk, a

CD-ROM, or a locked folder ona file server. A
padlock appears after the last menu title in the
menu bar of a write-protected stack.
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aborting a script, preventing 120
access. See protecting a stack
adding buttons 175-186

to acard or background 170-171
to Home cards 124-131

adding button text 205
adding cards to stacks 140-143
adding fields 237-244
adding graphics 286, 303-324
adding margins to fields 263-264
adding Paint text 330-334
adding search paths 23-24
adding text 236-237

to button 205
in field 60-62
with Paint Text tool 330—334

aligning graphics 328-329
alignment in fields, setting default 252-254
allocating memory, under MultiFinder 9

alternate Home stacks 134-137
AppleShare file server

setting user access for stack on 122
using stacks on 66

Application Memory Size, setting 9
applications

adding Home card buttons for 127-131
adding buttons that open 172-173
importing graphics from 365
opening from HyperCard 62-64
quitting 64
Search Paths card for 22

Arrow Keys in Text option 19-20, 40-41
moving through text 248

Art Bits stack 301-302
Authoring level, defined 17
Auto Hilite option 217
Auto Tab option 251

B
Back command (Go menu)

Prev command vs. 36
for reviewing cards 58

background(s) 156. See also background buttons;
background fields; background layer

adding buttons to 170-171
adding fields to 237-238
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background(s) (continued)
adding graphics to 286-324
adding Paint text to 331-333
checking number of 158
copying 161-162

when making new stack 98-100
copying buttons to 228-229
copying buttons on the same 228
copying fields to 275-276
copying fields on the same 274-275
copying graphics to 360-361
copying graphics on the same 358-359
creating new 159
exporting a snapshot of 366
getting information about 95, 163-164
locating fields on 259-260
moving between 160-161
moving buttons between 232-233
moving buttons from card to 230-231
moving fields between 279-280
moving fields from card to 277-279
moving graphics between 363-364
moving graphics from card to 361-362
naming or renaming 164
number of cards in 158
protecting 166—167
repositioning buttons on 221-222
repositioning fields on 268
repositioning graphics on 361, 362, 364
saving graphics on 357
selecting all graphics on 299
working with 156-168

Background Art stack 301-302
background buttons. See ado buttons

and overlapping elements 222-224
numbering of 223-224
reordering 224-226
Shared Hilite for 218-219

Background command (Edit menu) 157
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background fields. See also fields
and overlapping elements 269-271
changing appearance of 260-266
placing in report template 383
reordering 271-273
Shared Text option for 257-259
tabbing through 250-251

background layer. See also background(s)
card layer vs. 73-75, 140, 222

when adding buttons 170-171
when adding fields 237, 238, 242
when adding graphics 286
when entering or editing text 258
when selecting graphics 291

moving between card layer and 157
overlapping buttons in 224-227
overlapping fields in 269-274
overlapping graphics in 335-337
viewing 157

background picture 335-336
selecting 300

background script, viewing 95
backing up

importance of 9
when modifying stacks 89

Bkgnd Info command. See Bkgnd Info dialog box
Bkgnd Info dialog box 95, 163

Can’t Delete Background option 166-167
checking number of backgrounds with 158
Don't Search Background option 165
excluding backgrounds from searches with 164
naming or renaming a background with 164
protecting a background with 166
shortcut for choosing 164

blank button, creating 175-176
Blind Typing option 21
borders, drawing with patterns 324
Bring Closer command (Objects menu)

reordering a button with 225
reordering a field with 272

Index



browser-style Home card 135
Browse tool

choosing 34-35
shortcut for 172

editing text with 60-62, 244-246
editing shared text with 258
locating buttons with 200
locating fields with 244, 260
locked field and 282

Browsing level, defined 17
browsing methods 33-60
Brush 303-305
Brush Shape dialog box 304
Bucket 303

changing a graphic’s pattern with 343-344
positioning 307, 344

button(s) 76, 169, 170. See also background
buttons; card buttons

adding to card vs. background 170-171
adding to Home cards 124-131
adding visual effects to 215-216
assigning an icon to 208
changing an icon for 208
copying 227-229

from ReadyMade Buttons stack 172-175
creating 175-186

blank and transparent 175-176
with a graphic 184-186
with an icon 180-184
with icon and text 183-184
opaque or transparent 226-227
with text 176-179

deleting 234
getting information about 90-91
highlighting 217-219
on Home cards 14, 124-131
linking to cards or stacks 124-131, 209-215
locating 200-201
making transparent or opaque 226-227

buttons (continued)
modifying 202-208

by adding, changing, or removing text 205
by choosing style 205
by resizing 178

modifying icons of 186-194
moving to another card or background 232-233
moving from background to card 231
moving from card to background 230
moving through stacks with 39-40
naming or renaming 220-221
for opening applications from Home cards

127-128
for opening documents from Home cards

128-131
opening scripts of 233-234

from Home cards 125-126
for opening cards or stacks 209-215

from Home cards 125-126
overlapping of, solutions to 224-227
protecting from peeking 119
readymade 77, 172-173

copying 173-175
removing an icon from 208
reordering 224-226
repositioning 221-222
resizing 202—2-3
selecting 82
styles for 203-204
text in. See button text
tools for working with 171-172
viewing 200-201

Button Info command. See Button Info dialog box
Button Info dialog box 91

adding text and icon with 183-184
adding visual effects with 215-216

assigning icon to button with 181
Auto Hilite option 217
changing button style with 203
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Button Info dialog box (continued)
changing button text with 205
changing or removing an icon with 208
choosing button style with 204
creating link with 210
creating text button with 177-178
highlighting button with 217-219
making button opaque or transparent with 227
modifying icon with 186-187
naming button with 220
opening a script with 234
Shared Hilite option 218-219
Show Name option 221-222
varying highlighting among cards with 218-219

button numbers 223
button text 236

adding, changing, or removing 205
combining with button icon, 183-184
creating 176-179
setting or changing style of 179, 205-207

Button tool 171
locating buttons with 90, 200-201
opening a script with 234
repositioning a button with 221-222
resizing a button with 202-2-3
shortcut for choosing 172, 239

.
card(s) 3. See ako card fields; card layer

adding buttons to 170-171
adding fields to 237-238
adding graphics to 286
adding Paint text to 331-333
adding to stacks 140-143
copying 145-146
copying buttons to 228-229
copying buttons on the same 228
copying fields to 275-276
copying fields on the same 274-275
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cards (continued)
copying graphics to 360-361
copying graphics on the same 358-359
deleting 155-156
exporting a snapshot of 366
flipping through 44
getting information about 94, 149
going back to 58-59
going to specific 42-44
Home 14-15. See also Home cards
large, viewing 56-57, 143-145
linking buttons to 209-215
locating fields on 259-260
marking 151-152
moving. See cards, repositioning
moving buttons from background to 231
moving buttons to background from 230
moving buttons between 232-233
moving buttons on 221-222
moving field from background to 278-279
moving field to background from 277-278
moving fields between 279-280
moving fields on, 268
moving graphics to background from 361-362
moving graphics between 363-364
moving graphics on 325
naming 150
printing 369-376
protecting from deletion 154-155
repositioning 147-148

in Home stack 132-133
resizing 106-108
saving graphics on 357
viewing quickly 44
working with 140-156

card buttons. See also buttons
numbering of 223-224
and overlapping elements 222-224
reordering 224-226
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card fields
and overlapping elements 269-271
changing appearance of 260-266
numbering of 270-271
placing in report template 383
reordering 271-273
tabbing through 250-251

Card Info command. See Card Info dialog box
Card Info dialog box 94, 149

Can't Delete Card option 155
Card Marked option 151
Don't Search Card option 154
excluding fields from searches with 153
marking a card with 151
naming or renaming a card with 150
protecting a card with 154
scripting a link with 212
shortcut for choosing 149

card layer. See also card(s); card fields
background layer vs. 73-75, 140, 222

when adding buttons 170-171
when adding fields 237, 238, 242
when adding graphics 286
when entering or editing text 258
when selecting graphics 291, 299

moving between background layer and 157
overlapping buttons in 224—227
overlapping fields in 269-274
overlapping graphics in 335-337

card picture 335-336
selecting 300

card script, viewing 94
card size

changing 106-108
choosing 100

CD-ROM, using stacks on 67
changes, protecting a stack from 114-115
changing a button’s icon 208
changing button text 205
changinga field’s appearance 260-266

changing a graphic’s appearance 338-352
changing a Home card’s appearance 134
check box button, Auto Hilite and 217
circles, drawing 314-315
Clear Button command (Edit menu) 234
Clear Field command (Edit menu), 284
Clear Icon command (Edit menu) 199
Clear Picture command (Edit menu) 367, 368
clicking buttons to move around 39-40
clicking text 40
Clipboard, importing graphics via 365
Close Stack command (File menu) 32
Compact Stack command (File menu) 32, 111
Convert Stack command (File menu) 30
Copy Button command (Edit menu) 228
Copy Card command (Edit menu) 145

for creating miniature card 367
Copy Field command (Edit menu) 275
Copy Icon command (Edit menu) 198
Copy Text command (Edit menu) 244, 334
copying a background 98, 100, 161-162
copying a button 227-229

from Readymade Buttons stack 172-173
copying a card 145-146
copying a field 274-276

from Readymade Fields stack 241-242
copying a graphic 358-361

that comes with HyperCard 301-302
copying an icon 196-199
copying a report template 386-387
copying a stack 108-109
Copy Picture command (Edit menu) 302
Copy Report command (Edit menu) 386
correcting mistakes 97

in graphics operations 302-303, 368
in text entry 62, 252
undeleting a card 155

creating a background 159
creating a button. See buttons, creating
creating a field 237-238, 242-244
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creating a graphic 286-324
opaque or transparent 336-337

creating an icon 194-195
creating links 209-215

with LinkTo method 210-211
by scripting 212-215

creating a miniature picture of a card 367
creating Paint text 330-333
creating stacks. See stacks, creating
crosshair pointer

drawing an irregular polygon with 318
drawing circles, ovals, or rectangles with 314
drawing lines or free-form shapes with 312-313
drawing polygons with 315
modifying an icon part with 194
selecting a graphic with 292, 296

Curve tool
Draw Filled option with 321, 322
drawing with 312-313

customizing the Home stack 124-138
Cut Button command (Edit menu) 230, 231, 232
Cut Card command (Edit menu)

adding new first card with 142
copying a background with 161
moving a card with 147-148

Cut Field command (Edit menu) 277, 278, 279
Cut Icon command (Edit menu) 198
Cut Picture command (Edit menu) 362, 363
Cut Report command (Edit menu) 386

D
Darken command (Paint menu) 347, 348
darkening a graphic 346-348
default text format

choosing 252-254
for fields 254
overriding 254-256
for Paint text 331
restoring 257

Delete Card command (Edit menu) 155
deleting a background with 167
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Delete Report command (Edit menu) 388
Delete Stack command (File menu) 123
deleting. See also correcting mistakes; removing

a background 167-168
a button 234
button text 205
acard 155-156
a field 284
a graphic 367-368

with Brush 304
with Eraser 303, 368
with Spray tool 305

a report template 388
scripts 103
search paths 24
a stack 123
text 252

deletion
protecting a background from 166-167
protecting a card from 154-155
protecting a stack from 114-115

directory, Home cards as 14
directory dialog box 11, 23
Distort command (Options menu) 352-353
double-clicking, as error 40
double-clicking Paint tools or patterns, effects of

356
Draw Centered option (Options menu) 313, 315
Draw Filled option (Options menu) 320

for filled shapes without borders 324
drawing lines and shapes 312-319

circles, ovals, and rectangles 314-315
with different line widths 322-323
filled with patterns 320-322
in inverse 319
line or free-form shape 312-313
in multiples 326-327
polygons 315-319

Draw Multiple option (Options menu) 326
Duplicate Icon command (File menu), for copying

an icon 197
duplicating. See copying
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E
editing an icon 186-194
editing a graphic 338-352
editing text 62, 244-257

keyboard shortcuts for 256
Edit menu commands

Background 73-75, 157
Clear Button 234
Clear Field 284
Clear Icon 199
Clear Picture 367, 368
Copy Button 228
Copy Card 145

for miniature picture of card 367
Copy Field 275
Copy Icon 198
Copy Picture 360
Copy Report 386
Copy Text 244, 334
Cut Button 230, 231, 232
Cut Card

adding new first card with 142
copying a background with 161
moving a card with 147-148

Cut Field 277, 278, 279
Cut Icon 198
Cut Picture 362, 363
Cut Report 386
Delete Card 155

for deleting a background 167
Delete Report 388
Icon. See Icon Editor
New Button 195
New Card

adding card with 141, 142
copying a background with 161, 162

Paste Button 228-233
Paste Card

adding new first card with 143
copying a background with 161

copying a card with 146
creating miniature card with 367

Edit menu commands, Paste Card (continued)
making card first in stack with 148
moving a card with 147

Paste Field 275-280
Paste Icon 199
Paste Picture 361-364
Paste Report 387
Paste Text 244, 334
Report Items 382
Report Name 388
Text Style

choosing button text style with 207
choosing default field text format with 253
overriding default field text format with 255
with Paint text 331

Undo 97
Revert command vs. 357
undeleting a card with 155
undeleting field text with 252
undeleting a graphic with 302, 368

user level and 18
Edit Pattern dialog box 310, 311
elements, overlapping

buttons 224-227
fields 269-274
graphics 335-337

entering and editing text in fields, 60-62, 244—257
and Arrow Keys in Text option 248
keyboard shortcuts for 256

Eraser, deleting a graphic with 303, 368
erasing. See correcting mistakes; deleting

to correct Paint mistakes 303
with Brush 304
with Bucket 307-308
with Spray tool 305

error correction. See correcting mistakes
error messages 88-89
Esc key

going to last card seen with 58
for Undo command, with Paint tools 97, 302, 368

evaluating stacks 86-87
Export Paint command (File menu) 366
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5
FatBits option (Options menu) 338-340
field(s) 76, 235, 236

Field Info command. See Field Info dialog box
Field Info dialog box 93

adding margins with 264

adding to card or background 237-238
adding margins to 263-264
changing appearance of 260-266
copying 274-276

from Readymade Fields stack 239-242
creating 242-244
deleting 284
displaying lines in 265-266
entering and editing text in 62, 244-257

after copying 242
getting information about 93
grouping text in 282—283
locating 259-260
locking and unlocking 281-282
making opaque or transparent 273-274
moving to another card or background 279-281
moving from background to card 278-279
moving between 249-251
moving from card to background 277-278
naming 266-267
numbering of. See field numbers
overlapping of, solutions to 269-274
peeking at 260

preventing 119
preventing word wrap in 246-248
printing text in 376-377
protecting 119, 281-284
readymade 77, 239-240

copying 241-242
reordering 271-273
repositioning 268
resizing 261
searching for text in 47-49

exclusions when 47, 153-154, 283-284
selecting 83
styles for 262-263
tabbing through 249-251
tools for working with 238-239

Auto Tab option 251
changing field style with 262-263
checking field number with 250
choosing default text format with 252
displaying lines in field with 265
Don’t Search option 283

Shared Text option and 259
Don’t Wrap option 247-248
Fixed Line Height option 254, 256
Lock Text option 281
making a field opaque or transparent with

273-274
naming a field 266
preventing text wrap with 246
protecting field from search with 283
Shared Text option 258
Show Lines option 265
Wide Margins option 264

field names, choosing 266-267
field numbers 223

reordering fields and 272, 273
tabbing order and 250

field size, changing 261
field style, changing 262-263
field text 236

adding to cards 60-62
changing to Paint text 333-334
choosing look of, 252-257
clicking 40
copyinga field with 275-276
copyinga field without 274—275
correcting mistakes in 252
creating fields for 237-238
entering and editing 60-62, 244—257

and Arrow Keys in Text option 248
on every card 257-259
grouping 282-283
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Field text (continued)
hidden, viewing, 245
moving through, 19-20
placing in report template 383-384
printing 376-377
printing reports using 378-379
selecting for report template 382
Shared Text option, for background fields

257-259
Field tool 238

locating fields with 92, 259
manipulating fields with 238
repositioning a field with 268, 272
resizing a field with 261

File menu commands
Close Stack 32
Compact Stack 32, 111

Convert Stack 30
Delete Stack 123
Duplicate Icon 197
Export Paint 366
Import Paint 365
New Icon 194
New Stack 99
Open Stack

moving to another stack with 58
opening multiple stacks with 31

opening a stack with 25, 26
Print Field 376-377
Print Report. See Print Report dialog box
Print Stack. See Print Stack dialog box
Protect Stack. See Protect Stack dialog box
Quit HyperCard 68
Save A Copy 109
user level and 18

files, finding 10-11, 22-24
file server

setting user access for stacks on 122
using stacks on 66

Fill command (Paint menu)
changing a graphic’s pattern 342-343
filling area with pattern 309

filled shapes, drawing 320-322
without borders 324

Find command (Go menu)
finding text with 45—46

searching a specific field with 48-49
Find command (Icon menu) 198, 199
Finder

changing stack name in 106
checking version number of 7
copying a stack in 109
making HyperCard startup application 137-138

finding buttons 200-201
findinga file

directory dialog box for 11, 23
Search Paths cards for 22-24

finding text. See searching for text
finding a transparent field 244
Find Whole command 50-51
First command (Go menu)

adding card with 142
making card first in stack with 148

flipping a graphic 350-351
flipping through cards 44
Flip Vertical command (Paint menu) 350-351
Flip Horizontal command (Paint menu) 350-351
floppy disk system, using HyperCard on 6, 7
font

overriding default 254-256
restoring default 257
setting default 252-254

Font menu
changing default font for field with 255
overriding default font with 254
restoring default font for field 257
setting button text font with 205, 206

font size

choosing default 252-254
overriding default 254-256
preset 254
restoring default 257
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G graphics (continued)

General tools 78, 79 copying 358-361
Go menu commands 35—37 to another card or background 360-361

Back
Prev vs. 36
reviewing cards with 58

Find 45-47
searching a specific field with 47—49
searching for a whole word or phrase with

50-51
First

adding card with 142
making card first in stack with 148

Help 64
Home 24, 60
Last 36
Message. See Message box
Next Window 56
Prev, Back vs. 36
Recent 59
Scroll

moving a window with 52
resizing a window with 55
viewing a large card with 56, 144

graphic(s) 76
adding to card or background 286-324
adding to Home cards 134
aligning 328-329
changing appearance of 338-352

by changing pattern 342-345
by darkening or lightening 346-348
by flipping vertically or horizontally 350-351
by inverting 346
by outlining 348-349
by rotating 90° 349-350
by slanting, rotating, or distorting 352-353

changing pattern of 342-345
changing size of 341
combining options for 329-330

multiple copies 359
readymade graphics 301-302
on same card 358-359

creating 286-324
opaque or transparent 336-337

creating buttons with 184-186
creating your own patterns for 309-311
darkening or lightening 346-348
deleting 367-368
distorting 352-353
drawing lines and shapes 312-319

circles, ovals, and rectangles 314-315
with different line widths. 322-323
filled with patterns 320-322
in inverse 319
line or free-form shape 312-313
in multiples 326-327
polygons 315-319

drawing patterned lines and borders 324
editing 338-352
filling with patterns 306-311, 320-322
flipping 350-351
importing 365
inverting 346
making opaque or transparent 336-337
magnifying for editing 338-340
miniature pictures of cards 367
moving 325

to another card or background 363-364
from card to background 361-362

outlining 348-349
overlapping, solutions to 335-337
with Paint text. See Paint text
painting with Brush 303-305
painting with Bucket 306-308, 343-344
painting with Spray tool 305-306
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graphics (continued)
readymade 77

copying 301-302
repositioning 325
reverting to last version of 357-358
rotating 349-350, 352-353
saving on card or background 357
selecting 84, 291-300

all in current layer 299
after creation 298
entire card or background picture 300
nonrectangular 294-295
rectangular 292-293
without white space 296-298, 299

slanting 352-353
special effects with 326-330
text with. See Paint text
tools for working with 287-291
using modifier keys for 355
using power keys for 353-354
working with 285-368

Grid option (Options menu) 328-329
Group command (Style menu) 283
grouping text 282-283

H
hand pointer, viewing large card with 56, 143, 144
hardware requirements 6
help, getting 64—66

Help command (Go menu) 64
hidden buttons, locating 201
hidden field text, viewing 245
hidden menu bar, viewing 33
highlighting, adding to buttons 217-219

on specific cards 218-219
Home cards 14—15

adding buttons to 124-131
buttons on 14, 124
changing appearance of 134
renaming 131-132
reordering 132-133

returning to 60
Home command (Go menu) 24, 60
Home icon, starting HyperCard with 10
Home menu commands 15

New Link to Application 127
New Link to Document 129
New Link to Stack 126
Rename This Card 132
Reorder Cards 133

Home stack 12-24
alternate, using 134-137
as control center for Macintosh 137-138
customizing 124-138
deletion warning 13

going to (Home command) 24, 60
locating 10-11
Preferences card 15-21
Search Paths cards 22-24
startup with 10-11, 137-138

house icon, getting to Home stack with 24, 60
HyperCard

with CD-ROM 67
earlier-version warning 29-30, 96-97
getting help in 64-66
hardware requirements for 6
Home stack required for 12
installing 7
introduction to 1-5
layers of elements in 222-223
with MultiFinder 8-9
in network environment 66
opening applications from 62-64
preset text format in 254
quitting 68
readymade elements in 77. See also specific

elements

running from locked disk 67
software requirements for 6, 7
starting 9-12
starting Macintosh with 137-138
uses for 2-3
windows in 51
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HyperCard Help stack 64
HyperCard Reference vs. 65
readymade button for 173

HyperTalk 2, 73
printing options with 369

HyperTalk expressions, placing in report template
383, 384

HyperTalk Reference stack 64
getting to 65

I,J
icon(s)

assigning to buttons 180-184, 208
copying or moving 196-199
creating 194-195
creating buttons with 180-184
deleting from stack 199
modifying 186-194
removing from buttons 208
scrolling through 198
selecting, selecting a graphic vs. 292

Icon command (Edit menu). See Icon Editor
Icon dialog box 182

changing or removing an icon with 208
opening Icon Editor from 187

Icon Editor 189
copying or moving an icon with 196-199
creating an icon with 194
deleting an icon with 199
menus in 191-194
modifying icon in 189-194
opening a new icon in 194-195
role of 186
shortcut for choosing 190
shortcut to specific icon in 198

Icon menu
commands and keyboard shortcuts 192
Find command 198-199

408

Image Writer, Print dialog box for 374
importing a graphic 365
Import Paint command (File menu) 365
installing HyperCard 7
inverse, drawing in 319
Invert command (Paint menu) 346
Item Info dialog box 382-384
Items menu

Item Info command 382-384
New Item command 382

K
Keep command

Paint menu 357
Icon menu 192

keyboard shortcuts. See also specific tasks

for choosing tools 239
for Go menu 36
for Icon Editor menus 192-193
Power Keys option 353-354
for reordering buttons 226
for reordering fields in 272
for working with field text, listed 256

L
large cards, viewing 56-57, 143-145
Laser Writer

Print dialog box for 374
printing labels on 386

Lasso, selecting graphics with 84, 294-298
all in current layer 299
entire card or background picture 300

Last command (Go menu) 36
layers. See background layer; card layer
Lighten command (Paint menu) 347, 348
lightening a graphic 346-348
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lines
displaying in a field 265-266
drawing 312-313

in inverse 319
patterned, drawing 324
varying width of 322-323

Line Size dialog box (Options menu) 322-323
line spacing, setting default 252-254
Line tool

choosing 312
drawing with 312-313

patterned lines or borders 324
line width, selecting 322-324
linking information 5

creating buttons for 209-215
by LinkTo method 210-211
by scripting 212-215
using New Link to Stack (Home menu) 125

stack renaming and 106
LinkTo box 210-211
locating buttons 200-201
locating fields 259-260
locked disk, running HyperCard from 67
locked stacks

making changes to 116
using on file server 66, 122

locking and unlocking fields 281-282
looking at scripts 233-234
looking back through cards seen recently 58-59
looking through stacks. See moving through stacks

M
Macintosh control center, Home stack as 137-138
MacPaint

exporting a card or background snapshot to 366
importing a graphic from 365

magnifying a graphic for editing 338-340

mailing labels, printing 386
margins, adding to fields 263-264
marked cards, operations on 152-153

reports 375-376, 379
report templates 385

marking a card 151-152
memory requirements 6, 7

with MultiFinder 8—9

multiple stacks and 30-31
for running applications 63, 128

menu bar
in background layer 157
viewing hidden 33

menus. See also specific menus
hidden 33
Home 15

with Paint tools 289-291
stack 33-34

Message box
and Find command 45, 46, 47
getting help with 64
getting to Home stack with 24
going to card with 42-44
opening Navigator palette with 38
for marked card operations 153
marking or unmarking a card from 152

moving between backgrounds with 160

moving through stacks with 43, 44
moving to another stack with 56
opening an application from 62-63
returning to Home stack with 60
opening a stack from 25, 27

miniature picture of card, creating 367
mistakes. See correcting mistakes
modifier keys, using with Paint tools 355
modifying appearance of buttons 202-208
modifying an icon 186-194
modifying stacks 88-97

protection from 114-116
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moving back through cards seen recently 58-59
moving between backgrounds 160-161
moving a button 230-233

to another card or background 232-233
from background to card 231
from card to background 230

moving a card 147-148
moving a window 52-53
moving a field 268

to another card or background 279-281
from background to card 278-279
from card to background 277-278

moving a graphic 325
to another card or background 363-364
from card to background 361-362

moving an icon 196-199
moving a report template 386-387
moving through fields 249-251
moving through stacks 19-20, 33-60

with arrow keys 40-41
by clicking buttons 39-40
by clicking text 40
by flipping through cards 44
with Go menu 35-37
with Message box 42-44
with Navigator palette 37-38
reviewing cards viewed 58-59
by searching for text 45-51
viewing large cards 56-57

moving through text 19-20
Arrow Keys in Text option for 248
from one field to another 249-251

MultiFinder, using HyperCard with 8-9
multiple copies of graphics, creating 359
multiple lines or shapes, drawing 326-327

N
naming a button 220-221
naming a card 150
naminga field 266-267

410

naming or renaming a background 164
naming a report template 380
naming a stack 105-106
Navigator palette, moving through stacks with

37-38
network, using stacks on 66
New Background command (Objects menu) 159
New Button command (Edit menu), for assigning

new icon to button 195
New Button command (Objects menu)

creating a button with an icon 180
creating a button with text 177

New Card command (Edit menu) 141, 142
copying a background with 161, 162

new features in HyperCard 2.0 389
New Field command (Objects menu) 243
New Icon command (File menu) 194
New Item command (Items menu) 382
New Link to Application (Home menu) 127
New Link to Document (Home menu) 129
New Link to Stack (Home menu) 126
New Report command (Reports menu) 380
New Stack command (File menu) 99
New Stack dialog box 99-100
Next Window command (Go menu) 56
nonrectangular graphic, selecting 294-295

O
Objects menu commands

Bkgnd Info dialog box 95, 163
checking number of cards that share

backgrounds 158
naming or renaming a background with 164
protecting a background with 166
search exclusions with 165

Bring Closer command
reordering a button with 225
reordering a field with 272
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Objects menu commands (continued)
Button Info dialog box 91

changing button style with 203
changing button text with 205
creating a text button with 177
making button opaque or transparent with

DOT

modifying icon with 186
naming a button with 220
opening a script with 234

Card Info dialog box 94, 149
marking a card with 151
naming or renaming a card with 150
protecting a card with 154
scripting a link with 212
search exclusions with 153

examining stacks with 90
Field Info dialog box 93

adding margins with 264
changing field style with 262
choosing text format with 252
displaying lines in field with 265
locking a field with 281
makinga field opaque or transparent with

273
naminga field with 266
preventing text wrap with 246
protecting field from search with 283

New Background command 159
New Button command

creating a button with an icon 180
creating a button with text 177

New Field command, for creating a field 243
Send Farther command

reordering buttons with 225
reordering fields with 272

Stack Info dialog box 96, 104
checking free space with 110
checking number of backgrounds with 158
resizing cards with 107

opaque buttons, changing to transparent, 226-227
opaque fields, creating 273-274
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opaque graphics, creating 336-337
opening an application program 62-64

adding a button to Home card for 127-128
opening a button’s script 233-234
opening a document 62-64

adding a button to Home card for 128-131
opening HyperCard 9-12

at startup 137-138
opening a stack 25-31

adding button to Home card for 125-126
built in earlier version of HyperCard 29-30
multiple stacks 30-31
in new window 26, 27
readymade buttons for 173
with a password 27
write-protected 28

Open Stack command (File menu) 25, 26
moving to another stack with 58
opening multiple stacks with 31

Option key
copying a button with 228
copying a field with 275
using with Paint tools 355

Options menu
Brush Shape command 304
combining options in 329-330
Distort command 352-353
Draw Centered option, 313, 315
Draw Filled option 320
Draw Multiple option 326
Edit Pattern command 310, 311
FatBits option 338-340
Grid option 328-329
Line Size command 322
Perspective command 352-353
Polygon Sides command 315-316
Power Keys option 21, 353-354
Rotate command 352-353
Slant command 352-353

outlining a graphic 348-349

412

ovals, drawing 314-315
Oval tool 314
overlapping elements, solutions to

buttons 224-227
fields 269-274
graphics 335-337

P

padlock, in menu bar
as indicator of stack built in earlier version 29,

96
as write-protect indicator 28, 89, 116

Page Setup dialog box, selecting printing options in
370-371

Painting level, defined 17
Power keys option 21

Paint menu commands
Darken 347, 348
Fill 309

changing a pattern with 342-343
Flip Horizontal 350-351
Flip Vertical 350-351
Invert 346
Keep 357
Lighten 347, 348
Opaque 336
Pickup 344-345
Revert 357-358
Rotate Left 349-350
Rotate Right 349-350
Select 296, 298, 299
Select All 300
Trace Edges 348
Transparent 336

Paint text 236, 330
adding 330-334
changing field text to 333-334
choosing a format for 331-333
preset format for 331
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Paint Text tool
choosing 331
power keys disabled with 354

Paint tools 78, 79, 287-288. See also specific tools
choosing 81

double-clicking, effects of 356
Grid option and 329
menus with 81, 289-291
for special effects 326-330
Tilde (~) key with, for undeleting graphic 302,

368
using modifier keys with 355

password
opening a stack with 27
removing 121

setting 112-113
user level setting and 118

Paste Button command (Edit menu) 228-233
Paste Card command (Edit menu)

adding new first card with 143
copying a background with 161
copying card with 146
creating miniature card with 367
making card first in stack with 148
moving a card with 147

Paste Field command (Edit menu) 275-280
Paste Icon command (Edit menu) 199
Paste Picture command (Edit menu) 361-364
Paste Report command (Edit menu) 387
Paste Text command (Edit menu) 244, 334
patterns

changing 342-345
default 303
double-clicking, effects of 356
selecting 291

Patterns menu
changing or creating a pattern on 309-311
choosing a pattern from 307, 320, 324
editing a pattern on 310
replacing a pattern on 310-311
tearing off 290

Index

Patterns palette 290-291
choosing a pattern from 320, 324
shortcut for showing or hiding 290

peeking
at buttons 200-201
at fields 260
preventing 119

Pencil
drawing with 313, 319
editing a graphic with 338, 340

pencil pointer
creating icon with 195
editing icon with 189

Perspective command (Options menu) 352-353
phrase, searching for 50-51
Pickup command

Paint menu 344-345
Icon menu 192

pictures. See background picture; card picture;
graphics

planning a stack 85
pointers

arrow
with Button tool 175
with Field tool 241
copying a graphic with 359
moving a graphic with 325

Brush shape 304
Bucket

changing a graphic’s pattern with 343-344
positioning 307, 344

crosshair 194
drawing an irregular polygon with 318
drawing circles, ovals, or rectangles with 314
drawing lines or free-form shapes with

312-313
drawing polygons with 315
selecting a graphic with 292, 296

hand 56, 143, 144
I-beam 61

adding Paint text with 331
changing text format with 254
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pointers, I-beam (continued)
editable field shown by 244, 245
for editing text 62
failure to appear 246
grouping text with 283
locked field and 282

pencil
creating icon with 195
editing icon with 189

Spray tool 305
Tools palette and 80

Polygon Sides dialog box 315
choosing shape in 315-316

Polygon tool
choosing 317
Draw Filled option with 321, 322
drawing with 317-318

polygons, drawing 315-319
power keys, listed

for Icon Editor commands 192-193
for painting commands and options 354

Power Keys option 21, 353-354
Preferences card 15-21

Arrow Keys in Text option 19-20, 40-41
Blind Typing option 21
Power Keys option 21, 353-354 .

stack user level vs. 18

Prev command (Go menu), Back command vs. 36
Print dialog box 374
printer driver required 6
Print Field command (File menu) 376-377
Print Field dialog box 376-377
printing 369-388

entire stack 372-374
fields 376-377
mailing labels 386
Page Setup options for 370-371
preparing for 370
reports 378-379
report templates for 380-386. See also report

template(s)
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printing (continued)
single card 372
specific cards 375-376

Print Report dialog box 378-379
copying or moving a template 386
creating a template 380, 381, 384-385
deleting a template 388
printing from default template 378-379
renaming a template 387

Print Stack dialog box 372-373
marking cards for printing in 375
selecting options in 373

Private Access check box 112
protected cards, deleting 156
protected stacks

opening 27-28
trying to delete 123
types of 111

protecting a background from deletion 166-167
protecting a card from deletion 154-155
protecting a stack 111-122

from changes or deletion 114-116
ona file server 122
by limiting user level 117-119
with a password 112-113
by preventing peeking 119
by preventing script interruption 120

Protect Stack dialog box
limiting user level with 117-119
preventing changes or deletion with 114
preventing peeking with 119
preventing script interruption with 120
protection from changes or deletion with

114-115
removing a password with 121

restricting access with 112
setting file server access with 122
setting password with 112

Q
Quit HyperCard command (File menu) 68
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R

radio button, Auto Hilite and 217
readymade buttons 77, 172-173

copying 173-175
Readymade Buttons stack 172
readymade fields 77

copying 241-242
Readymade Fields stack 239-240
readymade graphics, copying 301-302
Recent command (Go menu) 59
rectangles, drawing 314-315
Rectangle tool 314
rectangular area of graphic, selecting 292-293
Regular polygon tool 315-317
removing button text 205
removing an icon 208
removing a password 121

removing search paths 24
Rename This Card (Home menu) 132
renaming a background 164
renaming a button 220-221
renaming a card 150
renaming a field 266-267
renaming a Home card 131-132
renaming a report template 388
renaming a stack 105-106
Reorder Cards (Home menu) 133
reordering buttons 224-226
reordering cards. See repositioning cards
reordering fields 271-273
reordering graphics 336
Report Items command (Edit menu) 382
Report Items dialog box 382, 384
Report Name command (Edit menu) 388
reports, printing. See printing; report templates
Reports menu

choosing a report template from 378
New Report command 380

report templates
copying or moving 386-387
creating 380-386
default, printing report from 378-379
deleting 388
for mailing labels 386
naming 380
renaming 387-388
saving 385, 387

repositioning buttons 221—222
repositioning cards 147-148

in Home stack 132-133
repositioning fields 268
repositioning graphics 361

after copying 361
after moving 362, 364

resizing a button 202—203
to show text 178

resizing cards 106-108
resizing a card window 53-56
resizing a field 261
resizing a graphic 341
resource fork, icons stored in 186
restoring default text format 257
restoring a graphic 357-358
restricting access. See protecting a stack
Revert command (Paint menu) 357-358
Rotate Left command (Paint menu) 349-350
Rotate Right command (Paint menu) 349-350
Rotate command (Options menu) 352-353
rotating a graphic 349-350, 352-353
Rounded Rectangle tool 314

S

Save A Copy command (File menu) 109
Save A Copy dialog box 109
saving graphics 357
saving a report template 385, 387
saving a stack copy 108-109
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scanned graphics, as card element 77
Scanned Images stack 301

copying graphics from 301-302
Scrapbook, importing graphics via 365
Scripting level, defined 17

Blind Typing option 21
scripts 73

background, viewing 95
button name changes and 221
button, viewing 91, 233-234
card, viewing 94
copying, error messages and 102-103
creating links with 212-215
deleting 102-103
field name changes and 266
field, viewing 93
for grouped text 282
for linking 212-215
looking at 90-96, 233-234
pre-programmed 77

with readymade buttons 172
preventing interruption of 120
stack, viewing 96
stack modification warning 88-89
viewing 90-96, 233-234

Scroll command (Go menu)
moving a window with 52
resizing a window with 55
viewing a large card 56, 144

Scrolling field style, in Field Info dialog box 263
Scroll window 52

hiding 56
resizing a window with 55
viewing large card with 56, 144

searching for text 45-51
exclusions when 47, 153-154, 164-165,

283-284
Paint text excluded from 333
Shared Text option and 259
in a specific field 47-49
speeding up 47
for whole word or phrase 50-51

416

search paths 23-24
Search Paths cards 22-24
Select All command (Paint menu) 300
Select command (Paint menu) 296, 298, 299
selecting an icon, selecting a graphic vs. 292
selecting a button 82
selecting default text format 252-254
selecting a field 83
selecting a graphic 84, 291-300

all in current layer 299
after creation 298
entire card or background picture 300
nonrectangular 294-295
rectangular 292-293
selecting an icon vs. 292
without white space 296-298, 299

selecting a pattern 291
selecting printing options

for entire stack 373
Page Setup 370-371

Selection tool 84, 291—300
Send Farther command (Objects menu)

reordering buttons with 225
reordering fields with 272

Set Password button (Protect Stack dialog box) 112
Set Startup command (Special menu) 137
shapes

drawing
circles, ovals, and rectangles 314-315
free-form 312-313
polygons 315-318

drawing patterned borders for 324
filled, drawing without borders 324

Shared Hilite option 218, 219
Shared Text option

I-beam pointer and 246
making text appear on every card with 257-259

Shift key, using with Paint tools 355
size of button, changing 202-203

Index



size of cards
in alternate Home stack 136
changing 106-108
choosing 100

size of field, changing 261
size of graphic, changing 341
slanting a graphic 352-353
Slant command (Options menu) 352-353
small Home card 136
software requirements 6, 7
special graphic effects 326-330
Special menu

in Finder, Set Startup command 137
in Icon Editor, commands and keyboard

shortcuts 192
Spray tool 303

painting with 305-306
Spray tool pointer 305
stack(s) 4—5

adding cards to 140-143
alternate Home 134-137
backup, importance of 9
on CD-ROM 67
changing name of 105-106
closing 32
compacting before closing 32
copying a report template between 386-387
creating 70-88

card layer vs. background layer 73-75
by copying from other stacks 98-99,

102-103
evaluation while 86-87
by modifying existing stacks 88-97
planning 85
scripts for 73
steps in 99-101
tools for 78-81

creating new backgrounds for 159
creating a new icon for 194-195
creating report templates for 380-386

stack(s) (continued)
deleting 123
deleting icons from 199
examining parts of 90-96
on file server 66
getting information about 96, 103-104
icons for 4
linking buttons to 209-215
links between 5

creating 209-215
locating buttons in 200-201
makinga card first in 148
modifying 88-97
moving between 57—58

moving a card in 147-148
moving a report template between 386-397
moving through 19-20, 33-60

with arrow keys 40-41
with buttons 39—40
by clicking text 40
by flipping through cards 44
reviewing cards viewed 58-59
with Go menu 35—37
with Message box 42-44
with Navigator palette 37-38
by searching for text 45-51

naming or renaming 105-106
opening 25-31

adding a button to Home card for 125-126
readymade buttons for 173

planning 85
printing all cards in 372-374
printing options saved with 371
protecting 111-122

Index

from changes or deletion 114-116
ona file server 122
by limiting user level 117-119
by preventing peeking 119
by preventing script interruption 120
from unauthorized access 112-113
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stack(s), protecting (continued)
Readymade Buttons 172
readymade elements in 77
Readymade Fields 239-240
readymade graphics in, copying from 301-302
reclaiming free space in 110-111
renaming 105-106
repositioning cards in 147-148
repositioning Home cards in 132-133
resizing cards in 106-108
saving a copy of 108-109
scripts and 73

stack icons 4
startup choice from 11-12

Stack Info command. See Stack Info dialog box
Stack Info dialog box 96, 104

checking free space with 110, 111
checking number of backgrounds with 158
resizing cards with 107
shortcut for choosing 104

stack menus 33-34
stack script, viewing 96
starting HyperCard 9-12

at Macintosh startup 137-138
stoppinga script, preventing 120
style of button, choosing 203-205
style ofbutton text, setting 205—207
style of field, changing 262-263
style of field text. See text format
Style menu

changing default text format with 255
changing format of characters with 254-256
choosing default text format with 254
Group command, grouping text with 283
setting button text with 205, 206

system software requirements 6, 7
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T
Tab key, moving through fields with 249-251

reordering fields and 273
template(s). See report template(s)
testing a button 175

after copying 229
after moving 233

testing a link 211, 215
testing a visual effect 216
text. See also button text; field text; Paint text

Arrow Keys in Text option 19-20
combining with an icon 183-184
creating a button with 176-179
formatting. See text format
role of 235
searching for 45-51

exclusions when 47, 153-154, 164-165,
283-284

Shared Text option and 259
types of 236-237

determining 246
working with, keyboard shortcuts for 256

text fields. See field(s)
text format

choosing default, 252-254
for individual characters 254-256
overriding default 254-256
for Paint text 331-332
restoring default 257
specifying in report template 383

text style. See text format
Text Style dialog box

for button text style 207
for choosing default text format 253
for formatting individual characters 255
for overriding default format 255
for Paint text 331-333
shortcut for opening 253

Tilde (~) key
for looking through cards viewed, 58
for undeleting a graphic 302, 368
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title bar 51

bringing into view 52-53
Tools menu 78-81. See also specific tools

Draw Filled option and 321
shortcuts for choosing General tools 172, 239
shortcuts for painting commands 354
tearing off 80
for working with buttons 82, 171-172
for working with fields 83, 238-239
for working with graphics 84, 287-291

Tools palette
choosing a tool from 80-81
creating 80

Trace Edges command (Paint menu) 348
transparent buttons

changing opaque buttons to 226-227
creating 175-176

transparent fields
changing opaque fields to 273-274
creating 243
finding 244

transparent graphics, creating 336-337
Typing level, defined 17
typing mistakes, correcting 97. See also correcting

mistakes

U
undeleting a card 155
undeleting field text 252
undeleting graphics 302-303, 368
Undo command (Edit menu) 97

Revert command vs. 357
undeleting a card with 155
undeleting field text with 252
undeleting a graphic with 302, 368

unlocking a field 282
updating Search Paths card 23-24

user levels 15-18. See also specific levels

Vy

Arrow Keys in Text option and 19-20
Blind Typing option and 21

Compact Stack command and 32
File and Edit menus with 18

limiting 117-119
listed 17
Power keys option and 21
Preferences card vs. stack 18

setting or changing 16

viewing cards quickly 44
viewing cards seen recently 59
viewing large cards 56-57, 143-145
viewing scripts 90-96, 233-234
visual effects, adding to buttons 215-216

W,X,Y
Wide Margins, for fields 264
windows

HyperCard vs. standard Macintosh 51

moving 52-53
opening multiple stacks in 30-31
resizing 53-56
viewing large cards in 56-57, 143-145

word, searching for 50-51
word wrap in text fields, preventing 246-248
write-protected stack, opening 28

Z
zoom box, resizing a window with 56

Index 419



 



The Apple Publishing System

This Apple™ manual was written, edited,

and composed on a desktop publishing

system using Apple Macintosh™

computers and Microsoft Word. Proof

pages were created on Apple

LaserWriter™ printers. Final pages were

produced in QuarkXPress and output

directly to film on Linotronic imagesetters.

Line art was created using Studio/8.

Display type is Apple’s corporate font, a

condensed version of Garamond. Text

type is Adobe Garamond. Ornaments are

ITC Zapf Dingbats. Some elements, such

as program listings, are set in Apple

Courier, a fixed-width font.

PosrScrirt, the LaserWriter page-

description language, was developed by

Adobe Systems Incorporated.
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